Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 23/11/2022, à 10:44

michcauch

[RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Bonjour à tous
Le PC (pas celui ne ma signature) : ThinkPad E320 avec (avant la panne) Xubuntu 20.04 et Windows 7
Lors d'une mise à jour (et pas une mise à niveau) la mise à jour s'est interrompue pendant les installations pour une raison inconnue. Le PC s'est mis en veille (il me semble) et il m'a été impossible de le sortir de veille, j'ai du forcé l’arrêt du PC.
Au démarrage suivant le grub s’affichait mais le lancement sur Xubuntu ne donnait rien. J'ai donc décidé d'installer un nouveau système, soit Lubuntu 22.04.1
L'installation n'a pas abouti avec un message simple : impossible d'installer Lubuntu 22.04.1
Tentative de démarrage et, là, plus rien. Le grub ne s'affiche pas.

Avant de tenter quoique ce soit j'ai créé un boot-info ici pour avoir les bons conseils et les suivre.
Merci d'avance pour votre aide.

Dernière modification par michcauch (Le 23/11/2022, à 21:36)


Cordialement
Michel
___
Ubuntu 22.04 sur Clevo N141WU

Hors ligne

#2 Le 23/11/2022, à 10:53

xubu1957

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Bonjour,

Collage du Boot-repair, pour les spécialistes :

boot-repair-4ppa200                                              [20221123_0923]

============================== Boot Info Summary ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos5)/boot/grub. It also embeds following components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_msdos biosdisk
    ---------------------------------------------------------------------------

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 7/2008: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Boot/BCD

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 7/2008: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 7/2008: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda4: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info: 

sda5: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda6: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

sdb: ___________________________________________________________________________

    File system:       iso9660
    Boot sector type:  Unknown
    Boot sector info: 
    Operating System:  
    Boot files:        /boot/grub/grub.cfg


================================ 2 OS detected =================================

OS#1:   Windows 7 (boot) on sda1
OS#2:   Windows 7 on sda2

================================ Host/Hardware =================================

CPU architecture: 64-bit
Video: 2nd Generation Core Processor Family Integrated Graphics Controller from Intel Corporation
Live-session OS is Ubuntu 64-bit (Boot-Repair-Disk 64bit 20200604, bionic, x86_64)

===================================== UEFI =====================================

BIOS/UEFI firmware: 8NET34WW (1.18 ) from LENOVO
The firmware seems EFI-compatible, but this live-session is in Legacy/BIOS/CSM mode (not in EFI mode).



============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: notGPT,	no-BIOSboot,	has-noESP, 	not-usb,	not-mmc, has-os,	has-win,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda1	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda2	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda3	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios
sda6	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

sda1	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	bootmgr,	is-winboot
sda2	: isnotESP,	part-has-no-fstab,	no-nt,	haswinload,	no-recov-nor-hid,	bootmgr,	is-winboot
sda3	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda6	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda1	: not--sepboot,	no---boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	no--grub.d,	sda
sda2	: not--sepboot,	no---boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	no--grub.d,	sda
sda3	: not--sepboot,	no---boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	no--grub.d,	sda
sda6	: maybesepboot,	no---boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	no--grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
Disk identifier: 0x18b643a0
      Boot     Start       End   Sectors   Size Id Type
sda1  *         2048   3074047   3072000   1.5G  7 HPFS/NTFS/exFAT
sda2         3074048 101587475  98513428    47G  7 HPFS/NTFS/exFAT
sda3       592371712 625139711  32768000  15.6G  7 HPFS/NTFS/exFAT
sda4       101588990 592371711 490782722   234G  5 Extended
sda5       584161280 592371711   8210432   3.9G 82 Linux swap / Solaris
sda6       101588992 473010175 371421184 177.1G 83 Linux
Partition table entries are not in disk order.
Disk sdb: 7.4 GiB, 7897874432 bytes, 15425536 sectors
Disk identifier: 0x2c534026
      Boot Start     End Sectors  Size Id Type
sdb1  *        0 1802239 1802240  880M  0 Empty
sdb2         964    5891    4928  2.4M ef EFI (FAT-12/16/32)
Disk zram0: 481.1 MiB, 504475648 bytes, 123163 sectors
Disk zram1: 481.1 MiB, 504475648 bytes, 123163 sectors
Disk zram2: 481.1 MiB, 504475648 bytes, 123163 sectors
Disk zram3: 481.1 MiB, 504475648 bytes, 123163 sectors

parted -lm (filtered): _________________________________________________________

sda:320GB:scsi:512:4096:msdos:ATA ST320LT007-9ZV14:;
1:1049kB:1574MB:1573MB:ntfs::boot;
2:1574MB:52.0GB:50.4GB:ntfs::;
4:52.0GB:303GB:251GB:::;
6:52.0GB:242GB:190GB:ext4::;
5:299GB:303GB:4204MB:linux-swap(v1)::;
3:303GB:320GB:16.8GB:ntfs::;
sdb:7898MB:scsi:512:512:msdos:JetFlash Transcend 8GB:;
2:494kB:3017kB:2523kB:::esp;

Free space >10MiB: ______________________________________________________________

sda: 230962MiB:285232MiB:54270MiB
sdb: 2.88MiB:7532MiB:7529MiB

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL                  PARTLABEL
sda                                                                                                              
├─sda1 ntfs     00C6C7D5C6C7C95C                     18b643a0-01                          SYSTEM_DRV             
├─sda2 ntfs     D026CC2026CC0984                     18b643a0-02                          Windows7_OS            
├─sda3 ntfs     A804D1CA04D19C1E                     18b643a0-03                          Lenovo_Recovery        
├─sda4                                               18b643a0-04                                                 
├─sda5 swap     a1f67ac9-923f-4818-9024-5ab8a9876429 18b643a0-05                                                 
└─sda6 ext4     9c02ccf5-550b-4359-9f10-3d14571b9541 18b643a0-06                                                 
sdb    iso9660  2020-06-13-00-42-55-00                                                    Boot-Repair-Disk 64bit 
├─sdb1 iso9660  2020-06-13-00-42-55-00               2c534026-01                          Boot-Repair-Disk 64bit 
└─sdb2 vfat     D055-8513                            2c534026-02                          Boot-Repair-Disk 64bit 

Mount points (filtered): _______________________________________________________

            Avail Use% Mounted on
/dev/sda1     1.1G  24% /mnt/boot-sav/sda1
/dev/sda2       4G  91% /mnt/boot-sav/sda2
/dev/sda3       6G  62% /mnt/boot-sav/sda3
/dev/sda6   138.8G  15% /mnt/boot-sav/sda6
/dev/sdb         0 100% /cdrom

Mount options (filtered): ______________________________________________________

/dev/sda1   fuseblk         rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
/dev/sda2   fuseblk         rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
/dev/sda3   fuseblk         rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
/dev/sda6   ext4            rw,relatime
/dev/sdb    iso9660         ro,noatime,nojoliet,check=s,map=n,blocksize=2048

====================== sdb/boot/grub/grub.cfg (filtered) =======================

Boot-Repair-Disk session
Boot-Repair-Disk session (failsafe)

==================== sdb: Location of files loaded by Grub =====================

           GiB - GB             File                                 Fragment(s)
            ?? = ??             boot/grub/grub.cfg                             1

======================== Unknown MBRs/Boot Sectors/etc =========================

Unknown BootLoader on sdb

00000000  33 ed 90 90 90 90 90 90  90 90 90 90 90 90 90 90  |3...............|
00000010  90 90 90 90 90 90 90 90  90 90 90 90 90 90 90 90  |................|
00000020  33 ed fa 8e d5 bc 00 7c  fb fc 66 31 db 66 31 c9  |3......|..f1.f1.|
00000030  66 53 66 51 06 57 8e dd  8e c5 52 be 00 7c bf 00  |fSfQ.W....R..|..|
00000040  06 b9 00 01 f3 a5 ea 4b  06 00 00 52 b4 41 bb aa  |.......K...R.A..|
00000050  55 31 c9 30 f6 f9 cd 13  72 16 81 fb 55 aa 75 10  |U1.0....r...U.u.|
00000060  83 e1 01 74 0b 66 c7 06  f3 06 b4 42 eb 15 eb 02  |...t.f.....B....|
00000070  31 c9 5a 51 b4 08 cd 13  5b 0f b6 c6 40 50 83 e1  |1.ZQ....[...@P..|
00000080  3f 51 f7 e1 53 52 50 bb  00 7c b9 04 00 66 a1 b0  |?Q..SRP..|...f..|
00000090  07 e8 44 00 0f 82 80 00  66 40 80 c7 02 e2 f2 66  |..D.....f@.....f|
000000a0  81 3e 40 7c fb c0 78 70  75 09 fa bc ec 7b ea 44  |.>@|..xpu....{.D|
000000b0  7c 00 00 e8 83 00 69 73  6f 6c 69 6e 75 78 2e 62  ||.....isolinux.b|
000000c0  69 6e 20 6d 69 73 73 69  6e 67 20 6f 72 20 63 6f  |in missing or co|
000000d0  72 72 75 70 74 2e 0d 0a  66 60 66 31 d2 66 03 06  |rrupt...f`f1.f..|
000000e0  f8 7b 66 13 16 fc 7b 66  52 66 50 06 53 6a 01 6a  |.{f...{fRfP.Sj.j|
000000f0  10 89 e6 66 f7 36 e8 7b  c0 e4 06 88 e1 88 c5 92  |...f.6.{........|
00000100  f6 36 ee 7b 88 c6 08 e1  41 b8 01 02 8a 16 f2 7b  |.6.{....A......{|
00000110  cd 13 8d 64 10 66 61 c3  e8 1e 00 4f 70 65 72 61  |...d.fa....Opera|
00000120  74 69 6e 67 20 73 79 73  74 65 6d 20 6c 6f 61 64  |ting system load|
00000130  20 65 72 72 6f 72 2e 0d  0a 5e ac b4 0e 8a 3e 62  | error...^....>b|
00000140  04 b3 07 cd 10 3c 0a 75  f1 cd 18 f4 eb fd 00 00  |.....<.u........|
00000150  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001b0  04 17 00 00 00 00 00 00  26 40 53 2c 00 00 80 00  |........&@S,....|
000001c0  01 00 00 3f e0 6f 00 00  00 00 00 80 1b 00 00 fe  |...?.o..........|
000001d0  ff ff ef fe ff ff c4 03  00 00 40 13 00 00 00 00  |..........@.....|
000001e0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|
00000200




Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would restore the [(generic mbr)] MBR in sda, and make it boot on sda2.
Additional repair would be performed: unhide-bootmenu-10s

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#3 Le 23/11/2022, à 13:28

geole

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Bonjour.
Ton début d'installation Lubuntu a certainement commencé.
Il n'y a plus aucun ubuntu. Le MBR veut maintenant trouver ubuntu dans une partition swap au lieu d'une  partition EXT4
Je te propose de relancer ton support d'installation
De choisir essayer avant d'installer.
De lancer gparted
De supprimer SDA5 et SDA6,
De créer  une partition  fat32 de 36 Mo
De lui mettre le drapeau ESP
Puis de relancer ton installation.
Si même message d'erreur, essaie de regarder s'il n'y en pas un autre qui s'est affiché peu de temps avant.

Hors ligne

#4 Le 23/11/2022, à 15:12

michcauch

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Merci geole
J'ai fait ce que tu as proposé, j'ai supprimé SDA5 et SDA6, créé une partition  fat32 de 36 Mo.
Maintemant j'ai la partition fat32 de 36 Mo en SDA5 et une partition SDA6 nouvelle.
Ensuite j'ai commencé l'installation de Xubuntu 22.04.1 (et non Lubuntu qui ne veut pas se connecter en WiFi).
L'installateur ne reconnait pas l'existence de la partition windows 7 (alors que les partitions sont bien décrites sur gparted) et au moment de finaliser l'installation (je place / sur SDA6) j'ai ce message (encore compréhensible pour moi !) :

No EFI System Partition was found. This system will likely not be able to boot successefully and the installation process may be fail.
Please go back and add an EFI System Partition or continue at your own risk.

Je fais quoi maintenant (il est évident que je suis retourné en arrière) ?


Cordialement
Michel
___
Ubuntu 22.04 sur Clevo N141WU

Hors ligne

#5 Le 23/11/2022, à 15:25

geole

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Pour le premier problème, tu as certainement oublié de mettre le flag ESP  sur la partition FAT32
Pour le second problème, tu as  certainement booté en EFI alors qu'il ne le faut pas car windows   est installé en LEGACY


Il faudrait de tu déactives EFI du bios ou alors que tu ne choisisses pas le fichier  de boot EFI mais le fichier de boot LEGACY

Pour vérifier si le boot  n'est pas fait en EFI

[ -d /sys/firmware/efi ] && echo "Installé en mode EFI" || echo "Installé en mode classique"

Hors ligne

#6 Le 23/11/2022, à 15:44

michcauch

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

geole a écrit :

Pour le premier problème, tu as certainement oublié de mettre le flag ESP  sur la partition FAT32

oui, par maladresse, j'ai confondu Étiquette et Drapeau (c'est corrigé)

[ -d /sys/firmware/efi ] && echo "Installé en mode EFI" || echo "Installé en mode classique"

donne installé en mode EFI
mais est-ce pour la clef ou le PC ? (mode EFI ou Legacy ça dépasse nettement mes très modestes compétences en informatique).


Cordialement
Michel
___
Ubuntu 22.04 sur Clevo N141WU

Hors ligne

#7 Le 23/11/2022, à 16:09

geole

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Cela veut dire que le boot naturel de ton ordinateur se fait en EFI.
La clé USB a booté en EFI. Mais ton windows ne sait pas le faire


Depuis l'an 2000 le nouveaux ordinateurs peuvent avoir deux modes de fonctionnement
    ANCIEN,   (légacy)
       Dans le  bios, on indique les disques qui servent au boot   et le bios va lire le premier secteur du disque et exécute les commandes contenues dans le secteur. Ces commandes doivent faire le nécessaire pour faire la suite.
      C'est comme cela que windows 7 met en route.
   EFI,
    Le bios va lire la totalité des disques connectés à la recherche des toutes les partitions FAT16/32 contenant des fichiers normaux dont la terminaison est .EFI   Ces fichiers ont alors une taille importante et peuvent faire pas mal de choses.

Evidemment, les deux modes sont incompatibles.
A partir de l'année 2020, pas mal d'ordinateurs neufs n'ont plus la partie LEGACY.

Il faut donc que tu ailles dans le bios pour faire ton choix et la clé usb doit être branchée pour être visible du bios
  Certains bios permettent de déactiver soit la partie EFI soit la partie LEGACY

Si tu ne trouves pas dans le bios, fait des photos que tu posteras dans un site de partage.    On essaiera de te guider pour trouver.

Hors ligne

#8 Le 23/11/2022, à 16:37

michcauch

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Pour le bios, pas de problème. J'ai tout mis en Legacy mais maintenant tout démarrage devient impossible.
En fait dans le menu Startup du bios à UEFI/Legacy Boot il y avait both (pour le PC) et j'ai mis Legacy (pour le PC et la clef).

Si je cherche à démarrer sur la clef, le menu de boot tourne en rond, je valide il revient, etc...
Si je cherche à démarrer sur le PC alors j'ai le message :

error:unknown filesystem.
Entering rescue mode...
grub rescue>

La clef ne semble pas vouloir démarrer en Legacy, me semble-t-il.


Cordialement
Michel
___
Ubuntu 22.04 sur Clevo N141WU

Hors ligne

#9 Le 23/11/2022, à 16:45

geole

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Nous voila mal barré, avec quel outil avait été faite la clé?
As-tu les moyens de la refabriquer avec un autre ordinateur?
As-tu encore le support d'installation de windows7 qui permettrait de fabriquer un boot windows?
Tu as fait avec un outil assimilant la clé à un cdrom.
Certains bios n'aiment pas.
Dans ton contexte, la partie EFI accepte.
et il est possible que la partie LEGACY ne supporte pas de booter

sdb: ___________________________________________________________________________
    File system:       iso9660
    Boot sector type:  Unknown
    Boot sector info:

Sinon, tu bootes en EFI, tu installes, puis tu rebootes et tu pourras faire une cle avec ventoy qui est duale. https://doc.ubuntu-fr.org/ventoy

Dernière modification par geole (Le 23/11/2022, à 16:53)

Hors ligne

#10 Le 23/11/2022, à 16:57

michcauch

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

geole a écrit :

Nous voila mal barré, avec quel outil avait été faite la clé?
As-tu les moyens de la refabriquer avec un autre ordinateur?

Avec l'outil disque de Ubuntu (j'ai mon PC, voir ma signature)
J'ai aussi une clef avec boot-repair, peut-être puis-je tenter une réparation standard ou alors l'utiliser pour réinstaller le grub ?

geole a écrit :

As-tu encore le support d'installation de windows7 qui permettrait de fabriquer un boot windows?

Non, je n'en ai jamais eu mais il y a une partition recovery sur le PC mais comme il ne boot pas je n'y ai pas accés !

Edit : après les conseils (justifiés) de xubu1957

Dernière modification par michcauch (Le 23/11/2022, à 17:20)


Cordialement
Michel
___
Ubuntu 22.04 sur Clevo N141WU

Hors ligne

#11 Le 23/11/2022, à 16:59

xubu1957

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Pour info, le forum dispose de balises de citation.             smile

Dernière modification par xubu1957 (Le 23/11/2022, à 22:16)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#12 Le 23/11/2022, à 17:10

geole

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Fabrique une clé de boot avec ventoy avec ton ordinateur  et retente de booter tout en restant LEGACY.

Vindows7 ne peut pas être converti en EFI.

Dernière modification par geole (Le 23/11/2022, à 22:17)

Hors ligne

#13 Le 23/11/2022, à 21:35

michcauch

Re : [RÈSOLU] PC ne voulant plus démarrer (plus de système Ubuntu)

Ça marche !!!
Merci geole pour ton aide.
J'ai donc fabriqué une clef ventoy, contrôlé une nouvelle fois que le boot était bien réglé en legacy (et non both ou efi), à l'installation j'ai eu encore le message lié à la non existence d'une partition efi, je suis passé outre.
L'installation s'est bien déroulée, redémarrage et tout roule.
Je retiendrai bien qu'un double boot avec windows 7 nécessite un BIOS en legacy.
Merci encore.


Cordialement
Michel
___
Ubuntu 22.04 sur Clevo N141WU

Hors ligne