Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/11/2022, à 08:17

pehache

[Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

Bonjour,

A la base j'essaie d'installer Lubuntu 22.04.01 sur une carte uSD (64Go) sur un Dell Laltitude 7490. Je crée un clef d'installation, je peux booter dessus et lancer l'install, mais pendant l'installation tout se fige à un moment ou à un autre (parfois alors que les écritures sur la carte SD n'ont même pas commencé). Je n'ai plus du tout la main et la seule solution est d'éteindre le PC par un appui long sur le bouton on/off.

J'ai essayé 2 clefs différentes, 2 ports USB différents, et j'ai même essayé avec Lubuntu 20.04 au lieu de 22.04 : toujours pareil, ça plante sévèrement pendant l'install.

Du coup j'ai tenté avec Xubuntu, sachant que l'installeur est différent. Là j'arrive à installer complètement Xubuntu, à booter sur la carte SD, commencer à utiliser Xubuntu... Jusqu'au moment où je tente une MAJ des paquets de la distrib, et là ça recommence : plantage complet, tout se fige, appui long le bouton power. J'ai recommencé 2 fois, en réinstallant, c'est systématique.

Qu'est-ce qui peut bien se passer ??

J'ai soupçonné la carte SD, qui bien que neuve pourrait être défaillante. Mais pourquoi ce serait systématiquement pendant les MAJ que ça plante ?

Je relève des messages d'erreur concernant la carte SD, sans savoir quel est le degré de gravité:

dmesg | grep mmc 

rapporte l'erreur suivante toutes les 5 secondes environ :

mmc0: cannot verify signal voltage switch

Et pendant le boot de Xubuntu sur la carte SD je peux voir un certain nombre d'erreurs relative à ACPI ou au système de fichier de la carte SD : https://prnt.sc/qbbt7u9KBp-h

Ceci dit j'ai essayé d'écrire sur toute la carte SD puis de la relire sans que ça fasse d'erreur (cat /dev/zero > toto, puis cat toto > /dev/null)

Si quelqu'un a une idée...

Dernière modification par pehache (Le 08/12/2022, à 22:31)

Hors ligne

#2 Le 29/11/2022, à 15:27

inbox

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

Salut,

Les erreurs ACPI ne sont pas importantes.

Peux-tu donner le retour complet de cette commande ?

sudo dmesg | grep mmc

Vu qu'il s'agit d'une micro SD, as-tu essayé avec un autre adaptateur ?

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 29/11/2022, à 19:23

pehache

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

C'est un lecteur de micro-SD sur ce PC, donc pas d'adaptateur.

Voilà l'output de dmesg (avec Xubuntu live... avec Lubuntu live il y a avait un message toutes les 5 secondes) : https://prnt.sc/i8SEJ0KSAxib

Mais là je n'arrive même plus à booter sur la carte SD, elle n'apparait plus dans le menu de boot du BIOS. Je vais essayer sur un disque externe pour voir.

Hors ligne

#4 Le 29/11/2022, à 20:48

inbox

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

Ce lecteur interne, s'il est resté sans être utilisé, peut contenir de la poussière. Si c'est le cas, ça pourrait expliquer ton problème d'accès à la carte.

Donne le retour, en texte et non pas en image de ces commandes :

sudo dmesg
sudo lshw

Après avoir installé "lshw" si besoin.

Dernière modification par inbox (Le 29/11/2022, à 21:01)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#5 Le 29/11/2022, à 21:23

pehache

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

Le problème a l'air en fait plus profond et n'a probablement rien à voir avec la carte SD : j'ai installé Xubuntu sur un disque externe, l'install se passe bien, je peux booter sur le disque, mais assez rapidement tout l'OS se fige de façon irrémédiable.

Alors soit ce PC est plus ou moins incompatible avec Linux (du moins les distribs que j'ai essayées... On voit pas de mal de gens qui galèrent à installer un Linux dessus sur le web), soit il a un souci hardware. C'est un PC pro que j'utilise habituellement sous Windows, et c'est vrai qu'un freeze complet ça m'est déjà arrivé avec... Genre 3/4 fois depuis un an : la fréquence n'a rien à voir (avec Linux c'est quelques minutes d'utilisation au mieux) mais c'est peut-être le même problème qui est derrière.

Je pense que c'est mort... A moins de tenter une distribution autre que *ubuntu ?

Hors ligne

#6 Le 06/12/2022, à 22:56

pehache

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

J'ai trouvé ça : https://medium.com/@natchanan.th/linux- … 063e4d34a7
et ça https://www.reddit.com/r/linuxquestions … i915_dell/

Les kernels > 4.19 provoquent des plantages avec le GPU sur ce Dell (et sans doute sur tous les PC équipés du même CPU/GPU)

J'ai installé Xubuntu 18.04.1, avec le kernel 4.15, et ça roule nickel, plus aucun freeze smile... Sauf que je ne peux pas faire les MAJ pour l'instant sans avoir appliqué le fix proposé sur ces liens, à savoir (je cite) "add i915.enable_psr=0 to the kernel parameter". Mais où faut-il ajouter ça ?

EDIT :
En fait si je comprends bien il faut faire un truc dans le genre :

sudo echo "options i915 enable_psr=0" > /etc/modprobe.d/i915.conf

Est-ce que ce fichier de conf va survivre aux MAJ et surtout aux upgrades (passage à 20.04 puis 22.04) ? Je suppose que oui...

Dernière modification par pehache (Le 07/12/2022, à 10:28)

Hors ligne

#7 Le 08/12/2022, à 00:37

pehache

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

J'ai appliqué le fix suggéré et ai upgradé vers 22.04... et toujours pas de freeze !

Par contre je n'ai plus de wifi sad : https://forum.ubuntu-fr.org/viewtopic.p … #p22627372

Hors ligne

#8 Le 08/12/2022, à 22:30

pehache

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

Problème wifi résolu...

Pour les freezes, le fix ne résout pas 100% du problème en fait. Quand l'écran se met en veille il ne se rallume jamais, et d'après ce que je lis ici et là ça a l'air d'être la même cause.

Pour éviter ça, dans "Power Manager", onglet "Display", je dois mettre "Blank after" sur "never". Bizarrement, on peut aparemment quand même utiliser "Put to sleep after" et "Switch off after" sans que ça fasse freezer. De même pas de problème en sortie de veille du PC. Je vais utiliser comme ça si ça va, sinon je reviendrai en 18.04

Hors ligne

#9 Le 14/12/2022, à 17:57

xubu1957

Re : [Résolu] Plantages de Lubuntu/Xubuntu sur Dell Latitude 7490

Bonjour,

Pour cet ordi, pour info > [Résolu] install sur dell inspiron 7490.

Le numéro est semblable, mais c'est pas le même modèle !

Dernière modification par xubu1957 (Le 14/12/2022, à 19:35)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne