Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 16/11/2006, à 11:04

Haplo

[Résolu] Probleme son : realteck (intel)

Bonjour.

J'ai réinstaller ubuntu, avec ma grande surprise, passé a une nouvelle version (ou sur mon laptop, le wifi marche... alors dual boot wink j'avais deja un ubuntu tanto, mais sur un fixe, et sur mon laptop le wifi ne marchais pas... donc j'avais laisser un peut tomber, et perdu un peut "la main" ^ [enfin bref, je m'égare])

Comme dit dans le titre : je n'ai aucun son.

le laptop est un Asus W7J, avec Ubuntu Edgy 6.10 wink

http://doc.ubuntu-fr.org/materiel/chips … da_realtek ceci ne marche pas, le fichier ALSA-Configuration.txt n'existe pas...... sad



quand je fait cat /proc/asound/card0/codec#0

Codec: Realtek ALC660
Address: 0
Vendor Id: 0x10ec0861
Subsystem Id: 0x10431205
Revision Id: 0x100340
Default PCM: rates 0x140, bits 0x0e, types 0x1
Default Amp-In caps: N/A
Default Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Node 0x03 [Audio Output] wcaps 0x405: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00 0x00]
  Power: 0x0
Node 0x04 [Audio Output] wcaps 0x405: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x80 0x80]
  Power: 0x0
Node 0x05 [Audio Output] wcaps 0x405: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x80 0x80]
  Power: 0x0
Node 0x06 [Audio Output] wcaps 0x405: Stereo Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x80 0x80]
  Power: 0x0
Node 0x07 [Audio Output] wcaps 0x605: Stereo Digital Amp-Out
  Amp-Out caps: N/A
  Amp-Out vals:  [0x00 0x00]
  Power: 0x0
Node 0x08 [Audio Input] wcaps 0x10051b: Stereo Amp-In
  Amp-In caps: ofs=0x02, nsteps=0x0d, stepsize=0x0b, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
  PCM: rates 0x140, bits 0x02, types 0x1
  Power: 0x0
  Connection: 6
     0x0d* 0x0c 0x0f 0x10 0x11 0x15
Node 0x09 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x0a [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x0b [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x081f: OUT HP Detect
  Pin Default 0x01214110: [Jack] HP Out at Ext Rear
    Conn = 1/8, Color = Green
  Pin-ctls: 0x40: OUT
  Power: 0x0
  Connection: 1
     0x16
Node 0x0c [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0837: IN OUT Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x20: IN
  Power: 0x0
  Connection: 1
     0x19
Node 0x0d [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x08337: IN OUT Detect
  Pin Default 0x01a1993e: [Jack] Mic at Ext Rear
    Conn = 1/8, Color = Pink
  Pin-ctls: 0x24: IN
  Power: 0x0
  Connection: 1
     0x18
Node 0x0e [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0817: OUT Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x40: OUT
  Power: 0x0
  Connection: 1
     0x19
Node 0x0f [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0833f: IN OUT HP Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x40: OUT
  Power: 0x0
  Connection: 1
     0x1a
Node 0x10 [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0833f: IN OUT HP Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x20: IN
  Power: 0x0
  Connection: 1
     0x1b
Node 0x11 [Pin Complex] wcaps 0x400001: Stereo
  Pincap 0x0863: IN
  Pin Default 0x99330130: [Fixed] CD at Int ATAPI
    Conn = ATAPI, Color = Unknown
  Pin-ctls: 0x00:
Node 0x12 [Pin Complex] wcaps 0x400301: Stereo Digital
  Pincap 0x0810: OUT
  Pin Default 0x99430120: [Fixed] SPDIF Out at Int ATAPI
    Conn = ATAPI, Color = Unknown
  Pin-ctls: 0x40: OUT
  Connection: 1
     0x07
Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x14 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x0d 0x10
Node 0x15 [Audio Mixer] wcaps 0x20050f: Stereo Amp-In Amp-Out
  Amp-In caps: ofs=0x0c, nsteps=0x17, stepsize=0x0b, mute=1
  Amp-In vals:  [0x12 0x12] [0x17 0x17] [0x00 0x00]
  Amp-Out caps: ofs=0x0c, nsteps=0x0c, stepsize=0x0b, mute=1
  Amp-Out vals:  [0x0c 0x0c]
  Power: 0x0
  Connection: 3
     0x11 0x14 0x1c
Node 0x16 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x03 0x15
Node 0x17 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x04 0x15
Node 0x18 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x05 0x15
Node 0x19 [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x06 0x15
Node 0x1a [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x80 0x80] [0x80 0x80] [0x00 0x00] [0x00 0x00]
  Connection: 4
     0x04 0x06 0x15 0x03
Node 0x1b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x80 0x80] [0x80 0x80] [0x00 0x00] [0x00 0x00]
  Connection: 4
     0x04 0x06 0x15 0x03
Node 0x1c [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-In vals:  [0x00 0x00] [0x00 0x00]
  Connection: 2
     0x0c 0x0f
Node 0x1d [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x1e [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x1f [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0817: OUT Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x40: OUT
  Power: 0x0
  Connection: 1
     0x18
Node 0x20 [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0817: OUT Detect
  Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
    Conn = 1/8, Color = Black
  Pin-ctls: 0x40: OUT
  Power: 0x0
  Connection: 1
     0x17
Node 0x21 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x22 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x23 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
  Amp-Out caps: ofs=0x0f, nsteps=0x0f, stepsize=0x0b, mute=1
  Amp-Out vals:  [0x8f]

et quand je fait lspci

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

avec amarok, les pistes semblent être "lu", et même les sons système je ne les ai pas donc....


ça fait deja deux jours que je bataille avec, mais bon, je n'ai pas envie de repasser sous windows juste car je n'ai pas de son....

merci
Stéphane

Dernière modification par Haplo (Le 16/11/2006, à 22:12)

Hors ligne

#2 Le 16/11/2006, à 11:13

zanoni

Re : [Résolu] Probleme son : realteck (intel)

Bonjour,

Est-ce que tu as essayé de lancer la commande alsamixer pour voir les volumes ?

Hors ligne

#3 Le 16/11/2006, à 11:50

Haplo

Re : [Résolu] Probleme son : realteck (intel)

non, mais je vien de le faire.

sous PCM, y a la barre qui "est dans le rouge" , avec un 100<>100
front y a 00, et pas de barre (meme pas le cadre)
CD 78<>78
Mic 100<>100
IEC958 y a MM
et Inmut so[ound?] y a Mic

voila... wink (je ne sais pas a quoi cela sert, je l'avoue wink )

Hors ligne

#4 Le 16/11/2006, à 12:01

powerpicton

Re : [Résolu] Probleme son : realteck (intel)

<troll>...mais pourquoi passez vous à edgy ?? roll </troll>

fait

sudo nano /etc/modules

et envoi nous le contenu du fichier...

pareil avec :

sudo nano /etc/modprobe.d/sound

ps: Avant toute chose...As tu une deuxième carte son ?

Dernière modification par powerpicton (Le 16/11/2006, à 12:02)


...Non je ne suis pas un Troll !! Je suis juste un peu poilu...
Config :- ubuntu - feisty fawn -AMD athlon 64 4400+ *2 -2 go de ram - Nvidia 8600 gt
Débutant Ubuntu ? allez ici --> http://forum.ubuntu-fr.org/viewtopic.ph … 98#p348298 ou là : http://www.microsoft.com/fr/fr/default.aspx ^^

Hors ligne

#5 Le 16/11/2006, à 12:07

Haplo

Re : [Résolu] Probleme son : realteck (intel)

euh, non, pas de deuxieme carte son, sur un laptop (ordinateur portable, excuser mon anglicisme hmm ) c'est un peux dure wink

sudo nano /etc/modules :

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
sbp2

sudo nano /etc/modprobe.d/sound :  fichier vide....

Hors ligne

#6 Le 16/11/2006, à 12:12

powerpicton

Re : [Résolu] Probleme son : realteck (intel)

je ne voudrais pas être désagréable, mais tu as vraiment lu et appliqué les explications de la page : http://doc.ubuntu-fr.org/materiel/chips … da_realtek

Parce que mon aide ne sera pas meilleur que cet article...


...Non je ne suis pas un Troll !! Je suis juste un peu poilu...
Config :- ubuntu - feisty fawn -AMD athlon 64 4400+ *2 -2 go de ram - Nvidia 8600 gt
Débutant Ubuntu ? allez ici --> http://forum.ubuntu-fr.org/viewtopic.ph … 98#p348298 ou là : http://www.microsoft.com/fr/fr/default.aspx ^^

Hors ligne

#7 Le 16/11/2006, à 12:37

Haplo

Re : [Résolu] Probleme son : realteck (intel)

oui, mais j'ai un probleme quand je le fait : mon fichier /etc/modprobe.d/sound est vide..... donc je ne peut pas aler a la ligne pour modifier la ligne wink

c'est pour cela aussi que je demande de l'aide wink

Edit : le fichier n'existe meme pas.... et pourtant, j'ai installer ALSA ... sad
Edit 2 : revérification : l'action sudo tar jxf /usr/src/alsa-driver.tar.bz2 ne change rien du tout... mais l'archive est bien la hmm

Dernière modification par Haplo (Le 16/11/2006, à 12:57)

Hors ligne

#8 Le 16/11/2006, à 12:56

powerpicton

Re : [Résolu] Probleme son : realteck (intel)

bon on va essayer un truc...

tu ouvres le fichier /etc/modprobe.d/alsa-base en root (avec kate sous kde, gedit sous gnome)

sous kde :

kdesu kate /etc/modprobe.d/alsa-base

et tu rajoutes (ou modifies je ne sais pas trop hmm)

options snd-hda-intel model=3stack

tu sauves...en suite tu redémarres !

je croise les doigts pour toi wink

Dernière modification par powerpicton (Le 16/11/2006, à 12:58)


...Non je ne suis pas un Troll !! Je suis juste un peu poilu...
Config :- ubuntu - feisty fawn -AMD athlon 64 4400+ *2 -2 go de ram - Nvidia 8600 gt
Débutant Ubuntu ? allez ici --> http://forum.ubuntu-fr.org/viewtopic.ph … 98#p348298 ou là : http://www.microsoft.com/fr/fr/default.aspx ^^

Hors ligne

#9 Le 16/11/2006, à 14:37

powerpicton

Re : [Résolu] Probleme son : realteck (intel)

ben alors !! pas encore testé ??
Qu'est ce que t'attends ?? Aller, hop,hop,hop !!!

tonguelol


...Non je ne suis pas un Troll !! Je suis juste un peu poilu...
Config :- ubuntu - feisty fawn -AMD athlon 64 4400+ *2 -2 go de ram - Nvidia 8600 gt
Débutant Ubuntu ? allez ici --> http://forum.ubuntu-fr.org/viewtopic.ph … 98#p348298 ou là : http://www.microsoft.com/fr/fr/default.aspx ^^

Hors ligne

#10 Le 16/11/2006, à 16:30

Haplo

Re : [Résolu] Probleme son : realteck (intel)

sorry, defois faut aller en cours big_smile (bon je l'acccorde, avoir cour de 1heure a 3 heure sa le fait pas, vaut mieu secher, mais bon.... ^^)

sinon, si j'ai tester. au reboot, horreur, les hopo crache un son strident et aigu, et sa fait "planter" le demarage, alors j'ai du passer par le live cd, monter la partoche et supprimé (enfin, mettre un # devant wink ) la ligne...

on va recommencer les test wink big_smile


Edit : bon au moins sa prouve qu'il est capable de sortir du son.... wink

Dernière modification par Haplo (Le 16/11/2006, à 16:35)

Hors ligne

#11 Le 16/11/2006, à 20:57

Haplo

Re : [Résolu] Probleme son : realteck (intel)

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2480

j'aimerai savoir comment effectuer le changement (appliquer le patch)

merci smile

Hors ligne

#12 Le 16/11/2006, à 21:59

Haplo

Re : [Résolu] Probleme son : realteck (intel)

bon, j'ai fait des test et avec un micro a moitier rentrer dans la prise du micro, avec ça, sa marche :

options snd-hda-intel model=3stack

y a moyen de désactiver le micro de manière "méchante" je veut dire par le désactiver, qu'il ne sois pas reconnu.. , en même temps je m'en fou du micro quoi..... big_smile

merci.

Dernière modification par Haplo (Le 16/11/2006, à 22:00)

Hors ligne

#13 Le 16/11/2006, à 22:03

Haplo

Re : [Résolu] Probleme son : realteck (intel)

Ok résolu.... encore un reboot pour voir si il n'y a pas de larcen au démarage (sa ne le ferai pas si j'arrive en cours et que je fout le bordel ^^ )

le volume du micro est beaucoup trop fort, donc sa fout la "merde"... wink

je reboot et je met résolu si cela marche.


Edit : c'est bon, j'ai supprimer toutes les methode d'aquisition de son, et y a pas un pet, sa marche nickel.

Merci a ceux qui m'on aider.
Stephane

Dernière modification par Haplo (Le 16/11/2006, à 22:11)

Hors ligne

#14 Le 18/11/2006, à 00:17

powerpicton

Re : [Résolu] Probleme son : realteck (intel)

cool, j'ai enfin réussi à aider quelqu'un !!!

lol big_smile

@+


...Non je ne suis pas un Troll !! Je suis juste un peu poilu...
Config :- ubuntu - feisty fawn -AMD athlon 64 4400+ *2 -2 go de ram - Nvidia 8600 gt
Débutant Ubuntu ? allez ici --> http://forum.ubuntu-fr.org/viewtopic.ph … 98#p348298 ou là : http://www.microsoft.com/fr/fr/default.aspx ^^

Hors ligne

#15 Le 24/11/2006, à 12:50

julius_

Re : [Résolu] Probleme son : realteck (intel)

Salut,

Je viens d'installer Ubuntu Edgy Eft et j'ai exactement le même problème que toi. Les fichiers qu'on t'a demandé de montrer le contenu sont exactement pareils chez moi et ton premier message ressemble à ce que j'obtiens aussi.

J'ai essayé d'ajouter la ligne dont vous parlez comme ceci dans le fichier alsa-base:

options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-hda-intel model=3stack

mais rien à faire, pas de son. Un truc bizarre, je double clique sur le haut parleur et je n'ai que lecture/capture et dans les préférences y'a que Volume général, PCM, enregistrement. Sous mon autre pc, y'a beaucoup plus que ca et je peux par exemple vérifier que le son sort sur le "line out" et pas sur le "line in" comme ca m'est déjà arrivé....

Help svp smile

#16 Le 24/11/2006, à 12:51

Julius

Re : [Résolu] Probleme son : realteck (intel)

Désolé j'étais pas loggé hmm

Hors ligne

#17 Le 24/11/2006, à 21:38

powerpicton

Re : [Résolu] Probleme son : realteck (intel)

essais un petit "sudo  update-modules"...peut etre un reboot derrière, sinon "sudo dpkg-reconfigure alsa-base", sinon, sinon c'est galère......

Tu peux peut-etre virer tout alsa, le réinstaller et le reconfigure à grand coup de "dpkg-reconfigure"... C'est dans le wiki, mais c'est chiant et je ne suis même pas sûr que tu ais un résultat sad

A tout hasard....gnome ou kde ??


...Non je ne suis pas un Troll !! Je suis juste un peu poilu...
Config :- ubuntu - feisty fawn -AMD athlon 64 4400+ *2 -2 go de ram - Nvidia 8600 gt
Débutant Ubuntu ? allez ici --> http://forum.ubuntu-fr.org/viewtopic.ph … 98#p348298 ou là : http://www.microsoft.com/fr/fr/default.aspx ^^

Hors ligne

#18 Le 24/11/2006, à 23:49

Julius

Re : [Résolu] Probleme son : realteck (intel)

C'est Gnome qui est installé...

J'essaye ca dimanche soir (ce n'est pas mon pc wink), merci de ta réponse !!!

Hors ligne

#19 Le 27/11/2006, à 20:14

Julius

Re : [Résolu] Probleme son : realteck (intel)

powerpicton a écrit :

essais un petit "sudo  update-modules"...peut etre un reboot derrière, sinon "sudo dpkg-reconfigure alsa-base", sinon, sinon c'est galère......

Aucun effet même après redémarrage. Mais je le répète, controleur de volume/editions/préférences, il n'y a que  "volume général", "PCM" et "enregistrement". Chez moi j'ai plein d'autres trucs !

Hors ligne