Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/12/2006, à 00:33

Tom_L

[Résolu] Disque SATA non reconnu lors de l'installation

Bonsoir à tous,

Une nouvelle machine à noël (un Fujitsu-Siemens Scaleo Pi1515-B63010), génial, sauf que...

Lors de l'install de Edgy le disque dur n'est pas reconnu, donc pas d'install possible hmm.

La carte mère est une MS-7293 avec southbridge VIA 8237A. En fouillant un peu sur le forum j'ai trouvé quelques infos, notemment les options à rajouter au démarrage :

noapic nolapic acpi=off irqpoll

Sans aucun effets chez moi... J'ai également testé l'Alternate CD: au moment de la detection des disques, l'installateur me propose de choisir un driver pour mon disque dur, mais le pilote VIA (ni aucun autre) ne donne rien...

D'après ce que j'ai compris le support du VIA 8237A devait être inclus dans le noyau 2.6.18. J'ai donc testé la Erd1 de Feisty (qui contient le noyau 2.6.19) mais ca ne donne rien, toujours les même résultats (testé avec les options au démarrage et avec l'Alternate CD)...

Suis-je condamné à rester sous XP ? sad
Si quelqu'un à une idée, je suis preneur...

Thomas.

Dernière modification par Tom_L (Le 01/01/2007, à 15:21)


~~~~~~
Thomas.

Hors ligne

#2 Le 31/12/2006, à 14:03

Tom_L

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Voilà ce que j'ai quand je fais un lspci:

ubuntu@ubuntu:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. Unknown device 0327
00:00.1 Host bridge: VIA Technologies, Inc. Unknown device 1327
00:00.2 Host bridge: VIA Technologies, Inc. Unknown device 2327
00:00.3 Host bridge: VIA Technologies, Inc. Unknown device 3327
00:00.4 Host bridge: VIA Technologies, Inc. Unknown device 4327
00:00.5 PIC: VIA Technologies, Inc. Unknown device 5327
00:00.6 Host bridge: VIA Technologies, Inc. Unknown device 6327
00:00.7 Host bridge: VIA Technologies, Inc. Unknown device 7327
00:01.0 PCI bridge: VIA Technologies, Inc. Unknown device b999
00:02.0 PCI bridge: VIA Technologies, Inc. Unknown device a327
00:03.0 PCI bridge: VIA Technologies, Inc. Unknown device c327
00:0f.0 IDE interface: VIA Technologies, Inc. Unknown device 5337 (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. [b]VT8237A[/b] PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCIE Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
02:00.0 VGA compatible controller: nVidia Corporation Unknown device 01d3 (rev a1)
04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
05:06.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)

Le bridge VIA 8237A a l'air d'etre reconnu, par contre toujours pas de disque dur visible.... et puis y'a un peu trop de Unknown device à mon gout... Je continue à chercher....

EDIT: je viens de réaliser quelque chose d'étrange: le lecteur DVD est lui bien reconnu, par contre pas de DD.

Dernière modification par Tom_L (Le 31/12/2006, à 14:06)


~~~~~~
Thomas.

Hors ligne

#3 Le 31/12/2006, à 14:59

Tom_L

Re : [Résolu] Disque SATA non reconnu lors de l'installation

J'ai du neuf:

Si je change SATA MODE de IDE à RAID dans le BIOS de la carte mère alors le disque est bien reconnu. Par contre j'ai aucune idée de ce que ca change, ni ce que c'est que le mode RAID.

Si quelqu'un s'y connait, je veux bien une petite explication sur ce mode RAID (j'aimerai surtout savoir ce que ca change, si ca ne va pas me poser d'autres problèmes)...

Merci,
Thomas.


~~~~~~
Thomas.

Hors ligne

#4 Le 01/01/2007, à 15:20

Tom_L

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Aucun problème avec le mode RAID, l'installation se déroule normalement...

Ce post s'est finalement résumé à un monologue, mais merci quand même à ceux qui s'y sont intéressé...

Thomas.


~~~~~~
Thomas.

Hors ligne

#5 Le 01/01/2007, à 15:55

tellmewhy

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Bonjour Tom_L,  TRÈS BONNE ET HEUREUSE ANNÉE 2007, pour tes Unknown device suite à l'utilisation de la commande lspci tu peux faire ceci :

sudo update-pciids

Retapes derrière "lspci" et admire la différence.
Là description se trouve dans cette mine d'or (le trésor de cep) :
http://www.cepcasa.info/divers
au chapitre "lspci et nouveaux materiels".:)

#6 Le 13/01/2007, à 11:08

Mojette

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Hello,

J'ai la meme config et le meme pb de reconnaissance du DD avec les distribs Linux. Dans ta maip, est-ce que winXP reste bootable ?
A+

#7 Le 13/01/2007, à 15:16

Tom_L

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Salut,

Je n'ai pas gardé XP, j'ai juste Ubuntu d'installé... Je peux pas te dire, désolé...


~~~~~~
Thomas.

Hors ligne

#8 Le 13/01/2007, à 21:58

Mojette

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Bonsoir,

Pour les DD en SATA sur motherboard avec chipset VIA, celui-ci n'est pas reconnu au boot => Ubuntu ne reconnait pas le DD dur sur lequel je voulais installer: ca gène pas mal ...
Si on reload les derniers descriptifs pci 'sudo update-pciids', c'est mieux car j'ai le chipset VIA au lieu de "unknown" avec la commande 'lspci'
Par contre, comme ca tourne toujours en ram, c'est bloquant pour redémarrer (car tout est volatile dans ce bas mode). Comment relancer le scan des bus en mode console ?
Je vais retenter les option au boot 'pci=noacpi' et 'acpi=force irqpoll'

Enfin, pour avoir testé, si on change le BIOS ca merde avec XP: le DD n'est pas vu, donc ca bloque rapide

Status: Ubuntu ca boote mais sans le disque: ca limite grave l'emploi.

#9 Le 15/01/2007, à 19:00

Williamm

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Salut,

Je crois que j'ai trouvé le forum de mes rêves !!!
J'ai le même Fujitsu-Siemens Scaleo Pi1515-B63010, que j'ai eu certainement moins cher, car pendant les soldes d'après Noël... mais bref.
Mon problème est donc le même disais-je, Ubuntu et Gparted ne reconnaissent pas le disque dur SATA en ntfs sur lequel est XP. Je souhaite conserver un double boot.
Concretement, j'ai aussi un peu de mal à saisir exactement ce qu'il est possible de faire pour un débutant moyen poursuivant l'objectif supreme qui est le mien (Ubuntu en double boot). Peut-on avoir un résumé des choses à faire ? Par exemple de la part de ceux qui ont réussis ;-)
Merci d'avance
William

#10 Le 16/01/2007, à 01:05

Tom_L

Re : [Résolu] Disque SATA non reconnu lors de l'installation

Tom_l a écrit :

Aucun problème avec le mode RAID, l'installation se déroule normalement...

Ce post s'est finalement résumé à un monologue, mais merci quand même à ceux qui s'y sont intéressé...

Thomas.

Comme je le dis précédemment, aucun problème (même après 2 semaines d'utilisation intensive) pour Ubuntu si tu changes le mode du disque dur de IDE à RAID (dans le Bios du pc).

Par contre:

Mojette a écrit :

Bonsoir,

Pour les DD en SATA sur motherboard avec chipset VIA, celui-ci n'est pas reconnu au boot => Ubuntu ne reconnait pas le DD dur sur lequel je voulais installer: ca gène pas mal ...
Si on reload les derniers descriptifs pci 'sudo update-pciids', c'est mieux car j'ai le chipset VIA au lieu de "unknown" avec la commande 'lspci'
Par contre, comme ca tourne toujours en ram, c'est bloquant pour redémarrer (car tout est volatile dans ce bas mode). Comment relancer le scan des bus en mode console ?
Je vais retenter les option au boot 'pci=noacpi' et 'acpi=force irqpoll'

Enfin, pour avoir testé, si on change le BIOS ca merde avec XP: le DD n'est pas vu, donc ca bloque rapide

Status: Ubuntu ca boote mais sans le disque: ca limite grave l'emploi.

ca à l'air de poser problème pour XP (ne boote plus). Je n'ai que Ubuntu d'installé sur ma machine, je n'ai donc pas testé, et ne peux pas essayer de régler le problème...

Désolé, je ne peux pas t'en dire plus...:(


~~~~~~
Thomas.

Hors ligne

#11 Le 16/01/2007, à 03:59

mrim972

Re : [Résolu] Disque SATA non reconnu lors de l'installation

bsr à tous ,
Ai eu ce pb avec une carte-mère ASUS M2V-TVM chipset K8M890 + southbridge 8237A (alors que la doc constructeur indiquait 8237R et Rplus). Vous me direz qu'est-ce que ça change ...eh bien voilà ... les chipset 8237, 8237R sont "buggués" et vont même jusqu'à ne pas reconnaître les disques SATA2 (cf maxtor ...il faut configurer les SATA2 en SATA1 avec un cavalier sur les HDD) ....Mais le 8237A est apparemment tout récent, en tout cas suffisamment récent pour ne pas être pris en compte par les noyaux de certaines distrib' ... c notamment le cas avec mandriva 2007 Free ...peut-être que la version payante n'a pas ce pb, slackware 10.1 et 10.2 idem  ...pas essayé la 11.0, la Suse 10.0 aussi...par contre avec FEdora 6 et Zenwalk 4.2 ça fonctionne parfaitement Vt 8237A + SATA2 !!
donc simplement un pb de mise à jour du noyau de vos distrib' ...faut chercher un patch ou se le faire soi-même sur le module du noyau 'sata_via' ...malheureusement je n'ai pas les liens, qui indiquent comment patcher les noyaux, sous la main ....
ah tiens ...j'ai  retrouvé un site ...pas facile ...mais ça marche apparemment ...j'ai  pas encore essayé sur la mandriva 2007 free : http://www.linuxquestions.org/questions/showthread.php?t=457355 ...reponse de jcliburn...
je vais essayer pour m'amuser, mais moi j'utilise zenwalk 4.2 téléchargé sur le site de quebecos ...et ça fonctionne impecc sous linux sans activer le mode RAID (g qu'un seul disque SATA2) ...(et çacontinue à fonctionner sous windows)

Si j'ai quelque chose de plus simple ...je le posterais ...

#12 Le 20/01/2007, à 22:09

williamm

Re : [Résolu] Disque SATA non reconnu lors de l'installation

La discussion me semble avoir été fructueuse sur ce forum

http://forum.telecharger.01net.com/telecharger/systemes_alternatifs/linux/probleme_reconnaisance_disque_dur_sata_resolue-394546/messages-1.html