Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 21/01/2007, à 18:55

happyusers

[RESOLU] Carte son ISA muette

Bonjour,
j'ai booté la version 6.10 sur un PC avec port ISA sur lequel j'ai une carte son SB16. J'ai suivi les conseils de Zergy mais n'ai pu aller au bout. J'ai configuré isapnp.conf et je l'ai testé, il est bon. En revanche, lorsque je cherche à charger le module snd-sb16 par Modprobe "sudo modprobe snd-sb16 io=0x220 irq=5", j'ai des erreurs, une collection de messages retrouvés dans dmesg du type :
[17181993.412000] snd_sb16: Unknown symbol snd_sb16dsp_interrupt
[17181993.412000] snd_sb16: Unknown symbol snd_mpu401_uart_interrupt
[17181993.412000] snd_sb16: Unknown symbol snd_sbmixer_read
[17181993.412000] snd_sb16: Unknown symbol snd_pcm_suspend_all
[17181993.412000] snd_sb16: Unknown symbol snd_sbmixer_suspend
[17181993.412000] snd_sb16: Unknown symbol snd_sb16dsp_pcm
[17181993.412000] snd_sb16: Unknown symbol snd_mpu401_uart_new
[17181993.412000] snd_sb16: Unknown symbol snd_opl3_hwdep_new
[17181993.412000] snd_sb16: Unknown symbol snd_sbdsp_reset
[17181993.412000] snd_sb16: Unknown symbol snd_sbdsp_create
Quelqu'un peut il me dire ce qu'il me reste à faire, c'est ma deuxième tentative pour passer à Linux et elle échoue avec cette fichue carte son!
Merci de vos lumières..

Dernière modification par happyusers (Le 08/02/2007, à 15:38)


Quand on a un marteau en main, tout problème ressemble à un clou

Hors ligne

#2 Le 25/01/2007, à 18:27

happyusers

Re : [RESOLU] Carte son ISA muette

A priori j'ai résolu le problème.
Pour installer le module snd-sb16 par modprobe, il faut connaitre les paramètres de la carte. J'ai relevé ceux-ci sur la configuration Win98.
Le problème est que le dma avait un mot-clé incorrect. On trouve sur pas mal de post les mots-clés dma0 et dma1 mais il faut, dans mon cas du moins, utiliser dma8 et dma16. Résultat, le mot dma1 qui provoquait l'erreur avait été stocké, suite à une première tentative, dans un fichier au fin fond de modprob.d/sound ou je ne sais quoi et toute nouvelle tentative, y compris avec les mots-clés corrects se soldait par un échec. Ce fichier corrigé, l'installation de snd-sb16 s'est passée comme sur des roulettes et j'ai du son.
# sudo modprobe snd-sb16 irq=5 io=0x220 dma8=1 dma16=5 ..
PS : je ne sais pas très bien quelle a été l'utilité de alsaconf que j'ai lancé à un moment. Est-il utile en cas d'installation de snd-sb16 manuelle?
Pourriez-vous me dire de quelle façon rendre le module résident au boot c'est à dire que mettre dans quel fichier (modules, modules.conf, conf.module,..)? (Ubuntu 6.10)
Merci


Quand on a un marteau en main, tout problème ressemble à un clou

Hors ligne

#3 Le 12/09/2008, à 18:21

thomas tototmk

Re : [RESOLU] Carte son ISA muette

Merci, cependant, je n'ai pas trouvé le fichier à modifier (sound...)
Où est-il ?

Merci