Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 12/08/2012, à 13:44

GwenArBreizhou

Pb de Multiboot non réglé par Boot-repair

Bonjour,
contrairement à mon espoir, boot-repair n'a rien réparé alors qu'il m'a bien dit "Le démarrage de l'ordinateur a été correctement réparé"

J'ai mis un message à boot.repair@gmail.com mais ce sont les vacances ;o))

Donc mon problème : Après une installation Live-CD, sur un deuxième disque (slave avec Windows XP sur le master), je ne pouvais booter que sur Windows (aucun passage par Grub ou un autre multiloader).
Depuis le live-CD, comme présenté ici,
http://forum.ubuntu-fr.org/viewtopic.php?id=509791
j'ai tenté la réparation mais maintenant, je n'ai plus accès à rien du tout.
Je me retrouve avec une invite grub rescue> que je fasse booter sur sda ou sur sdb comme cela m'avait été demandé à la fin de la réparation

http://paste.ubuntu.com/1141341/

Par contre, je ne sais pas si c'est en lien mais je n'ai eu aucune des fenêtres des options avancées pendant le processus de réparation. Boot-repair a effectué le travail sans que j'intervienne.

Que faire maintenant ?

D'avance merci de votre réponse,


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#2 Le 12/08/2012, à 14:33

Natix

Re : Pb de Multiboot non réglé par Boot-repair

Salut,

Essaye de réparer grub à la main à l'aide des commandes suivantes après avoir lancé un live usb sur ton pc:

sudo fdisk -l                      # pour vous aider à trouver la partition sur laquelle est votre ubuntu
sudo mount /dev/sdaX /mnt          # montage de celle-ci en remplaçant le X par le bon numéro de partition
sudo mount --bind /dev /mnt/dev    # lien symbolique du dossier /dev en cours d'utilisation vers le disque monté
sudo mount --bind /dev/pts /mnt/dev/pts   # lien symbolique du dossier /dev/pts en cours d'utilisation vers le disque monté
sudo mount --bind /sys /mnt/sys    # lien symbolique du dossier /sys en cours d'utilisation vers le disque monté
sudo mount -t proc /proc /mnt/proc # Pour que Grub2 trouve /proc/mounts
sudo chroot /mnt /bin/bash         # mise à la racine du disque monté
mount -a                           # montage des partitions dans le chroot
apt-get install grub-pc            # installation du logiciel Grub2 (sur le disque maintenant à la racine)
update-grub                        # création d'un nouveau fichier de configuration : grub.cfg
grub-install /dev/sda              # installation de grub sur le MBR

Lien source Ici

Cordialement

Natix

Hors ligne

#3 Le 12/08/2012, à 15:20

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Merci de ta réponse,
si je n'ai pas de Live USB, je peux faire de même avec un live CD ?

D'avance merci,


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#4 Le 12/08/2012, à 15:36

Natix

Re : Pb de Multiboot non réglé par Boot-repair

Bien sur aucun problème

Hors ligne

#5 Le 12/08/2012, à 18:48

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Et bien malheureusement, ça ne change rien ...

Et pour être précis, le message d'erreur est
Error : Out of disk
Grub rescue>

Par contre, la racine de linux étant sur sdb1, j'ai changé la deuxième ligne en
sudo mount /dev/sdb1 /mnt

Mais à la fin, j'ai hésité et finalement j'ai laissé l'installation de GRub sur le mbr du premier DD
grub-install /dev/sda

Ai-je bien fait ?

D'avance merci,


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#6 Le 12/08/2012, à 19:13

Korak

Re : Pb de Multiboot non réglé par Boot-repair

Bonjour,

Avec deux disques-dur, il vaut mieux faire comme ceci:

- Windows sur un disque-dur et la première partie de son lanceur dans le MBR de ce disque-dur --> apparemment sda sur ton PC.
- Ubuntu sur l'autre disque-dur et la première partie de son lanceur (GRUB) dans le MBR de ce disque-dur --> apparemment sdb sur ton PC.

Régler le BIOS pour démarrer en premier sur le disque-dur contenant Ubuntu.

Et ça roule ma poule.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#7 Le 12/08/2012, à 19:28

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Donc grub sur sdb, d'accord.
Sauf que maintenant que le lanceur de XP a été écrasé, comment je fais pour le réparer ???

D'avance merci,


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#8 Le 12/08/2012, à 20:25

Korak

Re : Pb de Multiboot non réglé par Boot-repair

Avec Windows XP, je ne sais pas trop.

Avec Windows Vista et Windows 7, il suffit de démarrer sur le DVD d'installation, de choisir la ligne de commande et d'entrer une commande.

Essaie avec boot-repair en ayant que le disque-dur de Windows branché.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#9 Le 12/08/2012, à 21:31

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Korak a écrit :

Essaie avec boot-repair en ayant que le disque-dur de Windows branché.

Dans quel but ?


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#10 Le 12/08/2012, à 21:34

Korak

Re : Pb de Multiboot non réglé par Boot-repair

Remettre la première partie du lanceur de Windows dans le MBR de son disque-dur.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#11 Le 12/08/2012, à 21:39

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Ok, je vais tester ça demain alors.

Et ensuite, tu me conseilles donc de reprendre la technique proposée par Natix mais en installant grub sur sdb ?


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#12 Le 12/08/2012, à 21:50

Korak

Re : Pb de Multiboot non réglé par Boot-repair

GwenArBreizhou a écrit :

Et ensuite, tu me conseilles donc de reprendre la technique proposée par Natix mais en installant grub sur sdb ?

Si tu as bien procédé, la première partie du lanceur de Windows est dans le MBR de sda.

Et la  première partie du lanceur d'Ubuntu (GRUB) est dans le MBR de sdb.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#13 Le 13/08/2012, à 00:59

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Bonsoir...

Korak a raison...

Mais tu peux essayer les opérations proposées  ci dessous , à faire avec les deux disques branchés...

En session live Ubuntu, avec Boot-Repair ...
_1) restaurer un mbr sur le disque /dev/sda ... en passant par les "Options avancées" ...
Onglet "Options principales" ==> cocher "Restaurer le MBR"
Cocher "Faire apparaître le menu de démarrage" ==> 10 s .
Décocher "Réparer les systèmes de fichiers".

Onglet "Options de MBR" ...
Restaurer le MBR de   => sda (mbr)
"Partition démarrée par le MBR" ==> çà va indiquer ==>  sda1 (Windows XP) ...

Onglet "Autres options".
Cocher "Placer le drapeau de démarrage sur" ==> sda1 (Windows  XP)
Décocher "Réparer les système de démarrage de Windows" (puisque le bootinfo indique tous les fichiers de boot sont bien dans la partition /sda1, pas besoin de réparer ) ...

Faire "Appliquer" récupérer et poster l'URL du bootinfo de l'opération stp...

Au reboot sur le hdd /dev/sda , la machine devrait rebooter directement sur Windows...
Si c'est bon...  Réinstallation de grub ...

_2)Toujours avec Boot-Repair,  en session live ,réinstallation de Grub sur le Ubuntu en /sdb1... (pourquoi la partition pour Ubuntu 12.04 est en ext2 ?... elle devrait être en ext4...Dommage... Il n'y a pas de journalisations des fichiers, mais çà marche quand même...)
En passant par les "Options avancées" ...
Onglet "Options principales" ...
cocher "Réinstaller Grub"
Cocher "Faire apparaître le menu de démarrage" ==> 10s
Décocher "Réparer le système de fichiers".

Onglet "Emplacement de Grub" .
"OS par défaut au démarrage" ==> sdb1 (Ubuntu 12.04)
"Placer Grub dans " ==> sdb

Onglet "Autres options"
Cocher"Placer le drapeau de démarrage sur" ==> sdb1 (Ubuntu 12.04) .
Décocher "Réparer les systèmes de fichiers" ...

Faire "Appliquer" ...  stp poster l'URL du bootinfo de l'opération ...

Faire booter la machine sur le hdd /dev/sdb , il devrait y avoir le menu Grub... Windows et Ubuntu devraient démarrer...

Si Ubuntu ne démarre toujours pas , refaire la réinstallation de Grub en utilisant en plus, l'Option ...

Onglet " Options de Grub" .
Cocher "Purger Grub avant de le réinstaller " faire "Appliquer" en suivant les indications... stp poster l'Url du bootinfo de l'opération ... Merci ...
Et nous dire si çà démarrer cette foi-ci...

Bon courage...

@ Korak ... Comme tu peux le constater , la réparation recommandée n'a pas fait les deux opérations en même temps comme il faut...

Çà n'a pas restaurer un MBR generic dans le secteur de boot de /dev/sda, et réinstaller Grub comme il faut sur /dev/sdb1 et /sdb ...
Pourquoi, ? je ne sais pas ...
Çà a réinstaller Grub sur les deux disques (secteur d'amorçage) ...
Donc on refait deux opérations avec BR,en passant par les options avancées, comme indiqué ci-dessus...

On va voir si çà marche...

@+.  Babdu89 .

Dernière modification par Babdu89 (Le 13/08/2012, à 17:53)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#14 Le 13/08/2012, à 12:56

YannUbuntu

Re : Pb de Multiboot non réglé par Boot-repair

bonjour
de retour de congés, désolé pour le retard.

Babdu89 a écrit :

Çà n'a pas restaurer un MBR generic dans le secteur de boot de /dev/sda, et réinstaller Grub comme il faut sur /dev/sdb1 et /sdb ...
Pourquoi, ? je ne sais pas ...

parce-que Gwen a indiqué que sdb n'est pas amovible. Voir http://forum.ubuntu-fr.org/viewtopic.ph … #p10355281 pour + d'infos

@Gwen:
- solution temporaire
pour accéder à Windows le temps de régler GRUB: restaurer un MBR générique dans sda comme indiqué par Babdu ci-dessus. (ou bien: faire la "Réparation recommandée" en indiquant disque amovible =OUI, et en réglant le BIOS pour démarrer sur sda)
- réglage de GRUB: tu as l'erreur "out-of-disk". Par mail tu m'as indiqué avoir essayé l'option "out-of-disk" de Boot-Repair, quelle était l'URL qui est apparue suite à cette opération?
- est-il possible de débrancher le disque Windows (pour être sur que le BIOS demarre sur le disque Ubuntu), puis re-essayer Boot-Repair avec et sans l'option "out-of-disk" ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#15 Le 13/08/2012, à 13:17

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

YannUbuntu a écrit :

@Gwen:
- réglage de GRUB: tu as l'erreur "out-of-disk". Par mail tu m'as indiqué avoir essayé l'option "out-of-disk" de Boot-Repair, quelle était l'URL qui est apparue suite à cette opération?

1142918

Et donc, je teste quoi ? Parce que là, j'ai pleins de solutions proposées ...

Je teste celles de babdu89 ou je file sur les propositions de Yann ?

D'avance merci,


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#16 Le 13/08/2012, à 13:58

YannUbuntu

Re : Pb de Multiboot non réglé par Boot-repair

déjà tu peux vérifier que tu as bien accès à Windows (cf "solution temporaire" de mon precedent message).

Ensuite, dis-moi si tu peux débrancher ton disque Windows stp. (si oui ça simplifiera les tests).


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#17 Le 13/08/2012, à 14:34

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Pas de soucis pour débrancher.

Je regarde pour Windows.


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#18 Le 13/08/2012, à 15:00

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Onglet "Autres options".
Cocher "Placer le drapeau de démarrage sur" ==> sda1 (Windows  XP)

Impossible à cocher celui-là ... grisé de chez grisé ...


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#19 Le 13/08/2012, à 15:08

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Donc OK pour Windows.

J'attends la suite des instructions ;o))

@u plaisir,


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#20 Le 13/08/2012, à 16:10

YannUbuntu

Re : Pb de Multiboot non réglé par Boot-repair

parfait. Reste à trouver une solution pour faire fonctionner GRUB.
à ta place j'essairais ceci:
1) debrancher le disque Windows, puis faire une "Réparation recommandée". Indiquer la nouvelle URL et si GRUB apparait (si oui, est-ce que Ubutnu demarre correctement) au redemarrage du pc.
2) debrancher le disque Windows, puis utiliser Boot-Repair avec l'option "out-of-disk" cochée. Indiquer la nouvelle URL et si GRUB apparait au redemarrage du pc.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#21 Le 13/08/2012, à 17:08

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Je viens de terminer la "Réparation recommandée" (1144975) mais une chose n'est pas claire dans tes derniers écrits.
Pour le reboot, je reste avec un seul DD ou je remets le windows aussi ?


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#22 Le 13/08/2012, à 17:14

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Bon je vais d'abord tester avec un seul DD et on verra ensuite ...


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#23 Le 13/08/2012, à 17:21

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Donc avec uniquement le disque Ubuntu, je me retrouve avec le message
error:no such partition
grub rescue>

Et si je remets sda, je file sur Windows sans passage par grub ...

Et maintenant ?

J'essaie la version 2 ?
2) debrancher le disque Windows, puis utiliser Boot-Repair avec l'option "out-of-disk" cochée. Indiquer la nouvelle URL et si GRUB apparait au redemarrage du pc.


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#24 Le 13/08/2012, à 17:38

compte supprimé

Re : Pb de Multiboot non réglé par Boot-repair

Aurais-tu un disque sata et un disque ide ?

#25 Le 13/08/2012, à 17:48

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Bonjour...
Je continue de suivre...
Qu'est-ce que c'est que ce "micmac" au niveau du boot... Il se fait sur deux partitions ta partitions système /sd*1  et ta partition /home /sd*5 ...

(1144975)

============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos5)/grub on this drive.

sda1: __________________________________________________________________________

    File system:       ext2
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 12.04 LTS
    Boot files:        /etc/fstab

sda2: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda3: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  Unknown
    Boot sector info: 

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        /grub/grub.cfg /grub/core.img

et dans ton "fstab" ...

=============================== sda1/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
UUID=1d16986f-d388-48d5-be61-47794374315f /               ext2    errors=remount-ro 0       1
# /home was on /dev/sdb5 during installation
UUID=d20c5aad-c58e-4de0-af72-b672f255790b /home           ext4    defaults        0       2
# swap was on /dev/sdb2 during installation
UUID=d220ec55-90af-45da-941d-c379d9de5da3 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
UUID=d20c5aad-c58e-4de0-af72-b672f255790b	/boot	ext4	defaults	0	2
--------------------------------------------------------------------------------

Pas étonnant que tu aies un message disant que la partition système n'est pas trouvée...

Il y a eu pas mal de "bricolage"  fait sur ton hdd Ubuntu...

Je ne serais pas étonné que Yann te conseille de faire une réinstallation de Grub , sur le hdd Ubuntu seul branché... En employant l'option "Purger Grub avant de le réinstallé" comme je l'indique post#13 ... bien sûr en remplaçant   ; sdb* par sda*  ...

Attendons de voir ce que dit Yann...

@+.   Babdu89   .

Dernière modification par Babdu89 (Le 13/08/2012, à 17:51)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

Haut de page ↑