Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#51 Le 14/08/2012, à 08:47

YannUbuntu

Re : Pb de Multiboot non réglé par Boot-repair

à ta place je deplacerais le contenu de sda2 vers sdb, puis j'essaierais d'installer Ubuntu dans sda2.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#52 Le 14/08/2012, à 10:27

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Tu veux dire sur le DD contenant XP ?
C'est que la partition fait une dizaine de Go seulement ...

Et si c'était un problème matériel sur le disque dur, Ubuntu me l'aurait dit à l'install, non ?

Est-ce que ma bécane est assez puissante pour la version 12 ?
Est-ce que je n'aurais pas intérêt à essayer une ancienne version ?


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#53 Le 14/08/2012, à 10:59

YannUbuntu

Re : Pb de Multiboot non réglé par Boot-repair

Tu veux dire sur le DD contenant XP ? --> oui
C'est que la partition fait une dizaine de Go seulement --> 16Go, c'est suffisant pour le système Ubuntu. Tu pourras mettre tes documents ailleurs si tu en as beaucoup.

Et si c'était un problème matériel sur le disque dur, Ubuntu me l'aurait dit à l'install, non ?  -> ça depend du probleme

Est-ce que ma bécane est assez puissante pour la version 12 ? -> oui, vu que tu as réussi à démarrer sur le CD
Est-ce que je n'aurais pas intérêt à essayer une ancienne version ? -> tu peux essayer, mais à mon avis il vaut mieux essayer d'abord d'installer 12.04 sur le DD de XP.

Dernière modification par YannUbuntu (Le 14/08/2012, à 10:59)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#54 Le 14/08/2012, à 11:58

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Bonjour...

Question... Est-ce que le chroot en session live, indiqué par Faustus, à été exécute toutes les partitions systèmes OS ,Ubuntu compris ,démontées... Le démontage des partitions à faire à partir de Gparted en session live avant de lancer le chroot...

@ Yann , si tu te rappelles, on avait eu ce problème ,pendant la mise au point des scripts de réinstallation de Grub ,par BR ... Un contributeur Anglais t'avais averti, qu'il fallait que les partitions systèmes soient démontées avant de lancer la procédure par chroot...

Après pendant l'update de Grub, tous les OS présents sur la config étaient trouvés et au menu Grub...

Je ne suis pas remonté assez haut dans les posts ... Qu'a donné la réinstallation de grub avec BR ,en utilisant l'Option " Purger grub avant de le réinstallé "  ?.

@+.  Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#55 Le 14/08/2012, à 12:54

compte supprimé

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Bonjour...

Question... Est-ce que le chroot en session live, indiqué par Faustus, à été exécute toutes les partitions systèmes OS ,Ubuntu compris ,démontées... Le démontage des partitions à faire à partir de Gparted en session live avant de lancer le chroot...

Tu ne peux pas faire un chroot toutes partitions démontées ! Celle du système dont tu prends le contrôle (en l'occurrence ubuntu sur le disque) est forcément montée ! Ensuite la commande grub-install /dev/sda ne fait qu'écrire un "mbr grub", donc pas sur une partition, mais dans le mbr du disque. Enfin update-grub s'exécute comme si tu le lançais depuis le ubuntu du disque. C'est même ça le but du chroot... Tu peux de même tranférer le net, et du coup, si tu fais un apt-get install, ça s'installe sur le système dont tu as pris le contrôle (ubuntu sur le disque) et non pas sur le système en live... Etc.
Evidemment, je pense que ça n'a pas fonctionné parce qu'en fait il aurait fallu monter la partition de boot en /mnt/boot avant de procéder. Mais bon, c'est dur de savoir qui est où quand on ne voit rien... En l'occurrence, grub, le noyau et tout ça, étaient certainement sur cette partition de démarrage. Et probablement il n'y avait rien dans /boot...

Dernière modification par faustus (Le 14/08/2012, à 12:56)

#56 Le 14/08/2012, à 13:08

YannUbuntu

Re : Pb de Multiboot non réglé par Boot-repair

oui, il faut que l'OS dans lequel on chroote soit monté, mais os-prober ne détecte pas certains OS si leurs partitions ne sont pas démontées. Exception faite de Fedora notamment.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#57 Le 14/08/2012, à 13:28

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Merci Yann, pour cette précision...

Qu'a donné la réinstallation de grub avec BR ,en utilisant l'Option " Purger grub avant de le réinstallé "  ?

Il y a la réponse post#38 .... Mais çà n'a rien changé... Et si j'ai bien suivi, notre Ami a réinstallé Ubuntu, et se retrouve encore avec le même message...

Est-ce que ce n'était pas les résidus d'installation dans le boot de la partition /sda5 qui perturbait le démarrage?...

http://paste.ubuntu.com/1145633/

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        /grub/grub.cfg /grub/core.img

@+.  Babdu89    .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#58 Le 14/08/2012, à 13:32

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Et si j'ai bien suivi, notre Ami a réinstallé Ubuntu, et se retrouve encore avec le même message...
.

Ce qui devient démoralisant ...


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#59 Le 14/08/2012, à 13:36

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Il y a un bootinfo de cette réinstallation?...

Parce-que si le résultat est le même... Une idée comme çà ... Télécharger une autre iso, faire un autre live, et tenter une nouvelle installation... On devrait savoir ce qui est en cause, machine ou iso... Non?...


@+.   Babdu89 ...

Dernière modification par Babdu89 (Le 14/08/2012, à 13:39)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#60 Le 14/08/2012, à 13:54

compte supprimé

Re : Pb de Multiboot non réglé par Boot-repair

GwenArBreizhou a écrit :
Babdu89 a écrit :

Et si j'ai bien suivi, notre Ami a réinstallé Ubuntu, et se retrouve encore avec le même message...
.

Ce qui devient démoralisant ...

Mais tu as repris les mêmes partitions, non ?
Personnellement je commencerais par supprimer toutes les partitions (donc choix "autre" au moment de l'étape de partitionnement), puis je ferais une partition ext4 de 10 Go pour le système (point de montage /), une swap, puis le reste du disque, ext4 (point de montage /home).

#61 Le 14/08/2012, à 13:57

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Oui, et faire une installation sur une partition système en ext4 et non ext2 ...
Peut-être en profiter aussi pour changer d'iso ....
@+.  Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#62 Le 14/08/2012, à 21:47

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

faustus a écrit :

Mais tu as repris les mêmes partitions, non ?

Non, j'ai laissé l'installateur tout refaire ...


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#63 Le 14/08/2012, à 21:51

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Oui, et faire une installation sur une partition système en ext4 et non ext2 ...
Peut-être en profiter aussi pour changer d'iso ....
@+.  Babdu89   .

Je suis en train de refaire l'install depuis la version "alternate" ...

On va bien voir ...

Par contre, une question que je me pose.
Est-ce normal que l'installateur voit mes disques comme SCSI (sda, sdb ...) alors que j'ai des IDE (hda, hdb quand j'étais petit ;o)) ?


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#64 Le 14/08/2012, à 22:10

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Par contre, une question que je me pose.
Est-ce normal que l'installateur voit mes disques comme SCSI (sda, sdb ...) alors que j'ai des IDE (hda, hdb quand j'étais petit ;o)) ?

Il me semble que çà fait déjà un bout de temps que tous les disques sont vu en "SCSI" sous Ubuntu ... J'ai des SATA et EIDE dans ma machine, et tout les disques sont nommés en /sd* ...
Est-ce que c'est normal, je ne sais pas ,mais c'est une évolution apparue avant que Grub2 (Grub PC) soit installé dans Ubuntu... Avec Grub Legacy, il me semble que les disque étaient en /hd*  dans le menu list... Est-ce du au fait que Grub 2 fonctionne avec les UUID des partitions ?... Possible ... A moins qu'il y aie une autre explication ... Mais en tout cas çà fonctionne bien.
Je vais regarder dans les docs,il me semble qu'on en parle quelque part...

Dommage que tu réinstalles avec "l'alternate" , plutôt qu'une autre iso desktop, çà risque de fausser l’appréciation du résultat, si çà marche sans message "out-of-disk"...

Si çà coince encore, là ,je ne sais plus que penser...

@+.  Babdu89 ...


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#65 Le 14/08/2012, à 22:20

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Dommage que tu réinstalles avec "l'alternate" , plutôt qu'une autre iso desktop, çà risque de fausser l’appréciation du résultat, si çà marche sans message "out-of-disk"...

Laquelle m'aurais-tu conseillée ?
Je ne suis plus vraiment à une install près ;o))


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#66 Le 14/08/2012, à 22:25

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Il me semble que çà fait déjà un bout de temps que tous les disques sont vu en "SCSI" sous Ubuntu

C'est que ça fait un bout de temps que je n'avais pas refait une install Linux ...
Ma première date de 1998 avec la RH 5.0 du temps où j'étais encore à la fac ;o))


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#67 Le 14/08/2012, à 22:27

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Toujours une 12.04, en desktop, mais en n'utilisant pas celle que tu as téléchargé, avec laquelle tu as fais ton live, qui ne veut pas s'installer correctement ... Juste pour voir ... Dis nous ce que çà donne avec l'alternate quand même si tu as installé ...

Et si tu veux donner ton lien de téléchargement d'iso qui génère le message d'erreur, je vais télécharger à mon tour, et tester...

@+.  Babdu89


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#68 Le 14/08/2012, à 22:31

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#69 Le 14/08/2012, à 22:33

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Ma première date de 1998 avec la RH 5.0 du temps où j'étais encore à la fac ;o))

Waou... çà date... la 5.0 ...
J'ai récupéré une iso ,faite avec par des Canadiens, dessus il y a une option de démarrage, pour faire booter les vieux Bios sur l'usb ,lorsque ce n'est pas possible...
j'ai un Pentium 1, avec un celoron 366 Mh dessus ,usb1 &&& Enfin un truc "moderne" tu vois..( à l'époque"...) Et bien j'arrive à faire démarrer des session live usb avec toutou Linux dessus...

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#70 Le 14/08/2012, à 22:34

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Merci ,téléchargement encours...

Lorsque ce sera fini, on comparera les MD5 si tu veux bien ...

Ah!!!  Au fait, sur ton disque de 40 Go, tu fais une installation personnalisée ("Autre chose" à l'étape "Allouer de l'espace disque") , ou bien tu laisses faire l'installateur en automatique sur tout le disque ?...

Dernière modification par Babdu89 (Le 14/08/2012, à 22:55)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#71 Le 14/08/2012, à 23:45

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Alors en effet, pour les réinstall, je laisse maintenant l'installateur gérer l'espace disque ...

Mais là, je viens de récupérer le même message Out of disk après l'install de l'aternate ;o((
Et comme j'y ai cru, je lui ai demandé d'installer grub sur sda et je n'ai de nouveau plus accès à Windows ...
Mais bon ça n'est pas trop grave ...

C'est par contre inquiétant en ce qui concerne mon ordi ...

Qu'est-ce qui peut bien lui arriver ?


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#72 Le 15/08/2012, à 00:37

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Stp ,peux tu poster un bootinfo de la dernière installation?...

@+.  Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#73 Le 15/08/2012, à 01:14

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Numéro 1147792


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

#74 Le 15/08/2012, à 02:18

Babdu89

Re : Pb de Multiboot non réglé par Boot-repair

Ah... Pourquoi avoir installer Grub sur le secteur d'amorçage du disque Windows /sda ...?
On installe Grub première partie dans le secteur d'amorçage du disque d’installation de Ubuntu /sdb ,la deuxième partie sur la partition système Ubuntu /sdb1..
Grub devrait être installer sur le même disque /dev/sdb ...

Avec Boot-Repair en session live, en passant par les Options avancées" ...
Il faut réinstaller Grub dans "OS par défaut au démarrage" ==> sdb1 Ubuntu 12.04) ....  "Placer grub dans " ==> sdb
Valider l'opération ... Récupérer l'URL du bootinfo

Relancer Boot-Repair pour restaurer un MBR generic  dans /sda ... Récupérer l'URL du boot info ...

Est ce que çà reboot correctement?...


Si çà ne reboot pas ...

Tente une nouvelle installation , avec une iso non alternate, en mettant Grub dans le secteur d'amorçage du disque Ubuntu : /dev/sdb ... Pas /sda ...

Après on pourra pensé a un problème matériel ...

Bon courage ...

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#75 Le 15/08/2012, à 02:41

GwenArBreizhou

Re : Pb de Multiboot non réglé par Boot-repair

Babdu89 a écrit :

Avec Boot-Repair en session live, en passant par les Options avancées" ...
Il faut réinstaller Grub dans "OS par défaut au démarrage" ==> sdb1 Ubuntu 12.04) ....  "Placer grub dans " ==> sdb
Valider l'opération ... Récupérer l'URL du bootinfo

1147884

Babdu89 a écrit :

Relancer Boot-Repair pour restaurer un MBR generic  dans /sda ... Récupérer l'URL du boot info ...

1147892

Babdu89 a écrit :

Est ce que çà reboot correctement?...

Je teste et je te dis ça ;o))


Le site du Festival Riv'en Zic : http://rivenzic.free.fr
Physique et chimie dans le secondaire et pour la préparation au CAPES : http://gwenaelm.free.fr/
Mes coups de coeur et mes coups de gueule : http://leblogdugwen.blogspot.com/

Hors ligne

Haut de page ↑