Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 19/09/2012, à 21:18

iGor.m

Installer Ubuntu sur Asus Vintage V7 - P8H61E

Je me permets d'ouvrir une discussion ici, parce que celle-ci http://forum.ubuntu-fr.org/viewtopic.php?id=1043041 ne donne rien et que je ne sais pas bien où est mon problème. Problème de démarrer une session LIVE ou d'installation à cause de l'EFI ?

La machine est une tour Asus Vintage V7 - P8H61E, avec un Intel Core i3-2130, au départ sans OS d'installé, avec un Asus UEFI Bios Utility qu'il est trop super beau. Mais impossible de démarrer une session LIVE, que ce soit avec l'iso francophone, l'iso internationale, en EFI, en 'normal', en CD ou en USB, et avec toutes les variantes que ces critères rendent possibles. J'ai soit un écran noir avec un curseur qui clignote, soit un écran où l'affichage est tout déstructuré, avec des vilaines lignes vertes, blanches, sur fond violet, noir.

Pour Ubuntu, le seul disque qui m'a permis quelque chose est l'Alternate. J'ai pu installer, j'ai d'abord essayer en normal, mais là j'ai un beau grub rescue au démarrage. J'ai essayé en EFI, en mettant une partition /boot/efi en FAT32 de 250 MB, mais déjà l'installateur de l'Alternate n'aime pas trop, il me dit qu'on va pas savoir sur quelle partition démarrer... Mais néanmoins l'installation est en cours...
[edit] Au démarrage, j'ai un bel écran violet, noir, avec des lignes vertes et noires, et incapable de rien n'y faire...

Seulement, j'ai pu installer une Fedora, sans problème, en mode graphique. Pas de problème au démarrage. Mais j'aimerais bien une Ubuntu.

Dernière modification par iGor.m (Le 20/09/2012, à 21:49)


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#2 Le 19/09/2012, à 21:38

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

En démarrant sur un System Rescue CD, j'ai pu confirmer que c'est bien un disque dur GPT. Et dans la partition /boot/efi qui est amorçable, il y a bien une arborescence qui /EFI/ubuntu/grubx64.efi (ou un truc du genre), mais je ne peut pas l'afficher. Après un cat, l'affichage de la console n'est plus utilisable...

Il faut que j'aille dormir. Mais c'est vraiment infernal ce truc.


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#3 Le 20/09/2012, à 10:34

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Ce matin, vu que je n'ai pas avancé dans ma compréhension du problème et que je n'ai pas acheté cette tour pour en faire une décoration, j'ai installé une fedora 17 dessus. Et j'apprends à l'utiliser.
Reste que c'est un choix par défaut, même si ça fait un moment que je voulais faire le saut sur une autre distribution. C'est tout de même étonnant d'être incapable de démarrer une session LIVE ou d'installer Ubuntu sur cette tour.

Par exemple, là une configuration assez proche est rangée sous 'Ubuntu/Linux system'.

Je précise la configuration de cette tour :
Asus Vintage V7 - P8H61E
Intel Core i3-2130 @3.40 GHz

et le retour de deux commandes, depuis l'installation Fedora que j'utilise actuellement :

uname -a
Linux asus 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug 29 18:46:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H61 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation Device 104a (rev a1)
01:00.1 Audio device: nVidia Corporation HDMI Audio stub (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
04:00.0 USB Controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
05:00.0 PCI bridge: ASMedia Technology Inc. Device 1080 (rev 01)

Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#4 Le 20/09/2012, à 13:06

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Bonjour

Le problème vient probablement du kernel de Precise (v3.2). Fedora utilise un kernel plus récent (3.5).
Pour le vérifier, essayez d'installer Quantal 64bit ( http://cdimage.ubuntu.com/daily-live/cu … -amd64.iso ). Elle contient v3.5 aussi.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#5 Le 20/09/2012, à 13:38

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Tout d'abord, un GRAND merci pour cette réponse, parce que je commençais à me sentir seul... smile

Ok, je vais déjà essayer de démarrer en LIVE avec Quantal 64 bits. De mes nouvelles plus tard, donc.

Encore merci.


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#6 Le 20/09/2012, à 14:14

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

J'ai pu démarrer en LIVE-USB (UEFI) sur l'Asus. Pendant le chargement du système, l'écran était pas beau à voir, mais ça a démarré. Après l'affichage était correct, beaucoup de signalement de bugs, mais pour cette version, j'imagine que c'est un peu normal, non ?
Maintenant quant à l'installer pour vérifier... comment dire ? Y a moyen de le faire sans bousiller l'installation de Fedora, sur laquelle pour l'instant je peux à peu près travailler ?


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#7 Le 20/09/2012, à 14:22

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

iGor.m a écrit :

J'ai pu démarrer en LIVE-USB (UEFI) sur l'Asus. Pendant le chargement du système, l'écran était pas beau à voir, mais ça a démarré. Après l'affichage était correct, beaucoup de signalement de bugs, mais pour cette version, j'imagine que c'est un peu normal, non ?

Oui car Quantal est encore en développement. Mais c'est le bon moment pour signaler un maximum de bugs sur Launchpad, afin qu'ils soient corrigés au + vite.

iGor.m a écrit :

Maintenant quant à l'installer pour vérifier... comment dire ? Y a moyen de le faire sans bousiller l'installation de Fedora, sur laquelle pour l'instant je peux à peu près travailler ?

1) sauver vos docs sur disque externe (ou DVDs) au cas où.
2) M'indiquer votre URL Boot-Info

Puis je vous guiderai pour l'installation.

Dernière modification par YannUbuntu (Le 20/09/2012, à 14:23)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#8 Le 20/09/2012, à 16:38

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Ok, j'étais sorti un moment.

Alors j'ai démarré sur le LIVE-USB de Quantal en EFI et j'ai suivi le tuto du pour le boot-info.
À la première fois, il m'a dit qu'il y avait un RAID (j'ai laissé Fedora s'occuper des partitions...) et m'a demandé si je voulais faire la commande suivante :

sudo apt-get install -y --force-yes mdadm --no-install-recommends

j'ai dit ok, mais suis quand même allé jusqu'au bout, ce qui donne l'URL suivante :
http://paste.ubuntu.com/1216794/

puis j'ai appliqué la commande et le nouveau boot-info est là :
http://paste.ubuntu.com/1216800/

Pour ce qui est des backup, c'est bon, j'en ai deux de secours, et c'est pas du luxe de nos jours smile


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#9 Le 20/09/2012, à 18:06

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Ton problème vient du fait que Fedora a créé un partitionnement de type LVM:

Number  Start   End     Size    Type     File system  Flags
1      1049kB  525MB   524MB   primary  ext4         boot
2      525MB   2000GB  2000GB  primary               lvm

Et dans le LVM:

Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/vg_asus-lv_root: 53.7GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system  Flags
1      0.00B  53.7GB  53.7GB  ext4


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/vg_asus-lv_swap: 10.5GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system     Flags
1      0.00B  10.5GB  10.5GB  linux-swap(v1)


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/vg_asus-lv_home: 1936GB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system  Flags
1      0.00B  1936GB  1936GB  ext4

Donc il te faudra:
- soit réduire le /home de Fedora dans le LVM, puis installer Ubuntu en LVM,
- soit réduire la partition LVM et installer Ubuntu normalement dans l'espace libre.

Remarque: Fedora n'est pas en mode UEFI, donc tu peux remplacer EFI par LVM dans le titre de cette discussion.

Dernière modification par YannUbuntu (Le 20/09/2012, à 18:08)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#10 Le 20/09/2012, à 19:25

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

J'avais mis EFI, parce que je croyais que c'était la raison qui faisait que je n'arrivais pas à démarrer de session LIVE.

Donc on ne peut pas savoir dès à présent si Quantal 64 sera capable de démarrer correctement, d'où l'idée de l'installer à côté ? C'est bien ça.

J'avoue que je suis un peu perdu là. Je ne sais plus que faire. Réduire la partition LVM me semble une option envisageable. On peut pas dire qu'il me manque de la place non plus, même si c'est pas pour rien que j'ai choisi un HD de cette taille.


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#11 Le 20/09/2012, à 19:47

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Je suis désolé d'apparaître un peu les bras ballants (en tout cas c'est comme je me sens). Si on récapitule :
1. Je voulais bien installer ubuntu sur cette machine, comme seul OS
2. Je ne suis pas parvenu à démarrer de session LIVE et l'installation par Alternate ne démarrait pas bien. C'était vraisemblablement par ce que cette carte mère/processeur exige un kernel récent. J'avais cru que c'était en rapport avec ce nouveau type de BIOS, l'EFI.
3. J'ai pu installer Fedora, 2 fois. La première fois, j'ai pu faire mes partitions comme j'en ai l'habitude : /, swap et /home. La deuxième fois, il me demandait une partition /boot, face à cette situation, nouvelle pour moi, je l'ai laissé faire les partitions, ce qui a abouti à ce LVM (une sorte de partition logique ?)
4. Tu finis par me permettre de démarrer en LIVE grâce à une iso récente de Quantal.

Là, en réalité je me pose la question comment le mieux faire. Si il y a une chance raisonnable que Quantal soit installable et utilisable, pourquoi ne pas essayer de l'installer tout seul ? Sinon, en effet, l'installer à côté est peut-être plus raisonnable, pour voir.


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#12 Le 20/09/2012, à 20:29

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Le plus simple est d'installer Ubuntu en utilisant l'option "Installer Ubuntu sur tout le disque".
Cela effacera Fedora.

Tu peux changer le titre en "Installer Ubuntu sur Asus Vintage V7 - P8H61E" stp.

Dernière modification par YannUbuntu (Le 20/09/2012, à 20:31)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#13 Le 20/09/2012, à 21:07

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Je suis donc parti dans cette direction. Installer sur tout le disque. Au moment de la configuration d'amorçage, il me dit qu'il ne peut pas le faire sur le disque /dev/sda qui est le seul dans la machine. J'ai d'abord pensé que c'était à cause des partitions existantes. Alors j'ai fait les partitions d'abord avec Gparted, puis j'ai recommencé l'installation sur mes partitions : /, swap et /home.
Mais de même, il n'est pas en mesure d'installer le chargeur d'amorçage, grub quoi.


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#14 Le 20/09/2012, à 21:30

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

J'ai essayé de redémarrer mais en UEFI cette fois pour installer, et en effet il me demande un partition EFI. Mais problème similaire, l'installateur plante au moment de la configuration de grub.

Dernière modification par iGor.m (Le 20/09/2012, à 21:41)


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#15 Le 20/09/2012, à 21:56

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

J'ai réessayé une installation Fedora. J'avais pas vu le bouton à décocher pour éviter le LVM. Par contre il a absolument voulu une partition de boot. Donc il y a 3 partitions primaires et une étendu, dans laquelle il y a le swap.
Le grub est installé, et au démarrage un uname -a m'indique un Linux asus 3.3.4-5.fc17.x86_64

[edit]On dirait que je fatigue, de la peine à me relire. Quoi qu'il en soit, encore merci pour l'aide. smile Désolé de ne pas être plus enthousiaste, mais je ne m'attendais pas à ces difficultés. J'aurais dû vraiment mieux m'informer, si possible...

Dernière modification par iGor.m (Le 20/09/2012, à 22:00)


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#16 Le 20/09/2012, à 23:24

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

iGor.m a écrit :

j'ai fait les partitions d'abord avec Gparted, puis j'ai recommencé l'installation sur mes partitions : /, swap et /home.
Mais de même, il n'est pas en mesure d'installer le chargeur d'amorçage, grub quoi.

Quel message d'erreur?
Il aurait fallu indiquer l'URL Boot-Info pour savoir la situation exacte...

iGor.m a écrit :

J'ai essayé de redémarrer mais en UEFI cette fois pour installer, et en effet il me demande un partition EFI. Mais problème similaire, l'installateur plante au moment de la configuration de grub.

Idem.

iGor.m a écrit :

J'ai réessayé une installation Fedora. J'avais pas vu le bouton à décocher pour éviter le LVM. Par contre il a absolument voulu une partition de boot. Donc il y a 3 partitions primaires et une étendu, dans laquelle il y a le swap.

Tu vas devenir un as des installations smile
Ce que tu peux essayer de faire, c'est installer Ubuntu via l'installateur manuel, en mettant GRUB dans la partition root d'Ubuntu.
Par exemple, si tu as mis la partition root d'Ubuntu dans la partition sda5, sélectionnes sda5 dans la liste déroulante sous 'device for bootloader installation':

partitionner_manuellement_avec_installateur_ubuntu_3.png?cache=

Dernière modification par YannUbuntu (Le 20/09/2012, à 23:24)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#17 Le 21/09/2012, à 07:12

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Hello,

Ce matin j'ai un rendez-vous important pour moi, je devrais remettre pas mal de choses à plus tard. Mais :
Dans le premier cas, le message d'erreur était : l'installateur n'est pas en mesure de configurer le chargeur d'amorçage sur ce périphérique : /dev/sda. Sélectionner un autre périphérique. Menu déroulant avec /dev/sda1, /dev/sda2, /dev/sda3. Aucun n'est accepté.
Là je peux soit installer sans le chargeur d'amorçage, soit annuler l'installation.
Dans le deuxième cas, l'installateur à planté, c'est lui qui me le dit comme ça, et je n'ai aucun choix. Au bout d'un moment l'écran devient noir, je peux passer en console pour redémarrer (par exemple).
Je vais essayer d'indiquer dans l'installateur manuel (que j'utilise de préférence pour faire mes partitions, afin de pouvoir réinstaller sans formater le /home) dans quelle partition installer le grub. On verra, mais je me dis que ça va être le même problème.

Question: quand je démarre sur la clé, dans l'EFI, je peux choisir de démarrer sur la clé avec un logo UEFI ou sans. Ça pose problème si je démarre plutôt sans ? Dans ce cas il ne me demande pas de créer une partition de boot EFI (et normalement il devrait vouloir y mettre le grub, non?)

Dans tous les cas, je ferais un boot-info, promis smile

Et je commence en effet à me débrouiller un petit peu question installation. Notamment dans l'utilisation de variantes de scripts de postinstallation (trouvées chez Nicolargo), que ce soit pour Ubuntu-Unity, Ubuntu-Gnome 3 ou Xubuntu. Évidemment pour Fedora, ça me prend plus de temps smile
Mais mes minces compétences me laissent assez démuni face à cette nouvelle situation smile

A plus tard...


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#18 Le 21/09/2012, à 09:06

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Attention, si tu veux installer un OS en mode UEFI (ou pas), il faut ensuite installer tous les autres dans le même mode.

- si Mode Legacy (non-EFI): il faut démarrer la clé en mode Legacy (non EFI), et installer GRUB dans /dev/sda

-si mode UEFI: il faut démarrer sur la clé en mode UEFI, formater ton disque en GPT via Gparted, et créer une partition EFI avant de lancer l'installateur Ubuntu.
Voir http://doc.ubuntu-fr.org/efi

N'oublie pas de m'indiquer ton URL Boot-Info à chaque fois que ça bloque ou avant de commencer une installation stp.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#19 Le 21/09/2012, à 11:35

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Le boot-info avant de faire quoi que ce soit aujourd'hui, donc avec une Fedora installée dessus :
http://paste.ubuntu.com/1218312

Puis je démarre en LIVE (legacy) sur la clé Quantal 64 de hier, et je procède à l'installation. Je choisis l'installation manuelle et partitionne comme suit :
/dev/sda1 = /
/dev/sda2 = swap
/dev/sda3 = /home
J'indique comme disque pour installer le grub /dev/sda1, et je lance la suite du processus d'installation.

Au moment de la configuration du chargeur d'amorçage, j'ai le message suivant :
"Échec de l'installation du chargeur d'amorçage.
Désolé, une erreur s'est produite. Il n'a pas été possible d'installer le chargeur d'amorçage à l'emplacement indiqué.
Comment souhaiteriez-vous procéder ?
Choisir un autre périphérique sur lequel installer le chargeur d'amorçage :
→ menu déroulant avec comme choix /dev/sda /dev/sda1 /dev/sda3
J'ai choisi /dev/sda et l'installation a repris. Revient au bout d'un moment la même fenêtre d'erreur. Là je choisis /dev/sda3, mais la fenêtre d'erreur réapparaît aussitôt.
Il reste comme choix :
- Continuer sans chargeur d'amorçage
- Annuler l'installation

Je choisis de continuer sans le grub. Apparaît une alerte qui me dit que "vous devrez installer manuellement un chargeur d'amorçage pour pouvoir démarrer Ubuntu (logique). Je dis OK. L'installation poursuit, jusqu'au message pour redémarrer. Je redémarre en pensant que ça allait démarrer sur la clé, mais même pas : écran noir et curseur clignotant.

Voici le boot-info après ces démarches:
http://paste.ubuntu.com/1218341

J'ai relancé pour voir boot-repair en faisant une réparation, ce qui a donné un message me disant que c'était réparé et une nouvelle url:
http://paste.ubuntu.com/1218343

Et je redémarre, et je vois bien un grub. Le premier choix est Ubuntu (j'ai pas bien vu la suite), et j'ai pu me logger. Je vais mettre à jour le système.

Il y a beaucoup de mieux, grâce à cet incroyable logiciel "boot-repair" !


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#20 Le 21/09/2012, à 12:03

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Suite.
Lors de l'installation des mises à jour, le gestionnaire de mise à jour reste figé sur "Configuration de grub-pc" et dans les détails, je ne vois rien d'affiché. Ne sachant pas que faire, j'ai voulu quitter l'update-manager, qui a quitté inoportunément. De là, plus possible de faire quoi que ce soit en rapport avec apt-get, "une autre ressource utilise le répertoire /var/...". J'ai notamment voulu ajouter le ppa du boot-repair, sans succès.

J'ai donc redémarré en LIVE et voici le boot-info :
http://paste.ubuntu.com/1218378

Ensuite j'ai procédé à une réparation via boot-repair :
http://paste.ubuntu.com/1218383

Et je redémarre sur la session Ubuntu, qui fonctionne.

[edit]
j'ai voulu installer le ppa pour boot-repair sur ma session Ubuntu. Lors du apt-get update, le processus s'est arrêté. J'ai été invité à utiliser la commande sudo dkpg --configure -a ce qui a aboutit à un message concernant grub-pc, me demandant où je voulais l'installer. J'ai choisi /dev/sda comme il me semble que boot-repair l'avait fait. Le processus a été jusqu'au bout sans problème apparent.
J'ai pu installer boot-repair. A tout hasard, je crée un rapport de boot :
http://paste.ubuntu.com/1218395

[edit] si je comprends bien ce qu'il s'est passé lors du sudo dpkg --configure -a, c'est que les mises à jour ont été faites ? Parce qu'ensuite, si je fait un sudo apt-get upgrade, il n'y a pas de mise à jour...

Dernière modification par iGor.m (Le 21/09/2012, à 12:36)


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#21 Le 21/09/2012, à 13:59

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Stop!
Il est temps de créer un rapport de bug !
Je ne peux pas le faire pour toi, mais je peux te guider:
1) démarre dans ta session Quantal installée
2) Connecte-toi à ton compte Launchpad (crée-en un si tu n'en as pas encore)
3) ouvre un terminal (Ctrl+Alt+T) et saisis la commande suivante:

ubuntu-bug ubiquity

Cela va collecter des infos sur ton installation.
4) dans le titre, mets "[quantal] Ubiquity fails to install grub-pc"
5) dans la description, traduis ton post #19 en anglais , et ajoute un commentaire de type "Original thread on ubuntu-fr: http://forum.ubuntu-fr.org/viewtopic.ph … #p10836481 "
6) valide la rapport de bug
7) indique-moi l'URL du rapport stp


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#22 Le 21/09/2012, à 14:43

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Étonnamment, je ne suis pas parvenu à me connecter à launchpad.net avec mon compte, via Firefox, même démarré sans addons. Mais j'ai pu le faire avec Epiphany, momentanément mon navigateur par défaut, pour la bonne cause.

Mon rapport de bug est là :
https://bugs.launchpad.net/ubuntu/+sour … ug/1054021

[edit] au passage, la commande ubuntu-bug ubiquity, fait bien tout, mais indique à la fin dans le terminal qu'il n'y a pas de paquet ubiquity. Je ne sais pas si c'est normal ou non.

Dernière modification par iGor.m (Le 21/09/2012, à 14:47)


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#23 Le 21/09/2012, à 17:22

YannUbuntu

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

iGor.m a écrit :

Étonnamment, je ne suis pas parvenu à me connecter à launchpad.net avec mon compte, via Firefox, même démarré sans addons. Mais j'ai pu le faire avec Epiphany, momentanément mon navigateur par défaut, pour la bonne cause.

il faudrait faire un rapport de bug pour ça wink

iGor.m a écrit :

Impeccable. Je l'ai mis un peu en forme.

iGor.m a écrit :

indique à la fin dans le terminal qu'il n'y a pas de paquet ubiquity.

c'est normal. Le paquet ubiquity n'est installé que dans le liveCD, pas sur une session installée.

Dernière modification par YannUbuntu (Le 21/09/2012, à 17:38)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#24 Le 21/09/2012, à 18:13

iGor.m

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Merci pour ton aide jusqu'ici, ainsi que la mise en forme du rapport de bug ! Très apprécié !


Sur Ubuntu depuis décembre 2009, et sous debian depuis avril 2013
Asus Vintage V7 - P8H61E - Intel® Core™ i3-2130 CPU @ 3.40GHz × 4 - 8Go RAM (dont 6 jamais utilisées :( ) - Debian Wheezy (64 bits) - Gnome 3.4
Lenovo Thinkpad X100E 3508-5GG - AMD Turion X2 Ultra Dual-Core 1.60GHz - 3Go RAM - Debian Wheezy (Xcfe)

Hors ligne

#25 Le 31/10/2012, à 21:38

ganix64

Re : Installer Ubuntu sur Asus Vintage V7 - P8H61E

Bonsoir,

Je viens de lire attentivement vos posts... je ne suis pas à ce niveau d'intervention.
Comme je l'ai signalé dans l'autre topic, je viens d'acheter un compaq CQ2910 AMD E1-1200 avec puce graphique radeon.
Là, le drame commence... découverte d'un nouveau bios et catastrophe UEFI.
Qu'est-ce que ce terme barbare ?
Aucun CD ou DVD live ne sont lus ! Pour l'instant je me vois condamné à utiliser W8.
J'ai découvert qu'il y avait maintenant des protections électroniques (certificats) ???
Je pense que mes commentaires ne vont pas vous avancer à grand chose dans votre quête.
Actuellement, je suis assez dégoutté d'être bloqué à ce niveau !
J'espère que dans un avenir très très proche, des programmeurs vont trouver une solution pour permettre à des non programmeurs comme moi à pouvoir utiliser des systèmes libres.
Salutation à tous.
:-)

Hors ligne

Haut de page ↑