Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 02/10/2012, à 18:35

cicitamos33

[Résolu] HPLIP | problème pour l'installation de dépendances.

Voulant faire fonctionner mon imprimante HP laserjet P1005 qui ne fonctionne plus depuis que j'ai migré vers Ubuntu 12.04 ( les impressions s'affichent mais rien ne se met en marche dans l'imprimante ), je suis allé voir sur le post de Pierguiar Installation de HPLIP 3.9.X sous 9.04, à 12.04, j'ai commencé à installer la version de hplip comme il l'indique ( hplip-3.10.9 ), et comme il l'indique aussi j'ai eu des dépendances à installer ( dont python devel, cups devel ), puis le terminal me demande d'installer libusb, et là je sèche. Quelqu'un a t-il une réponse ?
Voici ce qu'indique le terminal :

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a

Initializing. Please wait...


INTRODUCTION
------------
This installer will install HPLIP version 3.10.9 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Ubuntu 12.04.

Is "Ubuntu 12.04" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


ENTER USER PASSWORD
-------------------
Please enter the user (nguyen-minh)'s password:
Password accepted


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
warning: There are 4 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: This installer cannot install 'libusb' for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.

Dernière modification par cicitamos33 (Le 05/10/2012, à 11:59)

Hors ligne

#2 Le 02/10/2012, à 18:42

amj

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Bonjour
vous n'avez peut-être pas activer les dépôt universe

vous pouvez aussi-non le télécharger ici
http://pkgs.org/search/?keyword=libusb


Vive le logiciel libre !! Articles aléatoires sur Wikipédia sur les logiciels libre, sur linux.

Hors ligne

#3 Le 02/10/2012, à 18:57

PPdM

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Il y a des chances
Tu a pris la dernière version sur le site de hp ?
Normalement avec ton imprimante le Hplip fournit par défaut suffit.
avant de te casser la tête avec les dépendances essayes ceci

sudo apt-get remove hplip* --purge

puis

sudo apt-get autoremove

puis

sudo apt-get autoclean

reboot et

sudo apt-get install hplip

Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#4 Le 04/10/2012, à 10:37

cicitamos33

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Voilà j'ai reinstallé HPLIP comme tu l'as indiqué Pierguiar, mais je précise que avec la version de hplip fournie avec" ça ne marchait pas c'est pourquoi je suis allé sur ton post. Et la version de HPLIP que j'ai cherché sur hp n'est pas la dernière, mais celle que tu as indiqué dans ton fil.

dois je maintenant activer les dépôts universe ?. je suis allé voir dans le terminal pour éditer le fichier où se trouve la liste des dépots, et apparemment si si si ,Amj,  les dépôts universe y sont, sous le nom precise universe !!! C'est quoi le problème alors ?
Salut
Tâm

Dernière modification par cicitamos33 (Le 04/10/2012, à 11:06)

Hors ligne

#5 Le 04/10/2012, à 13:03

PPdM

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Tu ne risques rien a les activer, mais cela ne fonctionne toujours pas?


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#6 Le 04/10/2012, à 18:57

cicitamos33

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

donc : j'ai activé les dépots universes en allant chercher leur adresse dans la "source list", sur le terminal, que j'ai copié collé dans la logithèque>édition>sources de logiciels>autres logiciels>ajouter, mais non, l'imprimante ne marche toujours pas.
Donc je me suis dit qu'il fallait peut-être dèsinstaller HPLIP par défaut et re-suivre ta méthode avec le nouveau HPLIP, vu que j'ai ré-activé les depots universes, ça devrait marcher ?

Oulala...quel binz !

Hors ligne

#7 Le 04/10/2012, à 19:06

bahoui

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

bonsoir,

cicitamos33 a écrit :

donc : j'ai activé les dépots universes en allant chercher leur adresse dans la "source list", sur le terminal, que j'ai copié collé dans la logithèque>édition>sources de logiciels>autres logiciels>ajouter

pas comme ça . retourne le résultat de

 cat /etc/apt/sources.list

et

ls /etc/apt/sources.list

Dernière modification par bahoui (Le 04/10/2012, à 19:07)


Mettez [résolu] dans le titre quand le problème est réglé (cliquez sur "modifier" dans votre 1er message).

Hors ligne

#8 Le 04/10/2012, à 19:40

PPdM

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

cicitamos33 a écrit :

donc : j'ai activé les dépots universes en allant chercher leur adresse dans la "source list", sur le terminal, que j'ai copié collé dans la logithèque>édition>sources de logiciels>autres logiciels>ajouter, mais non, l'imprimante ne marche toujours pas.
Donc je me suis dit qu'il fallait peut-être dèsinstaller HPLIP par défaut et re-suivre ta méthode avec le nouveau HPLIP, vu que j'ai ré-activé les depots universes, ça devrait marcher ?

Oulala...quel binz !

Essayes d’abord avec kle HPLIP par defaut, ton imprimante est suffisamment ancienne, les dernières version de HPLIP n'apportent rien, a part le support des derniers modèles.


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#9 Le 05/10/2012, à 10:04

cicitamos33

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

excuse moi bahoui, en fait je suis plutôt novice, pour les dépots universe est-ce que tu me conseilles de juste aller dans le terminal et de mettre ces lignes de commandes ( post #7 ) ? c'est tout ?

Pierguiar, est ce que "kle HPLIP par défaut" est celui présent dans la logithèque ?

Merci à vous !

Hors ligne

#10 Le 05/10/2012, à 10:12

PPdM

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Oui, et ne t’inquiète pas nous sommes tous novices en quelque chose !


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

#11 Le 05/10/2012, à 10:33

alca94

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Bonjour
Pour activer les multiverse ,universes il faut aller dans "Paramètres système" ----> Sources de logiciels et cochez les cases
1349429440.png

Hors ligne

#12 Le 05/10/2012, à 11:51

cicitamos33

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

[résolu]
merci Pierguiar, j'aime bien cet esprit et c'est pour ça que j'ai opté pour Linux !!!

Donc... ne trouvant pas de solution j'ai carrément demandé à HP de m'en donner une, et ça a marché, et coilà comment j'ai fait

1. Hp m'a dit :
"HPLIP version 3.10.9 requires libusb-0.1 (libusb package) version, where
as in Ubuntu-12.04 , libusb-0.1 (libusb package) is not available and
upgraded libusb-1.0 (libusb-1.0-0 package) is available.

So please install latest HPLIP @ http://hplipopensource.com/hplip-web/in … index.html ( latest hplip supports libusb-1.0 ).
Note:- No need to uninstall older hplip package explicitly. Just run following command.

--> download hplip-3.12.10.run file to ~/Downloads folder.
$ cd ~/Downloads
$ sh hplip-3.12.10.run
--> Connect pinter
$ hp-setup

Traduction ( pour les nuls en english ) :  ça dit que hplip 3.10.9 a besoin de la dependance libusb-0.1, mais que dans ubuntu 12.04, libusb-0.1 n'est pas disponible, alors que libusb-1.0 y est ( disponible ). Du coup ils me conseillent de installer la dernière version de hplip 3.12.10, qui elle supporte libusb-1.0

2. Pour savoir comment télécharger et installer la dernière version de hplip 3.12.10, suivre ce lien

http://hplipopensource.com/hplip-web/in … index.html
Attention : mon imprimante est une HP Laserjet 1005, je ne sais pas si ça marche pour d'autres !
PS : à noter que au début, il faut remplacer "Desktop" par l'endroit où est contenu le hplip 3.12.10.run téléchargé dans vos fichiers, par exemple "Téléchargements" ...
Ensuite ça marche !!!!

Note :  par contre ça m'a occasionné un problème logiciel mais je sais pas encore à quel niveau, voici la capture d'écran qui a apparu :
capture

MERCI

Dernière modification par cicitamos33 (Le 05/10/2012, à 11:55)

Hors ligne

#13 Le 05/10/2012, à 12:47

PPdM

Re : [Résolu] HPLIP | problème pour l'installation de dépendances.

Oh pitaing !!  il va falloir que je fasse de nouveaux tests pour mettre a jour mon tuto, je te déteste !! lol


Linux n'est pas plus compliqué, il est différent.
GNU/Linux à Marseille Découvrir Marseille Ma librairie indépendante
Si vous pensez que le sujet du fil vous concerne, ne vous incrustez pas, postez une demande en donnant le lien de VOTRE fil

Hors ligne

Haut de page ↑