Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 04/10/2012, à 09:40

Racailloux

[résolu] sudo : Permission non accordée

Bonjour,

J'utilise souvent les discussions de ces forums pour m'aider à résoudre les problèmes que je rencontre, mais là pour le coup... je ne trouve pas de soucis équivalent.
Je souhaite monter un partage Samba sur une machine sous ubuntu 12.04 LTS (à jour). J'ai déjà réalisé cela il y a qq mois de cela et je veux rajouter un répertoire partagé de plus en auto-montage.

Lorsque je veux monter, il me réclame à juste titre un répertoire vers lequel monter le partage... mais là c'est le drame, impossible de créer un répertoire dans /media/ (alors que je l'avais fait il y a de cela un moment).
Vous pouvez admirer les droits de fou que j'ai alloué au répertoire qu'il appartient à "root" et que c'est "root" qui souhaite créer ce répertoire...

Pour info, j'ai pu créer le répertoire et monter le partage dans un autre répertoire que /media/ .... mais je veux essayer de laisser cela propre et mettre mes partages dans l'endroit prévu à cet effet... et puis je trouve bizarre que "root" n'ai pas les droits... qui les a dans ces cas là?

root@SheepyBuntu:/# sudo -i
root@SheepyBuntu:~# ls -al
total 36
drwx------  7 root root 4096 août  19 21:28 .
drwxr-xr-x 24 root root 4096 oct.   1 07:10 ..
-rw-r--r--  1 root root 3106 avril 19 11:15 .bashrc
drwx------  3 root root 4096 août  17 10:55 .cache
drwx------  5 root root 4096 août  17 10:56 .config
drwx------  3 root root 4096 août  19 21:23 .dbus
dr-x------  2 root root    0 sept. 30 11:52 .gvfs
drwxr-xr-x  3 root root 4096 août  17 10:56 .local
-rw-r--r--  1 root root  140 avril 19 11:15 .profile
-rw-------  1 root root 1024 août  19 21:29 .rnd
root@SheepyBuntu:~# ls -al /media/
total 4
drwxrwxrwx  4 root root    0 sept. 30 11:48 .
drwxr-xr-x 24 root root 4096 oct.   1 07:10 ..
dr-xr-xr-x  2 root root    0 sept. 30 11:48 documents
drwxrwxrwx  2 root root    0 sept. 30 11:48 photos
root@SheepyBuntu:~# cd /media/
root@SheepyBuntu:/media# mkdir test
mkdir: impossible de créer le répertoire «test»: Permission non accordée
root@SheepyBuntu:/media#

Dernière modification par Racailloux (Le 04/10/2012, à 19:00)

Hors ligne

#2 Le 04/10/2012, à 09:52

bbtux2

Re : [résolu] sudo : Permission non accordée

Chez moi, ça marche. N'aurait tu pas joué avec les acls

root@Acer:~# cd /media                                                                                                                                                                                     
root@Acer:/media# ls -la                                                                                                                                                                                   
total 8                                                                                                                                                                                                    
drwxr-xr-x  2 root root 4096 sept. 19 12:08 .                                                                                                                                                              
drwxr-xr-x 26 root root 4096 oct.   4 09:44 ..                                                                                                                                                             
lrwxrwxrwx  1 root root   45 mai   10 23:20 .directory -> /etc/kubuntu-default-settings/directory-media                                                                                                    
lrwxrwxrwx  1 root root   42 mai   10 23:20 .hidden -> /etc/kubuntu-default-settings/hidden-media
root@Acer:/media# mkdir ./test
root@Acer:/media# ls -la
total 12
drwxr-xr-x  3 root root 4096 oct.   4 09:45 .
drwxr-xr-x 26 root root 4096 oct.   4 09:44 ..
lrwxrwxrwx  1 root root   45 mai   10 23:20 .directory -> /etc/kubuntu-default-settings/directory-media
lrwxrwxrwx  1 root root   42 mai   10 23:20 .hidden -> /etc/kubuntu-default-settings/hidden-media
drwxr-xr-x  2 root root 4096 oct.   4 09:45 test
root@Acer:/# getfacl /media
# file: media
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
root@Acer:/# 

Hors ligne

#3 Le 04/10/2012, à 10:12

bbtux2

Re : [résolu] sudo : Permission non accordée

Ou plus simplement la partition montée en lecture seule.

Hors ligne

#4 Le 04/10/2012, à 11:25

Racailloux

Re : [résolu] sudo : Permission non accordée

Merci de vos réponses.

Voici le résultat de la commande sur la machine :

sheepy@SheepyBuntu:~$ getfacl /media
# file: media
# owner: root
# group: root
user::rwx
group::rwx
other::rwx

Je ne vois rien qui m’empêche d'avoir un root avec des droits? smile

Pour ce qui est du montage en ro, vous parlez de quel montage? du répertoire samba ou du disque de ma machine lui-même?

Hors ligne

#5 Le 04/10/2012, à 12:08

bbtux2

Re : [résolu] sudo : Permission non accordée

Si il est impossible de créer le répertoire depuis le serveur samba (Ce que j'ai cru comprendre), taper

bruno@Acer:~$ mount
/dev/sda6 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sda8 on /home type ext3 (rw)
/dev/sda7 on /usr type ext4 (rw)
bruno@Acer:~$

pour avoir la liste des montages.
Dans chaque ligne s'affichera en parenthèses les options de montages. rw pour lecture/écriture. (Et man mount si le problème vient de là).
Donne les commandes que  tu as utilisées pour effectuer le "montage du partage".
Ça peut paraître bête, mais vérifier si il reste de la place.
Si par contre, c'est depuis un "client", ton problème est certainement dû à une mauvaise conf de samba sur le serveur et/ou le client.
Le mieux serait de pouvoir tester d'un autre client. Chez moi sous kubuntu ça marche actuellement avec les partages sur ma box SFR,  Moins évident avec un serveur sous Mageia il y a un an.

Hors ligne

#6 Le 04/10/2012, à 19:00

Racailloux

Re : [résolu] sudo : Permission non accordée

Grâce à votre suggestion j'ai pu voir dans le retour de la commande "mount" une ligne concernant "gvfs-fuse-daemon"...
J'avais monté les répertoires déjà partagés à l'aide de AutoFS ...

Il m'a suffit d'aller éditer "/etc/auto.media" et de redémarrer le service...
Ceci explique aussi que AutoFS s'est réservé l'accès au répertoire, mais je trouve cela culotté smile

Merci de votre aide!

Hors ligne

Haut de page ↑