Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 01/04/2007, à 11:09

Arcane

[résolu]Probleme 7eme bouton de ma souris;)

Bonjour, alors je viens de suivre le tuto pour activer les boutons de ma intellimouse explorer  et me boutons suivant et précédent sur le coté fonctionnent nickel mais quand je veux me déplacer sur une page de haut en bas ma wheel/scroll (bouton du milieu) ca me fait un retour sur la page precedente ou sur la suivante. C'est inutile d'avoir 2x les même boutons et en plus ca me stresse parce que je suis habitué à me balader sur une page comme ca.
Pour l'instant j'utilise Alt+scroll pour me ballader mais c'est pas tres pratique(j'aimerais utiliser que le scroll)
Je précise que ca me fait cela que sur Firefox (nautilus est ok)
Je poste mes configs:

"^Firefox-bin$"
# Flip between browser tabs
None, Up, Alt_L|Left
None, Down, Alt_L|Right

"Nautilus"
# suivant/precedent
None, Left, Alt_L|Left
None, Right, Alt_L|Right
# Zoom
Control_L, Up, Control_L|KP_Subtract
Control_L, Down, Control_L|KP_Add
#Navigue entre les onglets du terminal
"^gnome-terminal"
None, Up, Control_L|Page_Up
None, Down, Control_L|Page_Down
"Rhythmbox" None, Up, Alt_L|Left
None, Down, Alt_L|Right
".*"
#None, Up, Alt_L|Left
#None, Down, Alt_L|Right

# Configuration file for setting imwheel startup parameters.

# Set this to "1" to make imwheel start along with your X session.
IMWHEEL_START=1

# Specify the command line parameters to pass to imwheel.
# Simply uncomment the bottom line, and if necessary replace
# the default options with your own. A button spec of "0 0 8 9"
# will grab the thumb buttons of most mice. "0 0 0 0 8 9" should
# work for mice with a scroll wheel with two axes. Keep in mind
# that each button number must be separated by a space.
#IMWHEEL_PARAMS='-k -b "0 0 6 7"'

et mon xorg

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ExplorerPS/2"
    Option         "Buttons"        "7"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "false"
    Option       "ButtonMapping" "1 2 3 6 7"
EndSection

Voila merci à vous d'avance++

Dernière modification par Arcane (Le 03/04/2007, à 11:43)

Hors ligne

#2 Le 03/04/2007, à 11:05

Arcane

Re : [résolu]Probleme 7eme bouton de ma souris;)

Ya personne qui connait la réponse?:(:(:(sniff

Hors ligne

#3 Le 03/04/2007, à 11:42

Arcane

Re : [résolu]Probleme 7eme bouton de ma souris;)

Bon bah merci quand meme à vous;)
J'ai résolu le probleme en virant le passage sur firefox dans ~/.imwheelrc

++

Hors ligne

#4 Le 01/05/2007, à 19:52

beleo

Re : [résolu]Probleme 7eme bouton de ma souris;)

Salut , je posséde également une souris optique Microsoft Intellimouse.
J'ai également installé imwheel mais mes fichiers sont quelques peut différents des tient.
Enfin , ils fonctionnes pour moi et les voici.

N.B. Avant toute modifications de fichiers , fais en une copie , pour pouvoir revenir en arriére , ci bessoin.

La section de mon /etc/X11/xorg.conf

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ExplorerPS/2"
    Option        "Buttons"    "7"
    Option        "ButtonMapping"    "1 2 3 6 7"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "false"
EndSection

le fichier /etc/X11/imwheel/startup.conf

# Configuration file for setting imwheel startup parameters.

# Set this to "1" to make imwheel start along with your X session.
IMWHEEL_START=1

# Specify the command line parameters to pass to imwheel.
# Simply uncomment the bottom line, and if necessary replace
# the default options with your own. A button spec of "0 0 8 9"
# will grab the thumb buttons of most mice. "0 0 0 0 8 9" should
# work for mice with a scroll wheel with two axes. Keep in mind
# that each button number must be separated by a space.
IMWHEEL_PARAMS='-k -b "0 0 6 7"'

le fichier ~/.imwheelrc

"^Firefox-bin$"
# Flip between browser tabs
None, Up, Alt_L|Left
None, Down, Alt_L|Right

"Nautilus"
# suivant/precedent
None, Left, Alt_L|Left
None, Right, Alt_L|Right
# Zoom[~/.imwheelrc

Control_L, Up, Control_L|KP_Subtract
Control_L, Down, Control_L|KP_Add

#Navigue entre les onglets du terminal
"^gnome-terminal"
None, Up, Control_L|Page_Up
None, Down, Control_L|Page_Down

"Rhythmbox"
None, Up, Alt_L|Left
None, Down, Alt_L|Right

".*"
#None, Up, Alt_L|Left
#None, Down, Alt_L|Right

Voila , cela marche chez-moi , chez toi aussi j'éspère.

Dernière modification par beleo (Le 01/05/2007, à 19:58)


Ubuntu 10.04 LTS.

Hors ligne