Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 01/04/2007, à 15:30

jorkar

[Résolu] Problèmes avec le driver radeon par défaut

Bonjour,

J'ai essayé Kubuntu Feisty en bêta sur mon Dell Inspiron 8600 (P-M 1,6GHz, ati radeon mobility 9600).
Le driver 3D libre (RV350) se charge, c'est une bonne nouvelle mais malheureusement l'affichage est vraiment dégueulasse:
1) il démarre en  1024*768 alors que mon matos est fait pour le 1280*800. De plus, il y a des traits horizontaux qui parcourent mon écran un peu comme quand on reçoit mal la télé hertzienne.
2) une fois démarré, je configure l'affichage en 1280*800 et là, catastrophe: par exemple la souris est un gros carré de la couleur du fond d'écran, les icônes s'affichent correctement seulement si je passe la souris dessus....

J'ai constaté qu'en faisant glxgears, j'avais avant l'affichage du nb de FPS l'erreur suivante

libGL warning: 3D driver claims to not support visual 0x4b

Comme indiqué sur le wiki, j'ai ajouté

Section "Extensions"
        Option "Composite" "disable"
EndSection

à xorg.conf. Il n'y a plus d'erreur avec glxgears mais l'affichage est toujours aussi nul.

J'ai aussi ajouté, comme indiqué sur le wiki:

Option "AccelMethod" "XAA" # Use XFree86 Acceleration Architecture
        Option "AccelDFS"    "1" # mettez à 0 si vous avez une carte AGP
#       Option     "AGPMode" "4" # Décommentez si vous avez une carte AGP
#       Option "AGPSize" "128" # Décommentez si vous avec une carte AGP AGP aperture size
        Option "GARTSize" "64"
        Option "RingSize" "8"
        Option "BufferSize" "2"
        Option "EnablePageFlip" "1" # Enable page flipping for 3D apps
        Option "ColorTiling" "1"
        Option "EnableDepthMoves" "yes"
        Option "UseFBDev" "false"
        Option "RenderAccel" "true" # Enable the hardware render acceleration
        Option "mtrr" "on"
        Option    "SubPixelOrder" "none"
        Option "DPMS"
        Option "DynamicClocks" "on"

mais ça ne donne rien de plus.

Est-il possible de désinstaller le driver radeon pour le driver mesa (2D)?
Quelqu'un d'autre a-t-il eu la même expérience que moi?

Je précise tout de suite que le driver radeon fonctionne très bien avec Kubuntu dapper.

Dernière modification par jorkar (Le 27/04/2007, à 23:20)


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#2 Le 01/04/2007, à 15:47

yostral

Re : [Résolu] Problèmes avec le driver radeon par défaut

jorkar a écrit :

Est-il possible de désinstaller le driver radeon pour le driver mesa (2D)?

Dans ton fichier xorg.conf, à la section Device, remplace radeon par vesa.


Quand tout le reste a échoué, lisez le mode d'emploi.

Hors ligne

#3 Le 01/04/2007, à 16:48

G-rom

Re : [Résolu] Problèmes avec le driver radeon par défaut

La liste des options pour le driver radeon est a adapté selon ta configuration, ne recopie pas l'exemple du wiki tel quel !!!
Sinon pour les problèmes d'affiche je pense que ça vient de ton écran de portable qui est mal détecté. Il faudrai que tu renseignes la fréquence horizontale et verticale dans ton xorg.conf.


Quand tu ne sais pas (cherche puis) demande, quand tu sais partage.

Hors ligne

#4 Le 13/04/2007, à 11:22

Jeff Joker

Re : [Résolu] Problèmes avec le driver radeon par défaut

Salut,

je vennais pour tenter d aider et en lisant le dernier post je ne suis dit :
Je ne sais pas trouver les frequence de mon ecran !!
du coup j utilise le parametrage simplifier de xorg.
J aimerais cependant bien savoir s il y a un moyen de mieux parametrer mon ecran !!

Merci d avance.

#5 Le 13/04/2007, à 11:24

ebrain

Re : [Résolu] Problèmes avec le driver radeon par défaut

J aimerais cependant bien savoir s il y a un moyen de mieux parametrer mon ecran !!

Oui, avec le manuel technique fourni avec ton écran, qui décrit ses spécifications.

Au cas où, la plupart des fabricants proposent aussi en général de télécharger ces petits manuels au format PDF sur leur site smile.

@+


Le Blender Clan, site communautaire francophone Blender :: www.blenderclan.org ::

Hors ligne

#6 Le 13/04/2007, à 12:38

Jeff Joker

Re : [Résolu] Problèmes avec le driver radeon par défaut

Justement si je demande c est parce que je n ai pas ce genre d infos
Il faudrait a la rigueur que je contact mon fournisseur mais vu que j ai un laptop, ils ne sont pas trop efficace sur ce genre de question !!!!
Je me demandais donc s il n y avait pas un autre moyen, par exemple un outil...

#7 Le 13/04/2007, à 13:46

lafourmie

Re : [Résolu] Problèmes avec le driver radeon par défaut

juste pour signaler que j'ai le même ordi que toi. hmm

Tu as peut être le même problème que j'ai eut. (je me sert d'ubuntu pas de kubuntu seule différence avec toi)

Essaye de voir sur mon post si ça peut t'aider. ( j'ai vue que tu y avais fait un tour.)

Hors ligne

#8 Le 21/04/2007, à 11:51

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

j'ai vu ton post: http://forum.ubuntu-fr.org/viewtopic.php?id=109787
J'installerais feisty lundi et je vous dis. Je compléterais le wiki ensuite.


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#9 Le 27/04/2007, à 23:17

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

Bonjour,

Voilà 2 jours que j'ai installé Feisty et j'ai bien galéré pour trouver la réponse... en faisant "man radeon"!
il fallait spécifier dans xorg.conf que j'ai un écran de portable c'est-à-dire rajouter dans la section Device:

        Option "MonitorLayout" "LVDS"

Et apparement, il ne sert absolument à rien de spécifier les fréquences de rafraîchissement etc...

Voici donc mon xorg.conf pour ceux que ça intéresse:

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"oss"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"stylus"	
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"eraser"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"		"cursor"
	Option		"ForceDevice"	"ISDV4"		# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"ATI Radeon 9600"
	Driver		"ati"
	BusID		"PCI:1:0:0"

        Option "AccelMethod" "XAA" # Use XFree86 Acceleration Architecture
        Option "AccelDFS"    "0" # mettez à 0 si vous avez une carte AGP
        Option 	"AGPMode" "4" # Décommentez si vous avez une carte AGP
#       Option "AGPSize" "128" # Décommentez si vous avec une carte AGP AGP aperture size
        Option "GARTSize" "64"
        Option "RingSize" "8"
        Option "BufferSize" "2"
        Option "EnablePageFlip" "1" # Enable page flipping for 3D apps
        Option "ColorTiling" "1"
        Option "EnableDepthMoves" "yes"
        Option "UseFBDev" "false"
        Option "MonitorLayout" "LVDS" # Ajoutez cette ligne si votre écran LCD présente une image baveuse
        Option "RenderAccel" "true" # Enable the hardware render acceleration
        Option "mtrr" "on"
        Option	"SubPixelOrder" "none"
        Option "DynamicClocks" "on"
	Option "DDCMode" "true"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Radeon 9600"
	Monitor		"Écran générique"
	DefaultDepth	24

	SubSection "Display"
		Depth		24
		Modes		"1280x800" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice     "stylus"	"SendCoreEvents"
	InputDevice     "cursor"	"SendCoreEvents"
	InputDevice     "eraser"	"SendCoreEvents"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Je vais de ce pas actualiser le wiki!

Je projette aussi d'installer Compiz, je reviendrais pour dire si ça fonctionne et sinon comment j'ai résolu mes problèmes.

Dernière modification par jorkar (Le 27/04/2007, à 23:39)


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#10 Le 28/04/2007, à 00:19

raspouille

Re : [Résolu] Problèmes avec le driver radeon par défaut

salut,
Pourquoi prendre le driver radeon ,alors que sous feisty ,il ya le "Gestionnaire de pilotes propriétaires" testé avec une ati radeon 9600 pro et une nvidia 7600 gs.Driver FGLRX plus rapide que RADEON.


Asus M51AC-FR034S && Linux Mint 17.1 Mate 64-bit (x86_64) GNU/Linux ...
Wiki.Mate-Desktop

Hors ligne

#11 Le 28/04/2007, à 01:28

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

~$ glxgears
10552 frames in 5.0 seconds = 2110.268 FPS
10914 frames in 5.0 seconds = 2182.609 FPS
10968 frames in 5.0 seconds = 2193.495 FPS
10781 frames in 5.0 seconds = 2156.043 FPS

Sachant que Beryl tourne en même temps, c'est pas mal non? tongue J'ai aussi installé planet-penguin-racer et il tourne nickel en 1280x800.

Sinon, ben moi je suis sous Kubuntu et le "gestionnaire de pilotes proprio" je ne l'ai vu nulle part. De toute façons, je préfère quand même utiliser le driver libre. Si, demain, ATI sort un driver buggé, moi je m'en brosserais pas mal. Et puis avec le driver proprio (fglrx), tu ne fais pas tourner AIGLX donc seulement XGL. Et avec XGL tu ne peux pas lancer de jeux... lol Donc au final, avec du libre, je fais plus de choses que toi avec du proprio! big_smile

Bon sinon oui j'ai installé Beryl parce que Compiz/Metacity sous KDE, c'est assez moche. Metacity dépend de GTK2... Bref.. J'ai juste suivi la procédure du wiki et ça roxe à mort!

Dernière modification par jorkar (Le 28/04/2007, à 01:36)


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#12 Le 28/04/2007, à 01:40

raspouille

Re : [Résolu] Problèmes avec le driver radeon par défaut

jorkar a écrit:

Sinon, ben moi je suis sous Kubuntu et le "gestionnaire de pilotes proprio" je ne l'ai vu nulle part. De toute façons, je préfère quand même utiliser le driver libre. Si, demain, ATI sort un driver buggé, moi je m'en brosserais pas mal.

Il n'y 'en a pas dans kde.
Le mieux, pour les drivers nvidia, c'est d'installer le paquet nvidia-glx ou nvidia-glx-new selon votre carte graphique, puis de modifier ton xorg.conf en changeant toutes les occurences de "nv" par "nvidia".


Asus M51AC-FR034S && Linux Mint 17.1 Mate 64-bit (x86_64) GNU/Linux ...
Wiki.Mate-Desktop

Hors ligne

#13 Le 28/04/2007, à 18:33

ncyshaolin

Re : [Résolu] Problèmes avec le driver radeon par défaut

Salut, j'ai le meme probleme que toi.
J'ai fait les changements que tu as fait mais rien ne marche. Ma resolution bug au dessus de 1024 avec les drivers libres. Mon xorg est:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	
	# path to defoma fonts
	Fontpath	"/usr/share/fonts/X11/misc"
	Fontpath	"/usr/share/fonts/X11/cyrillic"
	Fontpath	"/usr/share/fonts/X11/100dpi/:unscaled"
	Fontpath	"/usr/share/fonts/X11/75dpi/:unscaled"
	Fontpath	"/usr/share/fonts/X11/Type1"
	Fontpath	"/usr/share/fonts/X11/100dpi"
	Fontpath	"/usr/share/fonts/X11/75dpi"
	Fontpath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load		"i2c"
	Load		"bitmap"
	Load		"ddc"
	Load		"dri"
	Load		"extmod"
	Load		"freetype"
	Load		"glx"
	Load		"int10"
	Load		"vbe"
	Load		"type1"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "InputDevice"
	Identifier	"stylus"
	Driver		"wacom"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier	"eraser"
	Driver		"wacom"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Identifier	"cursor"
	Driver		"wacom"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
	Identifier	"Ecran generique"
	Option		"DPMS" "true"
	HorizSync 28-96
	VertRefresh 43-60
	DisplaySize 330 210
EndSection

Section "Device"
	Identifier   "ATI Radeon 9600"
   	Driver       "ati"
   	BusID        "PCI:1:0:0"
        Option 	     "AccelMethod" "XAA" # Use XFree86 Acceleration Architecture
        Option       "AccelDFS"    "0" # mettez à 0 si vous avez une carte AGP
        Option       "AGPMode" "4" # Décommentez si vous avez une carte AGP
#       Option       "AGPSize" "128" # Décommentez si vous avec une carte AGP AGP aperture size
        Option       "GARTSize" "64"
        Option       "RingSize" "8"
        Option       "BufferSize" "2"
        Option       "EnablePageFlip" "1" # Enable page flipping for 3D apps
        Option       "ColorTiling" "1"
        Option       "EnableDepthMoves" "yes"
        Option       "UseFBDev" "false"
        Option       "MonitorLayout" "LVDS"
        Option       "RenderAccel" "true" # Enable the hardware render acceleration
        Option       "mtrr" "on"
        Option       "SubPixelOrder" "none"
        Option       "DynamicClocks" "on"
   	Option       "DDCMode" "true"
	Option 	     "MonitorLayout" "LVDS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Radeon 9600"
	Monitor		"Ecran generique"
	Defaultdepth	24
	SubSection "Display"
		Depth	1
		Modes		"1024x768"	"800x600"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	4
		Modes		"1024x768"	"800x600"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	8
		Modes		"1024x768"	"800x600"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	15
		Modes		"1024x768"	"800x600"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	16
		Modes		"1024x768"	"800x600"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	24
		Modes		"1024x768"	"800x600"	"640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  	Screen		"Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	Inputdevice	"stylus"	"SendCoreEvents"
	Inputdevice	"cursor"	"SendCoreEvents"
	Inputdevice	"eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Merci de m'aider j'aimerais pouvoir utiliser AIGLX et le bureau 3D. Je sais que ca marche avec les drivers proprio ms j'ai pas envi de les utiliser.

HELP!

Hors ligne

#14 Le 28/04/2007, à 18:44

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

Donne ta config complète (fixe ou portable? carte graphique? écran si fixe?) et je pourrais t'en dire un peu plus!


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#15 Le 28/04/2007, à 18:51

ncyshaolin

Re : [Résolu] Problèmes avec le driver radeon par défaut

Je suis sur un portable dell Inspiron 8600 avec une ati radeon 9600. J'utilise l'écran de mon portable.

Hors ligne

#16 Le 28/04/2007, à 19:10

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

change ton xorg.conf par celui là j'ai enlevé les trucs inutiles et rajouté la bonne résolution

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
    
    # path to defoma fonts
    Fontpath    "/usr/share/fonts/X11/misc"
    Fontpath    "/usr/share/fonts/X11/cyrillic"
    Fontpath    "/usr/share/fonts/X11/100dpi/:unscaled"
    Fontpath    "/usr/share/fonts/X11/75dpi/:unscaled"
    Fontpath    "/usr/share/fonts/X11/Type1"
    Fontpath    "/usr/share/fonts/X11/100dpi"
    Fontpath    "/usr/share/fonts/X11/75dpi"
    Fontpath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load        "i2c"
    Load        "bitmap"
    Load        "ddc"
    Load        "dri"
    Load        "extmod"
    Load        "freetype"
    Load        "glx"
    Load        "int10"
    Load        "vbe"
    Load        "type1"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ImPS/2"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"    "/dev/psaux"
    Option        "Protocol"    "auto-dev"
    Option        "HorizScrollDelta"    "0"
EndSection

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "eraser"
    Driver        "wacom"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Identifier    "cursor"
    Driver        "wacom"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
    Identifier    "Ecran generique"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier   "ATI Radeon 9600"
       Driver       "ati"
       BusID        "PCI:1:0:0"
        Option          "AccelMethod" "XAA" # Use XFree86 Acceleration Architecture
        Option       "AccelDFS"    "0" # mettez à 0 si vous avez une carte AGP
        Option       "AGPMode" "4" # Décommentez si vous avez une carte AGP
#       Option       "AGPSize" "128" # Décommentez si vous avec une carte AGP AGP aperture size
        Option       "GARTSize" "64"
        Option       "RingSize" "8"
        Option       "BufferSize" "2"
        Option       "EnablePageFlip" "1" # Enable page flipping for 3D apps
        Option       "ColorTiling" "1"
        Option       "EnableDepthMoves" "yes"
        Option       "UseFBDev" "false"
        Option       "MonitorLayout" "LVDS"
        Option       "RenderAccel" "true" # Enable the hardware render acceleration
        Option       "mtrr" "on"
        Option       "SubPixelOrder" "none"
        Option       "DynamicClocks" "on"
       Option       "DDCMode" "true"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Radeon 9600"
    Monitor        "Ecran generique"
    Defaultdepth    24

    SubSection "Display"
        Depth    24
        Modes       "1280x800" "1024x768"    "800x600"    "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
      Screen        "Default Screen"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
    Inputdevice    "stylus"    "SendCoreEvents"
    Inputdevice    "cursor"    "SendCoreEvents"
    Inputdevice    "eraser"    "SendCoreEvents"
    Inputdevice    "Synaptics Touchpad"
EndSection

Section "DRI"
    Mode    0666
EndSection

Dernière modification par jorkar (Le 28/04/2007, à 19:11)


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#17 Le 29/04/2007, à 14:40

Cisubun

Re : [Résolu] Problèmes avec le driver radeon par défaut

Bon tout cela marche du tonnerre de dieu !

Juste une chose:
Etant donné que l'on est tous les deux sur des portables inspiron 8600 avec l'ATI M10, est ce que tu as un problème de rafraichissement malgrès tout cela ?

Je m'explique:
Bon j'ai un xorg.conf qui ressemble beaucoup au tien.
Plus de problème de rayure au milieu de l'écran (Merci d'ailleurs !!).

Mais :
Quand je lance une vidéo sur Totem ou VLC, l'écran de la vidéo est noire. Il me faut déplacer le lecture pour voir apparaitre l'image. Si je le retouche, hop l'image disparait... Obligé de recommencer le gris-gris (Je vais tester de ce pas avec Mplayer au passage).

Pareil quand je fais un petit : glxgears dans mon terminal,
Si je déplace l'écran de glxgears, il reste des traces de son passage partout ou je le déplace... Chose qui ne se produisait pas sur ma petite Edgy.

Si tu as des idées...


Sinon je vais de ce pas ré-installé compiz !

Hors ligne

#18 Le 29/04/2007, à 15:39

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

Oui j'ai le même problème de rafraîchissement mais franchement je ne trouve pas ça gênant du tout: quand je regarde un film, je le mets en plein écran et j'y touche plus.

Enfin j'ai quand même essayé avec les 2 lecteurs multimédias:
- vlc: je le déplace, plus d'image du tout.
- kaffeine (kde): je le déplace, l'image se déplace quand je relâche la barre de tire. Sinon, c'est assez marrant quand je le mets en plein écran et que je le déforme avec Beryl: tout se déforme, le lecteur lui même et les sous-titres mais pas la vidéo! Alors que quand je lis une vidéo en flash avec Firefox, la vidéo se déforme aussi!

Il faudrait essayer mais je n'ai pas le temps maintenant: rajouter la ligne

      Load        "v4l"

dans la section Module du xorg.conf. "v4l" signifie "video for linux" et je me demande si ce n'est pas en rapport avec ce problème.  A voir donc.

Edition: après une très brève recherche ça m'a l'air d'être fait pour les cartes TV.

Dernière modification par jorkar (Le 29/04/2007, à 15:42)


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#19 Le 30/04/2007, à 09:02

Cisubun

Re : [Résolu] Problèmes avec le driver radeon par défaut

Bon après test, v4l ne permet pas de corriger ce problème.

Je suis allé faire un tour sur le forum de DELL linux, et je n'ai rien trouvé de concluant...

Je planche toujours sur le xorg.conf !

Hors ligne

#20 Le 01/05/2007, à 12:39

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

En faisant glxgears dans une console et top dans une autre, je me suis rendu compte que glxgears bouffe 60 à 70% du temps processeur. Donc d'après la page du wiki, ce n'est pas bon...

Je vais aller voir dans les options à rajouter dans xorg.conf mais c'est tout de même un peu démoralisant....

Dernière modification par jorkar (Le 01/05/2007, à 12:40)


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#21 Le 12/10/2007, à 09:06

zerod

Re : [Résolu] Problèmes avec le driver radeon par défaut

Bonjour,
je profite du fait que j'ai le même portable que vous pour poser une chtite question, votre mise en veille de l'écran marche-t-elle correctement ? Chez moi si j'éteins la lumière dans la pièce je vois qu'il n'est en fait pas éteint, juste noir et sur les côtés je vois des halos de lumière...
merci d'avance

Hors ligne

#22 Le 12/10/2007, à 12:58

jorkar

Re : [Résolu] Problèmes avec le driver radeon par défaut

C'est pareil sur le mien. Mais bon, qu'est-ce qu'on peut y faire?


La géologie pétrolière se contrefout de votre envie ou besoin de conduire une automobile.
Jabber ID: jorkar@fritalk.com : http://presence.jabberfr.org/f63814f96538116bb64ff88adc81e548/text-fr.txt

Hors ligne

#23 Le 12/10/2007, à 13:45

zerod

Re : [Résolu] Problèmes avec le driver radeon par défaut

c'est justement ce que je cherche tongue

Hors ligne

Haut de page ↑