Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 03/12/2012, à 20:24

NoYzzY

[Mal résolu] J'ai cassé gnome en enlevant évolution

Bonsoir, je vous écris depuis un live-cd car j'ai flingué gnome en enlevant évolution (par la logitèque sad )
Toute aide m'évitant de ré-instaler est plus que bienvenue

(edit modo : merci de relire les règles du forum, notamment la partie sur l'utilisation du tag "urgent")

Dernière modification par slasher-fun (Le 07/03/2013, à 22:38)

Hors ligne

#2 Le 03/12/2012, à 20:26

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Je suis sous quantal et n'ai pas la possibilité d'ouvrir Unity ou une failback...

Hors ligne

#3 Le 03/12/2012, à 21:13

lann

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Il faut que tu réussisses à lire ton fichier /var/log/apt/history.log
Soit à partir du live cd ou par la console de récupération
Puis que tu réinstalles tous les paquets supprimés (ça devrait être le méta paquet gnome)

Hors ligne

#4 Le 03/12/2012, à 21:19

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Merci Iann pour ce début de piste.
Quelles sont les infos utiles dans history.log ?
Et surtout comment ré-installer gnome-panel depuis un liveCD?

Hors ligne

#5 Le 03/12/2012, à 22:13

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Pas de druides du code connectés ce soir?
Il doit bien exister un remede autre que la ré-installation.

Hors ligne

#6 Le 03/12/2012, à 22:52

lann

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

C'est un fichier texte qui te renseigne sur les dernières installations ou deinstallations que tu as fait
Pour pouvoir remettre ton système en état, il faut que tu boot sur ton système et que tu arrives sur la console

Bonne chance

Hors ligne

#7 Le 04/12/2012, à 10:20

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Bonjour, toujours depuis un live CD, j'ai un peu progressé mais suis toujours bloqué.

J'ai décidé de ré-installer gnome:

sudo apt-get install gnome

en ouvrant ma session en mode console. La totale, je vérifie que gnome-panel et gnome-shell sont bien installés.

Pour ce faire, depuis le live-CD, j'ai été modifier le fichier

/etc/x11/default-display-manager

en ajoutant # devant la seule ligne du fichier

/usr/sbin/lightdm

* info utile: Pour modifier les fichiers sur le SSD depuis le live cd en mode graphique, il faut ouvrir un terminal et taper

sudo nautilus

Je reboot et arrive enfin sur l'écran de connexion ou splashscreen (il me semble), j'ai réccupéré la possibilité d'utiliser gnome, gnome classique et Unity. Mais là où ça bloque, c'est que quand je tape mon Mdp, l'écran devient noir, prend deux seconde et revient sur le splashscreen, quel que soit mon choix (entre Gnome et Unity)

On avance  tongue

La je vais essayer de réinstaller

évolution - lightdm et gdm3

Si vous avez d'autres suggestions, ce serait un cadeau d'en haut car je suis dans la rédaction d'un livre que je devais terminer... aujourd'hui...

Coquin de sort...

Hors ligne

#8 Le 04/12/2012, à 10:41

A->

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

unity  --reset 

Hors ligne

#9 Le 04/12/2012, à 11:01

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Merci a->.

Avec cette commande  j'ai le retour suivant

warning: no DISPLAY variable set, setting is to: 0
ERROR: the reset option is now deprecated

Mais aussi: lorsque je tente de redémarer en mode graphique, je n'arrive même plus au splash (sans avoir rien modifié) et j'ai le message suivant:
[sdd] No caching mode page present
[sdd] Assuming drive cache: write trought

Je n'ai pas enlevé le # de la ligne:

/usr/sbin/lightdm

Pas évident...

Dernière modification par NoYzzY (Le 04/12/2012, à 11:10)

Hors ligne

#10 Le 04/12/2012, à 11:36

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Là, nouveau problème:

Depuis le live-usb de la version 12.10, je n'arrive pas à monter le SSD (mais bien les autres HHD)
De plus, lorsque j'essaye de booter en console pour éditer le fichier

/etc/x11/default-display-manager

J'ai le message suivant:

** (gedit2270): WARNiNG **: could not open x display

Je suis bloqué...

Hors ligne

#11 Le 04/12/2012, à 12:27

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Bon, pas de solution, pas de réponse significative... Je ré-installe en suivant la procédure suivante: Réinstallation
Dommage...

Hors ligne

#12 Le 04/12/2012, à 12:51

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

La (mes)aventure ne s'arrète pas là:

Après ré-installation, en conservant le /home, lorque j'arrive sur le splashscreen et que je mets mon mot de passe, écran noir puis retour sur le splashscreen...

J'en conclus que le fichier qui fait planter le démarrage est donc dans mon home.

Mais lequel et comment le réinitialisé?

Hors ligne

#13 Le 04/12/2012, à 13:47

NoYzzY

Re : [Mal résolu] J'ai cassé gnome en enlevant évolution

Finalement, j'ai ré-installer complètement /home compris et ai remplacé l'ensemble des fichiers du nouveau /home par les anciens, sauf ./gnome2
Il a fallu que je ré-installe lightdm et tout est à peu près rentré dans l'ordre...

Les druides du codes m'ont manqués...

Hors ligne

Haut de page ↑