Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 29/12/2012, à 16:19

h4ck.n3t

Pas de connexion ethernet

Bonjour à tous,

Un petit problème assez génant : je viens d'acquérir un pc portable lenovo (G780) et ma carte réseau ethernet n'as pas l'aire de vouloir fonctionner... Sous ubuntu. Car sous windows 7, pas de soucis. De plus,  ma connexion WiFi est parfaite, tant sous win que linux.

Voici un petit ifconfig :

br0       Link encap:Ethernet  HWaddr ba:73:87:03:bc:ac  
          inet adr:192.168.0.2  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::b873:87ff:fe03:bcac/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:39 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:0 (0.0 B) Octets transmis:7872 (7.8 KB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:487 erreurs:0 :0 overruns:0 frame:0
          TX packets:487 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:43140 (43.1 KB) Octets transmis:43140 (43.1 KB)

wlan0     Link encap:Ethernet  HWaddr 74:e5:43:4a:47:28  
          inet adr:192.168.0.121  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::76e5:43ff:fe4a:4728/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:1492 erreurs:0 :0 overruns:0 frame:0
          TX packets:1491 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:926623 (926.6 KB) Octets transmis:466197 (466.1 KB)

Première chose qui me pose question : pourquoi mon ethernet est en br0 et pas eth0 comme par défaut ? Et ensuite, pourquoi ma connexion ne marche pas, à telle point que si je vais de manière graphique dans "modifier les connexions", je ne la voit même pas dans "Connexion Filaire" (qui est vide du reste) ?

D'avance merci.


Ce n’est pas parce que un chemin prend la direction que l’on souhaite, qu’il nous amène où l’on veut.
Trouver des défauts à windows, c'est comme faire une division par zéro : c'est infini...

Hors ligne

#2 Le 29/12/2012, à 22:11

PascalHambourg

Re : Pas de connexion ethernet

ifconfig -a pour afficher toutes les interfaces, sinon ifconfig n'affiche que les interface actives.
La sortie de lspci -nnk peut aussi être utile.

br0 est habituellement le nom d'un pont ethernet ("bridge"), qui sert à lier plusieurs interfaces comme un switch virtuel. C'est assez souvent utilisé en relation avec la virtualisation, pour permettre aux machines virtuelles d'avoir accès au réseau local.

J'observe une anomalie : br0 et wlan0 ont des adresses IP dans le même sous-réseau.

Hors ligne

#3 Le 29/12/2012, à 22:53

h4ck.n3t

Re : Pas de connexion ethernet

Hum bizare en effet... br0 est peut-être dut au pont que j'ai tenté de faire via virtualbox.

Ifconfig -a me retourne la même chose, quand à lspci -nnk :

00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
	Subsystem: Lenovo Device [17aa:3977]
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: i915
	Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: mei
	Kernel modules: mei
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: ehci_hcd
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd-hda-intel
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: ehci_hcd
00:1f.0 ISA bridge [0601]: Intel Corporation HM76 Express Chipset LPC Controller [8086:1e59] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel modules: lpc_ich
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel modules: i2c-i801
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 630M] [10de:0de9] (rev a1)
	Subsystem: Lenovo Device [17aa:3901]
	Kernel modules: nouveau, nvidiafb
02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8162 Fast Ethernet [1969:1090] (rev 08)
	Subsystem: Lenovo Device [17aa:3979]
03:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
	Subsystem: Lenovo Device [17aa:31a1]
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Ce n’est pas parce que un chemin prend la direction que l’on souhaite, qu’il nous amène où l’on veut.
Trouver des défauts à windows, c'est comme faire une division par zéro : c'est infini...

Hors ligne

#4 Le 29/12/2012, à 23:14

PascalHambourg

Re : Pas de connexion ethernet

Visiblement ton noyau n'a pas de pilote pour ce contrôleur ethernet AR8162.
Fais une recherche dans le forum avec AR8162, tu trouveras notamment :
http://forum.ubuntu-fr.org/viewtopic.php?pid=11976031

Hors ligne

Haut de page ↑