Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 30/12/2012, à 19:04

degolarson

Wine ne lance pas squid.exe

bonjour
j'ai installé avec Wine le logiciel de réception de fichiers météo Squid http://www.greatcircle.be/grib-viewer/what-is-squid/
apparemment tout s'est bien déroulé, Squid est présent dans la liste des applications et j'ai mis un lanceur dans le tableau de bord mais voilà rien ne démarre, aucun signal
le fichier setup.exe est dans Téléchargements et les fichiers installés dans /home/joel/.wine

ai-je fait une erreur ? wine prend il en compte tous les .exe ?
merci


xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#2 Le 30/12/2012, à 19:29

degolarson

Re : Wine ne lance pas squid.exe

suite
après avoir essayé d'ouvir encore une fois j'ai vu une fenêtre "chemin introuvable" alors j'ai replacé le dossier Squid dans Téléchargements
mais ça ne change rien
incidemment j'ai fait tourner Squid sous xp sans problème , donc le fichier .exe est bon
j'ai essayé aussi

~$ squid
Commande 'squid' non trouvée, vouliez-vous dire :
 La commande 'squid3' du paquet 'squid3' (main)
squid : commande introuvable

squid3 c'est une histoire de proxy je verrai ça plus tard

Dernière modification par degolarson (Le 30/12/2012, à 21:31)


xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#3 Le 02/01/2013, à 14:07

degolarson

Re : Wine ne lance pas squid.exe

bonne année, et suite du précédent

~$ wine squid
wine: cannot find L"C:\\windows\\system32\\squid.exe"
joel@joel-K70IJ:~$ 

xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#4 Le 02/01/2013, à 14:15

serged

Re : Wine ne lance pas squid.exe

Il est mentionné "Nécessite .NET 3.5 SP1". L'as-tu installé ?

Note : il faut lancer la ligne de commande depuis le répertoire d'installation du logiciel. Du genre :

cd "~/.wine/Program Files/squid/"
squid

(vérifier les chemins...).


Linux-Mint Qiana 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#5 Le 02/01/2013, à 16:21

degolarson

Re : Wine ne lance pas squid.exe

Mono runtime est installé depuis juillet dernier
j'ai l'impression que le fichier squid.exe (ou même le setup ? pourtant squid est bien dans les appli ) n'est pas là où il faudrait

cd "~/.wine/Program Files/squid/"
bash: cd: ~/.wine/Program Files/squid/: Aucun fichier ou dossier de ce type
joel@joel-K70IJ:~$ 

de mémoire, quand j'ai installé squid une fenêtre m'a proposé de le mettre dans program files mais j'ai dû le mettre ailleurs parceque je croyais que Ubuntu n'avait pas accès à la partition qui contient xp
pour l'installer dans xp j'ai simplement fait un copiécollé du fichier setup depuis téléchargements dans la partition d'échange HD data puis après reboot sous xp dans le bureau xp
faudrait il refaire la manip ou replacer le fichier ?


xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#6 Le 02/01/2013, à 16:33

degolarson

Re : Wine ne lance pas squid.exe

suite
voici le chemin de squid.exe tel que je viens de le replacer
/home/joel/.wine/dosdevices/c:/Program Files/Squid/bin/squid.exe

~$ cd "~/.wine/Program Files/squid/bin/squid/"
bash: cd: ~/.wine/Program Files/squid/bin/squid/: Aucun fichier ou dossier de ce type
joel@joel-K70IJ:~

merci

Dernière modification par degolarson (Le 02/01/2013, à 16:41)


xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#7 Le 02/01/2013, à 19:29

serged

Re : Wine ne lance pas squid.exe

Il faut faire attention à la casse ! (=différence majuscule/minuscule). Le plus simple est d'utiliser la complétion du bash avec la touche tabulation, de faire des ls etc.

Je viens de l'installer sous un "vrai" Windows:
Le raccourci donne :
- Exécutable dans "C:\Program Files\Squid\bin\Squid.exe"
- Démarrer dans "C:\Program Files\Squid\Prerequisites"

Il faut donc faire un :

cd "~/.wine/Program Files/Squid/Prerequisites"
wine "~/.wine/Program Files/Squid/bin/Squid.exe"

Linux-Mint Qiana 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#8 Le 03/01/2013, à 11:49

degolarson

Re : Wine ne lance pas squid.exe

bonjour serged je vois au passage que nous partageons la même ferveur pour l'homme à la casquette
mais je suis toujours aussi paumé , j'ai pourtant bien vérifié la casse

joel@joel-K70IJ:~$ cd /home/joel/.wine/dosdevices/c:/Program Files/Squid/
bash: cd: /home/joel/.wine/dosdevices/c:/Program: Aucun fichier ou dossier de ce type
joel@joel-K70IJ:~$ cd /home/joel/.wine/dosdevices/c:/Program Files/Squid/bin/
bash: cd: /home/joel/.wine/dosdevices/c:/Program: Aucun fichier ou dossier de ce type

xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#9 Le 03/01/2013, à 12:31

degolarson

Re : Wine ne lance pas squid.exe

j'ai vu aussi un autre chemin, même résultat

joel@joel-K70IJ:~$ cd/home/joel/.wine/drive_c/Program Files/Squid/bin
bash: cd/home/joel/.wine/drive_c/Program: Aucun fichier ou dossier de ce type
joel@joel-K70IJ:~$ 

je me demande quel chemin utilise le lanceur

Dernière modification par degolarson (Le 03/01/2013, à 12:32)


xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#10 Le 03/01/2013, à 12:48

degolarson

Re : Wine ne lance pas squid.exe

et aussi

~$ cd "/home/joel/.wine/drive_c/Program Files/Squid/Prerequisites"
joel@joel-K70IJ:~/.wine/drive_c/Program Files/Squid/Prerequisites$ wine "~/.wine/Program Files/Squid/bin/Squid.exe"
wine: cannot find '~/.wine/Program Files/Squid/bin/Squid.exe'
joel@joel-K70IJ:~/.wine/drive_c/Program Files/Squid/Prerequisites$ 

xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#11 Le 03/01/2013, à 12:58

degolarson

Re : Wine ne lance pas squid.exe

suite

~$ cd "/home/joel/.wine/dosdevices/c:/Program Files/Squid/Prerequisites"
joel@joel-K70IJ:~/.wine/dosdevices/c:/Program Files/Squid/Prerequisites$ wine "/home/joel/.wine/dosdevices/c:/Program Files/Squid/bin/Squid.exe"
wine: Install Mono for Windows to run .NET 2.0 applications.
joel@joel-K70IJ:~/.wine/dosdevices/c:/Program Files/Squid/Prerequisites$ 

xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#12 Le 03/01/2013, à 13:15

degolarson

Re : Wine ne lance pas squid.exe

j'ai installé mono for windows , toujours rien, je pars au pub vider quelques bières

joel@joel-K70IJ:~/.wine/dosdevices/c:/Program Files/Squid/Prerequisites$ wine "/home/joel/.wine/dosdevices/c:/Program Files/Squid/bin/Squid.exe"
wine: Install Mono for Windows to run .NET 2.0 applications.
joel@joel-K70IJ:~/.wine/dosdevices/c:/Program Files/Squid/Prerequisites$ 

xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

#13 Le 03/01/2013, à 18:36

degolarson

Re : Wine ne lance pas squid.exe

je suis allé voir les propriétés du greffon lanceur dans le tableau de bord
commande : env WINEPREFIX="/home/joel/.wine" wine C:\\windows\\command\\start.exe /Unix /home/joel/.wine/dosdevices/c:/users/Public/Bureau/Squid.lnk
répertoire de travail : /home/joel/.wine/dosdevices/c:/users/joel/Mes documents/Téléchargements/Squid/bin


xp / Xubuntu 12.04.5   32b   3.2.0-67-generic    xfce 4.8.6         
Laptop AsusPRO79 I   250Go / 2.9Go    2 x Pentium (R) Dual-Core T4200  2GHz    année 2009
Cartes : IntelMobile4SeriesGMA500,   wifi  Atheros 9285       Freebox V5   
Doucement, nous sommes pressés !

Hors ligne

Haut de page ↑