Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#26 Le 03/01/2013, à 13:26

tony59

Re : "missing operative system"

Donc il faut que je transfert windows sur mon sdb (celui ou ubuntu est installé), que je réinstalle windows sur le sda et que je le restaure c'est bien ça?

Hors ligne

#27 Le 03/01/2013, à 14:31

men-go

Re : "missing operative system"

Re,

     ntfsclone comme son nom l'indique, te fait une image d'une partition NTFS. Il s'agit d'un gros fichier de la taille des données de la partition Windows en gros. C'est pour éviter de perdre des données et surtout éviter de réinstaller les logiciels. On peut même restaurer dans une autre partition (non bootable).

     Je ne t'ai pas dit "il faut". J'ai proposé une solution qui consiste à sauvegarder sur sdb (à moins que tu aies un disque USB externe), réinstaller Windows d'usine et  écraser cette installation par la restauration de la sauvegarde. Mais si quelqu'un a une meilleure solution, soit.

Hors ligne

#28 Le 03/01/2013, à 15:38

tony59

Re : "missing operative system"

J'ai trouvé ce topic, quelqu'un avec le même problème et le même pc que moi et qui a réussi à s'en sortir en "paramétrant son bios" mais il ne dit pas comment

Dernière modification par tony59 (Le 03/01/2013, à 18:01)

Hors ligne

#29 Le 03/01/2013, à 18:03

tony59

Re : "missing operative system"

malbo tu vois peut être une autre solution ?

Hors ligne

#30 Le 03/01/2013, à 19:07

malbo

Re : "missing operative system"

Non.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#31 Le 03/01/2013, à 19:47

tony59

Re : "missing operative system"

Bon, je vais essayer ta solution men-go, je suis ce tuto
http://forum.ubuntu-fr.org/viewtopic.php?id=441776

Par contre je ne sais pas quoi mettre comme réponse après l'execution du script, si je veux copier le windows 7 présent sur sda3 vers un dossier du sdb

Dernière modification par tony59 (Le 03/01/2013, à 19:51)

Hors ligne

#32 Le 04/01/2013, à 00:04

men-go

Re : "missing operative system"

Re,

Chtroumpf_#9 a écrit :

J'ai effectivement retrouver Windows en reparamétrant mon "Bios". Et je passe de Windows à Ubuntu en refaisant la manipulation inverse assez facilement.

C'est la solution qui a été donnée dans le topic que tu as indiqué. Il faut lire attentivement le post 3 de ce même topic:

malbo a écrit :

Il faut démarrer sur le disque dur sda en mode EFI parce que Windows y a été installé en mode EFI et il faut démarrer sur le disque sdb en mode BIOS parce que Ubuntu y a été installé en mode BIOS.
C'est à toi d'intervenir dans ton "Bios" pour que le disque dur sda démarre toujours en mode UEFI. Et pour que sdb démarre toujours en mode BIOS (mais ça à l'air de fonctionner déjà comme ça).
Je te préviens d'avance, il sera impossible de passer par Grub pour lancer Windows du fait de cette différence de mode EFI/BIOS. De même que le gestionnaire de démarrage de Windows ne pourra jamais lancer Ubuntu pour la même raison.

avant de te lancer dans l'usine à gaz que je t'ai suggérée. Teste déjà cette solution, ce que je t'ai donné c'est en vraiment en dernière extrémité et comme je te l'ai déjà dit, l'UEFI j'en ai que des connaissances livresques, je n'ai pas encore eu l'occasion de le tester par moi-même.

     Ceci étant, tu as dit que tu bootes Ubuntu quelque soit le mode, UEFI ou non. Moralité tant qu'on ne l'a pas testé, on ne sait pas complètement comment l'UEFI réagit. D'autre part tu peux te rapprocher de Chtroupmf en lui envoyant un message via le formulaire d'envoi de mails (voir dans Navigation/Liste des membres en haut à gauche) et lui demander de l'aide.

     Concernant les scripts dont tu parles, ils datent de 2011 et ils ont largement évolué depuis. Si on en arrive aux dernières extrémités je te donnerai la(es) commande(s) sans passer par les scripts.

Hors ligne

#33 Le 04/01/2013, à 08:48

malbo

Re : "missing operative system"

Peut-être que c'est à la demande d'un de vous deux, je viens de voir que Chtroumpf a pris la peine de détailler sa procédure de démarrage : http://forum.ubuntu-fr.org/viewtopic.ph … #p12076841
Comme Chtroumpf a exactement le même modèle d'ordi (c'est ce que je crois comprendre) et exactement la même version (2.14.1219) du "Bios" que tony59, cela devrait aider.

Dernière modification par malbo (Le 04/01/2013, à 08:52)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#34 Le 04/01/2013, à 11:06

men-go

Re : "missing operative system"

Bonjour,

            Etant donné que par la touche ESC on peut avoir un multi-boot, j'en déduis qu'il faut remettre le boot en mode UEFI et tester les deux méthodes, c'est à dire celle donnée par Chtroumpf qui consiste à donner la priorité des supports au moment où le boot fait le choix  de l'unité à prendre en compte et celle du choix de l'utilisateur par le boot direct via la touche ESC.

     Il est dit quelque part que si Ubuntu est installé en mode UEFI, GRUB peut booter Windows, auquel cas il s'agit d'une troisième solution qui est facile à mettre en oeuvre.

Hors ligne

#35 Le 04/01/2013, à 12:29

tony59

Re : "missing operative system"

C'est moi qui ai contacté Chtroumpf car il semblait avoir le même problème, sur le même pc. Je vais essayer de réinstaller ubuntu en mode uefi, pour cela j'ai un cd contenant ubuntu 12.10 64 bits "quantal quetzal", ça ira?

Hors ligne

#36 Le 04/01/2013, à 13:10

malbo

Re : "missing operative system"

Pour installer Ubuntu 12.10 en mode EFI, la doc indique ceci : http://doc.ubuntu-fr.org/efi#versions_d … n_mode_efi
Tu peux donc au choix utiliser l'iso de la version officielle qui est ubuntu-12.10-desktop-amd64.iso téléchargeable ici : http://releases.ubuntu.com/releases/qua … -amd64.iso
ou bien Ubuntu Sécurisée en version 64 bits : http://doc.ubuntu-fr.org/ubuntu_secure_ … chargement


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#37 Le 04/01/2013, à 14:38

tony59

Re : "missing operative system"

Bon, j'ai réinstallé ubuntu 12.10 64 bits en EFI sur le sdb en choisissant "supprimer la précédente version d'ubuntu", c'est à dire sans m'occuper du partitionnement pour le moment. Ensuite, j'ai lancé un boot-repair car seul ubuntu apparaissait dans le grub.

Et, ca y est, j'ai pu récupéré windows, cependant, mon grub à une drôle de tête
grub

Pour lancer windows, je prend "windows boot efi loader" mais j'aimerai faie un peu le ménage, est-il possible de supprimer les autres?

Hors ligne

#38 Le 04/01/2013, à 14:55

men-go

Re : "missing operative system"

Re,

     Avec la 12.10 tu as récupéré GRUB V2 qui gére des menus et des sous-menus. Ceci est généré par /boot/grub/grub.cfg. On peut supprimer tout ce que tu veux en modifiant grub.cfg mais au prochain update-grub, ce sera remis en l'état.

     Personnellement je boote toujours avec le même menu et j'ai installé un processus automatique qui remet en place mon menu personnel après que  update-grub soit passé. Si ça t'intéresse, je t'en toucherai un mot.

     As-tu essayé les autres façons de booter ? Ce n'est pas urgent mais tant qu'on y est. En plus ça peut toujours servir si un jour ton Ubuntu plante.

Hors ligne

#39 Le 04/01/2013, à 15:22

malbo

Re : "missing operative system"

tony59 a écrit :

Et, ca y est, j'ai pu récupéré windows,

Pour aller dans Windows, est-ce que tu dois obligatoirement passer par le menu de Grub ? Si oui, par quelle(s) entrée(s) du menu Grub dois-tu passer ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#40 Le 04/01/2013, à 15:51

tony59

Re : "missing operative system"

Alors pour booter j'ai le choix entre
boot

Si je choisis windows boot manger, windows se lance et si je prends l'un des ubuntu, j'arrive sur le grub ou je peux lancer au choix windows (via windows boot efi loader)  ou ubuntu

Dernière modification par tony59 (Le 04/01/2013, à 15:57)

Hors ligne

#41 Le 04/01/2013, à 16:19

malbo

Re : "missing operative system"

tony59,
Dans ton post #19, on peut voir que tu avais aussi cette entrée "windows boot manager" et moi j'avais cru que tu ne pouvais pas démarrer sur Windows 7 en passant par cette entrée. Qu'en est-il ?
Si c'est vrai que tu n'arrivais pas à démarrer Win7 dans le post #19, qu'est-ce qui pourrait expliquer que ça fonctionne à présent ?

Dernière modification par malbo (Le 04/01/2013, à 16:19)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#42 Le 04/01/2013, à 16:30

tony59

Re : "missing operative system"

C'est cela, quand je sélectionnais "windows boot manager" je tombais systématiquement sur la page "windows a besoin d'être réparé" qui me demandait ensuite un cd d'installation pour réparer le démarrage. Malheureusement, le logiciel présent sur le cd n’arrivait pas à repérer mon installation de windows et la seule chose que je pouvais faire était d'ouvrir une invite de commande. J'avais essayé de réparer le mbr depuis cette invite et commande mais le fichier bcdedit était introuvable.

Je ne sais pas trop pourquoi ça ne fonctionnait pas mais je sais que l'installation de la version d'ubuntu que tu as suggérée à résolu le problème

Dernière modification par tony59 (Le 04/01/2013, à 17:03)

Hors ligne

#43 Le 04/01/2013, à 16:53

malbo

Re : "missing operative system"

Merci pour ces explications très claires mais le fait que l'installation de Ubuntu en mode EFI ait pu résoudre le problème de l'entrée "windows boot manager" est un grand mystère pour moi.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#44 Le 04/01/2013, à 18:33

men-go

Re : "missing operative system"

Re,

    Reste à savoir si on peut booter Windows à la mise sous tension ou au redémarrage d'un des systèmes. Et si possible refaire un simple rapport de Boot-repair pour comparer avec les autres.

Hors ligne

#45 Le 05/01/2013, à 13:25

tony59

Re : "missing operative system"

Voila le rapport boor-repair
http://paste.ubuntu.com/1499288/

Est il possible de réduire la taille allouée à ubuntu sans le réinstaller? (En créant une partition lisible par windows)

Dernière modification par tony59 (Le 05/01/2013, à 13:44)

Hors ligne

#46 Le 05/01/2013, à 15:13

men-go

Re : "missing operative system"

Salut,

        Je vais comparer les rapports. Les problèmes que tu as eus me turlupinent et j'aimerais bien comprendre, même si j'en ai une petite idée. En ce qui concerne ta question il est tout à fait possible de réduire (jusqu'à un certain point) la taille des partitions par GParted. Peux-tu renvoyer le résultat de: 

sudo parted /dev/sdb print    # c'est pour ta question
ls -l /boot/efi     # ça c'est pour moi

Hors ligne

#47 Le 05/01/2013, à 15:16

men-go

Re : "missing operative system"

J'oubliais. Quand tu allumes ou que tu redémarres ta machine, ça boote sur quoi ??

Hors ligne

#48 Le 05/01/2013, à 16:40

men-go

Re : "missing operative system"

Re,

    J'ai récupéré l'état de ton disque 2 sur le dernier rapport. Ci-dessous, un exemple de ce que tu devrais avoir:

Disque /dev/sdd : 32,0GB
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : gpt

Numéro  Début   Fin     Taille  Système de fichiers  Nom  Fanions    Etiquette
 1      1049kB  129MB   128MB                             boot       SAN32-EFI  
 2      129MB   8037MB  7908MB  ext4                                 SAN32-UBUNTU
 3      8037MB  9908MB  1871MB  linux-swap(v1)                       SAN32-SWAP
 4      9908MB  28,7GB  18,8GB  ext4                                 SAN32-DATA
 5      28,7GB  32,0GB  3271MB  ext4                                 SAN32-home

Noter plusieurs choses
- L'exemple est une clé USB de 32Go donc pour toi il y aura une "petite" différence
- J'utilise des étiquette ou labels pour mieux m'y retrouver (ces étiquettes sont affichées par Nautilus, par mount -l .... mes /etc/fstab ainsi que grub.cfg sont définis avec des labels pour rendre les systèmes indépendants de l'UUID des partitions). Remarque: tes partitions Windows ont des labels
- Différents types de données sont dans différentes partitions: SAN32-UBUNTU est le système, DATA=données partagées ou peu accédées ou sauvegarde etc. home=home
- La partition système fait 8Go. Il s'agit d'une taille très acceptable pour Ubuntu (rien à voir avec W)
- La partition swap se trouve juste après la partition système pour éviter les trop grands déplacements du bras du disque lors des opérations de swapin/swapout (question de performance. Dans ton cas, la partition swap sur sda aurait été nickel, mais comme avec une grosse mémoire centrale on ne swappe pratiquement jamais, swap peut rester sur sdb)
- home se trouve après DATA parce que si au départ on l'a choisi un peu court, rogner DATA à la fin et agrandir home ne coûte pas cher en sécurité des données et en temps.

     Je précise que je ne fais pas du tout confiance aux automatismes de l'installation d'Ubuntu. Je formate mes partitions à ma sauce et je dis au moment d'installer, exactement où. Personnellement avec ta machine j'aurais installé tel que je viens de le dire, en plus j'aurais fait en sorte que le chargeur d'amorçage soit sur le disque 2 et pas sur le disque 1 pour éviter entre autres les problèmes que tu as eus.

     En ce qui concerne ces problèmes, par rapport à rapport précédent, il y a deux grosses différences:

sda1: old__________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 7: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bootx64.efi /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgr.efi 
                       /EFI/Microsoft/Boot/memtest.efi 
sda1: new__________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 7: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bootx64.efi /EFI/ubuntu/grubx64.efi 
                       /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgr.efi 
                       /EFI/Microsoft/Boot/memtest.efi
sda3: old__________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe 
                       /ubuntu/winboot/wubildr /ubuntu/winboot/wubildr.mbr
sda3: new__________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /bootmgr /Boot/bcd /Windows/System32/winload.exe

     Je pense que tes problèmes de boot de Windows est dû à  /ubuntu/winboot/wubildr /ubuntu/winboot/wubildr.mbr  dans la partition Windows alors que vraisemblablement les données afférentes n'existaient plus. A+

Hors ligne

#49 Le 05/01/2013, à 17:25

tony59

Re : "missing operative system"

Salut,

J'ai encore eu un problème de démarrage mais d'ubuntu cette fois. Je me demande si ce n'est pas du à la mis à jour qu'il a fait (je n'ai rien touché d'autre entre temps). Quand je voulais lancer ubuntu normalement j'avais l'écran violet avec le logo puis un écran noir et plus rien. Obliger de hard reboot. Résultat je l'ai lancé par le "Recovery mode" et je me retrouve dans un espèce de mode sans-echec. (Je dis ca car la carte graphique ne semble pas avoir été prise en compte, vu la résolution que mon pc affiche)

Bref voici les commandes
:

antoine@antoine-G75VW:~$ sudo parted /dev/sdb print
[sudo] password for antoine: 
Model: ATA Hitachi HTS72757 (scsi)
Disk /dev/sdb: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  99,6MB  98,6MB  fat32                 boot
 2      99,6MB  742GB   742GB   ext4
 3      742GB   750GB   8547MB  linux-swap(v1)
antoine@antoine-G75VW:~$ ls -l /boot/efi
total 2
drwxr-xr-x 6 root root 2048 janv.  4 13:07 EFI

PS: Quand je démarre la machine c'est windows qui se lance

Dernière modification par tony59 (Le 05/01/2013, à 17:28)

Hors ligne

#50 Le 05/01/2013, à 18:33

men-go

Re : "missing operative system"

Re,

     On est donc revenu à une situation normale au niveau du boot.

Concernant le boot Ubuntu, lorsque tu auras l'écran noir, tu attends une trentaine de secondes et tu fais Alt-Ctrl-F1. Si une console en mode texte apparaît (avec login ...), fais Alt-Ctrl-F7. Si tu retrouves un écran mauve avec un message qui dit qu'une partition n'a pas pu être montée, note de quelle partition il s'agit (l'UUID) et réponds "S" (comme skip).

En mode recovery, tu es effectivement en équivalent "mode sans échec".

Lors de ta réponse, tu peux me renvoyer:

ls -lR /boot/efi

qui va être un peu plus étoffé (je veux juste connaître comment sont implémentés les fichiers dans la partition EFI).

Hors ligne

Haut de page ↑