Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 01/03/2013, à 01:43

vallo

Acquisition Vidéo DV - dvgrab - kino

Bonsoir,
Récemment passé de 10.04 à 12.04 je galère pour acquérir depuis la migration mes vidéos faites avec un camescope SONY au format DV.
Les pages de Documentation "dvgrab", "kino" etc..  font référence aux modules raw1394, dv1394, ohci1394 et ieee1394.
Or ces modules ne sont pas installés chez moi (lsmod ne renvoie rien) et je ne vois pas comment les installer (modprobe ne les trouve pas)
En l'état, dvgrab et kino ne marchaient pas.
- dvgrab (lancé en sudo ou pas) restait en attente sans jamais démarrer le camescope et l'acquisition. Seul un Ctrl+C permettait de quitter.
           Found AV/C device with GUID 0x0800460101900b90
           Waiting for DV...

- kino ne marchait pas davantage. Il reconnaissait pourtant le camescope (Préférences-onglet IEEE1394)
J'ai passé les 2 commandes indiquées dans la page Kino à savoir

echo "KERNEL==\"raw1394\", GROUP=\"video\"" | sudo tee /etc/udev/rules.d/raw1394.rules
sudo udevadm trigger

et là ô miracle, dvgrab s'est mis à fonctionner et kino aussi (en fait kino freeze souvent mais l'acquisition se fait quand même).
Mes questions sont simples :
. Comment fonctionne l'acquisition DV sous 12.04 ?
. Comment dvgrab et kino marchent alors que les 4 modules précités ne sont pas installés ?
. Qu'ont fait les 2 commandes passées ?
. Ne serait-il pas judicieux de mettre à jour les pages de la documentation touchant l'acquisition de vidéos au format DV en spécifiant peut-être l'évolution.
Je le ferai bien si j'en étais capable, mais ce n'est pas le cas.
Merci aux spécialistes du format DV de contribuer à ce sujet.

Hors ligne

#2 Le 01/03/2013, à 23:57

richardgilbert

Re : Acquisition Vidéo DV - dvgrab - kino

Bonsoir;
Je ne sais pas si je vais répondr à ta question car je vaiz essayer prochainement dvgrab avec kino sur 12.04, mais la solution à l'acquisition du vidéo par DV est ici.
Kino n'est plus dévéloppé et l'entrée DV n'est plus fabriqué car les nouvelles caméras utilisent l'usb. Je pense que la documentation ne vas pas évoluer.


Debian, Ubuntu, ElementaryOS, Voyager Linux, Lubuntu & Crunchbang.

Hors ligne

#3 Le 03/03/2013, à 09:16

vallo

Re : Acquisition Vidéo DV - dvgrab - kino

Bonjour,
Effectivement, ça ne répond pas à ma question. J'ai effectivement pu acquérir mes vidéos en ligne de commande avec dvgrab après avoir passé les 2 instructions indiquées dans mon précédent post. Mais je cherche toujours à comprendre ce qu'ont fait ces commandes et quels sont les modules qui gèrent le DV.
Mes recherches ont un peu évolué puisque j'ai lu  par exemple que

lsmod | grep -i firewire

et

dmesg | grep -i firewire

listaient des modules ayant manifestement un rapport avec le port firewire (au lieu du 1394 traditionnellement utilisé. C'est donc en ce sens que je suggère de mettre à jour les pages de la documentation relative au DV).
Est-ce que par exemple les logiciels utilisés pour l'acquisition, anciens, ne seraient pas programmés pour utiliser des modules xxx1394 alors que maintenant le firewire est géré par des modules firewire-xxxx ?
Par ailleurs que représente le device fw0 ?
Merci encore aux spécialistes d'éclairer la communauté sur le sujet.

Hors ligne

#4 Le 23/05/2014, à 22:41

iawia

Re : Acquisition Vidéo DV - dvgrab - kino

Bonjour a toutes et tous , je relance le sujet de l acquisition dv ! j ai moi aussi le meme soucis sous 14.04 kino semble chercher "raw1394" alors qu a priori c es maintenant fw0 mais comment modifier ca ? et : ou comment faites vous l acquisition dv sous 14.04 et quelle logiciel merci pour toute info ..


CM : GA-G33M-DS2R
Proc : intel E2200(C2D)
RAM : 4GO PC2-8500
SYST : ubuntustudio 14.04

Hors ligne

#5 Le 26/05/2014, à 22:30

iawia

Re : Acquisition Vidéo DV - dvgrab - kino

Bonsoir , les modules semblent present et le fire reconnu (integre a CM) mais je n arrive a rien avec aucun logiciel d'acquisition ) , mon camescope n'est pas reconnu en firewire par kino ou autre et kino cherche raw1394 alors qu a priori d apres ce que j'au lu ,il me semble avoir les bons modules pour mon noyeau , j'espere que quelqu un pourra m 'aider car la je tourne en rond sur les docs.... Si j essaie de lancer qd meme le camescope en Firewire (avec kino ) j obtien freeze de la machine , Si je branche en usb le camescope il n apparait pas dans kino et pourtant apparait sous un lsusb ! Donc je me dis qu il n y a peut etre pas grand chose a faire mais quoi !!! J'aimerais pas reinstaller un xp et les drivers d origine de mon cam );  ci dessous le retour de quelques commandes

toto@toto-pc:~$ uname -a
Linux toto-pc 3.13.0-24-lowlatency #47-Ubuntu SMP PREEMPT Sat May 3 00:00:39 UTC 2014 i686 i686 i686 GNU/Linux
toto@toto-pc:~$ lspci | grep "1394"
05:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
toto@toto-pc:~$ lsmod | grep "1394"
toto@toto-pc:~$ lspci | grep "firewire"
toto@toto-pc:~$ lspci | grep "1394"
05:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
toto@toto-pc:~$ lsmod | grep "firewire"
firewire_ohci          35488  0
firewire_core          57689  1 firewire_ohci
crc_itu_t              12627  1 firewire_core
toto@toto-pc:~$


CM : GA-G33M-DS2R
Proc : intel E2200(C2D)
RAM : 4GO PC2-8500
SYST : ubuntustudio 14.04

Hors ligne

#6 Le 27/05/2014, à 16:10

iawia

Re : Acquisition Vidéo DV - dvgrab - kino

Personne pour m'aider sad Je cherche " et j avance un peu " enfin j'essaie de comprendre ! Voila donc a priori j ai les bons modules mais faut il que je fasse autre chose avec ces modules ?  D'autre part j'ai cherché et trouvé /dev/fw0 et ce "fichier"? est present quand mon camescope est eteint et disparait ! quand mon camescope est allumé ! donc il y a bien un lien .... quelqu un peux m expliquer pourquoi fw0 disparait etcomment je peux recuperer la video qui qui devrait "sortir" par fw0 ? J espere que vous comprendrez ! lol , merci pour toute aide @plus


CM : GA-G33M-DS2R
Proc : intel E2200(C2D)
RAM : 4GO PC2-8500
SYST : ubuntustudio 14.04

Hors ligne

Haut de page ↑