Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 09/03/2013, à 18:21

Rouge

ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Bonjour à tous !

j'avais installer sur ma machine (desktop récent monté moi même) ubuntu 12.04 LTS sans trop me soucier du mode dans lequel il était installer. Il s'était installé en mode bios sur mon SSD partitionné en master boot record (MBR ou ms-dos)

Au départ j'avais mis mon /home et ma swap sur le SSD (j'ai aussi 3 HDD derrière), mais après avoir vu que le SSD avait des cycles d'écriture limités, je me suis dis que j'allais refaire une installation en mettant mon /home et ma swap sur un HDD, et par la même installé le nouvel ubuntu en mode EFI.

J'ai donc créé un live usb avec ubuntu 12.04.2, j'ai booté dessus en mode UEFI, mis le SSD en en table de partition GUID (gpt), et lancé l'installation.
L'installation s'est bien passée, toutes les partition ont l'air nickels, mais au premier démarrage j'ai eu le droit à un "low graphics mode". En faisant un reset, j'ai pu démarrer ubuntu normalement, dans les drivers nvidia, la version expérimentale était selectionnée. J'ai donc installé le driver current updates mais j'ai eu une erreur au milieu de l'installation, redémarrage, je réessaye, et le driver s'installe (en démarrant de la moitié) comme s'il fallait l'installer en 2 fois. Le PC semble fonctionner correctement, mais souvent j'ai le droit à un "low graphics mode" au démarrage, qu'un reset suffit pour l'outre passer.....?

j'ai aussi testé avec la 12.10 en EFI et GPT : installation impec, premier démarrage impec, aucun driver d'installé au démarrage, mais quand j'ai voulu en installer un, au redémarrage, incapable d'utiliser ubuntu, je n'ai que l'image du bureau d'affichée....

j'ai testé la 12.04.2 en EFI mais MBR ce coup-ci : résultat, idem qu'en gpt, "low graphics mode" et même erreurs pour les drivers.

Je suis donc revenu à la 12.04.2 en BIOS et MBR : installation OK, premier démarrage OK, je n'ai plus de "low graphics mode", mais j'ai eu le me souci pour l'installation des drivers....

Je ne comprend pas du tout ce qu'il se passe, ni d'ou vient le souci, est-ce que j'oublie quelque chose quand je fais l'installation ??
Est-ce un souci de carte graphique, elle a l'air de bien fonctionner ???

Merci d'avance pour votre aide !

Ma config est dans ma signature


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#2 Le 09/03/2013, à 18:51

malbo

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

C'est peut-être dû au fait qu'une installation toute neuve de Ubuntu 12.04.2 est différente de ton ancienne installation 12.04. On en parle dans cette discussion : http://forum.ubuntu-fr.org/viewtopic.php?id=1202451
En bref, ta nouvelle installation n'a pas le même noyau (tu as un 3.5.0-XX au lieu d'un 3.2.0-XX) ni la même gestion de l'affichage que ton ancienne install.

Dernière modification par malbo (Le 09/03/2013, à 18:55)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#3 Le 10/03/2013, à 01:05

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Mouais, si je comprends bien, le x.org quantal ne fonctionne pas tellement .....
j'ai quand même essayer une install de la 12.10 en mode bios et mbr, ça n'a pas été très concluant .....
Voici ce que j'ai eu pendant l'installation :
1362870472.jpg

au premier démarrage j'ai eu le droit à ça :
1362870553.jpg

il y a bien un souci graphique....
J'ai fait un reset et le PC a démarrer correctement, mais des que j'ai installé un pilote et fais un redémarrage, je me suis encore retrouvé avec mon imge du bureau et rien d'autre....

J'ai pourtant installé la 12.10 sur une vielle config qui me sers de HTPC sans souci et ça tourne impeccable !!!!!
La 12.04.2 de mon portable tourne aussi très bien !!
Je ne comprend vraiment pas...

Résultat, je suis revenu à la 12.04.2 en EFI et gpt, j'ai déjà eu un crash de compiz et un "low graphics mode" mais sinon ça tourne....

Que faire pour que ce soit clean ? descendre d'une version de x.org ?

j'espère que la 13.04 va arranger les choses....

Dernière modification par Rouge (Le 10/03/2013, à 01:16)


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#4 Le 10/03/2013, à 02:26

Korak

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Bonjour,

Rouge a écrit :

je suis revenu à la 12.04.2 en EFI et gpt, j'ai déjà eu un crash de compiz et un "low graphics mode" mais sinon ça tourne....

Quand ça tourne avec les pilotes propriétaires nVidia, ouvre un terminal et lance la commande:

sudo nvidia-xconfig

Quand c'est fait, referme tout et redémarre le PC.

Puis reviens nous dire s'il y a un mieux.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

Hors ligne

#5 Le 10/03/2013, à 20:52

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

@korak : Voici le résultat de la commande :

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
                  Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as
'/etc/X11/xorg.conf.nvidia-xconfig-original'
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

et après un rallumage, ça tourne pour l'instant, pas de changemnt notable....

Dernière modification par Rouge (Le 10/03/2013, à 20:54)


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#6 Le 12/03/2013, à 01:12

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Alors là j'y comprend vraiment plus rien......
j'avais retiré mes 2 HDD de données pour pouvoir faire mon install tranquillement sans avoir peur de perdre mes données perso.
Maintenant que ça a l'air de tourner rond, je rebranche mes deux disques et là je comprend plus rien ...
Ma carte mets un temps infini à booter, et au final ubuntu ne se lance pas, je reste coincé sur un fond orangé...
J'essaie de booter sur une live USB, ça mets un temps fou, et je n'ai qu'un HHD sur les deux ??
Je retire les 2 HDDs, le PC démarre normalement !!!
Je débranche un HDD et je le branche vite fait sur une vielle config qui tourne sous 12.10, et là pas de problème, il est bien là avec toute mes données dedans !!
Maintenant je n'arrive même plus à booter sur la live USB.
Je vais craqué !!!.....

Voici les disques :
SSD  (gpt): /boot/efi + /
HDD (gpt): /home + swap
HDD (gpt): Data (qui était débranché pendant l'install)
HDD (gpt): Data (qui était débranché pendant l'install)

Quelqu'un a une idée de ce qui se passe ???

Dernière modification par Rouge (Le 13/03/2013, à 12:00)


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#7 Le 13/03/2013, à 10:48

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

personne....... snif


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#8 Le 13/03/2013, à 11:38

malbo

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

ce sont tous des HDD internes ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#9 Le 13/03/2013, à 11:55

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Oui ce sont bien des HDD internes.
Ces 4 disques fonctionnaient très bien avant que je décide de refaire une installation (ce que j'aurais du éviter au final...)
Ces 4 disques tournent tensemble depuis la 12.04...

Il me reste encore une condition à tester, essayer de démarrer sur live usb, avec seulement mes HDD de données branchés, Pour voir si c'est bien eux qui foutent la paguaille.....

Dernière modification par Rouge (Le 13/03/2013, à 12:00)


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#10 Le 13/03/2013, à 12:21

Haleth

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Pourquoi tu met de l'efi ?
Pourquoi tu met du gpt sur un ssd ? T'as un SSD de plus de 2Tb ?!

GPT, c'est uniquement pour gérer des disques >= 2Tb
Sert pas à grand chose dans les autres cas.

Tes disques externes, ils sont partitionnés en quoi, niveau FS ?
T'as quoi dans ton fstab ?

Essaye de boot en runlevel 1, pour avoir un peu plus de debug et un peu moins de foutoir


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#11 Le 13/03/2013, à 12:48

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Pourquoi tu met de l'efi ?

tout mon matos est récent, je voulais faire une installe fraiche et changer ma gestion des disque( avant mon /home était sur le SSD), du coup j'ai tenté l'efi pour voir et tester le fast boot et secureboot, j'aurai pas du....

Pourquoi tu met du gpt sur un ssd ? T'as un SSD de plus de 2Tb ?!

C'est aussi pour faire plus de 4 partions primaires.
Parce que Ayant acheté un PC portable sous ubuntu son HDD de 500 Go est en gpt. De plus, dans la doc http://doc.ubuntu-fr.org/tutoriel/parti … spensables j'ai lu :

2.3 Partition EFI ou BIOS-boot (si disque GPT)


Si votre disque dur est partitionné en GPT, il faudra y créer soit une partition EFI, soit une partition BIOS-Boot. Il n'y a pas besoin de leur attribuer un point de montage, car l'installateur s'en charge automatiquement4). Voir cette page pour plus d'informations.

Tes disques externes, ils sont partitionnés en quoi, niveau FS ?

Les deux sont en NTFS.


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#12 Le 13/03/2013, à 14:01

Haleth

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Pourquoi tu veux 4 partitions primaires ?

Les deux sont en NTFS.

J'imagine que ca ne doit pas bloquer le démarrage, donc. Tu utilises un w$ avec ?

As-tu regardé ton /etc/fstab, et as-tu boot en runlevel 1 ?


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#13 Le 13/03/2013, à 14:17

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Pourquoi tu veux 4 partitions primaires ?

C'était juste au cas ou. Pour l'instant sur mon SSD de 120 Go, seulement 60 sont prévu pour le / d'ubuntu. Je prévoyais le reste pour pouvoir tester d'autres OS, Je peux en mettre encore 4 autres tranquillou avec le recte d'espace !

J'imagine que ca ne doit pas bloquer le démarrage, donc. Tu utilises un w$ avec ?

Non, ils l'étaient il y a encore 2 ans, je n'ai pas changer le système de fichier depuis, ça fait parti des choses à faire !
Effectivement, ils ne m'ont jamais bloqué. c'est très étonnant ! D'ailleurs, pour vérifier, j'ai branché les disque sur un vieux PC (2006) qui tourne sous 12.10, et ils sont bien reconnus !!

As-tu regardé ton /etc/fstab, et as-tu boot en runlevel 1 ?

Je suis au boulot, donc je vais essayer ce soir....


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#14 Le 14/03/2013, à 23:41

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Voici mon fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=9a9a1878-dad3-419f-bf86-959ea8ea3e81 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=FCE0-5375  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sdb1 during installation
UUID=1b50a11d-6818-4612-89dc-47ead4d9c842 /home           ext4    defaults        0       2
# swap was on /dev/sdb2 during installation
UUID=42dfa7bf-ed06-4524-b9ea-c8d10d809acc none            swap    sw              0       0

"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#15 Le 15/03/2013, à 01:16

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Bon beh apres de multiples branchements et débranchements, je crois que je viens de découvrir qu'un de mes port SATA ne fonctionne plus.....
Du coup, dès qu'un disque était branché dessus, le boot était très très long, même en live usb !!
Ça arrive souvent ce genre de chose ?

Par contre, une fois rebranché les 4 HDDs sur les bon ports, le PC n'a quand pas voulu booter. Mais bon, en refaisant une bonne install je pense que ça résoudra la chose......j'espère.


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

#16 Le 15/03/2013, à 10:18

Haleth

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Port sata qui brule, c'est pas fréquent, non. M'enfin c'est complémentement un problème hard, pas soft.
Ton PC ne reboot plus sur les disque, j'imagine ?
Essaye avec une clé, et modifie les UUID dans /etc/fstab (s'aider avec /dev/disk/by-uuid)

Tu peux aussi reinstaller ton rootfs


Ubuntu is an ancien African word which means "I can't configure Debian"

Because accessor & mutator are against encapsulation (one of OOP principles), good OOP-programmers do not use them. Obviously, procedural-devs do not. In fact, only ugly-devs are still using them.

Hors ligne

#17 Le 15/03/2013, à 15:50

Rouge

Re : ubuntu efi (gpt) = low graphics mode, ubuntu bios (mbr) = ok ???

Le plus suprenant c'est que j'ai 6 ports SATA, Ils sont par groupe de deux.
Ca veut dire qu'il y a à chaque fois un controleur pour deux ports. Du coup je suis étonné que le port qui est sur le même controleur fonctionne bien. Logiquement c'est le controleur qui est HS le plus souvent...

En fait, dès qu'un disque est branché sur ce port défectueux ubuntu ne veut pas booter. En live USB, le boot est très long, le boot de la carte mère aussi !! Comme si la carte voyait un disque branché, essayait d'y accéder, mais au final n'y parviens pas...

Pour le coup je pars en vacnace ce soir, donc il y aura du neuf dans une semaine...

Merci pour votre aide.


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 12.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440

Hors ligne

Haut de page ↑