Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 12/03/2013, à 04:27

jee-el

caractères unicode /hexa/ ascii

bonjour quelqu'un!

voilà le problème .
je suis sous xfce et je n'arrive pas à introduire un caractère spécial, le pour mille. dans la table on trouve le %, comme sur mon clavier, mais pas le %o...
ici, je trouve une table qui a l'air assez complète...
codes hexa, unicode et ascii
là aussi
alngage unicode UTF-8

je trouve

unicode: ‰     hexa: %89     le caractère:      clav win :Alt 0137

en cherchant je trouve qu'il faut faire ctrl+MAJ+u +code et (non alt+code) résultat : ķ !eh oui! ‰en mettant le code hexa, j'ai un petit rectangle vertical sur libreoffice.
alors que ctrl+MAJ+u +25 me donne bien % ah, le "25" c'est en hexa. c'est 37 en unicode soit "7" idem avec "&" "26" en hexa et "38" en unicode, qui donne "8"!.

alors je suis un peu perdu, là...en plus la table intégrée à libreoffice met pour le % U+0025 (37). donc les caractères hexa et non unicode (*)

avec l'autre liste, le %o serait  "ctrl+MAJ+u +8240" c'est déjà pas le même et le résultat: néant et par curiosité, È serait obtenu par " ctrl+MAJ+u +200" résultat : À ?????

les aspirines? à gauche, derrière le`sucre!

lol

alors....j'attends!

il me semble qu'on cherche à unifier... oui, mais si 4 milliards s'y mettent on est pas dehors de l'auberge!


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#2 Le 12/03/2013, à 05:20

pingouinux

Re : caractères unicode /hexa/ ascii

Bonjour,
Pour connaître l'encodage des caractères en Unicode et UTF-8, j'utilise ce fichier (valeurs en hexadécimal) :

/usr/share/i18n/charmaps/UTF-8.gz

dont voici la ligne correspondant au caractère "pour mille" => ؉

<U0609>     /xd8/x89     ARABIC-INDIC PER MILLE SIGN

On obtient ce caractère ؉ avec Shift+Ctrl+U+609, ou bien

$ echo $'\xd8\x89'
؉

Ajouté : Voici les encodages pour les autres caractères que tu cites

% => <U0025>     /x25         PERCENT SIGN
& => <U0026>     /x26         AMPERSAND
7 => <U0037>     /x37         DIGIT SEVEN
8 => <U0038>     /x38         DIGIT EIGHT
È => <U00C8>     /xc3/x88     LATIN CAPITAL LETTER E WITH GRAVE
ķ => <U0137>     /xc4/xb7     LATIN SMALL LETTER K WITH CEDILLA
Ȁ => <U0200>     /xc8/x80     LATIN CAPITAL LETTER A WITH DOUBLE GRAVE

Dernière modification par pingouinux (Le 12/03/2013, à 05:31)

Hors ligne

#3 Le 12/03/2013, à 07:17

jee-el

Re : caractères unicode /hexa/ ascii

hello pinguinux!

après un moment de repos roll je suis de retour! voilà... le fichier décompressé dans "documents" (plus rapide d'accès)
eh beh! quelle liste! pas très pratique à consulter. mais très complète, et ça fonctionne...

un bon point!

en faisant ctrl+maj+u+609, j'ai bien ؉, ce qui ne me plaît pas.
en faisant ctrl+maj+u+2030

<U2030>     /xe2/x80/xb0 PER MILLE SIGN

j'ai ce qui me plaît mieux!

j'ai aussi trouvé ce site convertisseur de caractères qui peut être bien utile! et encore celui-ci très complet: Tableaux de Caractères

tout ça n'explique pas cependant ces différences constatées...

merci déjà pinguinux de m'avoir indiqué ce dossier!

un truc rigolo...ctrl+maj+u+2033 donne ″ (le pouce, unité de mesure) mais si on prend le "double prime" ctrl+maj+u+0022 et que sur libreO on a sélectionné le guillemet français, on se retrouve direct avec « , soit "ctrl+maj+u+00AB". vachement délicat!

Dernière modification par jee-el (Le 12/03/2013, à 08:08)


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#4 Le 12/03/2013, à 07:45

ar barzh paour

Re : caractères unicode /hexa/ ascii

voir aussi le site qui donne le codage (unicode) classé des caractères
codage de caractère
par exemple
pour le ‰ on le trouve dans Ponctuation / Ponctuation générale /Ponctuation générale
colonne 203 ligne 0 ce qui donne 2030 ( en hexa )
pour obtenir la caractère , comme l'a indiqué pingouinux Shift Ctrl U 2030
amuse-toi bien

Dernière modification par ar barzh paour (Le 12/03/2013, à 07:59)


Ubuntu 14.04.4 LTS 32 bits
Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz

Hors ligne

#5 Le 12/03/2013, à 08:09

ar barzh paour

Re : caractères unicode /hexa/ ascii

dans libre office il y a aussi ceci :
tu vas dans le menu
Insertion / Caractères spéciaux
choisis dans Sous-ensemble Ponctuation générale
clique sur le ‰
tu vois apparaître sur la droite le même signe en très gros et dessous U+2030


Ubuntu 14.04.4 LTS 32 bits
Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz

Hors ligne

#6 Le 12/03/2013, à 10:55

jee-el

Re : caractères unicode /hexa/ ascii

bonjour ar barzh paour (!)

merci, voilà, c'est ça!  quand j'ai déroulé le menu "sous-ensemble", j'ai rien trouvé vers le %, et en continuant la liste, j'ai passé un peu vite, et perdu dans la masse j'ai rien vu, ayant passé par dessus l'"onglet" ponctuation (d'autant plus que pour moi, c'est pas vraiment de la ponctuation...!)
bonne leçon de recherche! reste les "incohérences" évoquées en dessus!...

pour le lien, c'est le même que j'ai mis! lol


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#7 Le 12/03/2013, à 11:09

pingouinux

Re : caractères unicode /hexa/ ascii

jee-el #1 a écrit :

avec l'autre liste, le %o serait  "ctrl+MAJ+u +8240" c'est déjà pas le même et le résultat: néant et par curiosité, È serait obtenu par " ctrl+MAJ+u +200" résultat : À ?????

jee-el #5 a écrit :

reste les "incohérences" évoquées en dessus!...

Ce ne sont pas des incohérences, il ne faut simplement pas confondre décimal et hexadécimal.

8240 (décimal) => 2030 (hexadécimal)

‰ => <U2030>     /xe2/x80/xb0 PER MILLE SIGN

200 (décimal) => c8 (hexadécimal)

È => <U00C8>     /xc3/x88     LATIN CAPITAL LETTER E WITH GRAVE
Ȁ => <U0200>     /xc8/x80     LATIN CAPITAL LETTER A WITH DOUBLE GRAVE

Hors ligne

#8 Le 12/03/2013, à 11:26

ar barzh paour

Re : caractères unicode /hexa/ ascii

@ jee-el post #6
excuse pour le lien en double !!
effectivement je ne comprends pas non plus pourquoi dans libre office quand je tape sur la touche du " j'obtiens « 
dans gedit on obtient bien un "

Dernière modification par ar barzh paour (Le 12/03/2013, à 11:28)


Ubuntu 14.04.4 LTS 32 bits
Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz

Hors ligne

#9 Le 12/03/2013, à 11:33

pingouinux

Re : caractères unicode /hexa/ ascii

ar barzh paour   #8 a écrit :

pourquoi dans libre office quand je tape sur la touche du " j'obtiens «

C'est vraisemblablement parce que c'est la version française.

Ajouté :
Pour ne pas avoir ce comportement :
Outils -> Langage -> Pour tout le texte -> Aucun (Ne pas vérifier)

Dernière modification par pingouinux (Le 12/03/2013, à 11:53)

Hors ligne

#10 Le 13/03/2013, à 08:37

jee-el

Re : caractères unicode /hexa/ ascii

@ ar barzh paour
oui, c'est normal, c'est un choix disponible de configuration comme le dit justement pinguinux.
par contre le chemin est un cul-de-sac.
la modification est là:
dans writer: outils --> autocorrection --> options linguistiques. dans la partie inférieure, décocher "guillemets doubles". la position standard devient ".." et non plus « (CTRL+MAJ+U+00AB) et » (CTRL+MAJ+U+00BB)

Dernière modification par jee-el (Le 13/03/2013, à 10:13)


jee-el, Grand-Père Plex!
C-mère Gigabyte H87-HD3
C Graphique NVIDIA GTX 760
multiboot voyager 13.04 64bits Ubuntu 14.04/ XP sp3

Hors ligne

#11 Le 13/03/2013, à 19:24

ar barzh paour

Re : caractères unicode /hexa/ ascii

n'utilisant pas beaucoup la saisie de texte dans libre office , je n'ai pas bien cherché,
j'essayais de trouver quelque chose dans Outils/options....

j'ai donc décoché  Remplacer de Guillemets double dans l' onglet Options linguistiques de
Outils/Options d'Autocorrection
j'obtiens bien " maintenant et non « en début de saisie
bonne fin de journée à tous


Ubuntu 14.04.4 LTS 32 bits
Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz

Hors ligne

#12 Le 13/03/2013, à 19:25

ar barzh paour

Re : caractères unicode /hexa/ ascii

n'utilisant pas beaucoup la saisie de texte dans libre office , je n'ai pas bien cherché,
j'essayais de trouver quelque chose dans Outils/options....

j'ai donc décoché  Remplacer de Guillemets double dans l' onglet Options linguistiques de
Outils/Options d'Autocorrection
j'obtiens bien " maintenant et non « en début de saisie
bonne fin de journée à tous


Ubuntu 14.04.4 LTS 32 bits
Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz

Hors ligne

Haut de page ↑