Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 16/03/2013, à 11:42

capten

Activation du wpa2 pour le Ad hoc (Résolu)

Bonjour a tous
J'ai beau chercher partout sur ce sujet que je croyais "bateau"...mais impossible a trouver....
Je viens donc chercher vos lumières....
Voila...Je communique entre deux ordis sous Ubuntu sur un réseau Ad Hoc...mais avec une sécurité Wep, seule dispo sous ubuntu 10.04...Comment activer (dégriser ) le wpa2 sur ce type de réseau ...??:P...(comme sous ubuntu 12.10 d'ailleurs que
j'ai installé sur une des bécanes en question...!!)
Merci par avance!

Dernière modification par capten (Le 23/03/2013, à 12:37)

Hors ligne

#2 Le 17/03/2013, à 13:25

cracolinux

Re : Activation du wpa2 pour le Ad hoc (Résolu)

D'après la doc, les possibilités dépendent du driver utilisé par ta carte


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#3 Le 19/03/2013, à 14:10

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Merci de ta réponse cracolux
...mais de quelle doc parles tu ?
Une histoire de pilotes ? je ne sais pas...comment l'installer alors ....?
Tout ce que je constate (essai sur les 2 machines) c'est que sous Ubuntu 12.10, la création d'un rézo Ad Hoc en Wpa2 est
réglé en qq secondes dans le gestionnaire de connexion par défaut, et est impossible dans la v.12.04, (excellente par ailleurs et je ne souhaite pas abandonner la LTS sur l'ordi principal...)

Hors ligne

#4 Le 19/03/2013, à 22:31

cracolinux

Re : Activation du wpa2 pour le Ad hoc (Résolu)

mini_849148cettedocl.png


tongue


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#5 Le 20/03/2013, à 18:46

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Merci oui...c'est bien ce que je craignais...
Cette doc si précieuse en general ne donne (ou je n'ai pas trouvé) aucune procédure simple
et claire pour avoir une protection raisonnable (Wpa) de son rézo Ad hoc...sous la LTS (12.04)...
Pourquoi tant de haine ??:D:(
Même avec win 7 le ad hoc est protégeable par wpa2...
En fait le pied serait pour moi de pouvoir creér un hotspot Infra qui lui a l'air d'accepter le wpa2....
Mais la aussi impossible de le creer pour moi (ce serait parfait pr mon telephone Android qui refuse la connexion au Ad hoc....:(:(.....
Ah...c'est pas facile:|

Hors ligne

#6 Le 20/03/2013, à 20:07

cracolinux

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Désolé de pas pouvoir t'aider davantage.
Est-ce que tu peux expliquer la structure du réseau que tu souhaites mettre en place ?


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#7 Le 20/03/2013, à 20:59

navtex

Re : Activation du wpa2 pour le Ad hoc (Résolu)

une réponse


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#8 Le 21/03/2013, à 11:20

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Désolé de pas pouvoir t'aider davantage.
Est-ce que tu peux expliquer la structure du réseau que tu souhaites mettre en place ?


Ben je pensais avoir ete clair....pas plus que le titre de ma question...: creer un reseau Ad hoc securisé wpa2.....:rolleyes:

Hors ligne

#9 Le 21/03/2013, à 11:29

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Merci Navtex
...je regarde ça ...mais en anglais..dur ....déja que ça n'est pas simple (pour moi  s'entend...)
Bon ça n'était pas ma question de départ , mais effectivement ça serait encore mieux....

Hors ligne

#10 Le 21/03/2013, à 13:56

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

une réponse là


Houlala ....quelle galère pour creer un vrai hotspot (infra)....si je comprends bien il faut faire a la main
(bidouillages a l'infini..) le programme linux qui n'aurait pas encore été écrit ?...
Ce n'est pas mon métier....
Vais je devoir installer windows et creer mon spot avec Spotify ?
Même sous Android, il est tres simple d'en creer un (avec mon telephone)
le point fort de Linux n'est il pas les réseaux ?:(

Hors ligne

#11 Le 21/03/2013, à 13:58

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

............Désolé...je sors du sujet de ma question de départ !

Hors ligne

#12 Le 21/03/2013, à 20:14

navtex

Re : Activation du wpa2 pour le Ad hoc (Résolu)

traduction approx

Traduction: 
-------------premier point ,l' histoire de driver ,si ça marche avec Wind ça marche avec Linux
]-1------copier dans un terminal :

sudo apt-get install hostapd dnsmasq
sudo service hostapd stop
sudo service dnsmasq stop
sudo update-rc.d hostapd disable
sudo update-rc.d dnsmasq disable

2-------editer le fichier : 

 --------sudo gedit /etc/dnsmasq.conf
------et ajouter ces lignes:

# Bind to only one interface
bind-interfaces
# Choose interface for binding
interface=wlan0
# Specify range of IP addresses for DHCP leasses
dhcp-range=192.168.150.2,192.168.150.10


----------------wlan0 si c'est ton hotspot
-----------enregistrer et fermer

3------editer le fichier : 

 ------sudo gedit /etc/hostapd.conf
-------et ajouter ces lignes:

# Define interface
interface=wlan0
# Select driver
driver=nl80211
# Set access point name
ssid=monhotspot
# Set access point harware mode to 802.11g
hw_mode=g
# Set WIFI channel (can be easily changed)
channel=6
# Enable WPA2 only (1 for WPA, 2 for WPA2, 3 for WPA + WPA2)
wpa=2
wpa_passphrase=mon motdepasse


-------personnaliser monhotspot et mon motdepasse
---------------wlan0 si c'est ton hotspot


4--------creer un fichier vide  ,ou tu veux
--------qui s'appellera start.sh et copier dedans:

#!/bin/bash
# Start
# Configure IP address for WLAN
sudo ifconfig wlan0 192.168.150.1
# Start DHCP/DNS server
sudo service dnsmasq restart
# Enable routing
sudo sysctl net.ipv4.ip_forward=1
# Enable NAT
sudo iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
# Run access point daemon
sudo hostapd /etc/hostapd.conf
# Stop
# Disable NAT
sudo iptables -D POSTROUTING -t nat -o ppp0 -j MASQUERADE
# Disable routing
sudo sysctl net.ipv4.ip_forward=0
# Disable DHCP/DNS server
sudo service dnsmasq stop
sudo service hostapd stop


-------- à voir ppp0 : ou changer ,si c'est ta source internet

--------proprites/permissions/autoriser


 TERMINE TERMINE TERMINER 
pour mettre en route,tu ouvres un terminal dans le repertoire du fichier  ,glisses le fichier
enter ,mot depasse et c'est parti!

pour arreter ,fermer le terminal[/center]

Dernière modification par navtex (Le 21/03/2013, à 20:26)


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#13 Le 23/03/2013, à 10:52

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Merci Navtex de te donner ce mal ...
Je fais ça.....
mais vraiment pas de petit logiciel qui fait ça en graphique ? c'est étrange....
Canonical qui souhaite un diffusion grand public croit il vraiment que l'utilisateur moyen (que je suis)
va se lancer au clavier dans le terminal ?
Cela dit ,j'essaie....(et je ne sais pas si ma carte wifi est compatible....)
En fait il s'agit d'un petit portable 12p Dell Latitude D420
et ça ça me créé un hotspot AP ?...mais comment je le lance, le nomme , le règle si je n'ai pas d'interface graphique ?

Hors ligne

#14 Le 23/03/2013, à 12:19

navtex

Re : Activation du wpa2 pour le Ad hoc (Résolu)

pour régler ça : (point3)
sudo gedit /etc/hostapd.conf

# Define interface
interface=wlan0
# Select driver
driver=nl80211
# Set access point name
ssid=monhotspot
# Set access point harware mode to 802.11g
hw_mode=g
# Set WIFI channel (can be easily changed)
channel=6
# Enable WPA2 only (1 for WPA, 2 for WPA2, 3 for WPA + WPA2)
wpa=2
wpa_passphrase=mon motdepasse

_4°ligne ssid=mettre le nom de ton hotspot
_derniere ligne  wpa_passphrase=mettre ton mot de passe

enregistrer,quitter
pour le lancer:
par exemple ,si tu as enregistré le fichier ./start.sh  dans Documents(point4) , copies dans un terminal:

cd Documents
./start.sh

pour l'arreter ,fermes le terminal

et de rien,ça me dérouille  smile
#canonical est en progres ,il y a un an le wifi ne marchait meme pas, c'est le charme de Linux et des idéalistes.

Dernière modification par navtex (Le 23/03/2013, à 12:30)


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#15 Le 23/03/2013, à 12:27

navtex

Re : Activation du wpa2 pour le Ad hoc (Résolu)

si tu veux savoir si ta carte est compatible:

sudo lshw | less

chercher à  la section network si tu trouves

ath5k ou ath9k,


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#16 Le 23/03/2013, à 12:36

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Ok ça semble tres clair....
C'est pas pratique, mais si ça marche....
Surpris par contre sur ton propos concernant le wifi ; moi je suis sur ubuntu depuis la 10.04 et mon wifi fonctionnait bien pareil
que maintenant (réception )...!!
(Je vois que tu es aussi un voileux ? sympa ton blog....moi plus le temps et les sous; j'essaie de vendre le miens sur Martigues)
Bye  Thierry(capten@free.fr)

Hors ligne

#17 Le 23/03/2013, à 13:10

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

*-network
                description: Interface réseau sans fil
                produit: AR2413/AR2414 Wireless Network Adapter [AR5005G(S) 802.11bg]
                fabriquant: Atheros Communications Inc.
                identifiant matériel: 4
                information bus: pci@0000:04:04.0
                nom logique: wlan0
                version: 01
                numéro de série: 00:19:e0:6d:f7:90
                bits: 32 bits
                horloge: 33MHz
                fonctionnalités: pm bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=ath5k driverversion=3.2.0-39-generic firmware=N/A ip=10.42.0.86 latency=168 link=yes maxlatency=28 mingnt=10 multicast=yes wireless=IEEE 802.11bg
                ressources: irq:22 mémoire:e0100000-e010ffff

.....A la section network , j'ai ça .... dans le tas, je vois Ath 5k ...ça veut dire compatible (c'est sur mon ordi principal, je testerai
sur mon petit dell.....

Hors ligne

#18 Le 23/03/2013, à 13:27

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Hum ... sur le dell, a la manip de recherche d'infos sur le terminal que tu m'a recommandé, a la place de "ath5k" , j'ai "iwl3945"...c'est pas bon pour la création de vrai hotspot ?

Hors ligne

#19 Le 23/03/2013, à 13:40

capten

Re : Activation du wpa2 pour le Ad hoc (Résolu)

Sinon j'ai un vieux routeur wifi Asus qui lui bien sur peut le faire j'imagine, mais je ne sais pas s'il est possible de lui "injecter " l'internet que reçois mon petit Dell (Il reçoit internet a partir d'un hotspot Wifi extérieur  par l'intermédiaire d'une carte wifi usb Alpha avec une antenne extérieure...)

Hors ligne

Haut de page ↑