Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 28/03/2013, à 19:37

utaku_ryukko

[RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Bonjour,

J'ai un petit souci. Je viens de remarqué qu'il m'est impossible de lire un CD audio quelque soit le logiciel de lecture que je veux utiliser.
Il m'est possible de copier via Brasero et de ripper via SoundJuicer.
Quand j'insère mon CD, il m'ouvre le menu pour choisir ce que je veux faire.
Si je choisis VLC, le logiciel se lance, commence à jouer une piste (toujours la track10) pendant 4 seconde puis se bloque.
Si je choisis Rhythmbox, le logiciel se lance, mais le CD n'apparaît pas dans l'explorateur sur la gauche.

J'ai essayé en lançant Rhythmbox depuis la ligne de commande pour voir s'il y avait un message d'erreur et voici ce que j'ai:

Ubuntu1204:~$ rhythmbox

(rhythmbox:15716): libpeas-WARNING **: audiocd: /usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so: undefined symbol: discid_get_submission_url

(rhythmbox:15716): libpeas-WARNING **: Could not load plugin module: 'audiocd'

(rhythmbox:15716): libpeas-WARNING **: Error loading plugin 'audiocd'

J'ai aussi essayé un sudo apt-get purge suivi de sudo apt-get install pour Rhythmbox: Rien à faire sad

Quelqu'un aurait-il une solution?

Je suis sous Ubuntu 12.04 64 bits

Merci d'avance

Dernière modification par utaku_ryukko (Le 30/03/2013, à 13:21)

Hors ligne

#2 Le 28/03/2013, à 20:38

shoot76

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im


~ La mort d'une personne est une tragédie, celle d'un million c'est des statistiques. [J. Staline]

Hors ligne

#3 Le 28/03/2013, à 20:50

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Oui, le paquet Ubuntu-restricted était déjà installé et je n'ai aucun souci pour les MP3.
Je viens d'installer les seconds, puis re-boot.
Aucun changement: le CD se lance avec VLC ou Clementine, mais stoppe après 4 secondes.
Rien ne se passe avec Rhythmbox.

Hors ligne

#4 Le 29/03/2013, à 09:40

gouet

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

De quel CD s'agit-il? j'en ai un certain nombre de la warner dont je ne peux plus rien faire depuis que je n'ai plus de lecteur CD sad

Gouet

Hors ligne

#5 Le 29/03/2013, à 11:14

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

J'ai ce problème avec tous mes CD, que ce soit venant de majors ou de petits labels indépendants et même des compilations que j'ai gravé pour la voiture.

Info: mes CD se montent automatiquement ici cdda:://sr0

Voici le message d'erreur que j'ai quand je lance vlc:

Ubuntu1204:~$ vlc cdda://sr0
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x22fb108] main libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[0x7f46ac000b78] main input error: open of `cdda://sr0' failed

Hors ligne

#6 Le 29/03/2013, à 12:46

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Salut,

Est-ce que le paquet gvfs-backends est installé?


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#7 Le 29/03/2013, à 12:50

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Je viens de vérifier et il est bien installé, de même que:
gvfs-daemons, gvfs-common, gvfs-libs, gvfs-bin et gvfs-fuse

Hors ligne

#8 Le 29/03/2013, à 12:54

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Tu dis: Info: mes CD se montent automatiquement ici cdda:://sr0 et ici vlc cherche: cdda://sr0 cdda::// vs cdda://, c'est normal cette différence : | ::? En général les cd se montent dans média, non? Essaye d'ouvrir le cd avec vlc mais media>ouvrir>un disque>cd audio pour voir.

Dernière modification par faucon50 (Le 29/03/2013, à 12:58)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#9 Le 29/03/2013, à 12:59

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Là je ne sais pas trop. J'ai suivi l'aide de VLC.
Ce qui est sur c'est quand je pointe sur le CD, ça m'affiche cdda::/sr0. Et je ne vois rien dans /media à part mes 2 HD

Hors ligne

#10 Le 29/03/2013, à 13:13

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

J'ai écris une connerie, les cd ne se montent pas! Tu as bien un dossier cdrom dans /media? Depuis quand ça ne marche plus? Peux-tu lire un dvd de photos ou autre données?

Dernière modification par faucon50 (Le 29/03/2013, à 13:18)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#11 Le 29/03/2013, à 13:35

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Non, pas de dossier cdrom dans media, J'ai bien un dossier cdrom dans mon Home mais il est toujours vide.

Je viens de tester certaines choses et j'ai des résultats bizarres.
Si j'insère le CD, choisis de ne rien faire puis j'ouvre VLC et fait Media >Ouvrir>CD Audio et que je choisis /dev/sr0 dans la drop list, je n'ai aucun souci. Le CD démarre normalement et j'ai la liste des titres (si le CD est trouvé dans la base de données).
Par contre si j'insère le CD et choisis Lancer avec VLC, là ça ne marche plus. Le CD se lance (toujours sur la piste 10 s'il ya plus de 10 pistes) puis se bloque après 4 à 6 secondes. Et si j'ouvre la liste de lecture, je ne vois plus les titres mais une simple liste Track1 à TrackXX.

Et même en choisissant de ne rien faire quand j'insère le CD puis ouvrir soit Rhythmbox ou Clementine, le CD est invisible dans la liste des périphériques.

EDIT: aucun souci pour lire un DVD du commerce (même si j'ai du désinstaller puis réinstaller libdvdcss2) ou un CD/DVD de données.

Dernière modification par utaku_ryukko (Le 29/03/2013, à 13:36)

Hors ligne

#12 Le 29/03/2013, à 13:59

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Poste ton /fstab.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#13 Le 29/03/2013, à 14:01

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=1e3346ce-31a8-4ac7-a0da-d4f4f0d3a46a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=03b8dc20-4db4-4685-85b5-45c2e2943e0b none            swap    sw              0       0
# DataStorage Hard Drive 1TB
UUID=3939db73-2d25-48d6-aaac-f2087091e1be /media/DataStorage               ext4    auto 0       1

Hors ligne

#14 Le 29/03/2013, à 15:39

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Le fstab est ok. Déplace ce dossier cdrom dans /media là où il doit et essaye un dvd données et regarde si le dossier cdrom contient ces données.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#15 Le 29/03/2013, à 15:51

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

OK. Fait.
Avec un DVD Video ou Données, le montage se fait automatiquement dans /media.
Par contre, avec un CD Audio, rien n'apparaît dans /media et le dossier cdrom que j'ai transféré reste vide.
Je vois le CD listé dans la liste des périphérique. Mais il n'apparaît plus quand je lance Rhythmbox ou Clementine.
Et je dois faire la manip que j'ai cité précédemment pour pouvoir l'ouvrir avec VLC.

Hors ligne

#16 Le 29/03/2013, à 16:08

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Je ne sais pas comment fonctionnent Rhythmbox ou Clementine et unity mais la démarche: "j'ouvre VLC et fait Media >Ouvrir>CD Audio et que je choisis /dev/sr0 dans la drop list, je n'ai aucun souci. Le CD démarre normalement et j'ai la liste des titres", permet de lire tes CDs, ce qui est déjà une bonne chose. Perso j'ouvre toujours mes CDs de cette manière, avec vlc et Deadbeef sans problème.

Change de titre car devenu inadapté, pour un truc du genre: cd audio>ouvrir avec Rhythmbox ou Clementine ne fonctionne pas.

Ouvre Rhythmbox et Clementine dans un terminal et fait la manip media>ouvrir>cd audio pour voir si ils donnent des erreurs.

P.S. Est-ce que le paquet  libcdio-cdda1 est installé?

Dernière modification par faucon50 (Le 29/03/2013, à 16:11)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#17 Le 29/03/2013, à 16:22

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Voici pour Rhythmbox:

Ubuntu1204:~$ rhythmbox

(rhythmbox:5834): libpeas-WARNING **: audiocd: /usr/lib/rhythmbox/plugins/audiocd/libaudiocd.so: undefined symbol: discid_get_submission_url

(rhythmbox:5834): libpeas-WARNING **: Could not load plugin module: 'audiocd'

(rhythmbox:5834): libpeas-WARNING **: Error loading plugin 'audiocd'

(rhythmbox:5834): Rhythmbox-WARNING **: Unable to start mDNS browsing: MDNS service is not running

(rhythmbox:5834): libdmapsharing-WARNING **: Unable to initialize mDNS: Le démon n'est pas en cours d'exécution

(rhythmbox:5834): libdmapsharing-WARNING **: Unable to notify network of media sharing: The avahi MDNS service is not running
Sense key: 0x70 0x00 0x03 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x11 0x00 0x00 0x00 0x00 0x00 0x00 

Je vois le CD audio quand je demande Musique>Ajouter (dossier ou fichier), mais rien ne se passe quand je clique sur Ouvrir après avoir sélectionné.

Voici pour Clementine:

Ubuntu1204:~$ clementine
14:21:07.916 DEBUG NetworkProxyFactory:30           Detected system proxy URLs: ("", "", "", "") 
14:21:07.916 DEBUG CoverProviders:34                Registered cover provider "Amazon" 
14:21:07.934 INFO  Player:533                       Registered URL handler for "di" 
14:21:07.934 DEBUG InternetModel:94                 Adding internet service: "DigitallyImported" 
14:21:07.959 DEBUG InternetModel:94                 Adding internet service: "Icecast" 
14:21:07.978 DEBUG InternetModel:94                 Adding internet service: "Jamendo" 
14:21:07.987 INFO  Player:533                       Registered URL handler for "lastfm" 
14:21:07.987 DEBUG CoverProviders:34                Registered cover provider "last.fm" 
14:21:07.987 DEBUG InternetModel:94                 Adding internet service: "Last.fm" 
14:21:07.987 INFO  Player:533                       Registered URL handler for "grooveshark" 
14:21:07.987 INFO  PlaylistManager:417              Registered special playlist type "grooveshark-search" 
14:21:07.988 DEBUG InternetModel:94                 Adding internet service: "Grooveshark" 
14:21:07.990 INFO  Player:533                       Registered URL handler for "magnatune" 
14:21:07.990 DEBUG InternetModel:94                 Adding internet service: "Magnatune" 
14:21:07.994 DEBUG InternetModel:94                 Adding internet service: "SavedRadio" 
14:21:07.994 INFO  Player:533                       Registered URL handler for "sky" 
14:21:07.994 DEBUG InternetModel:94                 Adding internet service: "SKY.fm" 
14:21:07.994 INFO  Player:533                       Registered URL handler for "somafm" 
14:21:07.994 DEBUG InternetModel:94                 Adding internet service: "SomaFM" 
14:21:08.010 DEBUG GnomeGlobalShortcutBackend:50    registering 
14:21:08.040 DEBUG MainWindow:208                   Starting 
14:21:08.092 DEBUG MainWindow:266                   Initialising player 
14:21:08.092 DEBUG MainWindow:272                   Creating models 
14:21:08.094 DEBUG MainWindow:295                   Creating UI 
14:21:08.112 DEBUG MainWindow:662                   Creating equalizer 
14:21:08.112 DEBUG MainWindow:677                   Creating now playing widget 
14:21:08.153 DEBUG MainWindow:714                   Loading settings 
14:21:08.166 DEBUG MainWindow:760                   Initialising library 
14:21:08.166 DEBUG MainWindow:773                   Started 
14:21:08.173 INFO  DeviceManager:411                Device added: "DeviceKit/6VM62A36/Seagate/ST3500418AS/500105249280" 
14:21:08.177 INFO  DeviceManager:411                Device added: "/dev/sr0" 
14:21:08.191 DEBUG UbuntuUnityHack:74               Unity whitelist is "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'clementine']
" 
14:21:08.194 DEBUG GnomeGlobalShortcutBackend:93    registered 
14:21:11.149 DEBUG unknown                          "sni-qt/6789" INFO  14:21:11.149 void StatusNotifierItem::slotAboutToShow() Adding an "Activate" entry to the StatusNotifierItem context menu  
14:21:17.256 INFO  SongLoaderInserter:97            Loading audio CD... 
14:21:17.257 ERROR SongLoader:121                   Error while changing CDDA GstElement's state 

Là, c'est encore pire, je ne vois même pas le CD Audio

EDIT: je viens de vérifier, le paquet libcdio-cdda1 est bien installé

Dernière modification par utaku_ryukko (Le 29/03/2013, à 17:30)

Hors ligne

#18 Le 30/03/2013, à 07:10

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

J'ai tapé ceci sur la toile: Clementine Error while changing CDDA GstElement's state

Et voici le résultat: https://code.google.com/p/clementine-pl … il?id=2442

Ça a tout l'aire d'un bug de Clementine.

Et voici pour Rhythmbox (lis les messages et liens):

https://bugs.archlinux.org/task/17726

Les deux semblent pourris. Ça me rappel le bon vieux temps où j'ai viré Rhythmbox pour installer des lecteurs fonctionnels. cool


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#19 Le 30/03/2013, à 13:18

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

OK, merci.
J'ai suivi les liens. Le problème avec Clementine est exactement le même.
Pour Rhythmox, c'est légèrement différent mais il semblerait que ce soit le même module qui pose problème.

Il n'y a plus qu'à espérer que des patchs ou une nouvelle version corrigeront ceux-ci.

Merci pour ton aide. Je passe en RESOLU même si le problème ne l'est pas.
Heureusement que je peux tout ripper en FLAC ma collection de CD que je viens de récupérer après 6 ans dans un container.

Hors ligne

#20 Le 30/03/2013, à 13:35

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

De rien. smile J'ai aussi ripper les miens depuis un moment, c'est quand plus sympa de cliquer que de se lever à chaque fois, sans parler du bruit des lecteurs dvdrom avec un cd audio dedans. Prend quand même un bon ripper pour pas faire le boulot pour rien ou de mauvaise qualité. Test les fichiers .flac après ripp, suivant le ripper utilisé il peut y avoir de mauvaises surprises.

Peut-être qu'en cherchant sur la toile tu trouverais une solution pour faire fonctionner ces deux coucous...


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#21 Le 30/03/2013, à 15:31

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

J'utilise Sound Juicer. Je ne teste pas à 100%, mais je sample de temps à autre et je n'ai pas encore eu de mauvaises surprises.

La prochaine étape est de trouver un auto-radio qui peut lire les fichiers FLAC. Ca, ce n'est pas gagné.
J'ai trouvé des baladeurs qui peuvent le faire, mais pas encore d'auto-radio sad

Sinon, pour les 2 autres, j'espère que le passage à la 13.04 va résoudre les problèmes, mais j'en doute.

Hors ligne

#22 Le 30/03/2013, à 17:06

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

utaku_ryukko a écrit :

Sinon, pour les 2 autres, j'espère que le passage à la 13.04 va résoudre les problèmes, mais j'en doute.

Tu connais le proverbe: l'espoir est la seule consolation des ......! Perso ça fait longtemps que j'ai trouvé des remplaçants.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#23 Le 30/03/2013, à 17:24

utaku_ryukko

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

Lequel me conseillerais-tu?
J'ai testé Banshee mais je n'aime pas.
Il semblerait que Exaile ne soit pas trop mal, et corresponde à ce que je cherche.
Audacious me parait pas trop mal aussi.

Hors ligne

#24 Le 30/03/2013, à 17:40

fcn50

Re : [RESOLU]Problême avec Rhythmbox et Clementine - Lecture de CD Audio im

J'utilise Deadbeef pour la sique, une perle qui m'a fais rester sur nunux après mon passage en provenance de w$>foobar2000 alors ce que je cherchais un équivalent.

http://deadbeef.sourceforge.net/screenshots.html

http://sourceforge.net/apps/mediawiki/d … ing:Ubuntu

Si ça te dis, je t'aide volontiers pour la config et mise en oeuvre, c'est un soft super chouette, personnalisable à souhait et stable. Je peux même te refiler mon fichier de config couleurs pour te faire une idée...

Voici un fil où tu trouveras des infos: http://forum.ubuntu-fr.org/viewtopic.php?id=911611&p=1

Pour les vidéos c'est vlc, une fois configuré, c'est un monstre...

Dernière modification par faucon50 (Le 30/03/2013, à 18:02)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

Haut de page ↑