Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 13/04/2013, à 20:31

pascal996

[Abandonné] Problème d'amorçage W8/Ubuntu

Bonjour à tous.
J'ai récemment acheté un pc portable type Lenovo ideapad Z500. D'origine, il est livré avec W8. Mon but est d'y installer plusieurs OS. Je voudrais laisser le W8 d'origine, et y ajouter Ubuntu, XP et une autre distro GNU Linux. Je suis parvenu à installer Ubuntu Secure 12.10,(un grand merci au passage à YannUbuntu d'avoir developpé ça!) mais pour etre honnete, c'est plus par chance que par compétence. J'ai mis un sacré bazar dans le grub et ou le GPT.
Il se trouve que ce PC possède un bouton, le"novo button" qui permet d'acceder au bios.

*Si je demarre en mode uefi ceci apparait:

Ubuntu has been blocked by the current security policy
Windows manager has been blocked by the current security policy
Windows manager has been blocked by the current security policy
Ubuntu has been blocked by the current security policy

checking media fail
efi network 0 for ipv4 (20.........) boot failed
checking media fail

Puis il charge et fini par me proposer le  one key recovery:
soit restaurer depuis la sauvegarde initiale, soit choisr une image de restauration (un fichier back up en .wsi)


*Si je démarre en mode legacy

grub rescue, unknown file system


*Si j'appuie sur le fameux "novo button", j'ai un menu

Normal Startup          qui revient à demarrer en mode uefi
Bios set up             pour acceder au bios
System recovery         pour le one key recovery
Boot menu               qui me propose   

Ubuntu
Windows boot manager
Windows boot manager       
Ubuntu
efi network for ipv4
efi network for ipv6

Les efi network me ramenent au checking media fail
Les autres choix m'emmenent enfin au menu ubuntu habituel d'amorçage, ou je peux enfin choisir w8 ou Ubuntu.

Voilà donc la situation, apres avoir tenté plusieurs boot repair.
Meme si je parviens à utilser les 2 os, j'aimerais mettre un peu d'ordre dans tout ça, et surtout pouvoir demarrer sans utiliser le "novo button, qui est n'est pas pratique( il faut une crayon ou une pointe pour appuyer dessus, comme un reset)

Merci à ceux qui prendront le temps de me lire et de m'aider!
Un petit lien pour le boot info:

http://paste.ubuntu.com/5705695/

Dernière modification par pascal996 (Le 04/05/2013, à 00:09)

Hors ligne

#2 Le 14/04/2013, à 09:16

malbo

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Malheureusement Linux-Secure-Remix 12.10 n'est pas à jour et il est impératif à chaque fois que tu te sers de cet outil de le mettre à jour avec les commandes que j'indique ici : http://forum.ubuntu-fr.org/viewtopic.ph … #p13154581
En effet, le Boot-Repair que tu as utilisé est obsolète (c'est la version : 3.197~ppa34~quantal alors qu'on est rendu à la version 3.198~ppa11~quantal , oui ça évolue considérablement).
Je te suggère donc de commencer par refaire un Boot-Info en faisant les mises à jour que j'indique et à en poster l'URL comme tu l'as fait.

Dernière modification par malbo (Le 14/04/2013, à 09:19)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#3 Le 14/04/2013, à 12:21

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Tout d'abord, merci d'avoir répondu aussi rapidement!
voici le nouveau rapport après mise à jour
http://paste.ubuntu.com/5707392/
Je préfère ne plus prendre d'inititative hasardeuse, et attendre de connaitre les bonnes procédures.
Pendant l'install, j'avais crée une partition bios, je la soupçonne d’être inutile et source de problème, merci de m'éclairer!

Hors ligne

#4 Le 14/04/2013, à 12:59

malbo

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Je te fais remarquer que je ne t'ai pas raconté du pipeau :
Voici la "Réparation recommandée" que tu aurais obtenue si tu avais cliqué sur le bouton correspondant de Boot-Repair (extrait de ton Boot-Repair http://paste.ubuntu.com/5705695/ ) :

Recommended-Repair
This setting would reinstall the grub-efi of sda8, using the following options:        sda2/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s     restore-efi-backups

Et voici ce que tu obtiendrais à présent si tu acceptais la "Réparation recommandée" de Boot-Repair après les mises à jour nécessaires (extrait de ton Boot-Repair http://paste.ubuntu.com/5707392/ ) :

Recommended-Repair
This setting would reinstall the grub-efi of sda8, using the following options:        sda2/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s    backup-and-rename-efi-files

Oui, ce n'est pas du tout la même réparation...

J'ai déposé ce message pour demander de l'aide à YannUbuntu, le concepteur de Boot-Repair : http://forum.ubuntu-fr.org/viewtopic.ph … #p13212781

Dernière modification par malbo (Le 14/04/2013, à 13:07)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#5 Le 14/04/2013, à 13:25

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Bon, j'ai effectué la réparation recommandée et voici un copié collé de la boite de dialogue finale.
Les symptomes restent identiques:

Le démarrage de l'ordinateur a été correctement réparé.

Écrivez sur un papier l'URL suivante :
http://paste.ubuntu.com/5707505/

Si vous avez toujours des problèmes de démarrage, indiquez cette URL à :
boot.repair@gmail.com ou sur votre forum favori.

Vous pouvez maintenant redémarrer votre ordinateur.
N'oubliez pas de régler votre BIOS pour qu'il amorce sur le fichier sda2/EFI/ubuntu/grubx64.efi !

Les fichiers de démarrage de [L'OS actuellement utilisé - Linux-Secure-Remix 12.10 28feb2013] sont loin du début du disque. Votre BIOS pourrait ne pas les détecter. Vous voudrez peut-être re-essayer après avoir créé une partition /boot (EXT4, >200MB, en début de disque). Cela peut être réalisé via des outils tels que gParted. Puis sélectionnez cette partition via l'option [Partition /boot séparée :] de [Réparateur de démarrage]. (http://doc.ubuntu-fr.org/tutoriel/partition_boot)

Merci pour le transfert à YannUbuntu!

Hors ligne

#6 Le 15/04/2013, à 08:10

YannUbuntu

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

bonjour

pascal996 a écrit :

Je voudrais laisser le W8 d'origine, et y ajouter Ubuntu, XP et une autre distro GNU Linux.

XP n'est pas compatible UEFI, donc à votre place je désactiverais l'UEFI dans le BIOS puis tout réinstaller sur un disque partitionné Ms-Dos (pas GPT).


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#7 Le 15/04/2013, à 10:55

malbo

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

YannUbuntu a écrit :

à votre place je désactiverais l'UEFI dans le BIOS puis tout réinstaller sur un disque partitionné Ms-Dos (pas GPT).

@YannUbuntu : sauf si tu sais indiquer comment faire, j'ai cru comprendre que ce n'est pas évident de réinstaller Windows 8 en mode Bios sur un ordi livré pré-installé Windows 8. Ce que je veux dire c'est que je crois bien que la restauration du Windows 8 n'est possible qu'en mode EFI (si quelqu'un qui passe par là connaît le sujet et peut confirmer ou infirmer, ce serait utile)

Dernière modification par malbo (Le 15/04/2013, à 10:56)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#8 Le 17/04/2013, à 23:09

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Il me semble que l'idée de YannUbuntu est de passer le disque de GPT en MBR avec un autre système, ce qui implique la suppression de toutes les partitions (y compris la sauvegarde), puis de tout réinstaller, pour éviter ce conflit. Il semble y avoir une alternative à cela avec Paragon GPT Loader, un software payant, qui permet à XP de prendre en charge le GPT   http://paragon-gpt-loader.software.informer.com/1.0/
     Je vais pour l'instant m'en tenir à essayer de faire cohabiter w8 et ubuntu plus sainement, on verra plus tard pour XP.
     J'ai lu dans mon bios quelque chose comme," uefi for windows 8, other OS please use legacy mode". Cela veut il dire que mon bios ne supporte qu'un seul os en uefi? ce qui expliquerait peut etre le message:

Ubuntu has been blocked by the current security policy
Windows manager has been blocked by the current security policy

Merci pour votre implication,
à suivre

Hors ligne

#9 Le 18/04/2013, à 05:18

malbo

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Une solution est donnée dans cette page pour le ideapad Z500 (peux-tu rectifier ton premier post : tu as écrit 500Z au lieu de Z500) : http://askubuntu.com/questions/229858/a … -8-anymore
C'est le dernier message de la page :

Tried the whole process with Secure Boot and Fast Boot disabled, ran Boot-Repair after installing Ubuntu and now I can get to Windows 8 by choosing "Windows UEFI Recovery" on GRUB. I think, but I'm not sure; that Boot Repair was updated in the meantime.

Il y aurait donc deux actions à faire :
1) désactiver Secure Boot
2) désactiver Fast Boot


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#10 Le 19/04/2013, à 21:52

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

malbo a écrit :

Il y aurait donc deux actions à faire :
1) désactiver Secure Boot
2) désactiver Fast Boot

Le secure boot est désactivé, indispensable pour booter sur un cd ou une clef usb.
Une fois l'install faite, si je repasse en Secure Boot, j'ai un quadruple message d'erreur

 Ubuntu has been blocked by the current security policy
Windows manager has been blocked by the current security policy
Windows manager has been blocked by the current security policy
Ubuntu has been blocked by the current security policy 

Par contre la desactivation du secure boot permet de passer en mode UEFI ou Legacy: Si je choisis Legacy j'ai une proposition d'ordre de boot. UEFI ou Legacy. Depuis le depart je choisissais
(Legacy/Legacy) je n'avais pas encore testé (Legacy/UEFI).   Là je tombe directement sur le menu Ubuntu avec les choix de démarrage. Bon évidemment, w8 refuse de se lancer mais apparemment c'est un bug connu https://bugs.launchpad.net/ubuntu/+sour … ug/1024383 et des solutions existent!
Un bon pas de fait puisque je ne suis plus obligé de démarrer avec le fameux bouton (novo)
Reste plus qu'à faire démarrer w8.
Une autre question me taraude, pourquoi le bios me propose 2 fois chaque systeme en mode secure boot? est ce que le fait d'avoir crée une partition bios en plus m'a doublé les chemins de démarrage?

PS: désolé pour l'inversion 500Z Z500, effectivement, ça n'aide pas pour les recherches!

Hors ligne

#11 Le 20/04/2013, à 00:02

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

pascal996 a écrit :

Il me semble que l'idée de YannUbuntu est de passer le disque de GPT en MBR avec un autre système, ce qui implique la suppression de toutes les partitions (y compris la sauvegarde)

je crois que j'étais à coté de la plaque avec ce  commentaire!

Hors ligne

#12 Le 20/04/2013, à 05:11

malbo

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

pascal996 a écrit :

Une autre question me taraude, pourquoi le bios me propose 2 fois chaque systeme en mode secure boot? est ce que le fait d'avoir crée une partition bios en plus m'a doublé les chemins de démarrage?

C'est exactement ça. Depuis ta session normale de Ubuntu, tu pourrais renommer tous les fichiers de ta partition sda3 pour que leur extension .efi devienne _efi (exemple : bkpbootx64.efi deviendrait bkpbootx64_efi). De la sorte, tous ces chemins de démarrage comme tu les appelles ne seraient plus détectés par l'UEFI et tu ne les verrais plus dans le menu de démarrage. Moi, je te conseillerais de garder cette partition sda3 en l'état puisque ces fichiers renommés en _efi seraient en quelque sorte des sauvegardes des fichiers qui sont sur ta partition EFI (sda2).

Dernière modification par malbo (Le 20/04/2013, à 05:12)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#13 Le 20/04/2013, à 09:27

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Salut Malbo!

Voilà un screenshot de gparted.

screenshot gparted


Pourquoi le systeme de fichier de sda6 (biosgrub) n'est pas reconnu? Je suis pratiquement sur de l'avoir formaté en ext4 pendant l'install, comme préconisé.

malbo a écrit :

tu pourrais renommer tous les fichiers de ta partition sda3 pour que leur extension .efi devienne _efi (exemple : bkpbootx64.efi deviendrait bkpbootx64_efi). De la sorte, tous ces chemins de démarrage comme tu les appelles ne seraient plus détectés par l'UEFI et tu ne les verrais plus dans le menu de démarrage. Moi, je te conseillerais de garder cette partition sda3 en l'état puisque ces fichiers renommés en _efi seraient en quelque sorte des sauvegardes des fichiers qui sont sur ta partition EFI (sda2).

Est ce que tu parles de ma partition biosgrub? la sda6 donc? Je ne comprends pas ce que le sda3 vient faire là, je pnse qu'il s'agit d'une des partitiond de sauvegarde de Windows (oem)

Merci de ton aide en tout cas!

Hors ligne

#14 Le 29/04/2013, à 07:25

pascal996

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Bon, j'ai fini par opter pour la solution de YannUbuntu dans le post #6, à savoir formatage du disque en msdos puis Install d'XP, puis réinstall d'Ubuntu... Quant à W8, c'est déjà un vieux (mauvais) souvenir tongue
Tout fonctionne à merveille, il a juste fallu ajouter les pilotes SATA à XP pour qu'il reconnaisse mon DD.
Merci encore pour votre aide!
Est ce que j'édite en Résolu, sachant que la solution, n'est pas vraiment celle du problème de départ?

Hors ligne

#15 Le 29/04/2013, à 08:07

malbo

Re : [Abandonné] Problème d'amorçage W8/Ubuntu

Tu peux la mettre "Abandonné" au lieu de "Résolu". Ce qui donnerait (il faut modifier le titre de ton premier post) :

[Abandonné] Problème d'amorçage W8/Ubuntu

et merci d'avoir pris le temps de donner ces nouvelles.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

Haut de page ↑