Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 19/04/2013, à 14:24

bmzoom

[RESOLU] Wifi en panne

bonjour

Depuis une maj vers ubuntu 11.10 , la config réseau sans fil ne se maintient pas
Activer le réseau sans fil n'est pas coché , quand j'agis sur le menu de la barre d'état

Lorsque je rajoute une liaison filaire , le sans fil apparaît avec les différents opérateurs
Il n'est pas coché mais actif ds la barre d'état

C'est sur portable  Acer

lspci | grep Wireless

03:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)

Dernière modification par bmzoom (Le 21/04/2013, à 11:01)

Hors ligne

#2 Le 19/04/2013, à 23:37

alecoq

Re : [RESOLU] Wifi en panne

Bonsoir,


Il y a t'il quelque chose dans votre fichier /etc/network/interfaces ou c'est l'interface graphique qui gère votre wifi ?

Dans le deuxième cas je vous invite à modifier le fichier /etc/network/interfaces  pour se connecter de manière static à votre réseau Wifi, pour votre aider à configurer correctement lisez : http://doc.ubuntu-fr.org/wifi

Je vous souhaite une bonne continuation,
A bientôt !

Hors ligne

#3 Le 20/04/2013, à 11:23

bmzoom

Re : [RESOLU] Wifi en panne

ok - merci , je ne sais pas grand chose des interfaces , et voici le contenu de ... interfaces :

auto lo
iface lo inet loopback

Mon réseau est une freebox

Hors ligne

#4 Le 20/04/2013, à 14:27

alecoq

Re : [RESOLU] Wifi en panne

Quel chiffrement utilisez vous ? (WEP - WPA ?)

Hors ligne

#5 Le 20/04/2013, à 14:38

bmzoom

Re : [RESOLU] Wifi en panne

C'est du WEP (4BB + 7chiffres )

Hors ligne

#6 Le 20/04/2013, à 14:51

alecoq

Re : [RESOLU] Wifi en panne

D'accord.
Dans un terminal lancer la commande iwevent
Dans un autre terminal :

sudo editor /etc/network/interfaces

Dans ce fichier ajoutez les lignes :

auto wlan0
iface wlan0 inet dhcp
   wireless-essid [NOM SSID]
   wireless-key [CLE WEP]
   wireless-chanel [LE CANAL UTILISE (auto si automatique)]
   wireless-mode managed

Utilisez les commande ifdown wlan0 et ifup wlan0 pour test la configuration du fichier.


Toute fois un conseil (passer en chiffrement WPA) qui est plus sécurisé. smile Mais les informations si dessus sont pour le WEP

Dernière modification par alecoq (Le 20/04/2013, à 14:54)

Hors ligne

#7 Le 20/04/2013, à 16:01

bmzoom

Re : [RESOLU] Wifi en panne

ok , j'ai modifié interfaces

iwevent
Waiting for Wireless Events from interfaces...
15:52:02.165288   wlan0    Scan request completed
15:52:03.510402   wlan0    Scan request completed
15:52:03.546705   wlan0    Association Response IEs:010882848B961224486C32040C183060DD180050F2020101000003A4000027A4000042435E0062322F00DD07000C4300000000
15:52:03.546891   wlan0    New Access Point/Cell address:52:D2:69:DA:9D:D4
15:52:23.224535   wlan0    Scan request completed
15:53:03.226720   wlan0    Scan request completed

Est ce que dans le manager de la barre d'état ,  il faut changer la config de  la connection wifi ?
J'ai paramètres ipv 4 .. Automatique DHCP
Faut il ajouter un routage ( ce qui n'était pas nécessaire avant ! )

Dès que je débranche le cable réseau , la connection wifi décroche !

sudo ifdown wlan0
ifdown: interface wlan0 not configured

Je vais revenir vers une version ubuntu moins récente , qui connecte le wifi sans paramétrage ..

hmm

Dernière modification par bmzoom (Le 20/04/2013, à 18:39)

Hors ligne

#8 Le 21/04/2013, à 10:16

alecoq

Re : [RESOLU] Wifi en panne

Normalement, une fois le fichier modifier l'interface graphique ne gère plus la connexion wifi.

Le routage doit se faire automatiquement à la connexion au point d'accès, qui est le routeur.

Pour le sudo  ifdown  la carte réseau wlan0 est-elle activée ?

Hors ligne

#9 Le 21/04/2013, à 11:01

bmzoom

Re : [RESOLU] Wifi en panne

[RESOLU]

Je suis revenu à une version ubuntu antérieure ( natty )

auto lo
iface lo inet loopback

Tout est détecté direct , et le WEP est à jour en 2 lignes

Hors ligne

#10 Le 21/04/2013, à 14:56

alecoq

Re : [RESOLU] Wifi en panne

Bonne continuation !

A bientôt !

Hors ligne

Haut de page ↑