Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 26/04/2013, à 16:09

JLDAG

[ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Il semble qu'il lui manque la bibliothèque PngImagePlugin

voila ce que me donne la commande phatch dans un terminal :

jean-luc@jeanluc-System-Product-Name:~$ phatch
Traceback (most recent call last):
  File "/usr/bin/phatch", line 16, in <module>
    main(config_paths, app_file = __file__)
  File "/usr/share/phatch/phatch/app.py", line 203, in main
    from core.settings import create_settings
  File "/usr/share/phatch/phatch/core/settings.py", line 23, in <module>
    from pil import IMAGE_READ_EXTENSIONS
  File "/usr/share/phatch/phatch/core/pil.py", line 39, in <module>
    from lib import openImage
  File "/usr/share/phatch/phatch/lib/openImage.py", line 25, in <module>
    import thumbnail
  File "/usr/share/phatch/phatch/lib/thumbnail.py", line 62, in <module>
    import PngImagePlugin
ImportError: No module named PngImagePlugin
jean-luc@jeanluc-System-Product-Name:~$

Dernière modification par JLDAG (Le 04/05/2013, à 09:17)


Ubuntu  13.04 (64) sur PC INTEL Core2 Duo E5200  , MO : 4 Go, carte mère : Asus P5QPL-VM (chipset graphique Intel® GMA 4500)
Ubuntu 13.04 (64) sur PC INTEL Core i5-3470, MO : 8 Go, carte mère Gigabyte H77-DS3H

Hors ligne

#2 Le 26/04/2013, à 16:29

Kooothor

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 26/04/2013, à 18:52

JLDAG

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

OK, Phatch se lance avec la manipulation  proposée. Mais le programme ne peut traiter les images (au moins les jpg). j'ai le message suivant : Phatch ne peut pas gérer 1 image(s)  abandonner -  continuer quand même
Si je clique sur continuer quand même, j'ai le message : "désolé, aucun ficher valide"

Bref le programme se lance mais ne fonctionne pas.

Dernière modification par JLDAG (Le 26/04/2013, à 18:54)


Ubuntu  13.04 (64) sur PC INTEL Core2 Duo E5200  , MO : 4 Go, carte mère : Asus P5QPL-VM (chipset graphique Intel® GMA 4500)
Ubuntu 13.04 (64) sur PC INTEL Core i5-3470, MO : 8 Go, carte mère Gigabyte H77-DS3H

Hors ligne

#4 Le 26/04/2013, à 19:18

Kooothor

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Oui c'est le principe d'un bug, c'est que ça ne fonctionne pas.


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#5 Le 26/04/2013, à 20:58

JLDAG

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Merci quand même.


Ubuntu  13.04 (64) sur PC INTEL Core2 Duo E5200  , MO : 4 Go, carte mère : Asus P5QPL-VM (chipset graphique Intel® GMA 4500)
Ubuntu 13.04 (64) sur PC INTEL Core i5-3470, MO : 8 Go, carte mère Gigabyte H77-DS3H

Hors ligne

#6 Le 27/04/2013, à 12:44

vaches

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Bonjour,
pour resoudre le probleme
http://gehin.nicolas.c.free.fr/?Phatch-et-ubuntu-13-04
Bonne journee

Hors ligne

#7 Le 28/04/2013, à 11:25

roune

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Bonjour,
Les lignes de commandes indiquées permettent bien de démarrer phatch sous raring.
Mais, en effet, celui-ci dit qu'il "ne peut gérer les images" en proposant l'abandon !
Ici, phatch est très utile, voir nécessaire, si bien qu'on regrette de ne pouvoir l'utiliser.
Une mise à niveau de phatch efficace est un espoir vu que sur launchpad.net il y a des experts confirmés !

Hors ligne

#8 Le 04/05/2013, à 08:56

JLDAG

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

J'ai trouvé cette correction sur le launchpad

"I fixed my local installation of phatch by editing "/usr/share/phatch/phatch/lib/thumbnail.py" and changing "import PngImagePlugin" in line 62, to "from PIL import PngImagePlugin"."

et ça marche pour moi.


Ubuntu  13.04 (64) sur PC INTEL Core2 Duo E5200  , MO : 4 Go, carte mère : Asus P5QPL-VM (chipset graphique Intel® GMA 4500)
Ubuntu 13.04 (64) sur PC INTEL Core i5-3470, MO : 8 Go, carte mère Gigabyte H77-DS3H

Hors ligne

#9 Le 05/05/2013, à 16:12

cogefip

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

JLDAG a écrit :

editing "/usr/share/phatch/phatch/lib/thumbnail.py" and changing "import PngImagePlugin" in line 62, to "from PIL import PngImagePlugin"."

et ça marche pour moi.

Bonjour
Chez moi également, traité plus de 1000 photos en 2'
En revanche l'intégration à thunar semble ne pas fonctionner.

Cordialement

Hors ligne

#10 Le 09/05/2013, à 16:09

Moluskum

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Désolé, mais chez moi ça ne fonctionne pas.

J'ai toujours le message suivant : "Désolé, aucun fichier valide".

Une autre solution ?

Hors ligne

#11 Le 10/05/2013, à 08:13

JLDAG

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Avant d'appliquer cette modification, j'ai voulu supprimer toutes les modifications que j'avais faites précédemment et partir d'une installation propre. J'ai donc désinstallé Phatch à l'aide de la bibliothèque et j'ai supprimé le répertoire phatch dans /usr/share.
J'ai ensuite réinstaller phatch puis appliqué la modif au fichier /usr/share/phatch/phatch/lib/thumbnail.py

Dernière modification par JLDAG (Le 10/05/2013, à 08:15)


Ubuntu  13.04 (64) sur PC INTEL Core2 Duo E5200  , MO : 4 Go, carte mère : Asus P5QPL-VM (chipset graphique Intel® GMA 4500)
Ubuntu 13.04 (64) sur PC INTEL Core i5-3470, MO : 8 Go, carte mère Gigabyte H77-DS3H

Hors ligne

#12 Le 14/05/2013, à 02:47

Gedeon84

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

Merci à JLDAG: ta solution fonctionne en effet à merveille à condition de faire "un nettoyage complet" de l'installation comme indiqué + haut. Quelle chance d'avoir une communauté aussi réactive et compétente! Phatch est en effet un outil indispensable sur linux pour qui fait beaucoup de photos. Il y a bien GImp, ou XNViewMP qui ont ce genre d'outil, mais c'est plus long et complexe à mettre en oeuvre. Encore bravo..

Hors ligne

#13 Le 16/05/2013, à 17:59

JLDAG

Re : [ Résolu] Problème de lancement de Phatch sous Ubuntu 13.04

C'est à plusieurs que l'on peut résoudre ses problèmes. Koothor m'a aidé en me fournissant l'adresse du bug sous launchpad et Les intervenants sur lounchpad m'ont fournit la solution. Heureux de pouvoir en faire profiter les utilisateur du forum Ubuntu.fr.


Ubuntu  13.04 (64) sur PC INTEL Core2 Duo E5200  , MO : 4 Go, carte mère : Asus P5QPL-VM (chipset graphique Intel® GMA 4500)
Ubuntu 13.04 (64) sur PC INTEL Core i5-3470, MO : 8 Go, carte mère Gigabyte H77-DS3H

Hors ligne

Haut de page ↑