Contenu | Rechercher | Menus

Annonce

Les adresses laposte.net ne permettent pas de recevoir nos emails. Vous êtes invité à changer d'adresse dans vos paramètres de compte à votre prochaine connexion.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 26/04/2013, à 15:54

guyom.be

[RESOLU]Samba / Windows

Bonjour,

Je viens vers vous car j'ai un soucis,
Je suis dans un environnement active directory avec un file server Samba
(Environnement sous VMware Vcenter, DC=W2k8r2 DNS/WINS, File Server = SLES 64b ADS, Client Win 7 64b)
mon problème est le suivant :
Lorsque j'accède à mes fichiers via mon lecteur réseau j'ai des fichiers qui se mettent en lecture seule (DOCX/XLSX pour le moment principalement), je demande donc a être prévenu lorsque le fichier sera disponible en écriture. 15 secondes après (oui c'est quasiment ca à 1 secondes près) le fichiers est accessible et donc je peux le rendre en lecture écriture. mais de nouveaux lorsque je le referme et réouvre rebelotte. Je sais qu'aucun utilisateur ne l'ouvre car je suis seul à accéder au répertoire.
Note: ca ne le fait pas avec tout les fichiers (doc/docx/xls/xlsx), et ce n'est non plus une question de tailles de fichiers (aussi bien 180k que 3M)
Donc ma question est :
Es ce qu il y a un paramètres dans SAMBA / Linux afin de débloquer ou rendre les fichiers en lecture écriture instantanément ?

De plus, j'ai quelque lenteurs d'accès j ai réussi a rendre plus rapide grace à ces lignes dans le SMB.conf
max protocol = NT1
socket options = TCP_NODELAY
(j'ai essayer SO_RCVBUF=8192 SO_SNDBUF=8192IPTOS_LOWDELAY)
mais ca n'arrangeais pas les choses


Merci d'avance pour vos lumières.

Dernière modification par guyom.be (Le 30/04/2013, à 12:23)

Hors ligne

#2 Le 30/04/2013, à 12:22

guyom.be

Re : [RESOLU]Samba / Windows

Voilà problème résolu.

Solution que j'ai trouvé:
dans le SMB.CONF ajout des lignes :

read raw = yes                             
write raw = yes
max xmit = 65535                                                     
getwd cache = yes
lpq cache = 30
kernel oplocks= no
oplocks = yes

+ MTU à 9000 sur mes cartes réseau . maintenant ca trace bien et plus de soucis de lecture/ecriture

Désolé du dérangement. (je sais que ca n'était pas une version ubuntu mais la communauté ubuntu étant bien active )

Hors ligne