Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 27/04/2013, à 11:48

Nayan

Demande aide configuration lirc + xbmc + télécommande harmony

Bonjour à tous,

J’ai un PC Asus M70VM équipé de série d’un récepteur IR, sous Ubuntu.

Ce PC étant relié en HDMI à ma télé. Je souhaiterai utiliser ma télécommande Harmony One pour contrôler vlc sur ce PC, pas le PC en entier, juste vlc.

Je n’ai pas trouvé de dispositif "Ubuntu" dans le logiciel Harmony, J’ai donc ajouté le dispositif correspondant à mon PC (d’origine sous Vista) sans grandes attentes, mais surprise, les touches directionnelles fonctionnent smile Mais juste les touches directionnelles sad

Je voudrai savoir si vous sauriez m’aider à faire fonctionner les autres touches utiles comme :
-     OK / valider
-    Chapitre +
-    Chapitre -
-    Avance rapide
-    Retour rapide
-    Audio (sélection des langues)
-    Sous-titres (sélection)

Mes recherches sur Google n’étant pas fructueuses, je remercie par avance tous ceux qui pourront m’aider à faire évoluer mon problème

Nayan

Dernière modification par Nayan (Le 29/04/2013, à 12:38)

Hors ligne

#2 Le 29/04/2013, à 12:33

Nayan

Re : Demande aide configuration lirc + xbmc + télécommande harmony

Bonjour,

En cherchant un peu plus, j'ai vu de lirc permettait de faire fonctionner une télécommande, notamment avec xbmc.

Le récepteur intégré est un "ITECIR infrared receiver (CE)" d'après ce que j'ai pu trouver.
Ce récepteur semble bien pris en charge selon : http://www.lirc.org/html/table.html

ITE IT8704/05/12/18/20 CIR port	it87	lirc_dev lirc_it87	default		any
ITE8709 CIR port	ite8709	lirc_dev lirc_ite8709	default		any

j'ai eu un warning lors de : sudo m-a a-i lirc

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Aucune version du paquet lirc-modules-source n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
  lirc

E: Le paquet « lirc-modules-source » n'a pas de version susceptible d'être installée

Puis :

                              ┌─────────────────module-assistant, message d'erreur────────────────────┐
                              │ Échec de l'installation des sources de lirc-modules-source.           │  
                              │                                                                       │  
                              │ Paquet ignoré. Vous devez peut-être ajouter quelque chose à           │  
                              │ sources.list, comme les archives « contrib » et « non-free ».         │  
                              │                                                                       │  
                              ├───────────────────────────────────────────────────────────────────────┤  
                              │                               <SORTIR>                                │  
                              └───────────────────────────────────────────────────────────────────────┘  

Ce qui ne m'a pas choqué, selon la note :

Doc lirc a écrit :

Pour Maverick et après, lirc-modules-source ne doit pas forcement être installé (voir bug). Le paquet n'existe plus dans Precise Pangolin (12.04 LTS)

Puis :

                              ┌─────────────────module-assistant, message d'erreur───────────────────┐
                              │                                                                      │  
                              │                                                                      │  
                              │ Les en-têtes du noyau pour la version cible n'ont pas pu être        │  
                              │ trouvés et vous n'avez pas indiqué d'autres en-têtes valables à      │  
                              │ utiliser.                                                            │  
                              │                                                                      │  
                              ├──────────────────────────────────────────────────────────────────────┤  
                              │                               <SORTIR>                               │  
                              └──────────────────────────────────────────────────────────────────────┘  
                                
                                ┌───────────────module-assistant, message d'erreur─────────────────┐
                                │                                                                  │  
                                │ Toutefois, vous pouvez installer les fichiers d'en-têtes pour    │  
                                │ votre noyau, fournis par le paquet                               │  
                                │ linux-headers-3.8.0-19-generic. Pour la plupart des paquets de   │  
                                │ modules, ces fichiers sont tout à fait suffisants, et il n'est   │  
                                │ pas nécessaire d'avoir les sources originales du noyau.          │  
                                │                                                                  │  
                                │ Pour installer ce paquet, lancez la commande PREPARE depuis le   │  
                                │ menu principal ou en ligne de commande. :                        │  
                                │                                                                  │  
                                │ module-assistant prepare                                         │  
                                │                                                                  │  
                                │ ou                                                               │  
                                │                                                                  │  
                                │ apt-get install linux-headers-3.8.0-19-generic                   │  
                                │                                                                  │  
                                ├──────────────────────────────────────────────────────────────────┤  
                                │                             <SORTIR>                             │  
                                └──────────────────────────────────────────────────────────────────┘  

Les commandes n'ont rien changés :

root@Shiva:~# module-assistant prepare
Récupération des sources du noyau de la version : 3.8.0-19-generic
apt-get install linux-headers-3.8.0-19-generic 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
linux-headers-3.8.0-19-generic est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
apt-get install build-essential 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Fait.
root@Shiva:~# apt-get install linux-headers-3.8.0-19-generic
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
linux-headers-3.8.0-19-generic est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Plus d'erreur après.

Mais la commande irw rend la main tout de suite, le terminal ne se met pas en "attente" roll


Informations complémentaires :

root@Shiva:~# /etc/init.d/lirc restart
 * Stopping remote control daemon(s): LIRC                                                                                                                 [ OK ] 
 * Loading LIRC modules                                                                                                                                    [ OK ] 
 * Starting remote control daemon(s) : LIRC                                                                                                                [ OK ] 
root@Shiva:~# service lirc start
 * Loading LIRC modules                                                                                                                                    [ OK ] 
 * Starting remote control daemon(s) : LIRC                                                                                                                [ OK ] 
lircd: there seems to already be a lircd process with pid 4080
lircd: otherwise delete stale lockfile /var/run/lirc/lircd1.pid
root@Shiva:~# irw
root@Shiva:~#

J'ai déjà récupéré le fichier "http://lirc.sourceforge.net/remotes/logitech/HarmonyOne" qui a remplacé le fichier "/etc/lirc/lircd.conf"

root@Shiva:~# dmesg | grep lirc
[   20.316789] lirc_dev: IR Remote Control driver registered, major 249 
[   20.322355] rc rc0: lirc_dev: driver ir-lirc-codec (ite-cir) registered at minor = 0
root@Shiva:~# ps -eaf | grep lirc
root      7584     1  0 10:01 ?        00:00:00 /usr/sbin/lircd --output=/var/run/lirc/lircd1 --device=/dev/lirc0 --connect=localhost 8765 --pidfile=/var/run/lirc/lircd1.pid
root      8020  7887  0 10:55 pts/0    00:00:00 grep --color=auto lirc

Lors de l'install de lirc j'ai "choisi" sans certitude :
    Logitech/AST
puis :
    Microsoft Windows Media Center V2 (usb) : Direct TV Receiver

Je pense que le problème pourrait venir du fichier /etc/lirc/hardware.conf
Pouvez-vous m'aider à configurer correctement ce fichier ?

root@Shiva:~# cat /etc/lirc/hardware.conf
# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Logitech/AST"
REMOTE_MODULES=""
REMOTE_DRIVER="logitech"
REMOTE_DEVICE=""
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="logitech/lircd.conf.logitech"
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="Microsoft Windows Media Center V2 (usb) : Direct TV Receiver"
TRANSMITTER_MODULES="lirc_dev mceusb"
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE="/dev/lirc0"
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF="directtv/general.conf"
TRANSMITTER_LIRCD_ARGS=""

#Disable kernel support.
#Typically, lirc will disable in-kernel support for ir devices in order to
#handle them internally.  Set to false to prevent lirc from disabling this
#in-kernel support. 
#DISABLE_KERNEL_SUPPORT="true"

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="true"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""

Merci d'avance big_smile

Hors ligne

Haut de page ↑