Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/04/2013, à 17:33

lemoineo

[PHP]: activer la bibliothèque graphique gd2.1

Il semble que des fonctions (imagefromjpeg par ex) issues de gd qui marchaient sans problème ne fonctionnent plus.
ne pas oublier d'installer php5-gd ... quand même.
En fouillant un peu sur le web, j'ai cru comprendre qu'une version gd.2.1.0 était en préparation.
Une autre solution passant pas imagemagik fonctionne peut-être mais le code est à ré-écrire alors.. sad
j'ai trouvé gd-2.1.0-preview.tar.bz2 mais bon, tout est à recompiler et là, ça dépasse mes compétences ...
enfin, je me lance quand même ...
Après avoir dézippé le bidule, je tente selon la doc fournie (doc/install)

./configure
make 
make install

Mais ne fait que récupérer un

/usr/local/lib/libgd.so
/usr/local/lib/pkconfig

ce qui n'est pas si mal , mais il doit manquer le lien vers le php et
je n'ose pas remplacer le gd.so par une copie libgd.so renommée ... quoique ?
Peut-être que si ?
Olivier

Dernière modification par lemoineo (Le 28/04/2013, à 17:34)


mon boulot : développeur PHP ?
mes galeries : http://lemoineo.free.fr
Utilisateur Linux dans mes loisirs
le Kitesurf me permet de décrocher du PC !

Hors ligne

Haut de page ↑