Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 19/09/2005, à 14:13

quercy

HELP! plus de boot après install Hoari "hard disk boot sector invalid"

bonjour!

j'ai installé Ubuntu sur un disque déjà partitionné:
partition 25Go en NTFS avec winXP dessus
partition 15 Go en FAT32 sur laquelle j'ai installé Ubuntu hoari : / en ext3 sur 14 Go et swap sur 1Go (j'ai 1 Go de RAM)

tout se passe à merveille, detection de ma carte wifi impec, réseau wifi aussi...
il detecte WINXP, et me propose d'installer GRUB, ok

en fin d'install, le CD s'ejecte, et ensuite, je fait continuer, et là....il n'arrive plus à rebooter...
il n'y a plus de secteur de boot sur le message: "hard disk boot sector invalid" sad

je peux lancer kaela (knoopix) sur le cd...si ça peut etre utile?

que dois-je faire?

merci de votre aide smile

#2 Le 19/09/2005, à 14:21

cep_

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

Ou as-tu installé grub ? sur le mbr ? quel disque ?
Regarde les réglages du bios, pour voir sur quel disque doit se faire le boot en premier.
Sinon, avec le live cd, tu donnes le réultat d'un :
sudo fdisk -l  (ou su suivant le live)
de même le résultat de :
cat /boot/grub/menu.lst
et :
cat /boot/grub/device.map

#3 Le 19/09/2005, à 14:57

quercy

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

sur le bios, le boot se fait dans cet ordre
1-cd
2-HDD

le probleme est certainement que grub s'installe mal...
j'ai refait l'install de ubuntu, le probleme reste le meme!

donc, je vais voir avec kaela ce que me demandes...

#4 Le 19/09/2005, à 15:05

goodluck

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

partition 15 Go en FAT32 sur laquelle j'ai installé Ubuntu hoari : / en ext3 sur 14 Go et swap sur 1Go (j'ai 1 Go de RAM)

Ceci est incohérent : Une partition ne peut-être a la fois en fat32 et ext3, ni se subdiviser si elle est en fat
Une partition de 1 Go pour la swap est inutile, surtout en ayant 1 Go de memoire vive. Un maxi de 512 dans tous les cas.


Amicalement, Gerard ;)
http://counter.li.org/cgi-bin/certificate.cgi/302199
http://www.worldcommunitygrid.org/

Hors ligne

#5 Le 19/09/2005, à 15:07

goodluck

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

Réponds à cette question : OU as-tu installé grub : mbr ou partition.


Amicalement, Gerard ;)
http://counter.li.org/cgi-bin/certificate.cgi/302199
http://www.worldcommunitygrid.org/

Hors ligne

#6 Le 19/09/2005, à 15:14

quercy

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

alors voilà:

le fichier: file:/mnt/hda3/boot/grub/device.map

(hd0)    /dev/hda



le fichier:  file:/mnt/hda3/boot/grub/menu.lst

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.           
default        0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout        10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title        Windows 95/98/NT/2000
# root        (hd0,0)
# makeactive
# chainloader    +1
#
# title        Linux
# root        (hd0,1)
# kernel    /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default optons below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda3 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,2)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## nonaltoption boot targets option
## This option controls options to pass to only the
## primary kernel menu item.
## You can have ONLY one nonaltoptions line
# nonaltoptions=quiet splash

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title        Ubuntu, kernel 2.6.10-5-386
root        (hd0,2)
kernel        /boot/vmlinuz-2.6.10-5-386 root=/dev/hda3 ro quiet splash
initrd        /boot/initrd.img-2.6.10-5-386
savedefault
boot

title        Ubuntu, kernel 2.6.10-5-386 (recovery mode)
root        (hd0,2)
kernel        /boot/vmlinuz-2.6.10-5-386 root=/dev/hda3 ro single
initrd        /boot/initrd.img-2.6.10-5-386
savedefault
boot

title        Ubuntu, kernel memtest86+
root        (hd0,2)
kernel        /boot/memtest86+.bin 
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title        Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title        Microsoft Windows XP Professionnel
root        (hd0,0)
savedefault
makeactive
chainloader    +1

#7 Le 19/09/2005, à 15:25

quercy

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

alors là, je ne sais pas du tout où j'ai installé grub!!!
J'ai oublié de préciser que je suis un vrai newbie concernant Linux! tongue j'ai donc installé avec le tutoriel de yekubuntu.free.fr roll

et en plus je ne sais pas ce qu'est mbr...:|

donc je vais refaire une install en mettant FAT32 au lieu de ext3, et mettre 512 MB en swap...

je ne sais pas à quoi correspondent ext2, ext3 et tout le reste...
est ce qu'il vaut mieu des partitions differentes pour / et pour /home... je ne trouve pas de tutoriel ou l'install de ubuntu est expliquée pas à pas!

merci à vous tous...je vous tiens au courrant wink

#8 Le 19/09/2005, à 15:29

cep_

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

n'y a plus de secteur de boot sur le message: "hard disk boot sector invalid"

Mais ça c'est un message du bios ?

Svp, donne le résultat de ;
fdisk -l
que tu passeras dans un terminal avec les droits root.

#9 Le 19/09/2005, à 15:46

goodluck

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

alors là, je ne sais pas du tout où j'ai installé grub!!!

Si tu ne sais pas ce que tu fais, celà vas être dur pour t'aider. La prochaine fois installe grub sur le mbr (Master Boot Record) !


Amicalement, Gerard ;)
http://counter.li.org/cgi-bin/certificate.cgi/302199
http://www.worldcommunitygrid.org/

Hors ligne

#10 Le 19/09/2005, à 16:18

cep_

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

quercy a écrit :

donc je vais refaire une install en mettant FAT32 au lieu de ext3, et mettre 512 MB en swap...

je ne sais pas à quoi correspondent ext2, ext3 et tout le reste...
est ce qu'il vaut mieu des partitions differentes pour / et pour /home... je ne trouve pas de tutoriel ou l'install de ubuntu est expliquée pas à pas!

merci à vous tous...je vous tiens au courrant wink

Là tu as tout faux smile
Si tu réinstalles, (ce qui est probablement inutile) sans régler ce problème de "hard disk boot sector invalid", cela ne servira à rien.
En outre, tu trouveras sur le wiki quelques explications sur les systèmes de fichiers, ext2, ext3, fat. Et google t'en apprendra bien plus.
Pour ce qui est de mettre /home sur une fat, c'est une très mauvaise idée, tu perds les avantages des permissions et de la journalisation.
Faire une partition /home différente, cela a des avantages, mais si tu ne maîtrises pas bien le sujet, tu va au devant de problèmes, manque de place, etc. etc. Et tu devras aussi refaire ton partitionnement.
Tu peux très bien te faire la main ainsi et, plus tard, tu verras à faire une installation définitive.
Donc lis le forum, le wiki, et un minimum de documentation sur linux, sur des sites comme http://www.trustonme.net/, lea, andesi, framasoft, etc. etc.

#11 Le 19/09/2005, à 16:42

quercy

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

je pensais que ce serait assez simple...vu que je l'ai installé sans probleme (sans dual boot!)

la commande fdisk -l me renvoie qu'il est impossible d'ouvrir /dev/hda

lorsque j'ai installé grub, dans le protocole d'install d'ubuntu, il m'a juste dit qu'il avait repéré windows XP...et qu'il fallait installer grub...puis ensuite plus rien...tout s'est fait normalement.

maintenant, je n'ai plus rien au démarrage sinon "hard disk boot sector invalid"
et si je met knoppix, je vois qd même les partitions windows et ubuntu (et leurs fichiers)

mais lorque je veux réinstaller ubuntu, il me dit qu'il y a une erreur fatale lorsque je veux installer le système de fichier...si je vais directement sur installer grub, il me signal en rouge que la dernière install s'est mal passée...et voilà, je suis complètement bloqué!

sad sad sad

#12 Le 19/09/2005, à 16:46

cep_

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

Ben oui.
Alors, avec ton live, ouvre un terminal en root puis :
fdisk -l
Ou, su fdisk -l
ou sudo fdisk -l
ou... je ne sais pas ce que tu utilises comme live.

#13 Le 19/09/2005, à 17:31

quercy

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

bon...ouffff smile

tout est ok...j'ai relancé une nième installation avec l'option "partitionner automatiquement l'espace disponible"
il m'a mis 15.8 MB de syst de fichiers ext3
et 720 MB de swap
et ça a marché...ouffff!

Merci pour votre soutien !!! et les liens...je suis motivé !

wink

#14 Le 19/09/2005, à 20:02

tshirtman

Re : HELP! plus de boot après install Hoari "hard disk boot sector invalid"

il faudrait un modo pour mettre [résolu] svp (je suis pas modo tongue)!

Hors ligne

Haut de page ↑