Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 10/05/2013, à 14:39

seb1806

[RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Bonjour,

Je rencontre un soucis lors de l'installation du pilote proprio au sujet de ma carte graphique. J'espère que ce sujet aidera les personnes qui rencontrent le même soucis que moi.
Ma carte graphique est une ATI RS690m X1200 et je tourne sur xubuntu.
Malheureusement, ma carte n'étant pas reconnu par les nouvelles versions de Catalyst, j'ai du fouiller un peu avant de trouver les anciens pilotes compatibles ( pour ceux que ça intéresse http://support.amd.com/us/gpudownload/l … ng=English )

Comme si c'était trop facile je recevais un message d'erreur du style

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib32::none:3.0.0-17-generic; make sure that the version is being
correctly set by --iscurrentdistro

Ce message pourrait se traduire paradoxalement par une version d'ubuntu qui serait trop à jour ( si j'ai bien compris ce sujet http://ubuntuforums.org/showthread.php?t=1221221 )
J'ai donc suivi les conseil de " Mark Phelps's" (toujours dans le même sujet) et j'ai cherché un mode compatibilité avec une ancienne version d'ubuntu

./ati-driver-installer-9-3-x86.x86_64.run --listpkg

Grâce a cette commande on obtient :

Ubuntu Packages:
	Ubuntu/7.10
	Ubuntu/8.04
	Ubuntu/8.10
	Ubuntu/9.04
	Ubuntu/gutsy
	Ubuntu/hardy
	Ubuntu/intrepid
	Ubuntu/jaunty
	Ubuntu/source

Il nous reste donc plus qu'à choisir le pkg correspondant à la version choisie.
Pour ma part j'ai choisi la version 9.04. je lance la création des pkg et leur installation :

 ./ati-driver-installer-9-3-x86.x86_64.run --buildandinstallpkg Ubuntu/9.04

La création des Pkg se passe bien mais un soucis vient lors de l'installation, je rencontre les deux erreurs suivantes.

Error!  Build of fglrx.ko failed for: 3.2.0-32-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.593/build/ for more information.
Error!  Build of fglrx.ko failed for: 3.2.0-32-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/fglrx/8.593/build/ for more information.

Et à la fin de l'installation

Warning: Could not find configuration file
Please copy configuration file template to /etc/X11

(Je peux mettre les détail de l'installation entièrement, c'est que je ne trouve pas la balise [Spoiler] sur le forum)

je vais donc zieuter le make.log et je retombe là dessus

DKMS make.log for fglrx-8.593 for kernel 3.2.0-32-generic (i686)
Fri May 10 14:06:08 CEST 2013
/var/lib/dkms/fglrx/8.593/build /var/lib/dkms/fglrx/8.593/build
AMD kernel module generator version 2.1
cat: /lib/modules/3.2.0-32-generic/build/include/linux/utsrelease.h: No such file or directory
Error:
kernel includes at /lib/modules/3.2.0-32-generic/build/include do not match current kernel.
they are versioned as ""
instead of "3.2.0-32-generic".
you might need to adjust your symlinks:
- /usr/include
- /usr/src/linux
/var/lib/dkms/fglrx/8.593/build

Je ne comprends pas, quelqu'un peut m'aider ?

Merci,

Séb ;-)

Edit : L'installation s'est bel est bien mal déroulé/ Quand j'ouvre l'icone Ati Controler Center créee j'obtiens :

1368190238-ati.png

Edit : Plus d'interface graphique, écran noir après le Log hmm

Dernière modification par seb1806 (Le 13/05/2013, à 17:52)

Hors ligne

#2 Le 10/05/2013, à 16:40

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Salut,

Pour cette carte, c'est le pilote libre radeon.

sudo apt-get remove fglrx*
sudo rm /etc/X11/xorg.conf

Puis reboot.

Dernière modification par faucon50 (Le 10/05/2013, à 16:41)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#3 Le 10/05/2013, à 17:10

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Merci pour ton aide mais le pilote libre n'est pas extra, je cherche à me servir du pilote propriétaire.

Hors ligne

#4 Le 10/05/2013, à 18:06

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Tu peux essayer ça mais je n'y crois pas trop (c'est le proprio pour les vieilles CG):

Tape ces commandes un après l'autre puis reboot et donne le retour de: fglrxinfo:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#5 Le 11/05/2013, à 19:49

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Merci pour ton aide faucon.

Au redémarrage de l'ordi : écran noire après le log, plus d'interface graphique. Je ne peux avoir le mode console qu'avec le mode de dépannage. Bref ça craint hmm

sudo apt-get remove fglrx*

Me donne

W : Verrou non utilisé pour le fichier /var/lib/dpkg/lock en lecture seule
E : Impossible d'écrire sur le /var/cache/apt
E : Les listes de paquets ou le fichier <status> ne peuvent-être analkysés ou lu

A noté que je ne peux pas supprimer Xorg.conf puisqu'il n'existe pas de fichiers de ce nom dans le dossier.

Merci de votre,

Sébastien

Hors ligne

#6 Le 12/05/2013, à 08:57

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Essaye de booter normalement une fois devant l'écran noir tu tapes Ctrl + Alt + F2, si tu arrives en console, tu fais: sudo apt-get remove fglrx* puis sudo reboot, si ça marche, tu devrais retrouver ton bureau. Ce n'est pas Xorg.conf mais xorg.conf. Je peux déjà te dire que pour avoir une chance pour le fglrx tu devras retourner sous buntu 12.04 LTS, ta CG étant obsolète.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#7 Le 12/05/2013, à 14:08

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Merci Faucon, ça a fonctionné, j'ai pu retrouver mon bureau et repasser aux pilotes libres. C'est cool wink

A noter que je suis en 12.04 LTS. Il n'y a aucune manière pour moi d'installer le pilote propriétaire ? Je m'y suis mal pris ? J'arrive pas à comprendre.

Merci beaucoup,

Séb

Hors ligne

#8 Le 12/05/2013, à 15:20

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Extra. Fini pour toi le pilote proprio à moi de changer de CG. Déjà que c'est la dernière version pour la prise en charge pour les HD 2xxx - 4xxx, le seul moyen si tu as une tour, c'est de changer pour une plus récente.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#9 Le 12/05/2013, à 17:00

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

C'est dommage ça ! C'est pas grave. Merci pour tout, tu m'as vachement aidé;)

Hors ligne

#10 Le 12/05/2013, à 18:12

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Je sais pas pourquoi c'est dommage, tu n'as pas un matos du futur et la 12.04 LTS fonctionne bien, il y'a que des avantages contrairement à ces intermédiaires... De rien.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#11 Le 12/05/2013, à 20:05

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

C'était pour faire tourner quelques jeux comme Morrowind ou encore profiter de l'arrivée de steam sur linux.

Hors ligne

#12 Le 12/05/2013, à 20:29

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Il Y a sûrement la possibilité d'installer steam sur la 12.04.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#13 Le 12/05/2013, à 21:51

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

J'ai pu installer steam et mes jeux mais j'ai un soucis avec Opengl. Je me suis donc dis que c'était à cause du pilote Readon, d'où mon envie de passer au pilote Catalyst.

A l'ouverture de steam j'ai ce message d'erreur

1368388222-opengl.png

Et à lancement du jeu j'ai le droit à un joli
"Could not find required OpenGl entry point 'glGetError' ! Either your video card id unsupported, or your OpenGL driver needs to be updated"

Hors ligne

#14 Le 13/05/2013, à 07:17

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Là, tu es sur quelle version buntu, la 12.04?


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#15 Le 13/05/2013, à 13:25

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

C'est bien ça, plus précisément xubuntu 12.04.

Hors ligne

#16 Le 13/05/2013, à 15:48

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Tu peux toujours essayer le catalyst legacy du PPA mais pour moi ta carte est obsolète.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#17 Le 13/05/2013, à 17:06

Korak

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Bonjour,

faucon50 a écrit :

Tu peux toujours essayer le catalyst legacy du PPA

Oui, tu peux toujours essayer. Mais je n'y crois pas trop.

faucon50 a écrit :

pour moi ta carte est obsolète.

Pas pour moi: pour moi elle est plus qu'obsolète.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

Hors ligne

#18 Le 13/05/2013, à 17:52

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Je le crains aussi, je vais laisser tomber. J'ai perdu trop de temps avec ça.

Merci pour votre aide, c'est gentil

Hors ligne

#19 Le 13/05/2013, à 18:38

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Ah le temps c'est de l'argent... Si tu as une tour et un slot PCIe, tu mets une CG actuel et l'affaire est réglée pour moins d'argent que le temps/€ h.

Dernière modification par faucon50 (Le 13/05/2013, à 18:51)


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#20 Le 13/05/2013, à 18:46

Korak

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

faucon50 a écrit :

Si tu as une tour et un slot PCIe, tu mets une CG actuel et l'affaire est réglée

Oui, tout-à-fait.

Mais si le matériel est trop vieux, est-ce que ça en vaut la peine (financièrement parlant)?

Quels sont:

- Processeur?
- Taille de la RAM?
- Carte graphique? Je sais, on la connaît, c'est juste pour rappel.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

Hors ligne

#21 Le 13/05/2013, à 18:51

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Korak a écrit :

Mais si le matériel est trop vieux, est-ce que ça en vaut la peine (financièrement parlant)?

Ben même si le reste du bousin est un peu coucou, il pourra toujours mettre sa nouvelle CG sur un autre bousin à l'avenir, c'est pas perdu. Et bon, une de ces AMD HD 6450 par exemple, ça vaut rien aujourd'hui.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#22 Le 13/05/2013, à 18:59

Korak

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

faucon50 a écrit :

Ben même si le reste du bousin est un peu coucou, il pourra toujours mettre sa nouvelle CG sur un autre bousin à l'avenir, c'est pas perdu. Et bon, une de ces AMD HD 6450 par exemple, ça vaut rien aujourd'hui.

En voyant la description de la carte graphique:

ATI RS690m X1200

Il me semble que le m veut dire PC portable. Je me trompe?

Dernière modification par Korak (Le 13/05/2013, à 19:00)


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

Hors ligne

#23 Le 13/05/2013, à 19:05

fcn50

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Ah c'est bien possible, c'est d'ailleurs toujours le cas me semble-t-il (M) sur les nouveaux. Ben, si c'est le cas, les carottes sont cuites.


14.04.1 LTS, Xfce 4.10.1, Phenom II x6 1090T BE, SSD Patriot Inferno 60 Go, WD Black 1 To, Sapphire HD 7750 ULTIMATE, RME HDSP 9632, Dell U2713HM.
Un site qui vaut le détour: http://blog.syti.net  Une radio hors du commun: http://solenopole.org  You like the american dream? Wellcome to Guantànamo!

Hors ligne

#24 Le 13/05/2013, à 19:38

seb1806

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Désolé, c'est moi qui ait mal reporté le modèle, c'est bien une tour.
Voici plus de détails :

1343825787.png
(à l'époque j'étais sur mint)

A la limite vous pensez qu'un changement de carte graphique + ajout de RAM + Os64bits pourrait être intéréssant ?

Hors ligne

#25 Le 13/05/2013, à 20:27

Korak

Re : [RESOLU]Installation pilote propriétaire pas si facile que ça (ATI)

Pour moi, c'est oui.

2 Go de RAM (ou plus) et une carte graphique relativement récente devrait faire l'affaire.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

Hors ligne

Haut de page ↑