Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 23/05/2013, à 19:55

Kota Giupeh

Re : Impossible de monter disque dur externe WS Elements 1024 1To

hugo@hugo-1000HE:~$ sudo ddrescue /dev/sdb /dev/sdc
[sudo] password for hugo: 
ddrescue: Output file exists and is not a regular file.
ddrescue: Use '--force' if you really want to overwrite it, but be
aware that all existing data in the output file will be lost.
Try 'ddrescue --help' for more information.

Euh là je ne comprends pas le retour de la commande par contre. Qu'est ce que j'ai mal fait?

Hors ligne

#27 Le 23/05/2013, à 20:06

tiramiseb

Re : Impossible de monter disque dur externe WS Elements 1024 1To

lsusb n'aidera pas à voir le chemin.

Moi je le fais à l'ancienne, je fais un "sudo fdisk -l" et je devine lequel est quoi. Mais bon c'est pas le plus fiable - c'est faisable seulement si on a peu de disques... big_smile

Après avoir branché un disque, il y a des messages du noyau. Pour voir les messages du noyau, il faut faire "dmesg". Du coup si tu exécutes la commande suivante immédiatement après avoir branché un disque, ça devrait te parler du sdX qui y correspond :

dmesg | tail -20

Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#28 Le 23/05/2013, à 20:18

Kota Giupeh

Re : Impossible de monter disque dur externe WS Elements 1024 1To

effectivement c'est bien sdb et sdc alors smile
par contre voilà ce que j'obtiens hmm

hugo@hugo-1000HE:~$ sudo ddrescue /dev/sdb /dev/sdc
[sudo] password for hugo: 
ddrescue: Output file exists and is not a regular file.
ddrescue: Use '--force' if you really want to overwrite it, but be
aware that all existing data in the output file will be lost.
Try 'ddrescue --help' for more information.

Hors ligne

#29 Le 23/05/2013, à 20:20

tiramiseb

Re : Impossible de monter disque dur externe WS Elements 1024 1To

Bah c'est assez explicite non ? smile
Il te prévient que la destination n'est pas un fichier classique (normal, c'est un disque) et te dit que toutes les données présentes dessus seront écrasées par le résultat de ddrescue (c'est bien ce que tu veux, non ?).
Il te dit que si tu es sûr que tu veux faire ça, il faut utiliser --force. Donc :

sudo ddrescue --force /dev/sdb /dev/sdc

Puis tu peux aller dormir le temps que ça tourne, je pense smile


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#30 Le 23/05/2013, à 20:27

Kota Giupeh

Re : Impossible de monter disque dur externe WS Elements 1024 1To

Ah bon bah merci alors, le fait de me demander de "forcer" m'a un peu intimidé mais en effet ça semble plutôt limpide en fait ^^
Ben je vais laisser tourner ça et vaquer à mes occupations alors.
Merci

Hors ligne

#31 Le 23/05/2013, à 23:43

Kota Giupeh

Re : Impossible de monter disque dur externe WS Elements 1024 1To

Bon par contre je n'en suis qu'à 1 Go de récupéré au bout de 4h, à ce rythme récupérer mes 300 Go et quelques de données me prendra plusieurs semaines ce que mon ordi comme le DDE ne supporteront sûrement pas... que puis je donc faire selon vous?

Hors ligne

#32 Le 24/05/2013, à 08:39

tiramiseb

Re : Impossible de monter disque dur externe WS Elements 1024 1To

Bon par contre je n'en suis qu'à 1 Go de récupéré au bout de 4h

Ton disque est en tellement mauvais état que ça ne m'étonne pas du tout. Mais il faut savoir ce qu'on veut... smile
Par contre la vitesse de ddrescue n'est pas du tout linéaire, il peut accélérer ou ralentir selon les problèmes qu'il rencontre. Donc on ne peut pas extrapoler une durée totale.

à ce rythme récupérer mes 300 Go et quelques de données me prendra plusieurs semaines

En effet si la vitesse est linéaire, 1 Go en 4 heures ça fait presque 25 semaines pour tout récupérer (ddrescue doit lire le disque complet, il ne sait pas où sont tes données). Il faut espérer que ça s'accélère un peu smile Ça dépend en fait des erreurs que ddrescue trouve...

que puis je donc faire selon vous?

Avec beaucoup plus de possibilités de pertes, tu peux directement utiliser photorec ou équivalent pour essayer de récupérer des fichiers, mais ça risque de ne pas aller plus vite et ça risque même de ne pas marcher...

Dernière modification par tiramiseb (Le 24/05/2013, à 08:40)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#33 Le 30/05/2013, à 20:06

Kota Giupeh

Re : Impossible de monter disque dur externe WS Elements 1024 1To

Bon alors là c'est quand même pas mal la m***

En effet ddrescue étant beaucoup trop lent il n' pas abouti et j'ai fini par y mettre fin après une semaine d'activité qui a tout juste permis de copier une 15 de Go... mais surtout le gros problème c'est qu'aujourd'hui quand je veux ouvrir mon nouveau disque dur, acheté la semaine passée et sur lequel je n'ai rien fait hormis cette opération, j'obtiens le même type de message qu'avec mon DDE endommagé

Error mounting /dev/sdf1 at /media/hugo/Elements: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdf1" "/media/hugo/Elements"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdf1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Au secours !

Hors ligne

#34 Le 30/05/2013, à 20:08

tiramiseb

Re : Impossible de monter disque dur externe WS Elements 1024 1To

C'est peut-être un problème de câble ou de contrôleur (carte mère)


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

#35 Le 30/05/2013, à 20:20

Kota Giupeh

Re : Impossible de monter disque dur externe WS Elements 1024 1To

Je ne suis pas sûr de comprendre ta réponse, en tout cas je sais qu'après l'achat je pouvais correctement accéder à ce DDE et que ce n'est plus le cas maintenant. Donc je ne pense pas que le problème vienne directement de lui ou de mon ordinateur, du moins d'un point de vue matériel.

Hors ligne

#36 Le 30/05/2013, à 22:16

navtex

Re : Impossible de monter disque dur externe WS Elements 1024 1To

semaine passée et sur lequel je n'ai rien fait hormis cette opération, j'obtiens le même type de message qu'avec mon DDE endommagé

Error mounting /dev/sdf1 at /media/hugo/Elements: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdf1" "/media/hugo/Elements"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).

sur ce topic on obtient çà

ubuntu@ubuntu:~$ sudo ntfsfix /dev/sda4
Mounting volume... Failed to read $UpCase, unexpected length (57344 != 131072).
FAILED
Attempting to correct errors...
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully

à noter que la commande ntfsfix a résolu  ceprobleme de DDE


Voyager 14.04  sur Dell vostro 1720  2.66GHz × 2  - Ram 4Gio
Voyager- 14.04  sur  Asus X56V   2.16GHz × 2  - Ram 3,9 Gio
Xubuntu 14.04  sur  Panasonic CF-M34  PIII 0,93Ghz   500Mo
(Keep the wind in your back)               mon ébauche blog- http://voiliershy.wordpress.com/

Hors ligne

#37 Le 31/05/2013, à 08:36

tiramiseb

Re : Impossible de monter disque dur externe WS Elements 1024 1To

'après l'achat je pouvais correctement accéder à ce DDE et que ce n'est plus le cas maintenant. Donc je ne pense pas que le problème vienne directement de lui ou de mon ordinateur

Donc pour toi, du matériel ça ne peut pas tomber en panne ?


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXème siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

Hors ligne

Haut de page ↑