Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/06/2007, à 10:27

toufalk

[résolu] accent avec aspell

Bonjour,
J'utilise LaTeX avec Kile.
Mon problème, c'est que la correction orthographique ne fonctionne pas très bien.
J'enregistre mes fichiers au format utf8 parce que c'est le format du système.
J'ai l'impression que ça pose problème à aspell : il coupe les mots au niveau des accents.
Du coup, la correction orthographique perd tout son sens!! Et moi, j'en ai vraiment besoin, parce que j'oublie la moitié des accents.

Un petit screenshot pour mieux comprendre.
screenshotaspellaccentwu4.th.png

Ce que je fais, en ce moment, c'est copier tout dans firefox et j'utilise le correcteur de firefox... Mais, c'est pas pratique et je pense que c'est le même moteur.


Si quelqu'un a une solution...

Dernière modification par toufalk (Le 02/07/2007, à 14:51)

Hors ligne

#2 Le 01/07/2007, à 21:03

MH

Re : [résolu] accent avec aspell

>Du coup, la correction orthographique perd tout son sens!!

Bein oui, j'ai eu le même pb sous LyX. Cela vient de l'UTF-8 qui n'est pas l'encodage par défaut d'aspell pour le français. En ligne de commande il faut passer à aspell l'option "--encoding=utf-8". Depuis LyX, il y a une option qui permet de faire ça automatiquement (case à cocher "Use input encoding"). Sous Kile, je suppose que ça doit aussi exister... smile

#3 Le 02/07/2007, à 14:38

toufalk

Re : [résolu] accent avec aspell

Mouais, je me doutais que c'était un truc comme ça...
Maintenant, la question, c'est "Elle est où la config de aspell dans Kile??"
J'ai cherché partout dans les préférences utilisateur, et je n'ai rien trouvé.

Quelqu'un sait où ça se trouve??

Hors ligne

#4 Le 02/07/2007, à 14:49

toufalk

Re : [résolu] accent avec aspell

Encore une fois, j'aurais du tourné 7 mon clavier dans ma bouche avant de demander...

la réponse se trouve ici

Par contre, pas moyen d'utiliser ispell... mais aspell s'en sort bien.

Dernière modification par toufalk (Le 02/07/2007, à 14:50)

Hors ligne

#5 Le 02/07/2007, à 16:54

Jahman

Re : [résolu] accent avec aspell

Pour ispell en francais, il faut installer le paquet ifrench-gut.

Ensuite Kile est une appli KDE donc il faut lancer kcontrol et dans "Composants KDE" voir correction orthographique et sélectionner le bon dico. Je dis ca de tete donc c'est pt etre un peu différent.


Sous les octets, la plage

Hors ligne

#6 Le 10/11/2007, à 11:12

fphilibert

Re : [résolu] accent avec aspell

Jahman a écrit :

Pour ispell en francais, il faut installer le paquet ifrench-gut.

Ensuite Kile est une appli KDE donc il faut lancer kcontrol et dans "Composants KDE" voir correction orthographique et sélectionner le bon dico. Je dis ca de tete donc c'est pt etre un peu différent.

Bonjour, personnellement, j'ai essayé ispell+le paquet ifrench-gut avec LyX et ça ne fonctionne pas avec un document encodé en utf8 : soit l'ajout de mots utf8 au dictionnaire personnel est cassé, soit le correcteur orthographique ne démarre pas avec l'erreur suivante : ispell:  unrecognized formatter type 'utf8' (ceci lorsqu'on coche la case 'use input encoding'). La même erreur se produit lorsqu'on essaye ispell en ligne de commandes. Si quelqu'un a une solution (si elle existe, ce dont je ne suis pas certain...), je suis preneur...