Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/06/2013, à 12:49

renaud07

[résolu] Virtualbox : Activer extension CPU

Bonjour,

J'ai voulu tester la preview windows 8.1 64bits mais ça m'affichait une erreur qui me disait de rebooter :

Your PC needs to restart.
Please hold down the power button.
Error code: 0x000000C4
Parameters:
0×0000000000000091
0x000000000000000F
0xFFFFF801E5962A80
0×0000000000000000

J'ai ensuite tenté l'installation à partir de 8 et l'assistant d'install me dit que mon processeur n'est pas compatible "compreexchage128" ce qui correspond à l'extension CMPXCHG16B ou cx16. Pourtant mon processeur est bien compatible et j'ai découvert qu'il fallait activer l'extension dans Vbox via cette commande :

"c:\Program Files\Oracle\VirtualBox\VBoxManage.exe" setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1

J'aurais donc besoin de l'équivalent Linux, je suppose que je n'ai qu'a changer le chemin d'install mais quel est-il ?

Merci !

Dernière modification par renaud07 (Le 28/06/2013, à 14:36)


-AMD FX 8350 4,6 Ghz - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 14.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 14.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 14.04 64 bits/windows 7 64 bits

Hors ligne

#2 Le 28/06/2013, à 13:29

ssdg

Re : [résolu] Virtualbox : Activer extension CPU

Je n'ai pas ma machine sous la main, mais VBoxManage existe aussi sous linux (puisqu'il est fourni avec virtualbox). Du coup, mon second reflexe aurait été de tapper ça dans une console:

VBoxManage setextradata [vmname] VBoxInternal/CPUM/CMPXCHG16B 1

(le premier étant de faire un man VBoxManage)


s'il n'y a pas de solution, c'est qu'il n'y a pas de problème... ou pas.

Hors ligne

#3 Le 28/06/2013, à 14:36

renaud07

Re : [résolu] Virtualbox : Activer extension CPU

Merci ça marche wink


-AMD FX 8350 4,6 Ghz - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 14.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 14.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 14.04 64 bits/windows 7 64 bits

Hors ligne

#4 Le 13/08/2014, à 11:22

spyro

Re : [résolu] Virtualbox : Activer extension CPU

Bonjour,

Je déterre ce topic, car j'ai rien trouvé d'autre concernant cette erreur sur Ubuntu.

j'utilise Ubuntu 14.04LTS et la dernière version de VirtualBox
J'ai le même problème, mais la commande à saisir dans un terminal ne fonctionne pas chez moi.
voila ce que cela me retourne si je remplace vmname par le nom du HDD virtuel (au format VMDK=VMware)

wullfk@UbuntuLTS:~$ VBoxManage setextradata [Windows 8.1PRO] VBoxInternal/CPUM/CMPXCHG16B 1
VBoxManage: error: Could not find a registered machine named '[Windows'
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports
VBoxManage: error: Context: "FindMachine(Bstr(a->argv[0]).raw(), machine.asOutParam())" at line 804 of file VBoxManageMisc.cpp

J'ai pas mis l'extension .VMDK , de toute façon c'est le même résultat

et si j’essaie avec le nom du répertoire de la VM ou le fichier .vbox du même nom:

wullfk@UbuntuLTS:~$ VBoxManage setextradata [VM Windows 8.1Pro] VBoxInternal/CPUM/CMPXCHG16B 1
VBoxManage: error: Could not find a registered machine named '[VM'
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports
VBoxManage: error: Context: "FindMachine(Bstr(a->argv[0]).raw(), machine.asOutParam())" at line 804 of file VBoxManageMisc.cpp

Ça veut dire quoi "faire un man VBoxManage" ?

Merci d'avance de l'aide que vous pourrez m'apporter.

@+

Dernière modification par spyro (Le 13/08/2014, à 11:34)


Ubuntu 14.04LTS  Trusty Thar - sur ASUS P5B Deluxe avec Intel E6600 et 3,4Go DDR2 - carte graphique ASUS EN 9600GT 512Mo - VM VirtualBox Debian 7.6
connexion : FreeBox (V6) en routeur + Routeur D-Link DIR-855 + D-Link DGS 1008D
Navigateur : Firefox - Mail : Thunderbird
Blogs : http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Hors ligne

#5 Le 13/08/2014, à 13:19

renaud07

Re : [résolu] Virtualbox : Activer extension CPU

Salut,

Je me rappel plus très bien ce que j'avais tapé mais, je viens de tester et j'obtiens la même erreur que toi. Par contre ça fonctionne si le nom de la VM n'a pas d'espace et qu'il n'y a pas les crochets (j’avais donc dû sûrement taper ça) :

VBoxManage setextradata VMWindows8.1Pro VBoxInternal/CPUM/CMPXCHG16B 1

N'oublie pas de modifier le nom de la VM avant en enlevant les espaces, pour ça, faire clique droit dessus > configuration et changer le nom.

Dernière modification par renaud07 (Le 13/08/2014, à 13:22)


-AMD FX 8350 4,6 Ghz - Asus M5A97 R2.0 - nVidia GT610 - 8 Go RAM - 500 Go/1 To - dualboot Ubuntu  cinnamon 14.04 64 bits/windows 7 64 bits
-Dell vostro 3550 - Intel core i5 2410M 2.30Ghz  - HD Gaphics 3000 - 4Go RAM - 320Go - dualboot Xubuntu 14.04 64 bits/windows 7 64 bits
-Asus Eee PC 1225B - AMD C-60 1 Ghz - 4Go RAM - 500Go - dualboot Xubuntu 14.04 64 bits/windows 7 64 bits

Hors ligne

#6 Le 13/08/2014, à 13:29

spyro

Re : [résolu] Virtualbox : Activer extension CPU

Salut,

Merci pour ta réponse.
J'ai pas comme toi "VboxInternal" mais seulement l'extension .vbox, faut il que je laisse un espace entre le nom et l'extension, ou mettre un point?
Je vais essayer tout de même en mettant ceci
VMWindows8.1Pro vbox

@+


Ubuntu 14.04LTS  Trusty Thar - sur ASUS P5B Deluxe avec Intel E6600 et 3,4Go DDR2 - carte graphique ASUS EN 9600GT 512Mo - VM VirtualBox Debian 7.6
connexion : FreeBox (V6) en routeur + Routeur D-Link DIR-855 + D-Link DGS 1008D
Navigateur : Firefox - Mail : Thunderbird
Blogs : http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Hors ligne

#7 Le 13/08/2014, à 13:33

spyro

Re : [résolu] Virtualbox : Activer extension CPU

Même résultat :

wullfk@UbuntuLTS:~$ VBoxManage setextradata [VMWindows8.1Pro vbox] VBoxInternal/CPUM/CMPXCHG16B 1
VBoxManage: error: Could not find a registered machine named '[VMWindows8.1Pro'
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports
VBoxManage: error: Context: "FindMachine(Bstr(a->argv[0]).raw(), machine.asOutParam())" at line 804 of file VBoxManageMisc.cpp

Ubuntu 14.04LTS  Trusty Thar - sur ASUS P5B Deluxe avec Intel E6600 et 3,4Go DDR2 - carte graphique ASUS EN 9600GT 512Mo - VM VirtualBox Debian 7.6
connexion : FreeBox (V6) en routeur + Routeur D-Link DIR-855 + D-Link DGS 1008D
Navigateur : Firefox - Mail : Thunderbird
Blogs : http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Hors ligne

#8 Le 13/08/2014, à 14:35

spyro

Re : [résolu] Virtualbox : Activer extension CPU

J'ai aussi essayer sans mettre les crochets:

wullfk@UbuntuLTS:~$ VBoxManage setextradata VMWindows8.1Pro vbox Internal/CPUM/CMPXCHG16B 1
Oracle VM VirtualBox Command Line Management Interface Version 4.3.14
(C) 2005-2014 Oracle Corporation
All rights reserved.

Usage:

VBoxManage setextradata     global|<uuid|vmname>
                            <key>
                            [<value>] (no value deletes key)


Syntax error: Too many parameters

Soit dit en passant j'ai essayé la solution pour Windows (sur un autre PC sous Windows 7 Pro 64bits) et ça ne fonctionne pas non plus.
Essayé aussi cette autre solution pour Windows à saisir dans "Command Prompt" en tan qu'administrateur:
"%programfiles%\oracle\virtualbox\vboxmanage.exe" setextradata "Image Name" VBoxInternal/CPUM/CMPXCHG16B 1
En remplacant "Image Name" par "VM Windows 8.1Pro" avec ou sans extension le résultat est le même : erreur
même résultat

Je sais plus quoi essayer, que ce soit sur Ubuntu ou Windows

sur Ubuntu y a qu'en utilisant VMware-Player que ça fonctionne (installation effectuée), malheureusement avec VMware on peut pas faire de "snapshot" raison pour laquelle je souhaitais passer par VirtualBox.


Ubuntu 14.04LTS  Trusty Thar - sur ASUS P5B Deluxe avec Intel E6600 et 3,4Go DDR2 - carte graphique ASUS EN 9600GT 512Mo - VM VirtualBox Debian 7.6
connexion : FreeBox (V6) en routeur + Routeur D-Link DIR-855 + D-Link DGS 1008D
Navigateur : Firefox - Mail : Thunderbird
Blogs : http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Hors ligne

#9 Le 13/08/2014, à 14:46

spyro

Re : [résolu] Virtualbox : Activer extension CPU

Si cela peut apporter de l'eau au moulin, j'ai constaté que le code erreur initial, n'est pas le même que sur le premier message de ce topic.
voici ce que j'ai sous Windows :

Your PC needs to restart.
Please hold down the power button.
Error code: 0x0000000A
Parameters:
0×FFFFFFE6
0x0000001F
0x00000000
0×81B2450B

et une très légère variante que ci dessus sur Ubuntu 14.04LTS:

Your PC needs to restart.
Please hold down the power button.
Error code: 0x0000000A
Parameters:
0×FFFFFFE6
0x0000001F
0x00000000
0×8152950B

La dernière ligne diffère.


Ubuntu 14.04LTS  Trusty Thar - sur ASUS P5B Deluxe avec Intel E6600 et 3,4Go DDR2 - carte graphique ASUS EN 9600GT 512Mo - VM VirtualBox Debian 7.6
connexion : FreeBox (V6) en routeur + Routeur D-Link DIR-855 + D-Link DGS 1008D
Navigateur : Firefox - Mail : Thunderbird
Blogs : http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Hors ligne

#10 Le 14/08/2014, à 10:35

ssdg

Re : [résolu] Virtualbox : Activer extension CPU

Et en mettant des guillements (") autour du nom de la VM ?


s'il n'y a pas de solution, c'est qu'il n'y a pas de problème... ou pas.

Hors ligne

#11 Le 14/08/2014, à 10:47

spyro

Re : [résolu] Virtualbox : Activer extension CPU

Non j'ai essayé, avec ou sans guillemets, avec ou sans crochets.

J'ai parcouru de long en large, la documentation de ma carte mère:  ASUS P5B DELUXE Rev.1.03G (BIOS 1226) Chipset P965
il s'avère que je ne dispose pas dans le BIOS de l'option VT-x indispensable pour une virtualisation de Windows 8 ou 8.1
J'en conclus que ma config, n'est pas compatible (mais c'est pas la seule dans ce cas).

That's all.


Ubuntu 14.04LTS  Trusty Thar - sur ASUS P5B Deluxe avec Intel E6600 et 3,4Go DDR2 - carte graphique ASUS EN 9600GT 512Mo - VM VirtualBox Debian 7.6
connexion : FreeBox (V6) en routeur + Routeur D-Link DIR-855 + D-Link DGS 1008D
Navigateur : Firefox - Mail : Thunderbird
Blogs : http://easy.pc.blog.free.fr OU http://easy-pc.over-blog.com

Hors ligne

Haut de page ↑