Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 27/07/2013, à 13:34

typix

[Résolu]Problème Plymouth

Bonjour,

Suite à l'installation de l'environnement Cinnamon, le splash-screen de lubuntu a disparu !
Au démarrage et à l'arrêt de mon ordinateur, je ne vois que du texte blanc sur fond noir, c'est pas joli surtout quand on peut afficher des plymouths relativement jolies.

Pour ce faire, j'ai regardé des discussions sur le forum pour réafficher le splash screen de lubuntu. J'ai cherché beaucoup, essayé plusieurs solution mais rien y fait.

J'ai aussi essayé d'installer plymouth-manager qui se lance mais ne modifie rien. (ça doit surement fonctionné mais je ne vois pas)

Suite à des recherches désespérées, j'ai choisi de supprimer le bureau Cinnamon.
Après cette suppression, l'environnement Cinnamon a disparu certes, mais le splash-screen etait toujours du texte blanc sur fond noir. Même en supprimant l'environnement Cinnamon, il est dit que sur le guide d'installation, que certains fichiers de configurations ne sont pas supprimés.

Quels sont ces fichiers de configuration ?

En attente de vous lire.

Dernière modification par typix (Le 11/08/2013, à 13:01)


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

#2 Le 27/07/2013, à 14:37

Babdu89

Re : [Résolu]Problème Plymouth

Bonjour.
Et si tu trouvais la réponse à ta question en t' inspirant de ceci ...

http://hybryde.cluster015.ovh.net/forum … f=7&t=1212

La commande suivante;

sudo update-alternatives --config default.plymouth

Permet d'afficher les thèmes installés dans Plymouth . Et de choisir parmi eux. 

Une foi le thème choisi et validé, on l'applique le choix de cette manière.

sudo update-initramfs -u

Quitter le terminal au prompt, et redémarrer .

En espérant que çà te permette de retrouver le thème de ton Lubuntu . Je ne pense pas qu'il soit désinstallé partes manips.

@+.  Babdu89 .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#3 Le 28/07/2013, à 15:58

typix

Re : [Résolu]Problème Plymouth

Bonjour,
Bonjour,

merci pour ta réponse mais j'ai déjà essayé ces commandes auparavant. Aucun succès ça aurait été trop simple sinon big_smile
Je sais bien que mon thème lubuntu n'a pas disparu.
J'ai aperçu qu'en appuyant sur la touche F11, le thème apparaissait pendant le démarrage ou l'arrêt, reste à savoir comment je peux faire apparaître le thème sans la touche F11 smile

à bientôt
typix.


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

#4 Le 29/07/2013, à 07:01

Babdu89

Re : [Résolu]Problème Plymouth

Bonjour.
Ah! , dommage.

Que donne ceci?.
Au démarrage de la machine, lorsque le menu Grub s'affiche . Tu édites la première ligne de l'entrée (touche  E)  et tu regardes dans le texte . Si tu vois derrière

quiet splash $vt_handoff

Tu supprimes " $vt_handoff "si il y est, ou tu l'ajoutes si il n'y est pas . Puis pour démarrer ta session tu utilises la touche  F10 . Çà modifie l'option de démarrage juste pour cette session .

Est ce que Plymouth s'affiche?.

J'ai des OS qui ont aussi un souci d'affichage de Plymouth, j'arrive à régler çà par ce "biais".

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#5 Le 29/07/2013, à 16:44

typix

Re : [Résolu]Problème Plymouth

Bonjour,

Quand j'ai vu votre message, ça m'a paru une bonne approche mais sauf qu'en essayant, le grub m'a dit que la commande quiet est inconnue.
Avant d'introduire la commande quiet splash $vt_handoff à la première ligne, j'ai regardé s'il y a avait quiet splash qq part mais non.
J'ai donc introduit cette commande en première ligne, mais aussi à la suite de la ligne "set-parameters" ou encore à l'intérieur de recordfail.
(recordfail c'est une balise présente par défaut, je suis sur lubuntu 13.04)
J'ai aussi essayé de mettre uniquement  $vt_handoff même si cela n'a pas de sens. (pour la machine bien sur et pour moi non plus d'ailleurs smile)
Et j'ai d'ailleurs exécuter ce script bash que j'ai trouvé sur le net :

#!/bin/bash
# ----------------------------------
# Author: D0rkye
# Homepage: http://d0rkye.zsenialis.com/
# Most code probably by kyleabaker: http://kyleabaker.com/2010/07/11/how-to … ot-screen/
#
# Fix for Ubuntu 11.04, for BURG, and some extra bloat by Paolo Bernardi (http://paolobernardi.wordpress.com/)
# ----------------------------------

# Usage: install_if_not_installed package_name
function install_if_not_installed
{
    PACKAGE="$1"
    INSTALLED=$(dpkg -L "$PACKAGE" > /dev/null 2>&1 && echo OK || echo KO)
    if [ "$INSTALLED" == "KO" ]
    then
        sudo apt-get install "$PACKAGE" -y
    fi
}

# Usage: contains regexp file
function contains
{
    REGEXP="$1"
    FILE="$2"

    grep "$REGEXP" "$FILE" > /dev/null && echo OK || echo KO
}

install_if_not_installed v86d
install_if_not_installed hwinfo

sudo hwinfo --framebuffer
echo "---------------------------------------------------------------"
echo "Please enter the best resolution from the list above"
echo "It usualy looks like this >>Mode 0x0323: 1024x768 (+4096), 24 bits<<"
echo "And you have to enter it like this >>1024x768-24<<"
echo "---------------------------------------------------------------"
read resolution

sed 's/GRUB\_CMDLINE\_LINUX\_DEFAULT\=\"quiet\ splash\"/GRUB\_CMDLINE\_LINUX\_DEFAULT\=\"quiet\ splash\ nomodeset\ video\=uvesafb\:mode\_option\='$resolution'\,mtrr\=3\,scroll\=ywrap\"/g' /etc/default/grub > ./newgrub
sudo cp -f ./newgrub /etc/default/grub
rm ./newgrub

sed 's/GRUB\_CMDLINE\_LINUX\_DEFAULT\=\"quiet\ splash\"/GRUB\_CMDLINE\_LINUX\_DEFAULT\=\"quiet\ splash\ nomodeset\ video\=uvesafb\:mode\_option\='$resolution'\,mtrr\=3\,scroll\=ywrap\"/g' /etc/default/burg > ./newburg
sudo cp -f ./newburg /etc/default/burg
rm ./newburg

sed 's/\#GRUB\_GFXMODE\=640x480/GRUB\_GFXMODE\='$resolution'/g' /etc/default/grub > ./newgrub
sudo cp -f ./newgrub /etc/default/grub
rm ./newgrub

if [ "$(contains uvesafb /etc/initramfs-tools/modules)" == 'KO' ]
then
    sudo echo "uvesafb mode_option=$resolution mtrr=3 scroll=ywrap" | sudo tee -a /etc/initramfs-tools/modules
fi

if [ "$(contains FRAMEBUFFER=y /etc/initramfs-tools/conf.d/splash)" == 'KO' ]
then
    echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
fi

sed 's/GRUB\_CMDLINE\_LINUX\_DEFAULT\=\"\(.*\)vt\.handoff\=7\(.*\)\"/GRUB\_CMDLINE\_LINUX\_DEFAULT\=\"\1\2\"/g' /etc/grub.d/10_linux > ./new10linux
sudo cp -f ./new10linux /etc/grub.d/10_linux
rm ./new10linux
sudo chmod +x /etc/grub.d/10_linux

sudo update-grub2
which update-burg > /dev/null 2>&1 && sudo update-burg
sudo update-initramfs -u
echo "The resolution should be fixed after a reboot"

Je ne pense pas que ce code soit pour plymouth mais plutôt pour fixer une résolution d'écran.
En réalité, ce script m'a modifié la résolution d'écran qui n'est pas accepté au démarrage (heureusement). Et au final ça m'a juste modifié les couleurs de fond du grub.
J'ai désormais un grub avec un fond bleu smile C'est plus joli que du blanc sur noir.

Je cherche donc toujours désespérément une solution et merci pour tes réponses.


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

#6 Le 29/07/2013, à 22:54

Babdu89

Re : [Résolu]Problème Plymouth

Bonsoir.

Désolé, mais je n'ai plus d'idée .

Bon courage.

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#7 Le 30/07/2013, à 11:58

typix

Re : [Résolu]Problème Plymouth

Bonjour,

merci quand même, est-ce qu'il y a une possibilité d'installer la commande quiet splash dans le grub ?

typix.


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

#8 Le 11/08/2013, à 12:58

typix

Re : [Résolu]Problème Plymouth

Merci Babdu89, problème résolu, fin c'était pas vraiment un problème au final :;)

grâce à ce post --> http://forum.ubuntu-fr.org/viewtopic.php?pid=11692331


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

#9 Le 02/01/2014, à 19:37

vince2corte

Re : [Résolu]Problème Plymouth

Salut typix !
Saurais-tu retrouver le post en question, car là, ça ne semble pas aller vers le bon fil de discussion. J'ai le même problème et je voudrais bien essayer de le résoudre. Merci.
Meilleur voeux !


La liberté commence où l'ignorance finit  - Victor Hugo
i7 2600k - P8Z77-V - NVidia GTX 680 2Go - EXSYS EX-16415 - RAM 16Go - SSD 120Go - HD 1To - Moniteur 27'' S27A850D en 2560x1440 - Ubuntu 12.04 LTS 64 bits - NAS Synology DS211+ 2x2To RAID 1

En ligne

#10 Le 03/01/2014, à 16:43

typix

Re : [Résolu]Problème Plymouth

Salut vince2corte,

Pour mon cas à moi, pour résoudre ce problème, j'ai ouvert le fichier grub.cfg en tant que root avec leafpad :

#leafpad /boot/grub/grub.cfg

Ensuite j'ai inséré ceci à 2 endroits :

quiet splash $vt_handoff

à la fin de la ligne 133 et à la fin de la ligne 132 juste après le ro
Si les lignes ne correspondent pas, essaye de trouver une ligne se terminant par un ro.
Si tu trouves la 1ere ligne avec un ro, tu trouvera une autre ligne se terminant par un ro qui est pas trop loin de la 1ere.

Mais cette tâche est à répéter après chaque mise à jour.
Voila, en espérant que tu résoudra ton problème.
A+ et Meilleur voeux !


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

#11 Le 03/01/2014, à 17:34

Babdu89

Re : [Résolu]Problème Plymouth

Bonjour.
C'est bien bizarre ce truc là...
Dans le fichier Grub.cfg de Hybryde Fusion 12.04, que j'utilise en permanence.
Il faut que je supprime la même chose ($vt_handoff) après le premier quiet splash ,pour que Plymouth s'affiche au démarrage. Sinon ,écran noir, avant d'arriver sur l'écran de connexion...

117	linux	/boot/vmlinuz-3.5.0-44-generic root=UUID=13e85d6b-8747-460a-a689-7cc49f349d06 ro   quiet splash 

J'ai aussi un Xubuntu 12.04 qui me fait çà ...

Mes autres distros installées ne posent pas ce souci...

@+.    Babdu89     .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#12 Le 03/01/2014, à 19:39

vince2corte

Re : [Résolu]Problème Plymouth

Merci beaucoup à vous deux. Je vais étudier ça de plus près au plus tôt.
@+


La liberté commence où l'ignorance finit  - Victor Hugo
i7 2600k - P8Z77-V - NVidia GTX 680 2Go - EXSYS EX-16415 - RAM 16Go - SSD 120Go - HD 1To - Moniteur 27'' S27A850D en 2560x1440 - Ubuntu 12.04 LTS 64 bits - NAS Synology DS211+ 2x2To RAID 1

En ligne

#13 Le 04/01/2014, à 20:39

typix

Re : [Résolu]Problème Plymouth

Merci de signaler ce problème Babdu89.
La première fois que j'ai utilisé Hybride Fusion, j'étais surpris par sa fluidité.

@+


Quel est la différence entre Windows et Linux ?
Avec Linux, vous êtes un peu ... comme Neo dans Matrix alors que sur Windows, je vous laisse imaginer ..

Hors ligne

Haut de page ↑