Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 05/10/2013, à 22:33

Frkevin

[Résolu] keryx

Bonjour
J'ai un problème avec ce logiciel.Je m'explique.
Je viens tous juste d'installer ubuntu, j'ai trouvez sur ce ubuntu.fr un lien qui permet de configurez ma clé wifi seulement voila pour ce faire j'ai besoins d’installer des paquets et ces dépendances.
Après des recherches, j'ai trouvez un petit logiciel "keryx", je lis le fichier le fichier README.
Il me dis que je dois le lancer dans un premier dans sur ubuntu, cela marche.
Après, je vais sur Windows (celui qui a internet) seulement je ne peut pas le lancer. Quant je double clique sur le fichier, une invite de commande s'ouvre et se referme d'un coup.
Je tiens a préciser que j’utilise la version portable (1.0-public21),
  Cordialement


PS: Je suis dessolé si un poste similaire existe déjà, ou que je me sois tromper d'endroit pour poster ce problème.

Dernière modification par Frkevin (Le 14/10/2013, à 19:22)

Hors ligne

#2 Le 05/10/2013, à 23:55

vikin712

Re : [Résolu] keryx

Bonsoir.

D'après la page de documentation sur keryx le site officiel n'existe plus. J'ai testé et c'est bien le cas.
La version que tu as téléchargé est bien une version portable mais pour système d'exploitation GNU/Linux. J'ai regardé dans l'archive il n'y a aucun exécutable pour Windows.
La version actuelle est programmée en Python c'est pour cela que l'invite de commande s'ouvre lorsque clique dessus mais ça n'ira pas plus loin.

#3 Le 06/10/2013, à 09:32

Frkevin

Re : [Résolu] keryx

Bonjour
Pour keryx:
   J'ai tester une versions plus ancienne de keryx (la verssions Keryx_Ubuntu_x86), il y a un exécutable pour Windows et un fichier keryx_linux_32bit sans extensions.
Je fait la même manipe c'est a dire:
je vais sous ubuntu, j'utilise la commande ./keryx_linux_32bit pour l’exécuter mais il me dit permissions denied j'ai tester avec la commande chmod mais rien n'a faire j'obtiens toujours le même résultat .
J'ai essayé de double clique dessus mais ça ne fait rien.

Sinon pour les paquets a télécharger j'ai essayé un autre logiciel (wubdepends) mais il y a une erreur dans le log:

Traceback (most recent call last):
  File "wubdepends3.py", line 518, in button_is_clicked
  File "wubdepends3.py", line 546, in periodic_call
  File "wubdepends3.py", line 364, in do_windows
  File "wubdepends3.py", line 243, in get_more
  File "wubdepends3.py", line 95, in get_package
  File "urllib.pyc", line 82, in urlopen
  File "urllib.pyc", line 190, in open
  File "urllib.pyc", line 325, in open_http
  File "httplib.pyc", line 856, in endheaders
  File "httplib.pyc", line 728, in _send_output
  File "httplib.pyc", line 695, in send
  File "httplib.pyc", line 663, in connect
IOError: [Errno socket error] (11004, 'getaddrinfo failed')

.

Cordialement

Dernière modification par Frkevin (Le 06/10/2013, à 09:33)

Hors ligne

#4 Le 06/10/2013, à 15:56

vikin712

Re : [Résolu] keryx

Bonjour.

Pourrais-tu poster le lien de la version qui contient exécutable Windows pour que je puisse tester. Merci.

#5 Le 06/10/2013, à 17:12

Frkevin

Re : [Résolu] keryx

je l'ai trouvé ici:
https://launchpad.net/keryx/+download c'est la 0.92  Keryx_Ubuntu_x86.zip
Sous Windows ça passe mais pour Linux ça merde. Je veux dire que quand 'exécute le fichier se trouvant dans le dossier "Linux" il me dit permissions denied.

J'ai aussi essayé la versions 0.91 de keryx (https://launchpad.net/keryx/stable/0.91).
La aussi il y a un exécutable pour Windows il marche mais sur Linux il y une erreur d'importation d'une bibliothèque wxkeryx.
Cordialement

Hors ligne

#6 Le 06/10/2013, à 17:54

vikin712

Re : [Résolu] keryx

J'ai testé les deux versions que tu as indiqué sur Ubuntu 12.04 et elles fonctionnent.

Pour la version Keryx_Ubuntu_x86.zip avant de lancer le fichier keryx.py qui se trouve dans le dossier source j'ai fait un clic droit dessus puis Permissions puis j'ai coché la case Autoriser l'exécution du fichier comme un programme.
Ensuite je l'ai lancé via un terminal avec la commande

./keryx.py

et le programme s'est ouvert.

Sur la version 0.91 le fichier était déjà exécutable. J'ai eu juste à le lancer et le programme s'est ouvert.
C'est bizarre ce problème de dépendance que tu rencontres parce qu'elle est présente dans l'archive.

Tu utilises quelle version Ubuntu et quelle architecture. 32 ou 64 bits ?

#7 Le 07/10/2013, à 16:07

Frkevin

Re : [Résolu] keryx

Bonjour
je suis sur la dernière versions d'ubuntu en 64 bits.
Je me suis en root.
Pour Keryx_Ubuntu_x86.zip:
Quand je clique: Execute allow executting file as programm, la crois s'enlève instantanément.
Pour la version 0.91, dans le dossier in n'y a pas d'exécutable mais un fichier keryx.py et j'obtiens toujours une erreur de dépendances.
Voici quelque screen du terminal:
1) en normal:
641227Screenshotfrom20131007154053.png
2) en root:
252632root.png
Cordialement

Dernière modification par Frkevin (Le 07/10/2013, à 16:08)

Hors ligne

#8 Le 07/10/2013, à 17:30

vikin712

Re : [Résolu] keryx

Bonjour.

Frkevin a écrit :

je suis sur la dernière versions d'ubuntu en 64 bits.

Normal qu'il y ait des problèmes de droits et dépendances. Tu utilises une version 32 bits sur une installation 64 bits.
Deux choix :
- 1 tu utilises la version de Keryx prévue pour système 64 bits.
ou
- 2 tu installes le paquet ia32-libs-multiarch pour pouvoir faire tourner la version 32 bits sur ton système 64 bits.

#9 Le 08/10/2013, à 18:37

Frkevin

Re : [Résolu] keryx

Bonjour
Pourtant la versions 32 bits de keryx s'exécute sur mon Windows 64 bits.
De plus je n'ai pas trouvé de keryx en 64 bits.
Cordialement

Hors ligne

#10 Le 08/10/2013, à 20:25

vikin712

Re : [Résolu] keryx

Bonsoir.

Frkevin a écrit :

Pourtant la versions 32 bits de keryx s'exécute sur mon Windows 64 bits.

Là tu parles de la version Windows.
Ubuntu et Windows ne fonctionnent pas de la même façon.

Frkevin a écrit :

De plus je n'ai pas trouvé de keryx en 64 bits.

Effectivement j'ai regardé un peu vite et ce que je croyais être des versions 64 ne sont en fait que les dépendances.
Donc installe le paquet ia32-libs-multiarch pour pouvoir faire tourner la version 32 bits sur ton système 64 bits.
J'utilise une version 64 bits d'Ubuntu toutes les versions que tu as indiqué se lancent sur mon pc.

Dernière modification par vikin712 (Le 08/10/2013, à 20:25)

#11 Le 09/10/2013, à 22:23

Frkevin

Re : [Résolu] keryx

Bonjour
N'y-a t-il pas moyen de télécharger tous les dépendances d'un coup car l y en a beaucoup ?
Cordialement

Hors ligne

#12 Le 09/10/2013, à 22:57

vikin712

Re : [Résolu] keryx

Bonsoir.

Je t'ai dit installe le paquet ia32-libs-multiarch et tu pourras faire tourner la version 32 bits sur ton système 64 bits.

#13 Le 10/10/2013, à 14:54

Frkevin

Re : [Résolu] keryx

Bonjour
l'or de l'installation de  ia32-libs-multiarch, 'obtiens des erreurs de dépendance alors que certaine dépendance sont déjà installé.Pr exemple j'aue erreur de pendance sur le paquet bluez-alsa_4.98-2ubuntu7_amd64 alors qu'une version ressente est déjà installé.
Je ne peut donc pas installer ia32-libs-multiarch
Cordialement

Hors ligne

#14 Le 10/10/2013, à 15:59

vikin712

Re : [Résolu] keryx

Bonjour.

C'est bizarre parce que tu dis utiliser la dernière version d'Ubuntu mais paquet bluez-alsa_4.98-2 est disponible sur Ubuntu 12.04. De plus le fichier Control du paquet ia32-libs-multiarch ne précise pas le numéro de version de bluez-alsa à installer. Donc normalement il ne devrait pas y avoir de problème.

Tape dans un terminal

sudo apt-get update

puis

sudo apt-get install ia32-libs-multiarch 

pour voir ce que cela donne.
Et si ça ne fonctionne pas indique si il y a des messages d'erreur.

#15 Le 11/10/2013, à 21:25

Frkevin

Re : [Résolu] keryx

Bonjour
les commandes que vous demande ne peut se faire si je suis connecter a internet que je n'est pas.C'est d'ailleurs pour ça que je veux utiliser keryx.
Cordialement

Hors ligne

#16 Le 12/10/2013, à 16:28

vikin712

Re : [Résolu] keryx

Bonjour.

J'ai testé après avoir supprimé le paquet ia32-libs-multiarch et ses dépendances toutes les versions indiquées et elles fonctionnent sur mon système.
Tu devrais si tu en as la possibilité connecter ton pc en filaire et installer keryx sur Ubuntu en utilisant le paquet deb. Si il manque des dépendances elles seront installées automatiquement.
Et si tu ne tu peux pas le connecter en filaire, télécharge tout de même le paquet deb depuis Windows et cherche à l'installer sur Ubuntu. Ainsi tu sauras quelques sont les dépendances manquantes et tu pourras les télécharger manuellement en les cherchant depuis cette adresse. http://packages.ubuntu.com/
Ensuite il te suffira de les installer manuellement avant d'installer le deb de keryx.

#17 Le 13/10/2013, à 12:55

Frkevin

Re : [Résolu] keryx

Bonjour
Mon problème a été résolu, merci.
Cordialement

Hors ligne

#18 Le 13/10/2013, à 13:14

vikin712

Re : [Résolu] keryx

Bonjour.

Édite ton premier message et ajoute [Résolu] devant le titre. Merci.

Dernière modification par vikin712 (Le 13/10/2013, à 13:14)