Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 17/10/2013, à 17:23

jfraudet

Résolu : probleme de clavier dans ubuntu 13.10

Bonjour

Je viens d4instqller ubuntu et j4qi des proble;e de clqvier lq touche qlt +arobase ne fonctionne plus et j ai le a a lq place du q etc Aider ;oi ;erci

Dernière modification par jfraudet (Le 17/10/2013, à 18:43)

Hors ligne

#2 Le 17/10/2013, à 17:23

jfraudet

Re : Résolu : probleme de clavier dans ubuntu 13.10

ubuntu 13.10

Hors ligne

#3 Le 17/10/2013, à 19:11

tiramiseb

Re : Résolu : probleme de clavier dans ubuntu 13.10

Salut,

Tu as configuré ton PC avec le clavier anglais.

Dans les paramètres système, tu peux choisir le type de clavier...

Hors ligne

#4 Le 17/10/2013, à 23:16

ysuire

Re : Résolu : probleme de clavier dans ubuntu 13.10

Ca ne marche pas, j ai le meme probleme ... et il est sense etre en francais ...


- PC Dell Optiplex GX520, Ubuntu 19.04 64 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 4 Go RAM PC4200
- PC portable Compaq CQ 62, Ubuntu 19.04 64 bits, Carte graphique Mobile Intel® GM45 Express Chipset, Processeur Intel® Celeron(R) CPU 900 @ 2.20GHz, 2.9 Go de RAM.

Hors ligne

#5 Le 17/10/2013, à 23:22

tiramiseb

Re : Résolu : probleme de clavier dans ubuntu 13.10

Ca ne marche pas

Quoi précisément ne marche pas ? Qu'as-tu fait exactement ?

Es-tu certain d'avoir sélectionné le bon clavier lors de l'installation ?
Un ordinateur ne choisit pas tout seul de mettre un clavier anglais si tu as bien sélectionné le clavier français...

Hors ligne

#6 Le 17/10/2013, à 23:26

ysuire

Re : Résolu : probleme de clavier dans ubuntu 13.10

J'ai fait l'update, mais j'ai compris ... apparemment le système choisit tout seul le qwerty par défaut, et il faut recliquer dans la barre du haut le clavier FR ... apparemment c'était un bug qui était déjà rencontré dans la beta, mais qui n'a pas été résolu. Donc il faut rappuyer sur "Fr" dans la barre des taches pour avoir à nouveau le clavier français.


- PC Dell Optiplex GX520, Ubuntu 19.04 64 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 4 Go RAM PC4200
- PC portable Compaq CQ 62, Ubuntu 19.04 64 bits, Carte graphique Mobile Intel® GM45 Express Chipset, Processeur Intel® Celeron(R) CPU 900 @ 2.20GHz, 2.9 Go de RAM.

Hors ligne

#7 Le 17/10/2013, à 23:31

tiramiseb

Re : Résolu : probleme de clavier dans ubuntu 13.10

Si je comprend bien, tu as simplement ajouté le clavier français dans la liste des claviers, en laissant le clavier anglais par défaut (premier de la liste)

Il faut :
- soit supprimer l'agencement anglais pour n'avoir que le français
- soit monter l'agencement français en premier dans la liste, pour qu'il soit par défaut

Hors ligne

#8 Le 17/10/2013, à 23:33

ysuire

Re : Résolu : probleme de clavier dans ubuntu 13.10

C'est le problème, c'est que j'ai déjà fait ça, mais ça n'y change rien ... je n'ai pas de clavier anglais dans la liste lol


- PC Dell Optiplex GX520, Ubuntu 19.04 64 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 4 Go RAM PC4200
- PC portable Compaq CQ 62, Ubuntu 19.04 64 bits, Carte graphique Mobile Intel® GM45 Express Chipset, Processeur Intel® Celeron(R) CPU 900 @ 2.20GHz, 2.9 Go de RAM.

Hors ligne

#9 Le 17/10/2013, à 23:36

tiramiseb

Re : Résolu : probleme de clavier dans ubuntu 13.10

Ah zut... Alors là en effet je ne sais pas quoi dire de plus...

Hors ligne

#10 Le 17/10/2013, à 23:38

ysuire

Re : Résolu : probleme de clavier dans ubuntu 13.10

Bah faut que les développeurs fassent le correctif, ça avait déjà été signalé sur launchpad, mais sans résultat : https://bugs.launchpad.net/ubuntu/+sour … ug/1238346

D'ailleurs, si quelqu'un a une idée pourquoi j'ai des icones dans la barre des tâches dignes d'un kde, qu'il me fasse signe ... je sais que c'est hors sujet mais j'aimerais bien régler ce truc là aussi lol


- PC Dell Optiplex GX520, Ubuntu 19.04 64 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 4 Go RAM PC4200
- PC portable Compaq CQ 62, Ubuntu 19.04 64 bits, Carte graphique Mobile Intel® GM45 Express Chipset, Processeur Intel® Celeron(R) CPU 900 @ 2.20GHz, 2.9 Go de RAM.

Hors ligne

#11 Le 19/10/2013, à 11:34

ricou33

Re : Résolu : probleme de clavier dans ubuntu 13.10

Bonjour,
+1
J'ai le même problème.
Pourquoi avoir mis ce topic à résolu ?

Hors ligne

#12 Le 19/10/2013, à 11:50

ysuire

Re : Résolu : probleme de clavier dans ubuntu 13.10

Parce qu'on a apporté une solution peut-être ...

Dernière modification par ysuire (Le 19/10/2013, à 11:50)


- PC Dell Optiplex GX520, Ubuntu 19.04 64 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 4 Go RAM PC4200
- PC portable Compaq CQ 62, Ubuntu 19.04 64 bits, Carte graphique Mobile Intel® GM45 Express Chipset, Processeur Intel® Celeron(R) CPU 900 @ 2.20GHz, 2.9 Go de RAM.

Hors ligne

#13 Le 19/10/2013, à 13:08

ricou33

Re : Résolu : probleme de clavier dans ubuntu 13.10

Ben à part faire +1 dans launchpad (ce que j'ai fait) je ne vois pas vraiment ce qui règle le problème... hmm
T'as réussi à faire marcher ton @ autrement qu'en faisant un copier-coller ?

Hors ligne

#14 Le 19/10/2013, à 17:03

Bob_Io

Re : Résolu : probleme de clavier dans ubuntu 13.10

J'ai eu le même problème après installation dans mon VMWare Workstation.

Je l'ai résolu en allant sur Paramètres ->Clavier->Paramètres d'avancement(un lien hypertexte)
J'ai ajouté le clavier Français que j'ai associé à toutes les fenêtre et depuis ça marche du feu de Dieu ... @@@@@@@@@

Hors ligne

#15 Le 19/10/2013, à 17:04

Bob_Io

Re : Résolu : probleme de clavier dans ubuntu 13.10

Oups Paramètre d'agencement

Hors ligne

#16 Le 27/10/2013, à 00:23

ricou33

Re : Résolu : probleme de clavier dans ubuntu 13.10

Bonjour,

Le problème de l'arobase a été résolu en faisant :

sudo dpkg-reconfigure keyboard-configuration

et en choisissant la touche "Alt de droite" pour définir la touche de composition (ou un truc de ce style).
Le noyau est alors reconfiguré et tout revient dans l'ordre.
Le symbole €, qui avait disparu lui aussi en passant à la 13.10, est revenu en même temps que l'@  smile

Hors ligne

#17 Le 27/10/2013, à 00:44

hr

Re : Résolu : probleme de clavier dans ubuntu 13.10

ricou33 a écrit :

touche "Alt de droite" pour définir la touche de composition (ou un truc de ce style).

Non, pas ce style-là… wink
Dans la configuration dans le terminal ça s’appelle « Touche destinée à se subtituer à Alt Gr ». Le même paramètre s’appelle par contre « Touche de caractères alternatifs » dans les paramètres système.
De même « touche compose » dans le terminal s’appelle « touche de composition » dans les paramètres système.
Cette touche de composition permet aussi de taper @ d’ailleurs, mais autrement : touche de composition puis A puis T.

Dernière modification par hr (Le 27/10/2013, à 00:59)


Trois PC de bureau et un MacBook, tous datant des environs de 2006 et tournant en Ubuntu 16.04 64 bits

Hors ligne

#18 Le 28/10/2013, à 10:09

ysuire

Re : Résolu : probleme de clavier dans ubuntu 13.10

ricou33 a écrit :

Ben à part faire +1 dans launchpad (ce que j'ai fait) je ne vois pas vraiment ce qui règle le problème... hmm
T'as réussi à faire marcher ton @ autrement qu'en faisant un copier-coller ?

J'ai fait l'update, mais j'ai compris ... apparemment le système choisit tout seul le qwerty par défaut, et il faut recliquer dans la barre du haut le clavier FR ... apparemment c'était un bug qui était déjà rencontré dans la beta, mais qui n'a pas été résolu. Donc il faut rappuyer sur "Fr" dans la barre des taches pour avoir à nouveau le clavier français.


- PC Dell Optiplex GX520, Ubuntu 19.04 64 bits, Carte graphique Intel® 945G x86/MMX/SSE2, Processeur Intel Celeron 2.80 GHz, 4 Go RAM PC4200
- PC portable Compaq CQ 62, Ubuntu 19.04 64 bits, Carte graphique Mobile Intel® GM45 Express Chipset, Processeur Intel® Celeron(R) CPU 900 @ 2.20GHz, 2.9 Go de RAM.

Hors ligne

#19 Le 28/10/2013, à 14:48

Henriette D.

Re : Résolu : probleme de clavier dans ubuntu 13.10

Hello, j'ai le même souci, mon clavier ne correspond pas.

Dans les paramètres d'agencement du clavier, j'ai seulement le choix entre English (USA) et Belge.
Je suis sous le clavier belge mais le @ n'est pas au bon endroit, le - et aussi le !
Comme je n'ai que le choix entre "belge" et "english" je ne vois pas comment trouver une alternative à l'agencement actuel...

Hors ligne

#20 Le 29/10/2013, à 19:38

perco

Re : Résolu : probleme de clavier dans ubuntu 13.10

bonsoir à tous,

meme problème pour moi ...

si je redémarre.. galère > qwerty ! alors que dans la config je n'ai que le clavier belge...

alors mettre mon mot de passe ...


GNU linux la liberté pour ceux qui veulent ...
Ubunteros depuis 7.04 Feisty Fawn.

Hors ligne

#21 Le 29/10/2013, à 19:55

perco

Re : Résolu : probleme de clavier dans ubuntu 13.10

Re,

sur un autre post :

http://forum.ubuntu-fr.org/viewtopic.ph … #p15049261

la solution fonctionne chez moi.

Plus de problème après redémarrage !


GNU linux la liberté pour ceux qui veulent ...
Ubunteros depuis 7.04 Feisty Fawn.

Hors ligne

#22 Le 02/11/2013, à 15:55

ricou33

Re : Résolu : probleme de clavier dans ubuntu 13.10

Bonjour,

@hr : en effet j'avais raconté un peu n'importe quoi, et de toute façon quand je ferme ma session la touche ALT-GR se remet à foirer à l'ouverture.

La solution de la touche ALT-GR, j'ai fini par la trouver en cherchant un peu, comme celle du clavier anglais d'ailleurs.
En créant un nouvel utilisateur, je me suis rendu compte que ça fonctionnait correctement pour lui avec une conf toute neuve. Ça voulait donc dire que le problème se trouvait sur ma conf utilisateur. J'ai donc cherché avec dconf-editor en comparant les deux séries de paramètres.

Pour le problème de la touche ALT-GR et de mon arobase, du symbole euro, etc :
Avec dconf-editor dans org/gnome/desktop/input-sources, j'avais xkb-options = ['compose:ralt'] que j'ai remplacé par ['compose:menu'] => résolu

Pour le problème du clavier français/anglais, j'ai supprimé la solution de contournement avec le clavier anglais, et j'ai modifié le paramètre suivant :
Avec dconf-editor dans desktop/ibus/general j'avais engines-order = ['xkb:us::eng','xkb:fr::fra','xkb:fr:oss:fra'] que j'ai remplacé par ['xkb:fr::fra'] tout seul => résolu également.

Edit :
J'avais oublié, il y a une deuxième modif que j'ai faite pour le clavier : même opération que engines-order avec preload-engines.

Dernière modification par ricou33 (Le 02/11/2013, à 16:01)

Hors ligne

#23 Le 03/11/2013, à 02:14

hr

Re : Résolu : probleme de clavier dans ubuntu 13.10

Super ! Tout est donc réglé chez toi.
DConf Editor est effectivement un outil bien commode pour certaines choses un peu tordues qui résistent. Je m’en sers de temps en temps pour détricoter des histoires de config bizarres.
Pour engines-order et preload-engines, je n’ai pas bien compris ce que l’aide très succinte de dconf en dit. As-tu trouvé de la doc plus claire sur ces paramètres ?

Dernière modification par hr (Le 03/11/2013, à 02:14)


Trois PC de bureau et un MacBook, tous datant des environs de 2006 et tournant en Ubuntu 16.04 64 bits

Hors ligne

#24 Le 03/11/2013, à 09:39

ricou33

Re : Résolu : probleme de clavier dans ubuntu 13.10

Oui, ça fait du bien de retrouver un clavier correct après deux semaines de recherches smile
Ben non, pas trouvé (ni cherché) de doc là-dessus.
Je me suis contenté de comparer ma conf avec une toute neuve, et puis j'ai essayé en y allant à tâtons...

Hors ligne

#25 Le 03/11/2013, à 13:41

hr

Re : Résolu : probleme de clavier dans ubuntu 13.10

ricou33 a écrit :

Je me suis contenté de comparer ma conf avec une toute neuve, et puis j'ai essayé en y allant à tâtons...

D’accord. Chez moi j’ai aussi un problème, très mineur mais qui m’ennuie parce qu’il est incompréhensible, sur une configuration modifiée du clavier. J’ai essayé de jouer sur ces paramètres dans dconf mais sans effet, d’où ma question.
Pas bien grave, le clavier fonctionne comme je l’ai défini, même s’il faut que je ruse un peu pour la configuration. Pour l’utilisation c’est transparent.

Dernière modification par hr (Le 03/11/2013, à 13:43)


Trois PC de bureau et un MacBook, tous datant des environs de 2006 et tournant en Ubuntu 16.04 64 bits

Hors ligne