Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 17/10/2013, à 22:15

melodie

Sondage : Lubuntu avec FAKE-PAE, êtes-vous concerné ?

Un membre anglophone de la communauté Lubuntu, Nio Wiklund, alias sudodus, a mis au point une version de Lubuntu avec un job Upstart nommé "FAKE PAE":
https://help.ubuntu.com/community/Lubuntu-fake-PAE
En quoi cela consiste-t-il ?  Un autre membre, nommé Bernd Kreuss, a proposé de faire fonctionner des versions de Ubuntu >=12.10 fonctionner sur des machines telles que l'IBM Thinkpad T40 et d'autres dotées de processeurs Pentium M et Celeron M : http://ubuntuforums.org/showthread.php?t=2113826

L'astuce consiste à ajouter le marqueur "pae" au processeur, qui en fait est doté de cette instruction, mais pour des raisons (?) cela n’apparait pas dans un "cat /proc/cpuinfo" par exemple. (Il me manque des infos pour comprendre tout le tintouin, mais en gros le script créé par Bernd Kreuss résoud ce problème pour une grande partie des machines un peu anciennes).
Voici la page du ppa de "fake-pae": https://launchpad.net/~prof7bit/+archive/fake-pae

Alors le kernel PAE va pouvoir reconnaitre toute la RAM sur les machines dotées de 4 Go de mémoire vive et plus, mais au détriment de beaucoup de machines qui sont encore fonctionnelles et n'auront jamais la capacité de prendre plus de 1 ou 2 Go de RAM de toute manière.

Le Fake PAE peut permettre de continuer à utiliser Ubuntu, et tout au moins Lubuntu sur ces machines. Je crois que je n'aurais pas l'occasion de tester, mon seul vieux clou est un T30 avec un processeur Intel Pentium IV dont le flag pae est bien visible.

Voici les questions pour le sondage:
avez-vous une ou des vieilles machines qui ne tournent pas avec les kernels PAE (fournis par défaut depuis la 12.10 à ce qu'on m'a dit ?)

êtes-vous intéressé par des versions de Ubuntu/Lubuntu dotées du service upstart fake-pae ?

Et enfin: seriez-vous intéressé si un ppa s'ouvre pour fournir des kernels non pae, afin de fournir toutes les machines avec ou sans processeurs dotés d'une instruction "pae véritable", vue ou non vus ?

Comptez-vous ! J'ai proposé de lancer ce sondage et le résultat en sera reporté sur la mailing liste qa-lubuntu où la pertinence de la continuité de ce projet a été mise en discussion:
https://lists.launchpad.net/lubuntu-qa

Merci par avance,
Mélodie

Hors ligne

#2 Le 18/10/2013, à 03:24

moko138

Re : Sondage : Lubuntu avec FAKE-PAE, êtes-vous concerné ?

NB : ton premier lien stipule bien qu'il s'agit de permettre l'installation de versions de -buntu strictement postérieures à la 12.04;
et ce sur des machines dont le proc a bel et bien la fonction pae, fonction que les iso ne reconnaîtraient pourtant pas.
  Il s'agit donc d'un cas très marginal !

  Les vieilles machines ne sont pas concernées car elles n'ont pas la fonction pae ni une ram supérieure à 3,2 Go, et elles utilisent des cartes graphiques agp qui, me semble-t-il, sont exclues du noyau depuis la 12.10.
Pour ces bécanes Xubuntu 12.04 LTS est un excellent choix.

Hors ligne

#3 Le 18/10/2013, à 12:21

melodie

Re : Sondage : Lubuntu avec FAKE-PAE, êtes-vous concerné ?

moko138 a écrit :

  Les vieilles machines ne sont pas concernées car elles n'ont pas la fonction pae ni une ram supérieure à 3,2 Go, et elles utilisent des cartes graphiques agp qui, me semble-t-il, sont exclues du noyau depuis la 12.10.

Bonjour,

Il s'agit de vieilles machines oui : entendons-nous, j'ai un IBM T30, sorti en 2000 ou 2001, qui non seulement a la fonction PAE, mais en plus n'a pas besoin de "fake-pae" parce que cpuinfo voit le flag pae. Par contre, des T42, et d'autres machines Pentium M et Celeron M, plus récents même que mon thinkpad T30 ont la fonction pae mais elle ne se voit pas.

Quand à la carte graphique, c'est une ATI 7500 Mobility (intégrée) et donc elle est activée par le driver radeon, tout bêtement.

Ces machines n'auront jamais besoin de plus de (4) Go de RAM et ne peuvent les supporter, mais le job upstart PAE, lui, permet d'utiliser les versions récentes de Ubuntu, ce qui inclus aussi le noyau, la capacité à continuer à mettre à jour le noyau, puisque ce "fake-pae" en est totalement indépendant.

Le cas ne semble pas isolé. Il y a des sondages sur le forum anglophone, et il y a un rapport de bug. Voici les liens vers les pages concernées:
le rapport de bug suivi de nombreux commentaires:
Unable to start Ubuntu 12.04 live CD with syslinux loader on Pentium M x86 Laptop due to bug in PAE kernel, initramfs or syslinux

le sondage sur le forum:
http://ubuntuforums.org/showthread.php? … st12640488

This brief poll is stopped now. The result at 100 replies is

* 30 persons have a Pentium M CPU
* 70 persons do not have a Pentium M CPU

This percentage may be biased, because people who have this CPU may be more willing to reply, so let us only count the number of Pentium M CPUs reported.

Bien sûr, c'est une brève citation prise au moment où le sondage a été arrêté. Le fil commence vraiment à la page précédente.


Nous attendons les participants francophones. smile
Vous pouvez suivre le nouveau fil sur la liste qa-lubuntu ici: https://lists.launchpad.net/lubuntu-qa/msg03878.html
(Lubuntu for kernels with a PAE flag)

Hors ligne

  • Accueil
  • » Forum
  • » LXDE
  • » Sondage : Lubuntu avec FAKE-PAE, êtes-vous concerné ?

Haut de page ↑