Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/08/2007, à 10:27

jujuz

export DISPLAY=.0.0 marche pas

Bonjour,

je suis en pleine install de Oracle AS Portal, je dois exporter le display pour mon utilisateur oracle qui doit installer le serveur d appli.

or

$ export DISPLAY=:0.0
$ xclock
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: :0.0

?? j ai oublie quelquchose ?

Hors ligne

#2 Le 29/08/2007, à 10:29

pixi-pix

Re : export DISPLAY=.0.0 marche pas

xhost  + avec l'adresse ip de la machine derriere ca donne quoi ?

Hors ligne

#3 Le 29/08/2007, à 10:35

jujuz

Re : export DISPLAY=.0.0 marche pas

xhost +

marche pas non plus
xhost + ip non plus

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xhost:  unable to open display ":0"

Hors ligne

#4 Le 29/08/2007, à 10:37

desmogone

Re : export DISPLAY=.0.0 marche pas

Salut et si tu mets :

export DISPLAY=127.0.0.1:0.0

Ca donne quoi ?

Desmogone, là, c'est vraiment pour tester ...


Phenom II X4 940 - RAM 4Go - 9600GT - HDD Sata 500Go -  ubuntu 14.04 LTS 64 bits
Portable LDLC 13" - Pentium 2020M - RAM 4G - SSD Sata 120Go - xubuntu 15.04 64 bits
MSI Wind Atom N270 - RAM 2Go - i945 - SSD Sata 80Go - ubuntu 14.04 LTS 64 bits

Hors ligne

#5 Le 29/08/2007, à 10:38

jujuz

Re : export DISPLAY=.0.0 marche pas

$ export DISPLAY=127.0.0.1:0.0
$ xclock
Error: Can't open display: 127.0.0.1:0.0

Hors ligne

#6 Le 29/08/2007, à 11:37

desmogone

Re : export DISPLAY=.0.0 marche pas

Et si tu mets l'adresse IP de ton PC ?

Ce qui est bizarre, c'est que sur ma machine virtuelle (je suis au boulot) quand je fais echo $DISPLAY, ça me ramène bien :0.0.

Et si je lance xclock, elle s'affiche sans pb.

Je n'ai malheureusement plus de solution pour toi pour le moment sad

Desmogone, qui va passer la main ...


Phenom II X4 940 - RAM 4Go - 9600GT - HDD Sata 500Go -  ubuntu 14.04 LTS 64 bits
Portable LDLC 13" - Pentium 2020M - RAM 4G - SSD Sata 120Go - xubuntu 15.04 64 bits
MSI Wind Atom N270 - RAM 2Go - i945 - SSD Sata 80Go - ubuntu 14.04 LTS 64 bits

Hors ligne

#7 Le 29/08/2007, à 11:41

jujuz

Re : export DISPLAY=.0.0 marche pas

merci de ton aide, en effet depuis longtemps sur linux c est la premiere fois que ca m arrive,
alors j ai finter le truc en me loggant par ssh avec l option -Y lol
c est pourri mais au moins cela m a debloqué

(je ne met pas resolu parceque le probleme initiale est toujours la)

++

Hors ligne

#9 Le 29/08/2007, à 13:32

jujuz

Re : export DISPLAY=.0.0 marche pas

-Y mais -X fonctionne aussi

Hors ligne

#10 Le 28/03/2008, à 18:45

pompomfred

Re : export DISPLAY=.0.0 marche pas

J'ai cherché un moment !!!
Sur une machine Ubuntu, le serveur X est configuré par défaut avec l'option "-nolisten tcp" et c'est pour ça que même avec le xhost +, l'export DISPLAY ne fonctionne pas. C'est pareil sur debian.

ex:
ps -ef | grep X
root     21721 21713  7 17:22 tty9     00:00:01 /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt9

Pour changer ça, il faut modifier /etc/gdm/gdm.conf:
# If true this will basically append -nolisten tcp to every X command line, a
# good default to have (why is this a "negative" setting? because if it is
# false, you could still not allow it by setting command line of any particular
# server).  It's probably better to ship with this on since most users will not
# need this and it's more of a security risk then anything else.
# Note: Anytime we find a -query or -indirect on the command line we do not add
# a "-nolisten tcp", as then the query just wouldn't work, so this setting only
# affects truly attached sessions.
#DisallowTCP=true
DisallowTCP=false

Le fait de redémarrer le serveur X ne marche pas (Ctrl-Alt-Backspace), il faut redémarrer la machine.
(Sur une redhat, init 3, puis init5 aurait suffit, mais les run-level sur ubuntu, j'ai pas tout compris, ya pas de fichier /etc/inittab par exemple plus configurer, entre autre, le run-level !)
Rq: sur redhat, ya meme un gdm-restart et gdm-safe-restart :-)

Au redémarrage:
ps -ef | grep X
root      6182  6175  1 17:27 tty7     00:00:02 /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth vt7

Et ce coup ci, ça fonctionne:

toto@ubuntu ~$ telnet serveurdistant
toto@serveurdistant ~$ export DISPLAY=ubuntu:0.0

Enfin, le message d'erreur classique:
toto@serveurdistant ~$ xlogo
Xlib: connection to "ubuntu:0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: ubuntu:0.0

Dans une autre fenetre: toto@ubuntu ~$ xhost + serveurdistant
toto@serveurdistant ~$ xlogo

Ceci dit, l'idéal, c'est de bannir telnet, et de ne se déplacer de serveur en serveur qu'avec des ssh -X serveurdistant.

Pour une 1ere intervention, c'est pas mal :-) ?

Fred

Hors ligne

#11 Le 13/08/2008, à 23:49

XavierHubin

Re : export DISPLAY=.0.0 marche pas

Pas besoin de rebooter, un ptit kill -HUP sur le PID de X ( 7074 tty7     SLs+   0:03 /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xaut) suffit à le relancer

Attention de sauvegarder les documents ouverts avant de lancer une telle commande .

#12 Le 09/09/2008, à 11:58

superman

Re : export DISPLAY=.0.0 marche pas

pompomfred a écrit :

J'ai cherché un moment !!!
Sur une machine Ubuntu, le serveur X est configuré par défaut avec l'option "-nolisten tcp" et c'est pour ça que même avec le xhost +, l'export DISPLAY ne fonctionne pas. C'est pareil sur debian.

ex:
ps -ef | grep X
root     21721 21713  7 17:22 tty9     00:00:01 /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt9

Pour changer ça, il faut modifier /etc/gdm/gdm.conf:
# If true this will basically append -nolisten tcp to every X command line, a
# good default to have (why is this a "negative" setting? because if it is
# false, you could still not allow it by setting command line of any particular
# server).  It's probably better to ship with this on since most users will not
# need this and it's more of a security risk then anything else.
# Note: Anytime we find a -query or -indirect on the command line we do not add
# a "-nolisten tcp", as then the query just wouldn't work, so this setting only
# affects truly attached sessions.
#DisallowTCP=true
DisallowTCP=false

Le fait de redémarrer le serveur X ne marche pas (Ctrl-Alt-Backspace), il faut redémarrer la machine.
(Sur une redhat, init 3, puis init5 aurait suffit, mais les run-level sur ubuntu, j'ai pas tout compris, ya pas de fichier /etc/inittab par exemple plus configurer, entre autre, le run-level !)
Rq: sur redhat, ya meme un gdm-restart et gdm-safe-restart :-)

Au redémarrage:
ps -ef | grep X
root      6182  6175  1 17:27 tty7     00:00:02 /usr/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth vt7

Et ce coup ci, ça fonctionne:

toto@ubuntu ~$ telnet serveurdistant
toto@serveurdistant ~$ export DISPLAY=ubuntu:0.0

Enfin, le message d'erreur classique:
toto@serveurdistant ~$ xlogo
Xlib: connection to "ubuntu:0.0" refused by server
Xlib: No protocol specified

Error: Can't open display: ubuntu:0.0

Dans une autre fenetre: toto@ubuntu ~$ xhost + serveurdistant
toto@serveurdistant ~$ xlogo

Ceci dit, l'idéal, c'est de bannir telnet, et de ne se déplacer de serveur en serveur qu'avec des ssh -X serveurdistant.

Pour une 1ere intervention, c'est pas mal :-) ?

Fred

Excelente première intervention Fred ... Aujourd hui, tu m'as enlevé une épine du pied ! Merci !

Par contre sur fedora (je sais .. on est sur le forum Ubuntu, je suis un fervent utilisateur d'ubuntu seulement au boulot ils m'ont filé Fedora ...) il y a pas de fichier gdm.conf en tout cas je l'ai pas trouvé... Mais vous pouvez activer/desactiver la connexion ip  au X via la commande : gdmsetup
(l'option ce trouve dans l'onglet : sécurité).

S.

Hors ligne

#13 Le 04/05/2009, à 02:29

sora570

Re : export DISPLAY=.0.0 marche pas

Bonsoir,

hey merci pour l'export display je n'avais pas tout a fait la bonne syntaxe et mon Kwin avait planter suite au effet graphiquement ce qui planter mon serveurX heureusement j'ai pus le relancer sans les effets apré un kill

Cordialement, sora

Hors ligne

#14 Le 31/03/2010, à 11:12

SteVal

Re : export DISPLAY=.0.0 marche pas

Bonjour à tous,

Pour info, la 9.10 intègre une nouvelle version de gdm où le fichier gdm.init est remplacé par gdm.schemas (toujours dans /etc/gdm)
Ceci répondu sans doute à l'interrogation de superman qui ne trouvait pas le gdm.init sous Fedora.

La partie de /etc/gdm/gdm.schemas à modifier est la suivante :

    <schema>
      <key>security/DisallowTCP</key>
      <signature>b</signature>
      <default>true</default>
    </schema>

et il suffit comme précédemment de remplacer true par false.

A+

SV

Hors ligne

#15 Le 01/08/2013, à 16:45

gl25.it

Re : export DISPLAY=.0.0 marche pas

Bonjour à tous,

J'utilise 12.04.2 LTS avec la session "Gnome Classic (No Effect)".
Je découvre ce n'est pas gdm qui gère mon écran, mais lightdm :

$ ps -ef  | grep '[b]in/X'
root      1594  1586  3 16:17 tty7     00:00:34 /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
$ ps -f 1586
UID        PID  PPID  C STIME TTY      STAT   TIME CMD
root      1586     1  0 16:17 ?        Ssl    0:00 lightdm

Du coup, il faut adapter les solutions que pompomfred et SteVal ont données pour gdm.

Pour cela, j'ai rajouté dans /etc/lightdm/lightdm.conf :

xserver-allow-tcp=true

Un petit redémarrage du système, ou juste de lightdm avec sudo restart lightdm après avoir fermé toutes ses fenêtres, et... ça fonctionne.
Merci pompomfred d'avoir diagnostiqué d’où venait le problème.


Ubuntist depuis Noël 2006.

Hors ligne

#16 Le 08/12/2017, à 13:54

chamblard

Re : export DISPLAY=.0.0 marche pas

Salut je relance le sujet car je n'y arrive pas !!!
Je m'explique :
mon client est client@ubuntu17.10Xorg et mon serveur est serveur@ubuntu16.04 et je voudrai ouvrir une application graphique type gedit depuis sudo su

Méthode 1 par ssh avec option -X et sur serveur j'ai bien X11Forwarding yes dans /etc/ssh/sshd_config

client@ubuntu17.10Xorg: $ ssh -X serveur@ubuntu16.04
serveur@ubuntu16.04: $ xclock

OK ca marche pour le moment. Je continue :

serveur@ubuntu16.04: $ sudo su
[sudo] Mot de passe de serveur .....
serveur@ubuntu16.04: # xclock
X11 connection rejected because of wrong authentication.
Error: Can't open display: localhost:10.0

Marche pas.
Une idée ?? une option a passer avec sudo su ?

Méthode 2 par ssh SANS -X

client@ubuntu17.10Xorg: $ xhost +
access control disabled, clients can connect from any host
client@ubuntu17.10Xorg: $ ssh serveur@ubuntu16.04
serveur@ubuntu16.04: $ xclock
Error: Can't open display:
serveur@ubuntu16.04: $ w  # ou who pour connaître l'ip
serveur@ubuntu16.04: $ export DISPLAY=XXX.XXX.XXX.XX:0.0
serveur@ubuntu16.04: $ xclock

ca bloque ici et obligé de faire CTRL-C pour stopper ! pas essayé avec sudo
Une idée aussi ici ? une explication ?
Merci  ;-)


ps : j'ai essayé

serveur@ubuntu16.04: $ ps -ef  | grep 'X'
root      1640  1579  0 11:32 tty7     00:00:12 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

ajout de xserver-allow-tcp=true dans  /etc/lightdm/lightdm.conf puis pour ubuntu 16.04 :

$ sudo service lightdm restart
ou 
$ sudo reboot

et j'ai toujours le -nolisten tcp vt7 !!!!
Comment faire?

Hors ligne

#17 Le 08/12/2017, à 15:22

gl25.it

Re : export DISPLAY=.0.0 marche pas

Bonjour chamblard.
C'est sur le client qu'il faut virer le -nolisten tcp du lancement de X (et faire xhost+). La conf du serveur ne devrait pas poser problème.
Note: le paramètre vt7 indique au serveur X de s'ouvrir sur le virtual terminal 7 (accessible via Ctrl+F7, vt par défaut), et n'a rien à voir avec le -nolisten tcp d'avant.


Ubuntist depuis Noël 2006.

Hors ligne