Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/12/2013, à 21:03

aiphes

Installer dernière version Gramps sur 12.04

Bonjour,

je voudrais installer gramps 4.0.2 (dernière version) mais il y a des dépendances python à installer.la version des dépots est la 3.3.1.
j'ai tenté :

$ sudo dpkg -i /home/happy/Téléchargements/gramps_4.0.2_all.deb
Sélection du paquet gramps précédemment désélectionné.
(Lecture de la base de données... 295807 fichiers et répertoires déjà installés.)
Dépaquetage de gramps (à partir de .../gramps_4.0.2_all.deb) ...
pycentral: gramps: has no Python-Version field, assuming default runtime
dpkg : des problèmes de dépendances empêchent la configuration de gramps :
 gramps dépend de python-gobject (>= 3.3.2) ; cependant :
  La version de python-gobject sur le système est 3.2.2-1~precise.
dpkg : erreur de traitement de gramps (--install) :

comment faire pour que gramps s'installe vaec ces dépendances ?

merci


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 12.04 (Gnome2)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 12.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

#2 Le 06/12/2013, à 22:30

aiphes

Re : Installer dernière version Gramps sur 12.04

j'ai vu qu'il fallait ensuite lancer une commande pour les dépendances mais cela enlève le programme:

$ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  python-pywapi linux-headers-3.2.0-56 linux-headers-3.2.0-56-generic-pae
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  gramps
0 mis à jour, 0 nouvellement installés, 1 à enlever et 3 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 34,7 Mo d'espace disque seront libérés.
$ sudo apt-get install python-gobject=3.3.2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: La version « 3.3.2 » de « python-gobject » n'a pu être trouvée
$ sudo apt-cache policy python-gobject
python-gobject:
  Installé : 3.2.2-1~precise
  Candidat : 3.2.2-1~precise
 Table de version :
 *** 3.2.2-1~precise 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     3.2.0-3 0
        500 http://fr.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

j'avance pas du coup..et je pense que c'est impossible d'installer la v4 sur une 12.04 ubuntu.

Dernière modification par aiphes (Le 06/12/2013, à 22:34)


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 12.04 (Gnome2)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 12.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

#3 Le 09/12/2013, à 19:15

kaiki

Re : Installer dernière version Gramps sur 12.04

Bonsoir,
Gramps 4.0.2 ne peut s' utiliser qu'à partir de 12.10. Il faut utiliser virtual box pour les versions antérieures à 12.10


Pc: Samsung R710
Utilisateur Windows depuis 3.1>3.11>95>98>xp>Vista
Sur ubuntu 10.04 depuis le 18/07/2010. Passage 12.04 > mai 2012. Passage 14.04>sept 2014

Hors ligne

#4 Le 14/12/2013, à 16:29

aiphes

Re : Installer dernière version Gramps sur 12.04

en effet, merci pour l'info.


PC Portable :ASUS M70V [ core2duo + geforce 9650M gt + 4go RAM ] + OS dualboot 2 DD > Windows 7 ET Ubuntu 12.04 (Gnome2)
Travail: Dell XPS Windows 7 avec VirtualBox : Serveur 12.04 XFCE - LAMP + Drupal + VirtualHosts

Hors ligne

Haut de page ↑