Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/09/2007, à 22:11

Darktux

[Tuto] Avoir du son qui sorte d'un casque usb audio

Un p'tit truc pour ceux et celles qui comme moi ont recherché le "pourquoi du comment" pour faire fonctionner son casque audio usb sur la feisty :

On va commencer par se pencher sur le nombre et l'ordre des périphériques audio contenus par notre ordi.
Un petit cat /proc/asound/cards va nous donner le nombre de cartes sons reconnues par nunux et l'ordre de priorité des périphériques.

Moi ça me donne :

0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebfc000 irq 21
1 [Headset        ]: USB-Audio - Plantronics Headset
                      Plantronics Plantronics Headset at usb-0000:00:1d.2-1, full speed

Ensuite un petit cat /proc/asound/modules pour la forme, et hop on connait l'ordre de chargement des modules liés au son.

Ce qui me donne :

 0 snd_hda_intel
 1 snd_usb_audio

C'est là que c'est embêtant, notre distribution adorée charge le module du chipset avant le module usb audio et en règle générale aucun son ne sort du casque; niet, nada, queud...

Donc à partir de là on va faire une petite manip sur le fichier alsa-base : gksudo gedit /etc/modprobe.d/alsa-base

Au début du fichier, on a :

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

Donc on va va changer les 2 premières lignes comme ceci :
install sound-slot-0 /sbin/modprobe snd-card-0 =>1 on remplace le 0 par le 1
install sound-slot-1 /sbin/modprobe snd-card-1 =>0 et inversement

Ceci va permettre de charger les modules dans l'ordre que l'on souhaite.

A la fin du fichier on a :

# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2

Là on va commenter la ligne options snd-usb-audio index=-2 en y ajoutant un #
Ce qui donne #options snd-usb-audio index=-2

Voilà, on a du son qui sort du casque et le micro fonctionne...

Cette astuce fonctionne correctement pour moi, j'espère qu'elle pourra aider ceux et celles qui galèrent pour paramétrer un casque audio usb sous linux



EDIT :

Une autre méthode existe et fonctionne tout en étant plus simple(trouvé en testant une debian)...

Toujours dans alsa-base dans cette partie du fichier

# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2

Commentez toutes les lignes puis rajoutez à la fin :

# Prevent abnormal drivers from grabbing index 0
#options snd-bt87x index=-2
#options cx88-alsa index=-2
#options saa7134-alsa index=-2
#options snd-atiixp-modem index=-2
#options snd-intel8x0m index=-2
#options snd-via82xx-modem index=-2
#options snd-usb-audio index=-2
#options snd-usb-usx2y index=-2
options snd-usb-audio index=0
options MODULE DE VOTRE CHIPSET SON index=1

Ceci va permettre de charger en priorité le module usb-audio au démarrage...

Dernière modification par Darktux (Le 22/09/2007, à 22:20)

Hors ligne

#2 Le 28/12/2007, à 17:09

totolouga

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Excellent Darktux!!
Ca faisait longtemps que je bataillais pour faire fonctionner mon HP USB

http://forum.ubuntu-fr.org/viewtopic.ph … 8#p1420388

Ben la ca y est ca marche:)
MERCI


Raph
Ubuntu Lucid sur HPnx8220

Hors ligne

#3 Le 30/12/2007, à 06:06

Eric Buist

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Une autre possibilité de solution est de changer, dans les applications utilisant ALSA, la carte son utilisée. Il faudrait mettre la seconde carte son plutà´t que la première pour avoir le casque sans inverser l'ordre de chargement des modules.

Hors ligne

#4 Le 05/01/2008, à 18:11

totolouga

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Merci Eric,
mais je ne trouve pas ou changer la carte pour les applis (sauf Kmix)....:rolleyes:
@+


Raph
Ubuntu Lucid sur HPnx8220

Hors ligne

#5 Le 08/03/2008, à 23:34

cubytus

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Merci!

Changer l'ordre de chargement des modules a fonctionné pour redonner la voix à l'Audigy 2 ZS qui cohabite avec le chipset intégré de la carte-mère!


MacBook Pro 8,1, i7 2,8GHz, 16Go, Scorpio Black 750Go. Mac OS X 10.6.8 + Ubuntu 12.04, 13.10, Windows XP, 7 et 8.
Un jour, Ubuntu sera aussi au point que Mac OS X. Ce jour, je te quitterai, Apple.

Hors ligne

#6 Le 09/03/2008, à 18:09

atlas2003

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

totolouga a écrit :

Merci Eric,
mais je ne trouve pas ou changer la carte pour les applis (sauf Kmix)....:rolleyes:
@+

Bonjour,
normalement un simple:

asoundconf list
asoundconf set-default-card NOM_DE_LA_CARTE

devrait suffire je pense


Blabla autour d'Ubuntu > http://back2web.com/blabla/

Hors ligne

#7 Le 24/04/2008, à 17:47

louiss18

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

darktux ! merci pour ta méthode qui me permet d'utiliser mon casque usb!
fonctionnement super!

Hors ligne

#8 Le 13/05/2008, à 14:11

Djidane535

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Je vous aime lol tongue Ca fait longtemps que je rêvais de faire fonctionner mon casque usb sous linux. Je suis passé de openSuse à Ubuntu et pour l'instant j'en suis entièrement satisfait, tout ce qui ne marchait pas avec openSuse marche pour l'instant ^^ Que du bonheur tongue

#9 Le 15/05/2008, à 23:06

Nicogeta

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonsoir, malgrès l'application de ces conseils, mon casque usb (Microsoft Lifechat Lx-3000) ne fonctionne toujours pas :s Le truc étrange, c'est que lorsque je le branche, j'entends la petite musique d'intro d'Ubuntu, mais après, plus aucun son, et ce, quel que soit les réglages (avant ou après bidouille expliquée ici) =/

Est-ce que ces conseils sont applicables pour Hardy Heron ?


voici, au cas où, les résultats de toutes les commandes décrites dans le tuto:

 0 [V8237          ]: VIA8237 - VIA 8237
                      VIA 8237 with AD1980 at 0xc800, irq 20
 1 [default        ]: USB-Audio - Microsoft LifeChat LX-3000 
                      Microsoft LifeChat LX-3000  at usb-0000:00:10.4-4.1, full speed
 2 [SAA7134        ]: SAA7134 - SAA7134
                      saa7133[0] at 0xf7e00000 irq 19

cat /proc/asound/modules

 0 snd_via82xx
 1 snd_usb_audio
 2 saa7134_alsa

gksudo gedit /etc/modprobe.d/alsa-base


# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-1
install sound-slot-1 /sbin/modprobe snd-card-2
install sound-slot-2 /sbin/modprobe snd-card-0
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
#   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
#   non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
#options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

J'ais essayé les deux techniques énnonées sans aucun résultat :'(

les modifications à faire ont changées ou.. ? Merci d'avance si quelqu'un peut m'aider smile

Hors ligne

#10 Le 18/05/2008, à 16:36

Nicogeta

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

up hmm

Hors ligne

#11 Le 25/07/2008, à 11:10

bdi

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonjour, retape la commande cat /proc/asound/modules apres la modif pour voir si l'ordre a changer
(pour que les modif soit pris en compte par le systeme il te faut redemarer le pc)

Hors ligne

#12 Le 06/11/2008, à 19:59

benito23

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonsoir a tous et a toute,
J'ai tout réalisé, et tout fonctionne, mis a part, un petit probleme persiste,
mon ordinateur reconnait désormais mon casque USB, mais les applications ne le font pas fonctionner:
c'est a dire: lorsque je vais dans systeme -->preference-->son
Mon casque et mon micro sont bien configurer, par contre, des que je lance une application quels qu'elle soit, Rien a faire les haut parleur de mon pc reprenne le dessu.
cat /proc/asound/modules me donne le résultat suivant:
0 snd_usb_audio
1 snd_hda_intel
je ne comprend donc pas pourquoi .
Quelqu'un aurai une explication silvouplais?

Hors ligne

#13 Le 06/11/2008, à 20:32

benito23

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

alors petite modification, mon casque fonctionne correctement en fait, c'est simplement avec mozila que cela ne fonctionne pas. Donc je reformule mon probleme tout en cherchant en meme temps comment configurer mozila pour qu'il fonctionne avec le casque usb.

Hors ligne

#14 Le 14/12/2008, à 00:39

Pili

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bon cela ne va pas forcément faire avancé le truc, mais moi après la manipulation et modification des préférences sons (système-->preference-->son ) dans laquelle je sélectionne le périphérique USB
et le sélecteur du système multimédia (systeme-->preference-->selecteur multimédia ) dans lequelle que les greffons à utiliser sont les 'personnalisés'
J'ai réussi à obtenir du son qui sort de mon casque sans fil au moyen de firefox et totem. Ce qui n'est pas mal... mais malheureusement des programmes comme vlc et exaile repasse toujours par les haut-parleurs du PC. Je suppose qu'il s'agit d'une configuration de gnome ou autre mais je n'ai pas encore trouvé la solution.
Bonne journée.


Plus encore que le changement, il faut faire l'éloge du sursaut.
Alexandre Lacroix

Hors ligne

#15 Le 05/01/2009, à 15:14

berensel

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

salut à tous et bonne année.
alors moi j'ai un souci avec mon casque usb j'ai du son genre son systéme mais les lecteurs videos passent par les enceintes je ne comprend pas. si quelqun a une solution a ce probléme je serai ravie de l'entendre merci d'avance


l'enemie est con il dit que c'est moi l'enemie alors que c'est lui !!!

Hors ligne

#16 Le 05/01/2009, à 15:18

berensel

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

purée vous étes vachement fort les gars je poste et hop sa se met a marcher tous seul j'admire
merci de votre aide ^^


l'enemie est con il dit que c'est moi l'enemie alors que c'est lui !!!

Hors ligne

#17 Le 06/01/2009, à 01:10

loicm54

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

pour les suivant,

tout est controlé par pulseaudio, mais il n'y a pas de gui par defaut, il faut les installer


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#18 Le 10/03/2009, à 22:37

Baaaaaaaat

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonjour à tous!

J'ai un casque Logitech USB que j'aimerais connnecter, et malgré les manips décrites ici, il ne marche pas... Quand j'essaie de faire un test dans "Préférences du son", ca me met ceci : audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Impossible d'utiliser le périphérique audio pour la lecture.

Quelqu'un saurait m'aider? Merci beaucoup!

#19 Le 12/03/2009, à 18:26

pose

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonjour j'ai exactement le même problème que Baaaaaaaat avec mon casque audio USB et ALSA

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Impossible d'utiliser le périphérique audio pour la lecture

Hors ligne

#20 Le 21/03/2009, à 21:49

Baaat

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Up

Hors ligne

#21 Le 21/03/2009, à 23:33

topazz

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Génial ! Merci pour ces infos.
J'ai mis à jour http://doc.ubuntu-fr.org/son_problemes pour que ce soit plus clair

Hors ligne

#22 Le 03/04/2009, à 12:03

feuille73

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

J'ai essayé ta méthode avec beaucoup d'espoirs, malheureusement sans résultat.
cat /proc/asound/modules me donne toujours :
0 snd_intel8x0
1 snd_usb_audio

Du coup, j'ai du son avec rythmnbox mais pas avec firefox...

Hors ligne

#23 Le 05/10/2009, à 12:49

kaham

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonjour a tous,

Je re up ce sujet car j'ai utilisé les 2 méthodes possibles sans aucune amélioration. Quand la session se ferme j'ai du son dans mon casque usb mais pas le reste du temps.

resultat de la commande apres avoir modifier alsa-base.conf et avoir redémarer : cat /proc/asound/modules

0 snd_hda_intel
1 snd_usb_audio

quand je vais dans "systeme > préférences > son", j'ai usb-audio (oss) qui fonctionne quand j'appuie sur test mais pas usb-audio (alsa), j'ai l'erreur suivante :

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Impossible d'utiliser le périphérique audio pour la lecture

Hors ligne

#24 Le 10/04/2010, à 21:05

mimi190

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonjour je vous explique mon problème: dans le fichier gedit /etc/modprobe.d/alsa-base je n'ai rien , il est vide  et j'ai un joli command not found avec asoundconf
merci de votre futur aide

Hors ligne

#25 Le 24/09/2010, à 00:55

talen

Re : [Tuto] Avoir du son qui sorte d'un casque usb audio

Bonjour, j'ai également un problème de son.

J'ai essayé votre méthode, elle n'a pas marché.

Quand je fais cat /proc/asound/modules j'ai seulement 0 snd_hda_intel et pas de 1  snd_usb_audio

Hors ligne

Haut de page ↑