Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/02/2014, à 00:19

Ljinod

[RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonjour,

Je vous écris en désespoir de cause : après 3 jours à chercher des solutions et bidouiller (avec des pincettes) mon BIOS je ne suis toujours pas parvenu à installer une version d'Ubuntu à côté de mon cher *ahem* Windows.
Voici mes péripéties :


Le contexte :
Je suis le détenteur depuis peu du MSI GE40 2OC-216FR livré avec Windows8, que j'ai mis-à-jour pour la version 8.1. Le BIOS de celui-ci supporte 3 modes : Legacy, UEFI, UEFI with CSM.
Le Secure-Boot ainsi que le Fast-Setup sont tous les deux désactivés.


Ce que je souhaite :
Avoir à ma disposition à la fois Ubuntu (de préférence la dernière version LTS) et Windows 8 - je suis un joueur PC je ne peux donc pas encore me passer de cet OS....malheureusement....


Mes problèmes :
C'est là que les histoires rigolotes commencent...Pour information, comme je n'ai pas de lecteur de CD/DVD j'ai créé à chaque fois une clef usb bootable, depuis un autre pc sous ubuntu 13.10 :

sudo dd bs=4M if=~/Downloads/ubuntu-<VERSION>-amd64.iso of=/dev/sd<X> && sync

J'ai d'abord commencé par essayer d'installer Ubuntu 12.04 et 13.10 en laissant mon BIOS en UEFI puisque, d'après la documentation, ce mode est supporté. Dans les deux cas j'arrive jusqu'à la fenêtre me demandant de choisir entre : installer - essayer - vérifier les erreurs; puis dès que je sélectionne une option j'ai un écran noir et plus rien ne se passe.
Je redémarre mon portable, relance l'opération jusqu'à arriver à l'écran de sélection, mets en surbrillance l'option "installer" ou "essayer", appuie sur "e" et insère après "quiet splash" :

nomodeset

ou

acpi=off

ou, cette fois avant "quiet splash"

acpi _ osi=Linux acpi _ backlight=vendor

Rien n'y fait j'ai toujours un bel écran noir et je n'ai pas d'autre choix que de redémarrer mon portable.


J'ai ensuite vu qu'il était possible d'installer Ubuntu en Legacy et après coup faire en sorte qu'il soit lancé en UEFI. Je m'exécute : je change mon BIOS en Legacy, je charge Ubuntu 13.10 sur la clef, je la branche, je vois un écran violet puis le logo Ubuntu avec les points en-desous signalant l'avancement du chargement (je me dis "ça y est, je vais y arriver") mais, hélas, mon ordinateur reste bloqué sur cet écran....
Pas encore abattu par cette nouvelle déception je charge cette fois la version 12.04.4 d'Ubuntu et je vais jusqu'à lancer l'installation (je me redis "ça y est, je vais y arriver") mais là l'installer me signale une erreur fatale : le bootloader n'a pas pu être installé.
Je me rappelle avoir lu à plusieurs reprises "Boot-repair" donc je me renseigne et j'effectue les manipulations (je me re-redis "ça y est, je vais y arriver")....bien entendu "Boot-repair" me signale une erreur lors de la tentative de réparation et me donne gentiment les liens suivants lors de mes deux tentatives non-consécutives : paste.ubuntu.com/6961928 puis paste.ubuntu.com/6962009.
Après la première tentative j'ai redémarré mon pc, changé le BIOS pour UEFI, constaté avec joie que je vois Grub me proposer les bons choix (i.e. Ubuntu, Ubuntu Recovery, Windows, Windows UEFI, MSI boot), lancé avec succès Windows mais sans succès Ubuntu qui reste bloqué sur un écran violet après Grub... Même résultat après la deuxième tentative de boot-repair...



Voilà, je dois admettre que je ne sais plus quoi faire et à ma grande frustration j'ai peur que la solution soit toute simple. Seulement je suis incapable de la trouver donc j'en appelle à votre aide sad.
Ljinod - un adepte de Linux légèrement perdu.

PS : d'ailleurs si quelqu'un peut me dire pourquoi avec la version 12.04 je peux presque finir l'installation alors qu'avec la 13.10 je reste bloqué au chargement, je suis preneur de l'explication !

Dernière modification par Ljinod (Le 25/02/2014, à 22:44)

Hors ligne

#2 Le 20/02/2014, à 00:38

Korak

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonjour,

Si ça peut te rassurer, j'ai installé Ubuntu 12.04.3 64 bits en dualboot avec Windows 8 pré-installé sans problème.

J'ai fais comme ceci:

1) Démarrage du PC et direction le BIOS. Pas d'option pour passer en mode Legacy donc mode UEFI obligatoire. Secure Boot laissé activé.
2) Démarrage du PC sur Windows 8 et réduction de la partition de Windows via l'outil intégré dans Windows pour avoir un espace libre (espace libre = pas de partition à cet endroit).
3) Démarrage du PC sur un LiveDVD d'Ubuntu 12.04.3 64 bits en session Live (Essayer Ubuntu sans l'installer) et tester si ça fonctionne correctement (carte graphique, son, réseau filaire et Wi-Fi).
4) Toujours en session Live, installation d'Ubuntu en cliquant sur l'icône de l'installeur.
5) Suivre les indications de l'installeur.
6) A la fin de l'installation, redémarrage du PC.

Maintenant, il y a une chose dont je ne me rappelle pas: c'est si l'installeur m'a proposé directement l'installation d'Ubuntu en dualboot avec Windows ou si j'ai du passer par "Autre chose".

Juste pour info:

1) Je dois appuyer sur F9 pour lancer le gestionnaire d'amorçage et pouvoir choisir de démarrer sur Ubuntu. Sinon, c'est démarrage sur Windows.
2) J'utilise toujours un LiveCD/DVD ou LiveUSB international d'Ubuntu.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#3 Le 20/02/2014, à 09:34

tiramiseb

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Salut,

Il est possible que ton PC soit trop récent pour les versions existantes d'Ubuntu.
Essaie avec la 14.04 ; je ne suis généralement pas fan de l'utilisation de versions en développement, mais c'est peut-être ta seule solution...
http://cdimage.ubuntu.com/daily-live/current/


Sébastien Maccagnoni-Munch - administrateur Linux depuis le XXe siècle
Consultant informatique indépendant - http://www.smm-informatique.fr
Geek et tout plein d'autres choses - http://www.tiramiseb.fr

En ligne

#4 Le 20/02/2014, à 09:45

Tamarou

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonjour,
Si c'est cette machine, elle a un composant graphique Intel Haswell. Avec cette puce, sur un autre PC, j'ai du utiliser un noyau 3.13, les précédents ne fonctionnaient pas. Le conseil de Tiramiseb va dans ce sens.
De plus l'écran semble noir, mais en fait c'est qu'il n'est pas éclairé, il faut lancer le kernel avec acpi _ backlight=vendor.

Enfin, tu devrais installer Ubuntu comme windows, en UEFI.

Dernière modification par Tamarou (Le 20/02/2014, à 09:48)


Utilisateur d'Archlinux/Xfce et Xubuntu 14.04

Hors ligne

#5 Le 20/02/2014, à 13:42

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonjour,

Merci pour vos réponses rapides tout d'abord smile.

@Korak : malheureusement je ne peux pas appliquer ta solution (j'ai réessayé par acquis de conscience) puisque comme je l'ai expliqué je me retrouve bloqué juste après avoir choisi l'option dans le grub, que ce soit en UEFI ou en Legacy...d'ailleurs avant je pouvais lancer une installation en Legacy avec la version 12.04 ce n'est plus le cas maintenant, je me retrouve avec des erreurs mémoires - je pense - car il m'affiche l'état de certains registres. Bref, c'est la joie !

@Tiramiseb : Ceci pourrait expliquer certaines choses en effet. Je suis entrain de récupérer Windows 8 professionnel pour tout remettre à plat (pas de CD d'installation de Win8 fourni avec ma machine et impossible de tout reformater via l'utilitaire Win...). J'essayerai donc ça après coup et je te tiendrai au courant.

@Tamarou : En effet c'est bien cette machine. Comme je l'ai dit juste au-dessus, je remets tout à plat puis j'essayerai ta proposition avant de me lancer dans la 14.04. yikes
Juste pour précision la ligne "acpi _ backlight=vendor" il faut la mettre avant / après "quiet splash" ? Parce que j'ai vu certains tutoriels dire avant, d'autres après. Est-ce que ça a un réel impact ?

Hors ligne

#6 Le 20/02/2014, à 13:48

Tamarou

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Juste pour précision la ligne "acpi _ backlight=vendor" il faut la mettre avant / après "quiet splash" ?

Ce n'est pas une ligne, juste une option en plus. Avant ou après quiet ça n'a pas d'importance.
Le lien de tiramiseb est une façon simple de tester le kernel 3.13. S'il fonctionne bien tu aviseras ensuite.

Dernière modification par Tamarou (Le 20/02/2014, à 14:18)


Utilisateur d'Archlinux/Xfce et Xubuntu 14.04

Hors ligne

#7 Le 20/02/2014, à 15:25

Korak

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

As-tu désactivé le démarrage rapide dans Windows?


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#8 Le 20/02/2014, à 15:56

Tamarou

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Le Secure-Boot ainsi que le Fast-Setup sont tous les deux désactivés.

Il dit l'avoir fait ?


Utilisateur d'Archlinux/Xfce et Xubuntu 14.04

Hors ligne

#9 Le 20/02/2014, à 16:01

Korak

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Tamarou a écrit :

Le Secure-Boot ainsi que le Fast-Setup sont tous les deux désactivés.

Il dit l'avoir fait ?

Oui, dans le BIOS.

Ma question est: As-tu désactivé le démarrage rapide dans Windows?


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#10 Le 21/02/2014, à 08:58

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Oui je l'ai également désactivé dans Windows.

Je n'ai pas pu faire de tentatives hier je m'y mets aujourd'hui et je donnerai des nouvelles en fonction des résultats !

Hors ligne

#11 Le 22/02/2014, à 00:27

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Me revoici avec quelques nouvelles.

Pour changer je vais commencer par les bonnes : je suis actuellement sur un liveUSB de la version 14.04 qui a l'air de fonctionner correctement (je n'ai pas de soucis particulier pour le moment, mais je ne peux pas dire que j'ai eu le temps de l'explorer). J'ai pu la lancer sans avoir à changer quoique ce soit de plus par rapport à avant, c'est-à-dire que mon BIOS est en UEFI avec le Fast-Setup ainsi que le Secure-Boot désactivés, et sans faire de manipulation particulière. J'ai même réussi à lancer et terminer l'installation !

Comme nous ne vivons pas dans un monde parfait, j'ai encore un soucis : je n'ai pas de Grub au démarrage :-/. Mon ordinateur se lance automatique sous Win8 sans que j'aie mon mot à dire. Je dois avouer ne pas avoir fait de recherches poussées sur ce problème donc pour le moment j'ai seulement tenté de lancer Boot-Repair via la liveUSB avec le message suivant (qui, somme toute, me semble normal) :

W: Failed to fetch http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

Je regarderai ça plus en détails demain, je vais me contenter de savourer mon hypothétique installation fonctionnelle pour ce soir wink.

Hors ligne

#12 Le 22/02/2014, à 01:17

Babdu89

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonsoir.

. Je dois avouer ne pas avoir fait de recherches poussées sur ce problème donc pour le moment j'ai seulement tenté de lancer Boot-Repair via la liveUSB avec le message suivant (qui, somme toute, me semble normal) :

W: Failed to fetch http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found

Pour une utilisation de Boot-Repair installé sur trusty, si tu y tiens, voir ici.

http://forum.ubuntu-fr.org/viewtopic.ph … #p15954511

Mais à part en session installée Trusty, nous ne sommes pas obligé d'utiliser la même version de Ubuntu  pour installer et utiliser Boot-Repair.

Boot-Repair installé en session live Ubuntu 12.04 , 13.04 ,ou 13.10 fera les réparations la 14.04 aussi bien.
Si il s'agit d'installation en UEFI, bien prendre garde d'utiliser une iso 64 bits en live.

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#13 Le 22/02/2014, à 13:10

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Merci Babdu89 pour ta réponse.

J'écris encore d'une session LiveUSB de la 14.04 - pas de surprise au réveil, je n'ai toujours pas de Grub au démarrage - et j'ai effectué la manipulation qui me semble être celle décrite dans le lien http://forum.ubuntu-fr.org/viewtopic.ph … #p15954511 : j'ai remplacé "trusty" par "saucy" dans le fichier /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list.
Après un

sudo apt-get update && sudo apt-get install -y boot-repair

j'ai bien boot-repair d'installé sur la session live seulement lorsque je le lance il reste bloqué sur

Scanning systems (os-prober). This may require several minutes...

Du coup j'hésite à passer ma liveUSB 14.04 pour une 12.04 - puisqu'elle fonctionnait avant - sauf que je dois passer en Legacy et j'ai peur que ça chamboulle tout comme la dernière fois. Est-ce que quelqu'un a une autre manipulation à me faire tester ? Mes inquiétudes sont-elles fondées ?


En vous remerciant par avance !

EDIT : j'ai effecuté le Boot-Info-Script avec comme résultat http://paste.ubuntu.com/6975718/ si cela peut apporter plus d'informations. Il faut savoir que sdb correspond à mon SSD sur lequel j'ai mis / et sur sdb2 se trouve normalement la partition EFI de boot. sda correspond à mon HDD sur lequel j'ai mis swap et /home. sdc correspond à ma liveUSB de la 14.04.

Dernière modification par Ljinod (Le 22/02/2014, à 13:23)

Hors ligne

#14 Le 22/02/2014, à 15:41

Babdu89

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonjour.
Je lis en ce moment tes 3 rapports boot info.
Ton W$8 démarre ?.

Tu dis;

j'ai bien boot-repair d'installé sur la session live seulement lorsque je le lance il reste bloqué sur

Scanning systems (os-prober). This may require several minutes...

Il cherche les systèmes sur ta machine, il trouve Ubuntu, mais pas W$8 .

On voit ceci dans tes 2 rapports faits avec Boot-Repair.

=================== os-prober:
/dev/sdb7:Ubuntu 12.04.4 LTS (12.04):Ubuntu:linux
=================== os-prober:
/dev/sdb7:Ubuntu 12.04.4 LTS (12.04):Ubuntu:linux

Même si ton W$8 est installé et fonctionne, Boot-Repair ne le trouve pas. Il devrait être indiqué avant Ubuntu...

Dans la partition /sdb4 ,où normalement est installé ton W$8, dans les 3 rapports on y voit ceci.

sdb4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Windows/System32/winload.exe

Dans la ligne ;  Opérating system: il devrait être indiqué; Windows7 ou 8.

C'est ce qui bloque la lecture faite par Boot-Repair pour écrire le boot info. os-prober ne trouve pas W$8 .

Remarque, dans les deux boot info faits depuis Boot-Repair. Il est indiqué que tu as tenté de faire la réparation recommandée, mais que tu étais en mode Bios Legacy, pour réparer un système installé en UEFI. Çà ne peut pas marcher.

=================== UEFI/Legacy mode:
BIOS is EFI-compatible, but it is not setup in EFI-mode for this live-session.
SecureBoot maybe enabled.

j'ai bien boot-repair d'installé sur la session live seulement lorsque je le lance il reste bloqué sur

Combien de temps as tu laissé travailler? si c'est quelques minutes...

Stp, veux tu bien recommencer avec Boot-Repair installé dans trusty, et laisser travailler durant un bon quart d'heure.

Il est possible que Boot-Repair abandonne la recherche d'autre OS, en disant dans le rapport ce qu'il fait, et pourquoi il ne le trouve pas.

Attention ,on ne fait que des boot info script, pas la réparation recommandée.

Merci.

@+.  Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#15 Le 22/02/2014, à 16:57

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Merci d'avoir pris le temps de lire tout ça smile.

Je pense que les 2 premiers rapports Boot-Info ne sont pas représentatifs de mon problème à l'heure actuelle : j'ai complètement réinstallé Win8 pour avoir quelque chose de propre (ce n'est peut-être pas la meilleure des méthodes mais je n'avais rien de stocké sur cette machine et l'installation en Legacy avait créé quelques soucis - je crois).

Stp, veux tu bien recommencer avec Boot-Repair installé dans trusty, et laisser travailler durant un bon quart d'heure.

Je viens de le laisser tourner pendant une bonne heure - voire plus - mais il reste encore bloqué sur la même étape. :-/
Je vais tenté de redémarrer sur Win8 et j'éditerai mon message en fonction du résultat, juste pour confirmer que je peux bel et bien y aller.


EDIT   : Je suis bien sous Win8, aucun problème à signaler. Tout se lance comme un charme.
EDIT2 : Étant donné que boot-repair reste bloqué sur os-prober, j'ai lancé la commande suivante dans le terminal

# sudo os-prober
/dev/sdb2@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/sdb5:Ubuntu Trusty Tahr (development branch) (14.04):Ubuntu:linux

Dernière modification par Ljinod (Le 22/02/2014, à 18:53)

Hors ligne

#16 Le 22/02/2014, à 21:45

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Je me permets de faire un double post : mon problème est presque résolu !

J'ai commencé par suivre le tutoriel Reinstall Grub en effectuant les manipulations qui correspondent à mon cas, c'est-à-dire une partition /boot séparée et avec accès à Internet.
Je redémarre mon ordinateur : aucun changement. Je repense à la réponse de Korak et plus particulièrement au gestionnaire d'amorçage et je m'efforce de trouver ce fameux bouton : F11 dans mon cas. Miracle, je vois ubuntu ! (je le vois même deux fois, "mieux vaut deux fois qu'une" me direz-vous). Je crois donc que mon soucis se résume au fait que Windows soit situé avant Ubuntu dans le gestionnaire, je modifie donc ce paramètre dans le BIOS.

Mon "presque-problème", j'ai lancé Boot-repair deux fois (j'ai deux fois Ubuntu qui apparait dans le gestionnaire, ça ne me va pas vous comprenez :c) et j'ai eu une erreur dans les deux cas :

Est-ce que les connaisseurs voient une anomalie ?


En vous remerciant.

Hors ligne

#17 Le 22/02/2014, à 22:04

Korak

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Sais-tu démarrer Ubuntu via le gestionnaire d'amorçage?

Windows démarre-t-il toujours si tu ne touches à rien?

Si c'est oui pour les deux questions, ne touche plus à rien.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

#18 Le 23/02/2014, à 02:27

Babdu89

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Bonsoir.
En examinant les boot infos.

Tes installations sont faites en mode efi.

EDIT2 : Étant donné que boot-repair reste bloqué sur os-prober, j'ai lancé la commande suivante dans le terminal

# sudo os-prober
/dev/sdb2@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/sdb5:Ubuntu Trusty Tahr (development branch) (14.04):Ubuntu:linux

Donc le boot va se faire à partir de la partition de boot /sdb2  /boot efi.

Tu ne donnes pas le contenu des messages d'erreur. Il faut chercher...

La seule chose que je vois, c'est une erreur dans le fichier /etc/fstab de ton Trusty.

La ligne qui contient l'UUID de la partition de boot efi /sdb2 est commentée. Il y a un dièse en début de ligne. ( # ) .
Le système ne peut pas trouver cette partition dont il a besoin pour démarrer.

=============================== sdb5/etc/fstab: ================================
--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdb5 during installation
UUID=83945566-c139-4c1c-8149-02d4be7a3c28 / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sdb2 during installation
#UUID=BE0D-126A /boot/efi vfat defaults 0 1

# /home was on /dev/sda3 during installation
UUID=3a31384b-44e1-4efe-b8e8-a91e38d3cee8 /home ext4 defaults 0 2
# swap was on /dev/sda2 during installation
UUID=47f90c02-e110-4471-8b90-bc8a7d08b2bc none swap sw 0 0
UUID=BE0D-126A /boot/efi vfat defaults 0 1

On devrait voir ceci, il me semble.

# /boot/efi was on /dev/sdb2 during installation
UUID=BE0D-126A /boot/efi vfat defaults 0 1

Pas de  # en début de ;   UUID=BE0D-126A /boot/efi vfat defaults 0 1

En mode root.

sudo gedit /etc/fstab

Il faut faire la correction (supprimer le  #) dans le fichier  /etc/fstab de ton trusty .

On va voir si çà démarre ...

@+.  Babdu89  .

Dernière modification par Babdu89 (Le 23/02/2014, à 02:28)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

En ligne

#19 Le 25/02/2014, à 22:43

Ljinod

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Désolé pour la réponse tardive, une deadline m'a tenu occupé jusque là.

Alors en fait contrairement à ce que je pensais je n'ai pas pu redémarrer sur Win8 après avoir manipulé mon BIOS une n-ième fois. Comme il n'arrêtait pas de me faire des BSOD et que je n'arrivais pas à trouver la cause du problème...j'ai tout réinstallé.

Je suis revenu au moment où je peux choisir sur quel OS je veux démarrer en passant par le gestionnaire d'amorçage (je viens d'aller sur Win8 et là je suis sur la 14.04). Comme j'ai réussi à faire planter ma précédente installation en modifiant des paramètres je pense que je ne vais plus toucher à rien pour le moment, j'y reviendrai peut-être au moment de la sortie officielle de Ubuntu Trusty. smile

Merci pour vos réponses et d'avoir pris le temps de me lire - même quand je n'ai pas précisé les messages d'erreur de Boot-repair wink. D'ailleurs par rapport à ça, où est-ce qu'on peut voir les erreurs rencontrées par Boot-repair ? Parce que je n'ai vu qu'une fenêtre me disant qu'il y a eu une erreur mais pas de message explicatif mis à part le lien vers un pastebin.



Pour ceux qui liraient ce post voici un petit résumé :
Configuration : plateforme Intel Haswell avec processeur i7-4702MQ, 8Go de ram, 1x SSD 128Go, 1xHDD 1To
Problèmes rencontrés : Impossible de démarrer sur une liveUSB en mode UEFI. Après le choix du démarrage sur la liveUSB - "Essayer Ubuntu sans l'installer" ou "Installer Ubuntu" - j'arrivais systématiquement sur un écran noir et le rajout d'une quelconque option (parmi "nomodeset", "backlight=vendor", "acpi=off") n'a rien changé.

Solution : La version 14.04 d'Ubuntu ! Je peux démarrer sur la liveUSB et faire l'installation jusqu'au bout sans erreur. Par contre au démarrage Win8 est lancé par défaut (le Grub ne se lance pas automatiquement) donc pour accéder à Ubuntu je dois passer par le gestionnaire d'amorçage.
J'ai installé Ubuntu comme suit : j'ai créé, sous Win8, une partition de mon HDD de 30Go : 8Go de swap et 22Go pour /home. J'ai créé une deuxième partition de 15Go sur le SSD pour / (j'ai peut-être prévu trop gros, mais dans le doute...). Ensuite je démarre une session live sur la liveUSB pour vérifier que tout fonctionne correctement et si oui, je lance l'installation. J'ai choisi l'option "Faire autre chose" au moment où l'utilitaire m'a demandé où installer Ubuntu et j'ai défini manuellement mes partitions comme ci-dessus. En bas de cette même fenêtre il est demandé où installer le bootloader : j'ai précisé mon SSD (/sdX, pas une sous-partition) là où j'ai mis /.
Voilà.


PS : si j'ai raconté n'importe quoi ou si ma méthode d'installation pourrait être optimisée, n'hésitez pas à le dire !

Hors ligne

#20 Le 25/02/2014, à 22:57

Korak

Re : [RESOLU] Dualboot Windows8 et Ubuntu - UEFI

Si Ubuntu et Windows fonctionne correctement, c'est tout bon.

Moi aussi je doit passer par le gestionnaire d'amorçage. Sinon, c'est Windows qui se lance.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Carte graphique: AMD Radeon R5   Mémoire vive: 8 Go RAM
Je suis Parrain-Linux

Hors ligne

Haut de page ↑