Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 06/03/2005, à 18:39

Sleeper

[Résolu] PHP 4 ne fonctionne pas sous Apache 2

Bonjour..

Avant de poster j'ai retourné le forum et je n'arrive toujours pas a faire fonctionner mes script php sous apache2. Un probleme que bcp de personnes on rencontré et dont je n'ai pas trouvé la solution : au lieu d'afficher ma page php firefox me demandes de la telecharger..

Mon père qui n'y connait pas grand choses sous linux à essayé d'installer le couple Apache2/PHP4 en suivant le tuto de http://gfabio.blog.free.fr/?2004/12/12/ … ache2-php4 mais a oublié de désactiver "universe" avant l'install.. J'ai donc tout supprimé et recommencé la manipulation correctement !!!

J'ai créé un lien symbolique dans le dossier /var/www/ vers mon dossier "Websites" qui se trouve dans mon dossier perso puis j'ai suivi tous les conseils des posts concernant le sujet sans résultats !!!

Ce qui est sur c'est que le serveur apache fonctionne avec les pages .htm mais quand il sagit du php il me demande de les telecharger..

Alors est ce que quelqu'un pourrait me dire concretement ce qu'il faut modifier au fichier apache2.conf et httpd.conf pour faire fonctionner php4 sous apache..

Merci bcp pour votre aide..

Dernière modification par w3dev (Le 09/03/2005, à 03:37)


Intel Core i5 750 : 4Go DDR : HD 2To : ATI HD4850 1Go DDR3 : SyncMaster 226bw
Pourquoi choisir GNU/Linux ? : Les commandes de base
Openbox : sur Ubuntu ou Debian, le tout en un script.

Hors ligne

#2 Le 06/03/2005, à 23:59

actarus

Re : [Résolu] PHP 4 ne fonctionne pas sous Apache 2

Salut!

Il faut éditer le fichier de config d'apache soit httpd.conf et ajouter la ligne suivante :

AddType application/x-httpd-php .php .php4

Remarque : Pour plus de propreté, on peut mettre cette ligne dans le fichier mime.types

en ayant auparavant chargé le module php4 grace a la ligne suivante (toujours dans httpd.conf)

LoadModule php4_module        modules/libphp4.so

Hors ligne

#3 Le 07/03/2005, à 14:17

Sleeper

Re : [Résolu] PHP 4 ne fonctionne pas sous Apache 2

Merci, et pour que les changements soit pris en compte il faut relancer le serveur avec la commande restart je suposes ?


Intel Core i5 750 : 4Go DDR : HD 2To : ATI HD4850 1Go DDR3 : SyncMaster 226bw
Pourquoi choisir GNU/Linux ? : Les commandes de base
Openbox : sur Ubuntu ou Debian, le tout en un script.

Hors ligne