Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 22/10/2007, à 20:56

Harry_seldon

Plus de wifi avec Gutsy (un de plus)

Bonjour,

J'ai des problèmes avec ma connexion wifi depuis mon upgrade de feisty vers gutsy.
(Et yep un de plus !) J'ai pas trouvé de solution à mon pb, c'est pas faute d'avoir lu des pages et des pages  et d'avoir trouvé des pb proches du mien.

Pour commencer au début (il y a un mois), cela n'a pas été une mince affaire de paramétrer le wifi sous Feisty mais au final c'était parfait.
J'ai une carte LINKSYS WMP54G PCI sur un PC de bureau.

Sous Feisty, j'avais du utiliser ndispwrapper, le driver rt61.sys et au final le fichier interfaces qui allait bien était :
Fichier /etc/network/interfaces :

auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

auto eth1
iface eth1 inet static
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.254

#auto eth2
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

auto wlan0
#iface wlan0 inet dhcp

auto ra1
iface ra1 inet dhcp
pre-up iwconfig ra1 essid "FBX_network"
pre-up iwpriv ra1 set AuthMode=WPAPSK
pre-up iwpriv ra1 set EncrypType=TKIP
pre-up iwpriv ra1 set WPAPSK="abctiyalbdaplplca"
address 192.168.0.4
netmask 255.255.255.0

Fin fichier /etc/network/interfaces
Depuis que j'ai upgradé vers Gutsy je n'ai plus d'interface ra1 pour une raison que j'ignore. (Des idées ?)
Du coup j'ai essayé de réinstaller les drivers rt1 avec ndiswrapper mais je n'ai tjrs pas d'interface ra1 (J'ai aussi essayé de blacklister les drivers Gutsy rt61pci mais ça n'a fait que virer ra0)

J'ai essayé de remplacer les ra1 par ra0 dans mon fichier mais alors j'ai le message : "Invalid command : set". Manifestement L'interface ra0 ne supporte pas la commande set (pq ??).

Voilà la liste des commandes traditionnelles :
iwconfig

lo        no wireless extensions.

eth1      no wireless extensions.

wmaster0  no wireless extensions.

ra0       IEEE 802.11g  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lspci

00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801IB (ICH9) 2 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA IDE Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
02:00.0 Ethernet controller: Attansic Technology Corp. L1 Gigabit Ethernet Adapter (rev b0)
03:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 03)
03:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 03)
05:02.0 Network controller: RaLink RT2561/RT61 802.11g PCI
05:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)

ifconfig

eth1      Lien encap:Ethernet  HWaddr 00:1B:FC:E4:8E:92
          inet adr:192.168.0.3  Bcast:192.168.0.255  Masque:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:218 erreurs:0 :0 overruns:0 frame:0
          TX packets:218 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:19701 (19.2 KB) Octets transmis:19701 (19.2 KB)

ra0       Lien encap:Ethernet  HWaddr 00:1A:70:AE:C8:9E
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

wmaster0  Lien encap:UNSPEC  HWaddr 00-1A-70-AE-C8-9E-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)

iwlist scan

lo        Interface doesn't support scanning.

eth1      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

ra0       No scan results

sudo lshw -C network

  *-network
       description: Ethernet interface
       product: L1 Gigabit Ethernet Adapter
       vendor: Attansic Technology Corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: b0
       serial: 00:1b:fc:e4:8e:92
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1 driverversion=2.0.7 duplex=full firmware=N/A ip=192.168.0.3 latency=0 link=yes module=atl1 multicast=yes port=twisted pair speed=100MB/s
  *-network DISABLED
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: RaLink
       physical id: 2
       bus info: pci@0000:05:02.0
       logical name: wmaster0
       version: 00
       serial: 00:1a:70:ae:c8:9e
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci latency=64 module=rt61pci multicast=yes wireless=IEEE 802.11g

ndiswrapper -l
rt61 : driver installed
        device (1814:0301) present (alternate driver: rt61pci)

Pour rendre le tout plus mystèrieux : des fois ça marche, des fois ça marche pas.
Si je fais les commandes suivantes, ça marche (internet marche). Mais au reboot suivant, ça ne marche plus pour une raison inconnue.
sudo apt-get remove network-manager network-manager-kde
sudo apt-get install knetworkmanager

Tout ça pour dire que knetworkmanager a un comportement extrêmement bizarre, peu robuste, et peu bavard.
Ci après, je n'ai plus les références à ra1 ou ra0 dans mon fichier interfaces.
Quand je dis que ça ne marche pas après un reboot, je précise que je vois dans knetworkmanager mon réseau et quand je veux m'y connecter cela semble marcher, j'ai les étapes configuration du périphériques, configuration IP démarrée, valider la configuration IP, périphérique activé. Puis au bout de 3 secondes ça se déconnecte. Remarque, je viens de le faire 3 fois de suite et au bout de la 3eme fois il semble rester connecter plus longtemps mais bon c'est pas ce que j'appelle un fonctionnement stable (d'ailleurs il se déconnecte régulièrement, sous Feisty ct nickel). Et en plus j'aimerais fixer l'IP ce que knetworkmanager ne me laisse pas faire   

Bref, svp, aidez moi à retrouver mon ra1 qui accepte la commande set !

Merci
H

Hors ligne

#2 Le 22/10/2007, à 22:28

willy78

Re : Plus de wifi avec Gutsy (un de plus)

Trois solution:
1. avec le driver natif de gutsy rt61pci (glop)
Tu decharge le driver windows:

sudo ndiswrapper -e  rt61
sudo modprobe -r ndsiwrapper

Tu édite ton fichier interfaces et tu laisse que ça pour te connecter avec knetworkmanager

auto lo
iface lo inet loopback

Mais c'est pour du dhcp.
et tu n'en veux pas donc tu peux faire comme ça
(c'est pas les commandes iwpriv mais ça marche)

auto wlan0
iface wlan0 inet dhcp
    wpa-driver wext
    wpa-ssid FBX_network
    wpa-key-mgmt WPA-PSK
    wpa-psk "Ma_super_clé"

2. avec les driver cvs serialmonkey (comme pour feisty et c'est glop glop) connection internet obligatoire

sudo apt-get update
sudo apt-get install build-essential linux-headers-$(uname -r)
cd ~
mkdir ~/rt61
cd ~/rt61
wget http://rt2x00.serialmonkey.com/rt61-cvs-daily.tar.gz
tar -zxvf rt61-cvs-daily.tar.gz
cd rt61-cvs*/Module
make

A ce stade le driver est compiler,
Maintenant il faut l'installer mais avant il faut decharger l'ancien (rt61pci)

sudo ifconfig wlan0 down
sudo modprobe -r rt61pci
echo 'blacklist rt61pci' | sudo tee -a /etc/modprobe.d/blacklist

On installe le driver fraichement compilé!

sudo make install
echo 'rt61' | sudo tee -a /etc/modules

Il faut editer le fichier interfaces pour donner les parametre de connection

sudo gedit /etc/network/interfaces

Placer ces lignes (en WPAPSK TKIP):

auto wlan0
  iface wlan0 inet dhcp
  pre-up iwconfig wlan0 essid "mon ssid"
  pre-up iwconfig wlan0 mode managed
  pre-up iwpriv wlan0 set AuthMode=WPAPSK
  pre-up iwpriv wlan0 set EncrypType=TKIP
  pre-up iwpriv wlan0 set WPAPSK="Ma_cle_WPA_Ultra_Secrete_que_y'a_que_moi_qui_sais"

Note: Dorenavant l'interfaces s'appelle wlan0, normalisation decidé par serialmonkey adieu ra1 ou ra0 (en fait ça dépend de quelques fichiers de config elle peut quand meme s'appeler ra0 ou ra1)

3. avec ndiswrapper (pas glop)

sudo ifconfig wlan0 down
sudo rmmod rt61pci
echo 'blacklist rt61pci' | sudo tee -a /etc/modprobe.d/blacklist
sudo modprobe -r ndiswrapper
sudo modprobe ndiswrapper

Verifie le nom de ton interfaces avec iwconfig

Dernière modification par willy78 (Le 27/10/2007, à 02:51)


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#3 Le 22/10/2007, à 23:07

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

Merci pour ton aide.

Pour l'instant j'essaie la solution 1
Je n'ai pas d'interface wlan0

si je fais un sudo /etc/init.d /ntworking restart
j'ai le message
Ignoring unknown interface wlan0=wlan0.

Si je remplace par wlan0 par ra0 j'ai :
Ignoring unknown interface ra0=ra0.

Si qqun a des explications...

Demain je passe a la solution 2.

A+
H

Hors ligne

#4 Le 23/10/2007, à 06:32

willy78

Re : Plus de wifi avec Gutsy (un de plus)

Verifie le nom de ton interfaces avec iwconfig


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#5 Le 23/10/2007, à 13:12

jimichili

Re : Plus de wifi avec Gutsy (un de plus)

Bonjour,

J'ai eu aussi des problèmes de wifi lors de l'upgrade vers Gutsy alors que ma carte PCI Ovislink EvoPCIv2 (chipset Ralink RT61) marchait très bien sous Feisty. Je suis sous Xubuntu.

Je me connectais sur ma livebox avec une IP statique, comme Network-Manager ne fonctionnait (à peu près) qu'en itinérant, je l'ai enlevé via synaptic.

Après avoir paramètré ma connexion avec Network-Admin et en éditant /etc/network/interfaces, ça ne marchait pas trop mal. J'ai également désactivé avahi. Malheureusement la connexion était encore instable (déconnexion aléatoire de 10 min à 1 heure).

J'ai suivi le tuto ci-dessus, méthode 2 pour compiler et installer le driver serialmonkey. ça a l'air de bien fonctionner à nouveau et bonus, la commande iwlist ra0 scan me donne à nouveau la liste des réseaux et non plus un "no scan results" (mon interface est restée ra0).

Je vous tiendrais au courant quant à la stabilité. En tout cas merci Willy78.
JiM

EDIT : ça tourne depuis deux heures sans problème. Résolu pour moi donc.

Dernière modification par jimichili (Le 23/10/2007, à 15:26)

Hors ligne

#6 Le 23/10/2007, à 15:28

vince-60

Re : Plus de wifi avec Gutsy (un de plus)

Salut,

Ma pierre à l'édifice :
J'ai la carte LinkSys WMP54G, chipset RT61.
Sous Feisty, je n'avais aucun soucis. Carte reconnue tout de suite, avec le driver Feisty. Elle s'appelait ra1, et se connectait tout de suite à mon routeur.

Mais depuis Gutsy (installe from scratch, ou MAJ depuis Feisty), voici les changements :
- elle s'appelle maintenant wlan0
- je suis obligé au démarrage de taper "/etc/init.d/networking force-reload" pour que le réseau fonctionne.
Pourtant, en tapant cette dernière commande, dans "dmesg", j'ai exactement les mêmes messages que lors de la séquence de boot, preuve que tout s'y passe bien. Mais pourtant, pas de réseau une fois sur le bureau Ubuntu. Et rechargement des paramètres obligatoire...

Visiblement, Gutsy n'aime plus le RT61 !

Hors ligne

#7 Le 23/10/2007, à 22:03

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

Salut Willy78, salut tout le monde 

Bon la solution 2 ne marche pas. C'est vraiment rageant pq je sens que ce n'est pas loin de marcher.
Et d'ailleurs j'ai l'impression que j'ai le même problème qu'avec la solution 1, càd j'ai des problèmes avec le dhcp.

Voici les paramètres je suis dans la configuration de la solution 2.
J'ai notamment le message No DHCPOFFERS received à l'init. (avec la solution 1 j'avais de temps en temps des offres).

sudo /etc/init.d/networking restart

 * Reconfiguring network interfaces...                                          RTNETLINK answers: No such process
There is already a pid file /var/run/dhclient.ra0.pid with pid 1
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:1a:70:ae:c8:9e
Sending on   LPF/ra0/00:1a:70:ae:c8:9e
Sending on   Socket/fallback
DHCPRELEASE on ra0 to 192.168.0.254 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
There is already a pid file /var/run/dhclient.ra0.pid with pid 1
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:1a:70:ae:c8:9e
Sending on   LPF/ra0/00:1a:70:ae:c8:9e
Sending on   Socket/fallback
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

iwconfig

lo        no wireless extensions.

ra0       RT61 Wireless  ESSID:"FBX_network"  Nickname:""
          Mode:Managed  Frequency:2.447 GHz  Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Link Quality=85/100  Signal level:-51 dBm  Noise level:-103 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.

ifconfig

eth1      Lien encap:Ethernet  HWaddr 00:1B:FC:E4:8E:92
          inet adr:192.168.0.3  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::21b:fcff:fee4:8e92/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:6551 erreurs:0 :0 overruns:0 frame:0
          TX packets:6338 errors:0 dropped:0 overruns:0 carrier:3
          collisions:0 lg file transmission:1000
          Octets reçus:4203470 (4.0 MB) Octets transmis:1173044 (1.1 MB)

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:86 erreurs:0 :0 overruns:0 frame:0
          TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:14817 (14.4 KB) Octets transmis:14817 (14.4 KB)

ra0       Lien encap:Ethernet  HWaddr 00:1A:70:AE:C8:9E
          adr inet6: fe80::21a:70ff:feae:c89e/64 Scope:Lien
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:106001 erreurs:0 :0 overruns:0 frame:0
          TX packets:3417 errors:13 dropped:13 overruns:0 carrier:0
          collisions:5 lg file transmission:1000
          Octets reçus:11984492 (11.4 MB) Octets transmis:0 (0.0 b)
          Interruption:18

lspci

05:02.0 Network controller: RaLink RT2561/RT61 802.11g PCI

sudo lshw -C network

  *-network
       description: Ethernet interface
       product: L1 Gigabit Ethernet Adapter
       vendor: Attansic Technology Corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: b0
       serial: 00:1b:fc:e4:8e:92
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1 driverversion=2.0.7 duplex=full firmware=N/A ip=192.168.0.3 latency=0 link=yes module=atl1 multicast=yes port=twisted pair speed=100MB/s
  *-network
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: RaLink
       physical id: 2
       bus info: pci@0000:05:02.0
       logical name: ra0
       version: 00
       serial: 00:1a:70:ae:c8:9e
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt61 latency=64 module=rt61 multicast=yes wireless=RT61 Wireless

La solution 3 je l'avais essayé au début mais sans succès.

Si t'as une idée Willy78,  je suis preneur. Je commence à avoir épuisé mes ressources. J'hésite à faire une install avec format de gutsy (j'avais upgradé). Voire j'hésite à repasser sous Feisty !

H

Dernière modification par Harry_seldon (Le 23/10/2007, à 22:55)

Hors ligne

#8 Le 23/10/2007, à 22:13

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

Pour jimichili :

Est-ce que tu peux poster tes paramètres, stp ? Ca peut peut etre m'aider à repérer un défaut dans ma config.

Merci
H

Hors ligne

#9 Le 23/10/2007, à 22:28

willy78

Re : Plus de wifi avec Gutsy (un de plus)

Ca c'est tout bon:

Link Quality=85/100

Donne ton fichier interfaces:

cat /etc/network/inetrfaces

Et :

iwlist scan


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#10 Le 23/10/2007, à 22:41

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

Fichier interfaces

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet static
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.254

auto ra0
iface ra0 inet dhcp
pre-up iwconfig ra0 essid "FBX_network"
pre-up iwconfig ra0 mode managed
pre-up iwpriv ra0 set AuthMode=WPAPSK
pre-up iwpriv ra0 set EncrypType=TKIP
pre-up iwpriv ra0 set WPAPSK="abctiyalbdaplplca"

iwlist scan

lo        Interface doesn't support scanning.

ra0       Failed to read scan data : Device or resource busy

eth1      Interface doesn't support scanning.

Je v faire un reboot pour voir si ra0 est toujours busy

H

Hors ligne

#11 Le 23/10/2007, à 22:53

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

Après un reboot :

iwlist scan

lo        Interface doesn't support scanning.

ra0       Scan completed :
          Cell 01 - Address: 1E:1A:89:81:2E:BC
                    ESSID:"Janine"
                    Mode:Managed
                    Channel:2
                    Encryption key:on
                    Bit Rates:0 kb/s
                    Quality:0/100  Signal level:-76 dBm  Noise level:-256 dBm
          Cell 02 - Address: 1E:1A:89:81:2E:BD
                    ESSID:""
                    Mode:Managed
                    Channel:2
                    Encryption key:on
                    Bit Rates:0 kb/s
                    Quality:0/100  Signal level:-78 dBm  Noise level:-256 dBm
          Cell 03 - Address: 1E:1A:89:81:2E:BF
                    ESSID:"freephonie"
                    Mode:Managed
                    Channel:2
                    Encryption key:on
                    Bit Rates:0 kb/s
                    Quality:0/100  Signal level:-76 dBm  Noise level:-256 dBm
          Cell 04 - Address: 4A:7E:DA:AF:89:3B
                    ESSID:"freephonie"
                    Mode:Managed
                    Channel:8
                    Encryption key:on
                    Bit Rates:149 Mb/s
                    Quality:0/100  Signal level:-46 dBm  Noise level:-256 dBm
          Cell 05 - Address: 4A:7E:DA:AF:89:39
                    ESSID:""
                    Mode:Managed
                    Channel:8
                    Encryption key:on
                    Bit Rates:1 Mb/s
                    Quality:0/100  Signal level:-46 dBm  Noise level:-256 dBm
          Cell 06 - Address: 4A:7E:DA:AF:89:3A
                    ESSID:""
                    Mode:Managed
                    Channel:8
                    Encryption key:on
                    Bit Rates:1 Mb/s
                    Quality:0/100  Signal level:-46 dBm  Noise level:-256 dBm
          Cell 07 - Address: 00:10:C6:EA:6D:1C
                    ESSID:"Wanadoo_de59"
                    Mode:Managed
                    Channel:10
                    Encryption key:on
                    Bit Rates:1 Mb/s
                    Quality:0/100  Signal level:-58 dBm  Noise level:-256 dBm
          Cell 08 - Address: 00:16:41:4F:D9:68
                    ESSID:"Wanadoo_d195"
                    Mode:Managed
                    Channel:10
                    Encryption key:on
                    Bit Rates:1 Mb/s
                    Quality:0/100  Signal level:-80 dBm  Noise level:-256 dBm

eth1      Interface doesn't support scanning.

Au passage :
lsmod | grep rt61

rt61pci                28288  0
rt2x00pci              13184  1 rt61pci
rt2x00lib              21760  2 rt61pci,rt2x00pci
mac80211              196104  3 rt61pci,rt2x00pci,rt2x00lib
eeprom_93cx6            3712  1 rt61pci
rt61                  220048  1

iwconfig

lo        no wireless extensions.

ra0       RT61 Wireless  ESSID:"FBX_network"  Nickname:""
          Mode:Managed  Frequency:2.447 GHz  Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Link Quality=92/100  Signal level:-47 dBm  Noise level:-80 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.

Il n'y a toujours pas de point d'accès.

Hors ligne

#12 Le 23/10/2007, à 23:05

willy78

Re : Plus de wifi avec Gutsy (un de plus)

Ok je sais tu as deux driver pour ta carte c'est un de trop!

rt61pci                28288  0
rt2x00pci              13184  1 rt61pci
rt2x00lib              21760  2 rt61pci,rt2x00pci
mac80211              196104  3 rt61pci,rt2x00pci,rt2x00lib
eeprom_93cx6            3712  1 rt61pci
rt61                  220048  1

C'etait dans le tuto fais donc ces commande et reboot:

sudo modprobe -r rt61pci
echo 'blacklist rt61pci' | sudo tee -a /etc/modprobe.d/blacklist

Et des point d'accès il y en as 8 de lister!!!!!!
Dont 2 avec SSID cacher et le tiens est caché? (c'est important)

Dernière modification par willy78 (Le 23/10/2007, à 23:07)


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#13 Le 24/10/2007, à 14:32

jimichili

Re : Plus de wifi avec Gutsy (un de plus)

Bonjour,

Au cas où ça pourrait être utile, voici comme demandé ma configuration avec quelques précisions cependant :
D'après la commande suivante, ma carte est à base de chipset RT2561/RT61 rev B, et non pas RT2561/RT61 tout court, pour laquelle il faut peut-être un autre driver (pure supposition). C'est bien le driver nouvellement compilé et installé  qui est chargé (rt61).

~$ lshw -C Network
  *-network               
       description: Wireless interface
       product: RT2561/RT61 rev B 802.11g
       vendor: RaLink
       physical id: 1
       bus info: pci@0000:02:01.0
       logical name: ra0
       version: 00
       serial: 00:08:a1:a1:e8:5c
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt61 ip=192.168.1.2 latency=32 module

En ce qui concerne ma configuration réseau, mon pc de bureau est connecté en IP statique via WEP à une LiveBox (oui pas top sécurité, mais quand on habite en rase campagne...). Par curiosité je pense essayer en WPA dans les prochains jours.

~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

#wifi
iface ra0 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1
wireless-mode managed
wireless_keymode open
wireless-channel 9
wireless-key Ma_cle_WEP_hexa
wireless-essid Livebox-XXXX
auto ra0

#filaire
#iface eth0 inet static
#address 192.168.1.2
#netmask 255.255.255.0
#gateway 192.168.1.1

Hors ligne

#14 Le 24/10/2007, à 19:09

lavazavio

Re : Plus de wifi avec Gutsy (un de plus)

Bonjour a tous,

Je suis dans le meme cas que beaucoup, j'ai une carte wifi a base rt61 et pas de connexion au net.
Je suis sous ubuntu 7.10.
Quelques infos : IP statique / WPA / TKIP.
Quand je laisse NM chercher les réseaux en automatqiues, il me trouve mon reseau mais la connexion ne fonctionne pas (logique je suis en ip fixe).
Mais quand je passe en config manuelle du reseau, j'ai rien du tout.

J'ai essayé de "bidouiller" le fichier interfaces (/etc/network/interfaces) mais ca ne fonctionne toujours pas.

Pouvez vous m'aider svp...;)

Hors ligne

#15 Le 24/10/2007, à 19:19

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

A Jmichili : Merci. Effectivement faudrait que je teste le wifi en wep, mais comme j'ai deux autres pc sur le réseau ça m'embete. Sinon cote sécurité, c'est pas hyper important pour moi !

A Willy78,
Bon ça ne marche pas encore. (ça ne change rien)

Tu as raison sur les SSID, le mien n'est pas caché normalement, et pourtant on ne le voit pas dans le scan.
L'adresse MAC de ma freebox est : 00:07:CB:32:E9:18 . Je ne la vois pas dans le scan (devrais-je ?).
Ce qui est bizarre c'est qu'avec le driver rt61pci j'arrivais de temps en temps à me connecter via le knetworkmanager. Et knetworkmanager voyais mon réseau "FBX_network".

Est-ce que le dhcp est demandé au bon réseau (que veut dire la ligne en gras):
sudo /etc/init.d/networking restart

* Reconfiguring network interfaces...                                                                                                                       There is already a pid file /var/run/dhclient.ra0.pid with pid 5945
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/[b]00:1a:70:ae:c8:9e[/b]
Sending on   LPF/ra0/00:1a:70:ae:c8:9e
Sending on   Socket/fallback
DHCPRELEASE on ra0 to 192.168.0.254 port 67
There is already a pid file /var/run/dhclient.ra0.pid with pid 1
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:1a:70:ae:c8:9e
Sending on   LPF/ra0/00:1a:70:ae:c8:9e
Sending on   Socket/fallback
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

H

Hors ligne

#16 Le 24/10/2007, à 19:21

willy78

Re : Plus de wifi avec Gutsy (un de plus)

@lavazavio Mets ton fichier interfaces comme ça:

auto wlan0
iface wlan0 inet static
gateway 192.168.1.1                  #adresse de ta box
address    192.168.1.100               #ton adresse ip
netmask 255.255.255.0
wpa-driver wext
wpa-ssid FBX_network
wpa-key-mgmt WPA-PSK
wpa-psk "Ma_super_clé"

Ensuite fais :

etc/init.d/networking/restart


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#17 Le 24/10/2007, à 20:40

Harry_seldon

Re : Plus de wifi avec Gutsy (un de plus)

Bon en wep ça marche. Je vais rester comme ça en attendant qu'ubuntu daigne proposer un service de gestion de wifi digne de ce nom pq là je regrette violemment Windows.

Merci jmichlili. Comme quoi ton poste m'a bien servi !!

Merci aussi à willy78. Si jamais t'as d'autres idées pour faire marcher le wpa ça m'interessera !

Voilà mon fichier interfaces (partie wifi)

auto ra0
iface ra0 inet dhcp
wireless-essid FBX_network
#wireless-mode managed
#wireless_keymode open
wireless-channel 8
wireless-key 0123456789

Les 2 lignes en commentaires génèrent des erreurs dans la commande restart.

A+
H

Hors ligne

#18 Le 24/10/2007, à 21:59

willy78

Re : Plus de wifi avec Gutsy (un de plus)

le WPA que tu choisis c'est du WPA ou WPA2?
sinon essaye sans la ligne:

pre-up iwconfig ra0 mode managed

juste comme ça:

auto ra0
iface ra0 inet dhcp
pre-up iwconfig ra0 essid "FBX_network"
#pre-up iwconfig ra0 mode managed
pre-up iwpriv ra0 set AuthMode=WPAPSK
pre-up iwpriv ra0 set EncrypType=TKIP
pre-up iwpriv ra0 set WPAPSK="abctiyalbdaplplca"


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#19 Le 24/10/2007, à 22:25

lavazavio

Re : Plus de wifi avec Gutsy (un de plus)

willy78 a écrit :

@lavazavio Mets ton fichier interfaces comme ça:

auto wlan0
iface wlan0 inet static
gateway 192.168.1.1                  #adresse de ta box
address    192.168.1.100               #ton adresse ip
netmask 255.255.255.0
wpa-driver wext
wpa-ssid FBX_network
wpa-key-mgmt WPA-PSK
wpa-psk "Ma_super_clé"

Ensuite fais :

etc/init.d/networking/restart

Bon, alors, je n'y comprends rien.
Ca a marché 30min puis plus rien, impossible de me reconnecter.
Qu'est ce qui ne va pas ? hmm

Hors ligne

#20 Le 24/10/2007, à 22:35

willy78

Re : Plus de wifi avec Gutsy (un de plus)

Le probleme avec les config static si ça déconnecte y'a pas de demon qui cherche a reconnecter contrairement au dhcp.
Meme en faisant un

/etc/init.d/networking restart


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#21 Le 25/10/2007, à 16:33

lavazavio

Re : Plus de wifi avec Gutsy (un de plus)

oui meme en relancant ca ne remarche pas.

Hors ligne

#22 Le 25/10/2007, à 18:30

willy78

Re : Plus de wifi avec Gutsy (un de plus)

fais des iwlist scan en serie pour forcer le driver a trouver des reseaux quand tu voit qu'il scan ton reseaux fais un restart


Quelques tutos pour le wifi sous Ubuntu:
http://wlety.free.fr/forum

Hors ligne

#23 Le 03/11/2007, à 07:28

kooky

Re : Plus de wifi avec Gutsy (un de plus)

je suis dans le même cas que vince-60, avec ma carte wifi basée sur le chipset rt61, je suis aussi obligé au démarrage de taper :

sudo /etc/init.d/networking force-reload

...pour que le réseau en ip fixe et mode ad-hoc fonctionne.

Je voudrai savoir si il serait possible de créer un script qui lancerai cette commande au demarrage?

Si oui comment si prendre? roll

merci d'avance pour votre aide.:)

#24 Le 22/11/2007, à 10:48

ahsid

Re : Plus de wifi avec Gutsy (un de plus)

je ne sais pas si ça aidera, mais je viens de remarquer que j'avais des problèmes de connexion wifi avec ma freebox lorsque je mettais d'autre cryptages WPA que WPA (TKIP + AES),
WPA (TKIP) provoquait des déconnexions intempestives voir aucune connexions du tout et WPA (AES + CCMP) idem.


OpenSuse & KDE 4.4 (mais mon rêve c'est de pouvoir remettre Chakra, Sony de #&@*ù$&# ! )

Hors ligne