Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/07/2014, à 14:51

bg21

Erreur pour monter une partition chiffré

Bonjour

Je suis novice et il y a quelque temps, lors de l'installation d'Ubuntu, j'avais chiffré un disque entier avec les outils inclus dans la distribution.
Les mise à jours successives de Ubuntu ne m'avais jamais posés de soucis jusqu'à la version 14.04.
Maintenant, lorsque je veux accéder à mon disque, j'ai le message suivant:

"Une erreur est survenue en accédant à « Lecteur chiffré de 1,8 Tio ». Le système a répondu :The requested operation has failed: Error mounting /dev/dm-0 at /media/bruno/donnees: Command-line `mount -t "ext3" -o "uhelper=udisks2,nodev,nosuid" "/dev/dm-0" "/media/bruno/donnees"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/mapper/luks-60729a7c-2742-4c0a-b8c2-68f46bace6cf, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so "

La commande "dmesg | tail" donne :

[   47.197737] type=1400 audit(1404639410.155:73): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2112 comm="apparmor_parser"
[  321.506565] type=1400 audit(1404639684.463:74): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2621 comm="apparmor_parser"
[  321.506589] type=1400 audit(1404639684.463:75): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2621 comm="apparmor_parser"
[  321.509612] type=1400 audit(1404639684.467:76): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2621 comm="apparmor_parser"
[ 2167.284941] bio: create slab <bio-1> at 1
[ 2167.492323] bio: create slab <bio-1> at 1
[ 2167.779864] EXT4-fs (dm-0): mounting ext3 file system using the ext4 subsystem
[ 2167.780469] EXT4-fs (dm-0): bad geometry: block count 488378000 exceeds size of device (488377871 blocks)
[ 2167.880070] EXT4-fs (dm-0): mounting ext3 file system using the ext4 subsystem
[ 2167.880471] EXT4-fs (dm-0): bad geometry: block count 488378000 exceeds size of device (488377871 blocks)

Est-ce quelqu'un peut m'expliquer ce que cela veut dire afin que je trouve une solution (ou carrément me donner la solution) s'il vous plaît ?

Cordialement.

Dernière modification par Kanor (Le 07/07/2014, à 20:05)

Hors ligne

#2 Le 07/07/2014, à 00:13

Kanor

Re : Erreur pour monter une partition chiffré

Salut
il semblerait que tu utilise des partitions géré avec lvm
je propose de voir comment c'est configuré

sudo lvdisplay

voir aussi comment tes partitions sont monté

cat /etc/fstab

Hors ligne

#3 Le 07/07/2014, à 18:41

bg21

Re : Erreur pour monter une partition chiffré

Bonjour Kanor

Au sujet de lvm, non je ne l'utilise pas, j'ai eu une mauvaise expérience avec. Je suis certain que ce n'ai pas la cause de mon soucis.
Mon second disque est : sdb1
Voici le contenu de fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=38590395-642e-47d1-8b6f-76963e322378 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=61b0db22-f47a-4316-ac9d-01e7e6abc5d6 /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=7a1da0c2-e252-41bf-86f8-f39aca42389d none            swap    sw              0       0
# /passerelle on /dev/sda7
UUID=AE32-F721                            /passerelle     vfat    defaults,umask=0 0      0 

Mon disque en question, sdb1, n'est pas listé, car je ne voulais pas d'un montage automatique.
De plus, heureusement, j'ai un autre disque de secours sous MAGEIA qui lui accède encore à mon disque. J'ai déjà comparé mes 2 fstab,
et sous MAGEIA aussi, il n'est pas listé (je ne le monte que si j'en ai besoin, sinon je ne vois pas l'intérêt de crypter, mais c'est une autre
histoire)
Sous MAGEIA, un fois monté, son système de fichier est ext3 (oui, je sais, ça date un peu...)
Voilà ! J'en arrive à penser qu'il y a un bug avec la version 14.04 !?

Cordialement.

Dernière modification par Kanor (Le 07/07/2014, à 20:05)

Hors ligne

#4 Le 07/07/2014, à 20:04

Kanor

Re : Erreur pour monter une partition chiffré

Ok
Quand tu fais une recherche sur /dev/dm tu tombe en premier sur lvm
mais c'est aussi pour dm-crypt que tu dois utiliser

est ce que tu peux donner le retour de

fdisk -l 

avec le disque branché

Hors ligne

#5 Le 07/07/2014, à 20:16

bg21

Re : Erreur pour monter une partition chiffré

Oui, voilà :

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d'E/S (minimale / optimale) : 4096 octets / 4096 octets
Identifiant de disque : 0x1ad11ad0

Périphérique Amorçage  Début         Fin      Blocs    Id. Système
/dev/sda1   *          63  1023999164   511999551    7  HPFS/NTFS/exFAT
La partition 1 ne commence pas sur une frontière de cylindre physique.
/dev/sda2      1024000000  1638387711   307193856   83  Linux
/dev/sda3      1638389086  3907024064  1134317489+   f  Étendue W95 (LBA)
La partition 3 ne commence pas sur une frontière de cylindre physique.
/dev/sda5      1638389088  1646566109     4088511   82  partition d'échange Linux / Solaris
/dev/sda6      1646566173  3694564439  1023999133+  83  Linux
La partition 6 ne commence pas sur une frontière de cylindre physique.
/dev/sda7      3694564503  3907024064   106229781    b  W95 FAT32
La partition 7 ne commence pas sur une frontière de cylindre physique.

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 têtes, 63 secteurs/piste, 243201 cylindres, total 3907029168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0xe7073f92

Périphérique Amorçage  Début         Fin      Blocs    Id. Système
/dev/sdb1   *          63  3907024064  1953512001   83  Linux

Désolé, il y des partitions Windows, j'utilise des logiciels qui n'existent pas sous Linux !!!

Dernière modification par Kanor (Le 07/07/2014, à 20:21)

Hors ligne

#6 Le 07/07/2014, à 20:27

Kanor

Re : Erreur pour monter une partition chiffré

bg21 a écrit :

Désolé, il y des partitions Windows, j'utilise des logiciels qui n'existent pas sous Linux !!!

Pas de probléme tu es libre wink

Mais ce serait bien que rajoute les balise code tongue

Bon tu as quoi avec

ls -la /dev/mapper/

et

 cat /etc/crypttab

je préfére me renseigner avant de faire de te faire des manipulation.

Hors ligne

#7 Le 07/07/2014, à 20:52

bg21

Re : Erreur pour monter une partition chiffré

bruno@bruno-bureau:/dev$ ls -la /dev/mapper/
total 0
drwxr-xr-x  2 root root      60 juil.  7 19:10 .
drwxr-xr-x 17 root root    4360 juil.  7 19:10 ..
crw-------  1 root root 10, 236 juil.  7 19:10 control

puis

bruno@bruno-bureau:/dev$ cat /etc/crypttab
cat: /etc/crypttab: Aucun fichier ou dossier de ce type

Ha, il semble qu'il me manque quelque chose.

Hors ligne

#8 Le 12/07/2014, à 12:11

Kanor

Re : Erreur pour monter une partition chiffré

Pardon pour le silence mais j'étais un peu occupé  ;-)

je viens de relire le sujet et je t'avais pas demandé quand tu dis

Maintenant, lorsque je veux accéder à mon disque, j'ai le message suivant:

tu utilise quel outil pour accéder à ce disque ?

Hors ligne

#9 Le 12/07/2014, à 14:06

bg21

Re : Erreur pour monter une partition chiffré

Bonjour Kanor

Il n'y a pas de soucis pour le silence, je part moi même en vacances demain pour 2 semaines :-) !!!

J'avais crypté mon disque avec l'outil fourni de base, lors de l'installation de Linux : LUKS de mémoire.
Le système ouvre une fenêtre au démarrage me demandant le mot de passe, et c'est là que j'ai le message.
J'ai le même message avec Dolphin ou en ligne de commandes.

Désolé pour les balises code, je ne sais pas encore ce que c'est mais c'est promis, j'y travaillerai.

A plus tard.

Hors ligne

#10 Le 26/08/2014, à 17:51

bg21

Re : Erreur pour monter une partition chiffré

Bonsoir Kanor

J'ai fais quelques essais. J'ai réinstallé Ubuntu 12.10 puis Magéia 4 et enfin Ubuntu 14.04. Les 2 premières distributions m'ont permis d'acceder à mon disque
mais pas la dernière.
J'en déduis qu'elle est buggée vis à vis de LUKS.
J'ai résolu le problème en rétrogradant ma distribution.
Bonne soirée.

Hors ligne

Haut de page ↑