Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 28/08/2014, à 18:03

sirenoyel

Perte de Grub des que je boot sur Windows8.1

[Résolu] Perte de Grub des que je boot sur Windows8.1

Bonjour à tous,

Possesseur  d'un VAIO 171E13M, j'ai donc installé ubuntu dernière version 64 bit en dual boot via le CD live et en suivant le tuto.

Dans un premier temps suite à l’installe il m'était impossible de booter sur windows 8, à dire vrais lorsque j'essayais de booter sur windows 8 via Grub, windows n'était pas reconnu seul UBUNTU pouvait booter. Cepandant j'accédais à chaque redémarrage au GRUB.
Grosse panic j'ai donc utilisé mon lecteur de récupération windows8. Ouf mes données sur la partition windows ne sont pas écrasées. Mais suite à cette manip j'ai perdu le Grub.
En revanche, chose étrange, en bidouillant le bios j'arrive à lancer UBUNTU:
Je passe en mode legacy,
je redémarre, aucun system d'exploit n'est trouvé,
je retourne dans le bios,
je valide mode EFI,
je redémarre et la je retrouve mon Grub.

A partir de ce moment précis,tant que je lance UBUNTU je retrouve toujours mon Grub au démarrage, mais si j'ai le malheur de choisir le windows dans les choix du Grub, Windows redevient prioritaire. Donc obligé de rebidouiller le bios (comme indiqué ci-dessus) pour retourver le Grub.
Aussi, des lors que windows redevient prioritaire, j'accède au menu boot sous windows. Si mon choix s'oriente sur UBUNTU j'ai un message d'erreur systématiquement. Donc à partir de ce moment là je ne peux plus lancer UBUNTU

En résumé, Des que je repasse le Bios en EFI (suite au mode legacy inopérant), je retrouve GRUB avec la possibilité de choisir mon system d'exploitation Windows ou UBUNTU, si je lance UBUNTU, pas de problèle, à chaque redémarrage, je retrouve GRUB, mais des lors que je choisi windows, celui-ci redevient prioritaire et je ne retrouve plus GRUB. Par contre, j'accède au dual boot de windows, mais impossible de lancer UBUNTU, ça ce solde par un message d'erreur. Why???

PS : Dans mes programmes d'instals windows, j'ai remarqué que UBUNTU était installé. Pourtant je n'ai jamais utilisé WUBI. Est ce que c'est du au LIVE CD?

Je suis très débutant donc désolé si je manque de clareté.
Merci par avance de vos réponses.

Dernière modification par sirenoyel (Le 04/09/2014, à 12:17)

Hors ligne

#2 Le 28/08/2014, à 18:28

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Je viens de désinstaller ce programe UBUNTU dans windows. je viens de perdre complètement le dual boot via windows. J'accède à Grub mais il ne détecte plus rien.

Avant que je ne supprime ce programme UBUNTU dans windows, j'ai essayé boot repair disk, mais au final aucun résultat.

Je crois que je suis bon pour la réinstallation sad

Hors ligne

#3 Le 28/08/2014, à 19:28

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Salut,

Remets ton bios en uefi,

Ton Vaio doit avoir une touche "assist" qui permet un démarrage avancé. Tu devrais obtenir ceci:

assist -resize 50%

Essaie de voir si par F10 si tu peux atteindre l'invite de commandes

---------------------

Sinon, télécharge ce créé spécialement par Microsoft et crée un cd ou une clé bootable en suivant le tuto.
http://forum.pcastuces.com/images_de_re … f7s963.htm

Essaie de démarrer dessus et d'atteindre l'invite de commandes. Après on verra quelle est la situation.

Dernière modification par ikewdu (Le 28/08/2014, à 19:31)

Hors ligne

#4 Le 28/08/2014, à 20:40

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Merci. Je ne demare plus que sur Windows maintenant. Plus aucun grub en vue. What else?

Hors ligne

#5 Le 28/08/2014, à 22:16

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Re,

Si j'en crois ceci, il ne peut guère en être autrement.

sirenoyel a écrit :

Je viens de désinstaller ce programe UBUNTU dans windows. je viens de perdre complètement le dual boot via windows.

As-tu fait ce que je t'ai proposé ?

Hors ligne

#6 Le 29/08/2014, à 09:49

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Oui j'arrive sur l'invit de commande via f10. Penses tu que c'est possible de retrouver un dual boot fonctionnel ?

Hors ligne

#7 Le 29/08/2014, à 09:51

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

x:\windows\system32>

Hors ligne

#8 Le 29/08/2014, à 16:24

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Re,

Commence par taper ceci

diskpart
list disk
select disk 0
list volume 
list partition
exit

Fais une photo du résultat et propose-la.

Hors ligne

#9 Le 29/08/2014, à 17:02

Bougron

Re : Perte de Grub des que je boot sur Windows8.1

Bonjour
Afin de mieux comprendre ce que contient ce micro, un boot-info pourrait aider.
A la manière de Malbo
"Ouvre une session sur ton .buntu installé et de faire un Boot-Info en suivant cette procédure simplifiée : http://forum.ubuntu-fr.org/viewtopic.ph … #p16690381
Tu colleras l'URL de ce Boot-Info dans ta réponse".

Si tout semble OK, un démarrage  du boot boot via windows est certainement  possible et peut être la solution..


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#10 Le 29/08/2014, à 17:09

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Bon, comme Bougron propose autre chose, et que la cacophonie est ce qu'il y a de pire, je quitte le sujet. Bye.

Hors ligne

#11 Le 29/08/2014, à 17:38

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Salut, je ne peux malheureusement plus faire de session Ubuntu. J'ai supprimé un logiciel Ubuntu sous Windows, depuis, impossible de retrouver le grub et faire une session Ubuntu. J'ai bien détaillé plus haut mon problème.

Hors ligne

#12 Le 29/08/2014, à 17:51

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Donc, on en revient à ma proposition... Je commence à avoir une petite idée de ce que tu as fait... Je ne serais guère surpris qu'aucune partition Linux n'apparaisse sur ton disque dur.

Edit. Je viens de lire la fin de ton message, tu y parles de wubi. C'est exactement à cela que je pensais. Or wubi n'est pas compatible avec W8 en uefi... il va falloir

1. Supprimer Wubi
2. Réinstaller ubuntu correctement.

Dernière modification par ikewdu (Le 29/08/2014, à 17:57)

Hors ligne

#13 Le 29/08/2014, à 17:58

Bougron

Re : Perte de Grub des que je boot sur Windows8.1

ikewdu a écrit :

Bon, comme Bougron propose autre chose, et que la cacophonie est ce qu'il y a de pire, je quitte le sujet. Bye.

@ikewdu
Je te prie de ne pas te vexer, D'ailleurs je ne propose pas autre choses, Le boot-info est un outil qui permet de voir d'entrée un certain nombre de cboses.
C'est d'ailleurs dommages qu'on ne propose  pas d'entrée un outil 'état des lieux' plus simple que ce 'machin'.

Dernière modification par Bougron (Le 29/08/2014, à 18:06)


Ubuntu  BASH 16.04.1 sous windows10  et ubuntu-17.04-beta2 avec le noyau 4.10.0-13 et la future 17.10 depuis le 10 juillet avec le noyau 4.10.0-26
Lubuntu 14.04.4 en 32 bits  et  Lubuntu 16.06.3 en 32 bits noyau 4.10.0-33 pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  le noyau 4.8.0.36
Faites votre  auto-dépannage en lisant  https://doc.ubuntu-fr.org/diagnostic.

Hors ligne

#14 Le 29/08/2014, à 18:00

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Rassure-toi, je ne suis pas vexé. Mais le boot-info ne me semble pas utile. La commande diskpart va révéler à coup sûr que le dual-boot a été installé via wubi, ce qui explique tous les problèmes.

Hors ligne

#15 Le 31/08/2014, à 08:51

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Bonjour,  je précise que j'ai bien une partition Ubuntu. Sinon comment aurais je pu démarrer une session Ubuntu après un switch legacy puis efi dans le bios. De plus j'ai  créé moi même une partition ext4 pour Ubuntu, swap et home en ext 4. Mais depuis la suppression logiciel nommé  Ubuntu sous Windows, plus d'accès possible au grub.
Dois je réellement réinstaller Ubuntu ?
SI oui quelle version choisir en fonction de l'uefi ?
Quelle live choisir, USB ou Cd ?

Hors ligne

#16 Le 31/08/2014, à 08:57

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Re,

C'est justement parce que tu as dû passer en legacy que je doute que tu aies une partition ubuntu.  Sache que le "logiciel Ubuntu" n'existe pas. Tu as simplement installé ubuntu depuis Windows, ce qui a créé un gros fichier de plusieurs Go qui contenait tes partitions. Mais elles ne sont que virtuelles, et lorsque tu as supprimé ton "logiciel Ubuntu", tu les as supprimées par la même occasion.

Ton Windows démarre, dis-tu. Fais une capture d'écran du gestionnaire de disque (touche windows + X, puis "invite de commandes en administrateur" ). Tape (et c'est la seconde fois que je te le demande) :

diskpart
list disk
select disk 0
list volume
list partition
exit

Fais une photo du résultat. On saura alors à quoi s'en tenir sur la structure de tes partitions.

Par ailleurs, il faudra nécessairement nettoyer les traces de ton installation sous Wubi qui a dû laisser un fichier  \NST\AutoNeoGrub0.mbr quelque part sur ton PC, sans compter les traces dans la base bcd. J'ai traité un cas identique au tien l'an dernier ici (je te donne simplement la partie qui te concerne):

http://www.commentcamarche.net/forum/af … dows-8#160

Tu as la même chose: Par contre, j'accède au dual boot de windows, mais impossible de lancer UBUNTU, ça ce solde par un message d'erreur. Why??? Why ? Because tu as des traces de l'installation supprimée dans la base bcd ! un bcdedit /v t'en apportera la preuve.

Dernière modification par ikewdu (Le 31/08/2014, à 09:33)

Hors ligne

#17 Le 31/08/2014, à 10:06

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Ok je vais faire ça ce soir, mais je persiste sur le fait que j'ai installer Ubuntu via le live Cd gravé en Iso. lors de l'installation j'ai choisi autre puis j'ai crée mes partitions en réduisant la partition window. De ce fait, je serais surpris car je n'ai pas fais d'installation sous Windows avec WUBI. Mais bon je suis là pour apprendre.

Ce soir j'executerai cette commande.

Hors ligne

#18 Le 31/08/2014, à 10:41

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Alors, tu as fait non pas une, mais deux installations erronées (c'était le cas dans le lien que je t'ai proposé)... Le diskpart le confirmera. Mais l'installation "wubi" (ubuntu installé depuis windows) est certaine au vu de ce que tu as dit et des symptômes que tu décris.

Puisque tu feras la commande diskpart, fais aussi

 bcdedit /v

Au rythme où on progresse, on gagnera un "temps fou".

Dernière modification par ikewdu (Le 31/08/2014, à 10:43)

Hors ligne

#19 Le 31/08/2014, à 19:36

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Première étape concernant les volume.
DHFuysTRzkP_volume_2.png

Désolé si tu as reçu des messages intempestifs, je n'arrivais pas à coller l'image.

Hors ligne

#20 Le 31/08/2014, à 19:47

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

bcdedit /v

DHFuV7khov7_bcdedit_v.png

Hors ligne

#21 Le 01/09/2014, à 06:49

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Re,

Tu n'as pas fait exit à la fin du processus diskpart. Donc, bcdedit /v est à refaire (cmd toujours exécuté en admin, comme pour diskpart). Désolé.

Diskpart montre en effet des partitions inconnues (tu as donc fait deux installations, selon des méthodes différentes). Voyons encore s'il reste des traces de celle faite avec wubi, afin de les supprimer.

Dernière modification par ikewdu (Le 01/09/2014, à 06:54)

Hors ligne

#22 Le 01/09/2014, à 09:15

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Salut,
Du temps où j’accédais à ma session UBUNTU j'ai réalisé ce cliché avec Gparted.
Donc trois partition que j'ai créé moi même
18 Gb pour UBUNTU
950 Mb pour le swap
176 Gb pour le home

DIbklgeLcGL_gparted2.png

Hors ligne

#23 Le 01/09/2014, à 09:23

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

bcdedit /v

DIbky06yDEg_bcdedit_v.png

Hors ligne

#24 Le 01/09/2014, à 17:33

ikewdu

Re : Perte de Grub des que je boot sur Windows8.1

Si tu m'as proposé l'intégralité de bcdedit, tu n'as pas (ou plus) de wubi. Et le loader de Windows ne doit pas te proposer de choix au démarrage puisque seule une entrée est proposée ici.

Si ton windows démarre normalement (cad tout seul) en uefi et que tu as supprimé le contenu des partitions Linux, il ne reste qu'à réinstaller ton Ubuntu. Utilise le tuto de malbo pour ça:

http://forum.ubuntu-fr.org/viewtopic.php?id=1555511

Et si après cela, W8 ne démarre pas, ne supprime rien et on fera un rapport boot-info pour essayer de comprendre le pourquoi du problème.

Et

Hors ligne

#25 Le 01/09/2014, à 20:56

sirenoyel

Re : Perte de Grub des que je boot sur Windows8.1

Ok merci de ton aide

Pour installer en mode efi, dois-je passer par le bios et désactiver le secure boot ? je ne trouve pas cette info (peut être inutile).

Hors ligne