Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 14/12/2007, à 11:27

itoon

Pb Création Réseau ad-hoc Wifi

Bonjour,

Je souhaiterai réaliser un réseau ad-hoc Wifi entre deux ordinateurs identiques (HP nc8430) équipés d'Ubuntu Gutsy.

J'aimerai pouvoir réaliser mon réseau avec des adresses IP statiques. Je modifie donc mon fichier interfaces comme suit  (eth1 est l'interface wifi) :

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet static
address 192.168.2.6
netmask 255.255.255.0
wireless-mode ad-hoc
wireless-essid chat

je restart avec :

sudo /etc/init.d/networking restart

Le restart fonctionne mais pas de réseau ad-hoc ! (ping)

ifconfig me renvoit des trucs corrects :

eth1      Lien encap:Ethernet  HWaddr 00:13:02:3E:9B:55  
          inet adr:192.168.2.6  Bcast:192.168.2.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:32 :2697 overruns:0 frame:0
          TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:2838567 (2.7 MB) Octets transmis:574204 (560.7 KB)
          Interruption:17 Adresse de base:0xe000 Mémoire:f4000000-f4000fff

mais iwconfig me donne :

eth1      unassociated  ESSID:"chat"  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: Not associated
          Bit Rate:54 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:99  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2553   Missed beacon:0

Ici, je suis non associé  (Cell: Not associated)
Je me dis, à  tout hazard, je vais essayer en mode dhcp avec cette configuration :

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
wireless-mode ad-hoc
wireless-essid chat

Et après si je reessaye en mode static, ça fonctionne ! C'est à  ne rien y comprendre, comme si le dhcp activait quelque chose ...

iwconfig :

eth1      IEEE 802.11g  ESSID:"chat"  
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 02:13:02:56:06:E4   
          Bit Rate:54 Mb/s   Tx-Power:15 dBm   
          Retry limit:15   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:99  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2553   Missed beacon:0

on voit ici Cell: 02:13:02:56:06:E4   


J'aimerai pouvoir faire fonctionner sans passer par le dhcp.
Est-ce que quelqu'un a déjà  eu un problème similaire ? Des conseils à  me donner ? Quelque chose que je ne fait pas bien ?

Hors ligne

#2 Le 16/01/2008, à 21:58

Chiuchu

Re : Pb Création Réseau ad-hoc Wifi

Salut,

J'ai le même souhait que toi, faire du ad-hoc en wifi mais je n'ai pas encore trouvé comment faire. Quelqu'un s'y connait il ?

Merci !

Hors ligne

Haut de page ↑