Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 26/02/2008, à 01:19

Mystdeelite

(Résolu) Grub (à n'y rien comprendre !)

Bonjour,

Je suis novice, et je viens d'installer Ubuntu 7.10 sur mon disque dur externe.
Mon but étant de laisser ma config d'origine intacte ...

Donc l'install se passe super bien smile (partitionnement manuel ==> / = 10Go, /media/D_Ubuntu = environ 70Go & SWAP = 2048) ... Je décide donc en fin d'install de selectionner (hd1) pour l'install de grub !

Jusque là tout va bien !:cool:

Je redémarre la machine et là "hop" Erreur 17 neutral
Après plusieurs recherche je fini par trouver une solution et je fais ce qui suit :

sur la ligne 1 de l'interface de grub je choisi "e" (éditer) et je me rend compte que le root est BIEN sur (hd1,0) ... à tout hasard je test en éditant et je remplae par (hd0,0) !
Bingo ... ça boot nikel big_smile

Je décide de vérifier mon arborescence et je vois que /boot/grub/stage1 est bien sur ma partition "Système de fichiers" ... alors pourquoi ai-je dû sélectionner (hd0,0) censé être mon HDD interne (celui avec Vista) ? Enfin c'est ce que je me suis demandé !

J'ai donc fais un :

sudo gedit /boot/grub/menu.lst
J'y ai apporté les modifs suivantes (en Gras):

title        Ubuntu 7.10, kernel 2.6.22-14-generic
root        (hd0,0)
kernel        /boot/vmlinuz-2.6.22-14-generic root=UUID=0fef2803-b634-4b4b-be5d-7c68dbb3060f ro quiet splash
initrd        /boot/initrd.img-2.6.22-14-generic
quiet

title        Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root        (hd0,0)
kernel        /boot/vmlinuz-2.6.22-14-generic root=UUID=0fef2803-b634-4b4b-be5d-7c68dbb3060f ro single
initrd        /boot/initrd.img-2.6.22-14-generic

title        Ubuntu 7.10, memtest86+
root        (hd0,0)
kernel        /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title        Autre(s) Système(s) d'Exploitation :
root

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title        Windows Vista
root        (hd1,1)
savedefault
chainloader    +1

Là où y'a "0" c'était "1" et là où y'a "1" c'était "0"

Je reboot ... avec toutes les possibilités imaginables :
1- Avec boot en usb sur Disque Externe = OK Grub me lance bien Ubuntu ou Vista au choix
2- Avec boot sur HDD interne / HDD externe branché = Vista se lance en auto
3- Sans HDD Externe = Vista se lance en auto
Enfin impécable quoi !

Problème :
Lors de la MAJ massive que j'ai effectué, le "menu.lst" s'est re-modifié ! Mais seulement pour les (hd0,0) redevenus (hd1,0) .... le boot Vista (hd1,1) n'a pas bougé !

Je souhaiterais comprendre, SVP, pourquoi c'est mon HDD externe que Grub prend pour (hd0) alors que ça devrait être l'inverse non ?

Et je souhaiterais aussi savoir, SVP, si y'a un moyen que je ne sois pas obligé de modifier le "menu.lst" à chaque MAJ ?

Espérant avoir donné toutes les infos utiles à une réponse claire.
Merci d'avance à tous.

Cordialement,
Myst wink

Dernière modification par Mystdeelite (Le 29/02/2008, à 23:07)

Hors ligne

#2 Le 26/02/2008, à 01:23

slasher_fun

Re : (Résolu) Grub (à n'y rien comprendre !)

Mystdeelite a écrit :

Et je souhaiterais aussi savoir, SVP, si y'a un moyen que je ne sois pas obligé de modifier le "menu.lst" à chaque MAJ ?

Modifier la ligne "groot" pour la remplacer par

# groot=(hd0,0)

smile

Hors ligne

#3 Le 26/02/2008, à 01:29

Mystdeelite

Re : (Résolu) Grub (à n'y rien comprendre !)

slasher-fun a écrit :

Modifier la ligne "groot" pour la remplacer par

# groot=(hd0,0)

smile

D'accord, merci !

Donc :

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

devient ...

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

??

Et si mon principal PB est résolu grace à ça ... pour le reste j'ai mal compris un truc ou mon interrgation est justifiée ? (Désolé mais même quand ça marche j'aime comprendre tongue)

Encore merci smile

Hors ligne

#4 Le 26/02/2008, à 12:19

slasher_fun

Re : (Résolu) Grub (à n'y rien comprendre !)

Je souhaiterais comprendre, SVP, pourquoi c'est mon HDD externe que Grub prend pour (hd0) alors que ça devrait être l'inverse non ?
--> Euh... Ça c'est la magie de GRUB (enfin il doit y avoir une logique, mais je ne la connais pas smile)

Hors ligne

#5 Le 26/02/2008, à 12:37

vista sous belga

Re : (Résolu) Grub (à n'y rien comprendre !)

Salut physiquement ubuntu est bien sur hd1
Pour grub aussi d'ailleurs,
il suffit de taper
sudo grub
find /boot/grub/stage1
quit

tu auras comme réponse (hd1,0).

Mais lorsque tu démarres l'ordi, c'est le bios qui se charge.
Or tu demandes au bios de simuler le disque 2 comme étant
le premier. Grub "prend" l'information du bios au démarrage:
le disque 2 devient 1 et le disque 1 devient 2

Or dans le menu.lst les disques sont dans l'ordre physique et non "virtuel".
Il faut donc ajuster le menu.lst en fonction.
J'espère que c'est clai slasher-fun.:)

#6 Le 26/02/2008, à 22:26

Mystdeelite

Re : (Résolu) Grub (à n'y rien comprendre !)

vista sous belga a écrit :

Salut physiquement ubuntu est bien sur hd1
Pour grub aussi d'ailleurs,
il suffit de taper
sudo grub
find /boot/grub/stage1
quit

tu auras comme réponse (hd1,0).

Mais lorsque tu démarres l'ordi, c'est le bios qui se charge.
Or tu demandes au bios de simuler le disque 2 comme étant
le premier. Grub "prend" l'information du bios au démarrage:
le disque 2 devient 1 et le disque 1 devient 2

Or dans le menu.lst les disques sont dans l'ordre physique et non "virtuel".
Il faut donc ajuster le menu.lst en fonction.
J'espère que c'est clai slasher-fun.:)

Super clair !

C'est ce que je pensais, mais j'avais peur de spéculer smile je ne connais pas assez Ubuntu ni Grub pour avoir des avis bien précis ! (je suis déjà super content d'avoir réussi l'install en HDD externe et tout ce qui a suivi .... plus de son, connexion Wifi, etc ...)

Merci beaucoup pour cette réponse en tout cas.

Sinon pour le pb de MAJ du kernel on est bien d'accord que je mets :

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

pour conserver mon menu.lst intacte ?? big_smile

Encore merci à tous !
Myst

Hors ligne

#7 Le 28/02/2008, à 13:03

Mystdeelite

Re : (Résolu) Grub (à n'y rien comprendre !)

Up ! cool

Hors ligne

#8 Le 28/02/2008, à 13:09

vista sous belga

Re : (Résolu) Grub (à n'y rien comprendre !)

oui

#9 Le 28/02/2008, à 15:13

Mystdeelite

Re : (Résolu) Grub (à n'y rien comprendre !)

Merci à tous pour votre aide smile

===> Résolu ! big_smile

Hors ligne