Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 28/11/2005, à 23:13

Soipacon

Encodage des accents avec gnome sur partition ext3 (encore un...)

Bonsoir à tous,
Je sais que ce sujet a déja été discuté ici mais j'ai beau chercher, je tourne un peu en rond...
Alors voilà j'avais une partition de données fat32 que je montais avec l'option utf8 et je n'avais pas de problèmes d'accent.
Récemment j'ai copié ces données vers une partition ext3 nouvellement créée et depuis tout va de travers:
-Les noms des fichiers qui se trouvaient sur ma partition s'affichent avec des é à la place des é.
-Le fichier dédé que je télécharge avec amule s'affiche d?d?(invalid encoding).

Au loggin le choix de langue par défaut est francais utf8.
Mon fichier locale.gen donne:
fr_FR.UTF-8 UTF-8
fr_FR@euro ISO-8859-15                                                 
fr_FR ISO-8859-1                                                       
fr_FR.UTF-8@euro UTF-8       

J'ai testé ça : http://forum.ubuntu-fr.org/viewtopic.php?id=6446  mais ça ne change rien.

Quelqu'un aurait il une idée ? Je commence à m'embrouiller tout seul avec ces histoires de locales...

Dernière modification par Soipacon (Le 29/11/2005, à 19:42)

Hors ligne

#2 Le 29/11/2005, à 01:16

sly007

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Pas mieux... depuis les maj de nautilus, c'est bien le bordcel dans mes locales! j'ai refait cette manip aussi, ca ne change rien non plus....

Hors ligne

#3 Le 29/11/2005, à 19:26

Selmak

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

c'est ds le fstab qui faut que tu rajoutes l'option
iocharset=iso8859-15 et que tu rebootes ensuite

moi ça marche nickel sous ma Sarge wink


Ma Splendeur n'a d'égale que ma Grandeur

Hors ligne

#4 Le 29/11/2005, à 19:40

Soipacon

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Je me suis peut être mal exprimé mais c'est sur la partition ext3 que ça foire... et sur ce type de partition on ne peut pas spécifier l'encodage...

Hors ligne

#5 Le 30/11/2005, à 14:38

Soipacon

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Bon en fait aprés de nombreux essais je crois que je comprend un peu...

Pour les é à la place des é il a fallu que je convertisse les noms de fichiers en iso. Comme ma partition fat32 était montée avec l'option 'iocharset=utf8,codepage=850' (j'ai lu récemment que c'était déconseillé)et bien les noms de fichiers étaient convertis en utf et quand je les ai mis sur ma partition ext3 c'est comme s'ils avaient de nouveau été convertis en utf (oui je sais c'est bizarre comme explication mais ça a vraiment l'air d'être ça !).Car si on prend un fichier 'gégé' dont le nom est encodé en utf et qu'on lui dit de le convertir de iso à utf et bien on a gégé !

Et pis pour le 'dédé' téléchargé avec la mule, je me dis que c'est peut être bien normal de le voir d?d? si son nom est encodé en iso et que nautilus essai de le lire en utf... (si je converti ces noms de fichiers en utf8 tout rentre dans l'ordre)

Ce qui m'amène a une question, est-ce que les gens qui comme moi sont en 'full utf8' et qui téléchargent vers une partition ext3 ont souvent des 'd?d?(invalid encoding)'

Merci pour vos commentaires que j'attend impatiemment !!

Hors ligne

#6 Le 01/12/2005, à 13:35

Soipacon

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Désolé d'insister mais je répète ma question :

Est-ce que les gens qui comme moi sont en 'full utf8' et qui téléchargent (avec amule par exemple) vers une partition ext3 ont souvent des 'd?d?(invalid encoding)' ?

Merci d'avance pour les réponses.

Hors ligne

#7 Le 01/12/2005, à 19:04

Bismut

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

J'ai Ubuntu par défaut (et il me semble donc être en UTF-8) et je n'ai pas vraiment de problèmes de ce genre en téléchargeant sur mon Ext3


Mac Mini 2009 avec Archlinux
Asus EeePC S101 avec Archlinux
HTC Magic avec Android

Hors ligne

#8 Le 02/12/2005, à 21:09

pld1

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

a ma derniere install sa allait, tous mes fichiers étaient bien lu, mais depuis une semaine que j'ai réinstallé, c'est la deche hmm des (invalid encoding) a chaque fin de fichiers dl @ mumule portant un accent ....

je suis en train de chercher sur le forum, j'ai trouvé des choses comme

convmv -r --nosmart --notest -f iso-8859-1 -t utf8 *

ou le logiciel ut8migrationtool

sa reste a tester ....


Ceux qui trouvent que linux est difficile a installer, c'est qu'ils n'ont jamais éssayé de sortir avec quelqu'un du sexe opposé ! [bashfr]

Hors ligne

#9 Le 02/12/2005, à 21:14

pld1

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

wouwou, trouvé la solution smile

dabord telecharger et installer convmv

sudo apt-get install convmv

et apres

convmv -r --nosmart --notest -f iso-8859-1 -t utf8 *

et hop, sa scanne votre home a la recherche de (invalid encoding) , et met les accent comme il faut big_smile

voila, voila, j'espere que sa reglera ton probleme, moi en tout cas, reglé a 100%

a+


Ceux qui trouvent que linux est difficile a installer, c'est qu'ils n'ont jamais éssayé de sortir avec quelqu'un du sexe opposé ! [bashfr]

Hors ligne

#10 Le 02/12/2005, à 22:17

Soipacon

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

pld1 a écrit :

wouwou, trouvé la solution smile

dabord telecharger et installer convmv

sudo apt-get install convmv

et apres

convmv -r --nosmart --notest -f iso-8859-1 -t utf8 *

et hop, sa scanne votre home a la recherche de (invalid encoding) , et met les accent comme il faut big_smile

voila, voila, j'espere que sa reglera ton probleme, moi en tout cas, reglé a 100%

a+

D'abord merci pour cette solution, mais je crois qu'il faut faire attention car en utilisant l'option '--nosmart' de la commande convmv, tu converti même les noms de fichiers qui sont déja en utf8. Chez moi si j'ai un fichier 'gégé' qui est affiché correctement et que je lance ta commande, ce fichier devient 'gégé'.

Pour contouner le probleme, j'ai fait un petit script pour nautilus:

#!/bin/sh
#pour convertir le nom du fichier de iso-8859-1 à utf8

for filename
do
   newfilename=`echo $filename | iconv -f iso-8859-1 -t utf-8`;
    mv "$filename" "$newfilename";
done

Tu le rend executable et tu le met dans .gnome2/nautilus-scripts/ et aprés tu clique droit sur le (ou les) fichier(s) dont tu veux convertir les noms, tu lance le script... et ça a l'air de marcher.

Par contre ce qui me trouble c'est que si je fais:

convmv -r -f iso-8859-1 -t utf8 *

(j'enlève --nosmart pour qu'il vérifie l'encodage de départ et --notest pour qu'il ne fasse pas les changements)

et bien il m'annonce que mes fichiers portant la mention 'invalid encoding' sont déja en utf-8...

Alors d'accord mon script permet d'arranger les choses sans trop se prendre la tête mais le problème de fond est toujours là.

J'éspère que d'autres commentaires viendront et nous aiderons à comprendre ce qui se passe.

Hors ligne

#11 Le 02/12/2005, à 23:16

pld1

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

yep, pas mal le script
bon alors, ce qui est fortement embettant, c'est que ma commande n'est pas définitive ...

cad, que quand tu viens de finir de DL un fichier @ mumulue, tu as toujours ce (invalide encoding) .....

de plus, j'avais un fichier, il était avec ? et (invalide ...) a la fin, je l'ai utf8tisé, hop accent, et je vais pour le re utf8tiser, et cette fois il y a é a la place de mon accent hmm:/:/

l'utf8 est vraiment une chose a améliorer pour drapper ....


Ceux qui trouvent que linux est difficile a installer, c'est qu'ils n'ont jamais éssayé de sortir avec quelqu'un du sexe opposé ! [bashfr]

Hors ligne

#12 Le 02/12/2005, à 23:19

pld1

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

oui, ton script, pas mal , mais c'est un peu chiant de devoir le faire a chaque fichiers, mais c'est deja un eptite solution

Dernière modification par pld1 (Le 03/12/2005, à 02:34)


Ceux qui trouvent que linux est difficile a installer, c'est qu'ils n'ont jamais éssayé de sortir avec quelqu'un du sexe opposé ! [bashfr]

Hors ligne

#13 Le 06/12/2005, à 22:06

Soipacon

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Un petit up car malgrés ce bricolage, le problème est toujours là ...

Hors ligne

#14 Le 29/12/2005, à 15:29

wouaren

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Exactement les mêmes problèmes que toi avec le téléchargement de fichiers (archives) sur emule...
RELOU !


love ubuntu

Hors ligne

#15 Le 02/01/2006, à 08:42

NoZ

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

J'ai exactement le meme problème aussi...
Pour l'instant je vire les accents a la main mais c'est ch**nt effectivement...


1 laptops (Horny) - 3 desktops (Exilus/Astaroth/Rakshasa)
Sous ubuntu depuis la 4.10.
Je me debarrasse d'un Proliant 5000, 4x200Mhz et 5 disques SCSI. Faites une offre :)
Tu as un GPS? Participe a la cartographie libre: http://www.openstreetmap.org

Hors ligne

#16 Le 02/01/2006, à 10:01

mops

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Pas mieux que tout le monde. Des "invalid encoding" pour tout ce qui est telecharge avec amule et des caracteres bizarres dans la barre de titre de amsn en lieu et place des accents.


Sorry for the accents, qwerty powa...

Hors ligne

#17 Le 02/01/2006, à 12:12

DuKiCloCk

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

idem pour moi ... lol ! ca fait une belle petite brochette ! ;-)

sinon, je v tester le script merci ! smile

Hors ligne

#18 Le 22/01/2006, à 20:42

TIMsmith

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Idem pour moi. Au moins j'ai appris qu'il y avait tous ces tas de codages différents pour les noms de fichier. Pourquoi faire simple qd on peut faire compliqué.:D

Hors ligne

#19 Le 23/01/2006, à 23:52

sly007

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Euh... troisieme bécanne, et chaque fois pareil... Il y a un bug report la dessus?

Hors ligne

#20 Le 07/02/2006, à 22:12

Woookash

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Idem pour moi avec amule et compagnie..


Bruxelles powaaaaaaaaaa
http://blog.woookash.net

Hors ligne

#21 Le 07/02/2006, à 22:33

wam

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

on rappelle que l'utilisation du peer2peer décrite ici corresond au téléchargement légal de fichiers tels que les .deb et les .iso de distrib gratuites dont, on le sait tous, les noms sont souvent francisés et bourrés de caractères accentués wink
xémacs.deb
opéra.deb
àmule.deb
rède_hat.iso
...

Hors ligne

#22 Le 21/02/2006, à 01:47

tigermick

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Bonjour,

J'aurai aimé savoir si qq'un avais une solution définitive pour ce prob de "invalid encoding"
car les commande convmv me donne d'autre caractére mal encodé aprés en plus.

Donc j'aurai aimé savoir s'il y avais une façon de resoudre le prob definitivement afin que qd un fichier soit créé il n'y est plus ce prob de invalid encoding.

Merci d'avance pour toute les réponses!!

#23 Le 21/02/2006, à 03:49

Kyle

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

j'ai deja eu ce problème aussi ! notamment dans amsn, les accents se métamorphosent hmm

Hors ligne

#24 Le 21/02/2006, à 04:10

tigermick

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

bon finalement g trouvé la soluce et ça marche pour moi en tout cas...j'ai essayé et c nickel

"1 - Editez avoir les droits superutilisateurs le fichier environment :
sudo nano /etc/environment
Copiez y ce contenu, à la place de l'existant :
LANGUAGE="fr_FR:fr"
LANG=fr_FR

2 - Editez en root le fichier locale.gen :
sudo nano /etc/locale.gen
Copiez y ce contenu à la place de l'existant (ou commentez tout bêtement toutes les lignes en laissant uniquement décommentées celles ci) :
fr_FR.UTF-8 UTF-8
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15

3 - Tapez ensuite :
sudo locale-gen

4 - Rebootez.

5 - Enjoy."

source : http://forum.framasoft.org/viewtopic.php?t=13434

#25 Le 17/06/2006, à 11:42

FAWTS

Re : Encodage des accents avec gnome sur partition ext3 (encore un...)

Vouv voulez un truc marrant ? Je viens d'installer une Dapper avec VMPlayer afin de réccupérer le locale.gen original, mais ce fichier n'existe pas dans /etc ! Aurait-il été placé ailleur ? Si c'est le cas, cela explique pourquoi on a tous ce problème d'encodage!!!!

Hors ligne

  • Accueil
  • » Forum
  • » Archives
  • » Encodage des accents avec gnome sur partition ext3 (encore un...)

Haut de page ↑