Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 13/11/2016, à 02:14

teobzh

Systemctl après changement HDD Xubuntu [Resolu]

Bonsoir à toutes/tous.

Je viens vous voir pour un petit(/gros) soucis. Suite à un changement de disque dur (de 80Go à 1To), je n'ai plus accès au bureau graphique et je passe, au démarrage, sur le "recovery mode" de Xubuntu ;  si j'ai bien lu et cherché sur le net.
Je me retrouve avec quelques options mais qui ne résolves pas mon soucis.
J'ai quand même essayé et aussi cherché :
./viewtopic.php?id=1859201
https://help.ubuntu.com/community/Boot-Repair
http://doc.ubuntu-fr.org/reparer_ubuntu
Mais ça ne marche pas.!
Je précise que le HDD système est en ext4 et les autres HDD (dont 1 branché en USB) sont en NTFS.

1478995361.jpg

Je reconnais que je n'ai pas fait les choses très proprement ; à savoir ne pas avoir démonté le HDD de 80Go avant de brancher le HDD de  1To.
Je me doute que cela a une incidence. sad

Merci à tous pour votre aide.


Sur Toile Libre, choisir le lien « Insérer la miniature dans un forum : » 1469894479.png

Dernière modification par teobzh (Le 28/12/2016, à 20:08)

Hors ligne

#2 Le 13/11/2016, à 08:11

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour teobzh,

Peux-tu être plus explicite sur les manipulations effectuées ?

Avec des détails si possible, car, à part le fait que ton PC refuse de booter, tu n'expliques rien de ce que tu as fait.

Hors ligne

#3 Le 16/11/2016, à 16:40

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour Baltus.

N'étant pas chez moi cette semaine, je n'ai pas put faire beaucoup.
Pour répondre à tes questions.
J'ai lancé testdisk dessus mais pas de récupération de partition ou de système.
J'ai scanné le disque pour savoir s'il était défectueux mais rien non plus.
Je ne me suis pas beaucoup aventuré + car manque de temps et de certaines connaissances.
Je ne suis pas encore rentré dans le fstab pour voir si quelque chose ne collait pas.

Merci pour le coup de main.

Hors ligne

#4 Le 16/11/2016, à 19:52

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Salut,

Je parle des manipulations que tu as réalisé entre le moment où ton PC fonctionnait normalement et le moment où il ne fonctionnait plus.

Hors ligne

#5 Le 16/11/2016, à 20:16

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

J'ai retiré un HDD de 80Go qui me servait de petite sauvegarde, pour le remplacer par un autre HDD de 1To.
Le HDD de 1To n'est pas formaté. Il est en NTFS.
Il vient d'un poste de récup que j'avais et qui est mort. Il y avait Windows 8 dessus. (Avec toutes ses jolies partitions de bases).
J'ai tenté de le retiré (de souvenir) et de rebouter sans, mais pareil. Même résultat.
Et si je me souviens biens le HDD retiré était en Ext4.

Pour faire simple la config HDD est :

1 HDD 160Go système
2*1 To de sauvegarde en NTFS
+ le dernier que je viens de mettre.

C'est suffisant comme infos.?

Merci

Hors ligne

#6 Le 16/11/2016, à 20:44

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Oui, c'est plus clair.

Je comprends que tu n'as rien fait sur ton disque système ( le disque  de 160 Go) et que tu as accès au menu Grub au démarrage de ton PC.

Encore une question, sur quel disque est placé ton dossier /home ?

Quand tu démarres ton PC, dans le menu de Grub, tu as une option pour démarrer en mode "recovery".

Tu as ensuite un autre menu avec des outils, notamment pour réparer Grub.

Peux-tu essayer cette manip ?

Hors ligne

#7 Le 16/11/2016, à 20:52

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Mon /home est sur le HDD 160Go. Toujours de souvenir :
/swap 3Go
/ 20 ou 30 Go
/home le reste (peu de données dessus)

Hélas je ne suis pas chez moi cette semaine, donc je ne pourrais faire les manip que vendredi soir ou samedi.
Malgré tout, j'ai essayé de démarrer en mode "recovery" avec 2 des premières options mais pas de résultats (mais c'est plutôt vague sans avoir le nez dessus. wink ), et toujours de souvenirs.

Je tente ce week-end pour te tenir au courant. Je ne pourrais pas avant.

Merci pour ton aide et tes conseils.

Hors ligne

#8 Le 16/11/2016, à 21:04

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

OK, tu peux également essayer de débrancher tous les disques sauf le 160 Go, puis me dire si ton PC démarre normalement avec ce seul disque.

Hors ligne

#9 Le 16/11/2016, à 21:11

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Tu peux également créer un rapport Boot-info comme indiqué.

Hors ligne

#10 Le 19/11/2016, à 15:28

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour à tous/toutes
Bonjour Baltus

Merci pour les conseils et aide.

Après avoir fait les tests. Poste démarré avec le HDD système seul, j'en reviens au même point, à  avoir en console "recovery".
J'ai quand même testé les RAM pour savoir , mais tout est OK.

Pour ce qui est des modes "recovery" proposé au démarrage, avec réparation Grub. Ben ca ne  fonctionne pas. J'ai 3 mode avec 3 propositions de noyaux/sysytème Linux de proposé et je les ai tous fait. Aucun ne "répare".!
Je regarde cet aprèm ou ce soir pour le "boot-info", en sachant que j'ai au démarrage un "systemctl journal" pour des log si j'ai bien compris.
Donc là je ne vois plus trop quoi faire. Et je cherche aussi sur le net bien sûr.

Merci encore à tous pour le coup de main.

Hors ligne

#11 Le 19/11/2016, à 22:08

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Essaie de réinstaller xorg avec la commande suivante :

apt-get install -reinstall xserver-xorg

Dernière modification par Baltus (Le 19/11/2016, à 22:08)

Hors ligne

#12 Le 20/11/2016, à 20:48

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour.

J'ai lancé cet aprem la commande. Mais hélas, j'ai eu comme retour :
E: Command line option "r" [from -reinstall] is not understood in combinaison with the other options,
Donc la forcement encore un soucis. wink

Merci

Hors ligne

#13 Le 20/11/2016, à 20:59

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Oui désolé, il manque un tiret, c'est :

apt-get install --reinstall xserver-xorg

Ou, si tu n'es pas en "root"

sudo apt-get install --reinstall xserver-xorg

Hors ligne

#14 Le 22/11/2016, à 19:22

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Pas de soucis j'avais corrigé entre temps.
Désolé pour le retard, mais cette semaine encore je ne suis pas chez moi.
J'ai bien lancé la commande à l'invite (j'ai un gros doute de savoir si j'étais en "root" ou pas)
Mais je relancerai ça ce week-end, j'aurai + de temps. En sachant que j'ai déjà vu un retour négatif.
De plus en lançant un apt-get update j'ai des erreurs à la récupération des paquets.
Comme si je n'étais pas connecté au net ou que la carte réseau n'étais pas installé.
Je confirmerai tout cela vendredi ou  samedi. Je n'ai pas accès en ce moment.
Merci pour le coup de main.
De plus, il ne reste plus que le HDD système de branché dessus.

Hors ligne

#15 Le 28/11/2016, à 19:20

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonsoir.

J'ai essayé ce week-end de lancer boot-repair sur une clé bootable sur mon poste mais impossible de booter dessus.  Pourtant mon PC est bien paramétré pour booter dessus.
Je vais relancer ce soir pour essayer. Sinon j'ai bien une commande qui me donne un journal : journalctl -xb. Mais pour ce que j'ai pu voir, le joournal est long. Très long.!
Et je ne vois pas comment l'exporter. J'ai aussi penser à tenter une réparation avec une clé live USB de Xubuntu.

Hors ligne

#16 Le 01/12/2016, à 00:21

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonsoir.

Après de nombreux tests. Autant sous Hiren's qu'en live USB. Je ne vois plus quoi faire.

Merci pour le coup de main Baltus.
Hélas rien n'avance et mis à part ce soir où j'ai eu une petite étincelle.! (le PC à "booté" sur le bureau Normal.!)
Depuis ça, je reviens sur mon ecran de recovery et de nouveau sans accès (graphique au bureau...)

J'ai surement fait une erreur à l'installe.... 3 partitions :

1 /swap de 3Go avec le grub dessus sad
1 / de 60Go maxi
1 /home pour le reste
Sur 160Go de HDD.

A mon avis c'est mon swap en erreur (avec le grub....!!??)

Je pars sur 2 solutions...

La réparation.!??! ou...
Le formatage en propre.!??!

Merci du coup de pouce...

Hors ligne

#17 Le 01/12/2016, à 07:18

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Vois-tu le menu Grub au démarrage ? Tu dois voir un menu avec plusieurs lignes dans ce genre.

Hors ligne

#18 Le 01/12/2016, à 22:13

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

Sinon, grub sur la partition swap, c'est effectivement déconseillé. Il faut installer grub sur le disque qui boot en premier (/dev/sda par exemple).

Regarde la doc.

tutoriel:partitionner_manuellement_avec_installateur_ubuntu

Dernière modification par Baltus (Le 01/12/2016, à 22:31)

Hors ligne

#19 Le 05/12/2016, à 23:19

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonsoir.

Bon décision prise. Plutôt que de passer 3 semaines à trouver une panne, je suis reparti sur une nouvelle installe. J'ai un peu galèré pour l'installe.
Allez savoir pourquoi ma clé bootable n'était plus vue/reconnue.
Pourtant formatée (de nombreuses fois.!) puis ré-écrite avec : unetbootin ; yumi ; rufus ; et encore d'autres outils...
Bref l'install est repartie.
Ma question maintenant pour la gréffer à mon post faut-il que je créée une partition /boot.?
C'est une vieille machine qui tourne sous 1.5Go de RAM avec une CM Gigabyte GA-K8NF-9-RH.
C'est pas très récent mais pour un serveur de fichier c'est suffisant.! (+ quelques utilisations basiques à coté)
Je part sur 3 Go de /swap
42 Go de racine /
et 110 Go environ de /home.
Un /boot est-il préférable ou c'est bien sur la racine.??
J'ai un doute maintenant avec ce que j'ai pu lire...
Merci pour vos retours.

Hors ligne

#20 Le 06/12/2016, à 20:50

Baltus

Re : Systemctl après changement HDD Xubuntu [Resolu]

La partition /boot n'est pas utile.

Pour les 3 autres partitions, c'est bon.

Hors ligne

#21 Le 09/12/2016, à 19:40

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour.

Ne voulant pas perdre trop de temps j'ai opté pour la ré-installe.
Par contre j'ai fait une partition /boot séparée de 1Go environ.

Je vais très surement clôturer ce sujet car mon problème est réglé maintenant.
Même si la solution n'était pas de formater mais plutôt de réparer le grub ou le boot

Merci Baltus pour tes conseils et ton aide.

Hors ligne

#22 Le 17/12/2016, à 01:23

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonsoir à tous/toutes.

Je reviens sur mon sujet que je pensais cloturer pour les fêtes...
En fait NON pas du tout...

Après une ré-installe propre et avec juste mon HDD système je me retrouve après quelques manipulations au même point. C'est à dire à mon premier post.!! Super.
Donc la me dit. Mon "Coco" y'a forcément un soucis quelque part... Je me demande si c'est sur le fstab ou niveau matériel.!??
Donc pour faire simple je vais commencer par donner ma config matérielle...

lscpu me donne :

https://lut.im/PX31VXf3z5/CkCHZZHXo0l04Ffq.jpg

lspci :

https://lut.im/MaiMUHmWAO/K7R8QLLeWpFDC06p.jpg

Désolé de le donner que par des images copier/coller mais sur ce poste je n'ai plus d'accès au net.

J'ai bien tenté un lshw mais là ca va faire quelques pages... smile

Pour la liste des HDD c'est la :

https://lut.im/GlBoG1iBTc/RgWIb4fl01agLHsD.jpg

Donc la je ne comprends plus trop. Je suis repati sur une installe propre en ayant reconnecté toutes les pièces "presque" chacunes leur tour...

Merci pour vos éclaircissements.!! Je comprend pas ce qui ne va pas...


Edit : Désolé si la mise en page n'est pas bonne, ni l’hébergeur. Mais après 4 ou 5 essais sur "toile libre", pas moyen d'uploader mes images...

HDD débranchés sauf le HDD système. Même résultat.!
Test des RAM dans le week-end.



Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Edit 2 : Impossible hier soir de me connecter sur "toile libre" c'est pourquoi j'ai choisi un autre hébergeur. Désolé

Dernière modification par teobzh (Le 17/12/2016, à 14:55)

Hors ligne

#23 Le 17/12/2016, à 02:06

Bougron

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonsoir
J'ai noté ta remarque
"Désolé de le donner que par des images copier/coller mais sur ce poste je n'ai plus d'accès au net."
Mais je pense que tu as un périphérique USB (ne serait-ce que la live-usb d'installation si tu bootes avec et que tu as choisis "essayer avant d'installer"
Il suffit que tu le montes, que tu y  fabriques un répertoire du style capture
que tu te positionnes dans ce répertoire, que tu fabriques un fichier que tu l'ouvres

touch capture1 
gedit capture1

tu pourras y coller la capture1       ainsi de suite
Après tu démontes le support USB et tu vas à un endroit qui a internet.

Actuellement, je comprends que tu as fais une installation nouvelle.

que tu as booté
que tu as répondu à la demande de choix du grub en sélectionnant la première ligne. pour avoir un boot standard
que tu as répondu à ton nom puis à ton mot de passe
et que l'écran reste noir.........
1ere question :   Que donne la commande  Crtl Alt T

J'ai vu dans la discussion que tu sais choisir de booter en recovery
Il me semble que  tu sais aller en "root"

2e question :  que donne la commande   ping 8.8.8.8

3eme question si la seconde a répondu : Que donne la commande ping www.google.com

4eme question si la troisième question a répondu: Fais les mises à jour logicielles

apt update
apt upgrade

5eme question..
Comme c'est probablement un problème graphique,  il faudrait le nom de la carte graphique
     Si tu l'as indiquée dans la discussion, excuses ma demande.

6eme question; Tu indiques que tu n'as pas internet
   Est-ce le fait que tu es dans un lieu ne disposant pas du  wifi ni d'un câble RJ45?
   Est-ce le fait que ton micro ne sait pas se connecter au réseau?


Des pistes à oublier
1)Le  contenu du fichier FSTAB. S'il est très mauvais c'est un plantage du grub.  S'il n'est pas très bon, c'est un ralentissement du boot de quelques minutes. (90 secondes par ligne fausse)
2) Boot-repair
  Dès l'instant ou àç l'écran tu a quelques ligne te proposant un choix de boot cet outil est à boublier

Des pistes à savoir
J'ai vu un cas où l'écran restait noir pendant 40 minutes avant de s'afficher.
Alors combien de temps attend-tu avant de tout casser?
Boot-info (le petit copain de boot-repair) est à favoriser. Il donne plein de enseignements
Tu n'as qu'une ligne a poster mais il faut que le réseau fonctionne.


Quelques commandes
Si de nouveauu le boot se plante, faire les commande qu'il indique, Elles sont du style
      journalctl  -xb   => dans ce cas, il faut regarder tout ce qui est en rouge.....
                                      C'est dans une ligne rouge qu'on y trouver l'erreur
                                    Mais toutes les lignes rouges ne sont pas des erreurs
                                 le plus simple est de les noter pour un tri dans le forum
         fsck  /dev/sdX Cela lance la réparation de la partition X ou finit de la détruire..


En fait, je ne sais pas trop si tu as besoin du forum:
On te dit "La partition /boot n'est pas utile."
Ton action devrait être de ne pas en créer. Ta décision "Par contre j'ai fait une partition /boot séparée de 1Go environ."
Mais le problème n'est pas à ce niveau.

Dernière modification par Bougron (Le 17/12/2016, à 02:35)


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne

#24 Le 17/12/2016, à 17:08

teobzh

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour Bougron.

Je vais essayé de répondre au mieux à tes questions et ce que tu m'as dit. wink

Pour ta première question la commande ctrl+alt T ne me donne rien. Autant au démarrage que lorsque je suis arrivé sur l'écran en "root" (image de mon premier post)

Il me semble que  tu sais aller en "root"

Oui je sais allé en root. c'est d'ailleurs le seul mode qui me soit proposé après le démarrage.
Ou alors je doit repartir sur un live usb pour passer en console puis en root via le live usb.? C'est là que je comprend pas trop.
Soit je suis sur le live usb, soit sur mon écran de démarrage et directement en root.

Pour répondre à ta seconde question. Non je ne ping pas le 8.8.8.8
Ce qui répond donc aussi à la troisième question. smile
J'ai meme essayé de "pingué" ma box et un des autres postes de ma maison mais sans résultat.!

Pour la carte graphique
la commande :

lshw -enable pci -class display

me renvoie

1481980033.jpg

Pour ta 6ième question : c'est le micro qui ne sait plus se connecter il est connecté en filaire sur un cpl. Je précise que tout fonctionne car un second poste à été connecté, ainsi que celui en question avant le "plantage".

Retour des commandes :

 journalctl  -xb
systemctl : option invalide -- 'x'
fsck /dev/sda
fsck de util-linux 2.27.1
e2fsck 1.42.13 (17-MAY-2015)
/dev/sda est en cours d'utilisation.
e2fsck: Ne peut continuer, arrêt immédiat.

Pour finir, loin de moi l'envie de ne pas "écouter ou lire".

En fait, je ne sais pas trop si tu as besoin du forum:
On te dit "La partition /boot n'est pas utile."
Ton action devrait être de ne pas en créer. Ta décision "Par contre j'ai fait une partition /boot séparée de 1Go environ."

Mais tout simplement quand j'ai posé ma question je n'avais pas eu de réponse. Donc ne sachant pas, j'ai fait un "choix".
Peut etre que c'était une erreur. Mais ca ne doit pas avoir grande incidence sur mon soucis.

Voilà pour ces infos, j'espère qu'elles seront suffisantes.

Merci pour vos retour et votre aide

Hors ligne

#25 Le 17/12/2016, à 18:11

Bougron

Re : Systemctl après changement HDD Xubuntu [Resolu]

Bonjour Teobzh
Merci pour tes retours.
Il me reste  pas mal de choses a comprendre.
J'ai bien noté que tu fais une installation Xbuntu que je ne pratique pas, mais je pense que la base est identique à Ubuntu

Je suis donc surpris que la commande Ctrl Alt T ne fonctionne pas....  Mais comme je vois que tu as écrit
ctrl+alt T   => Je vais donc te proposer   ctrl+alt+t
Il faut une combinaison des trois touches. Donc une seule frappe.

Je suis aussi surpris de la commande  journalctl   -xb te retourne une erreur.
Pour cette commande lshw -enable pci -class display   Il va falloir que j'agrandisse  pour lire

Tu confirmes le problème que ce logiciel ne sait pas se connecter a internet
Mais,   lorsque tu es en mode root, il y a beaucoup d'actionsà faire
dont l'une indique qu'il faut activer le réseau. Y as-tu pensé. Moi-même j'ai oublié de le repréciser.

Pour la commande, fsck, c'est normal. Elle est à faire uniquement lors des boots qui se plantent et qui indiquent qu'il faut la faire. Donc c'est normal que tu aies eu ce message d'erreur

je te propose de regarder l'échange 1 de ma discussion qui me semble proche de ton problème.
https://forum.ubuntu-fr.org/viewtopic.php?id=1994634
et de voir ce que tu peux en tirer

Dernière modification par Bougron (Le 17/12/2016, à 18:12)


Ubuntu  BASH 16.04.1 sous windows 10        et ubuntu-17.04-beta2 avec le noyau 4.10.0-13
Lubuntu 14.04.4 en 32 bits pour un vaio pcg-k215s
Ubuntu 16.04.2 avec le noyau 4.4.0-71 et  avec le noyau 4.8.0.36
Un site que les débutants en ubuntu doivent consulter  http://ubuntu.i17.fr/

Hors ligne