Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 04/01/2017, à 09:12

Usharn

pb installation HORUS 3d

Bonjour,

j'aimerais installer un logiciel 3d horus sous ubuntu.

(https://github.com/bqlabs/horus/blob/ma … /ubuntu.md)

quand je tape la troisieme ligne de commande dans un terminal j'obtiens ce message d'erreur

usharn@usharn-Toshiba:~$ sudo add-apt-repository ppa:bqopensource/opencv
[sudo] Mot de passe de usharn : 
 
 Plus d’info : https://launchpad.net/~bqopensource/+archive/ubuntu/opencv
Appuyez sur [ENTRÉE] pour continuer ou Ctrl-C pour annuler l’ajout

gpg: le porte-clefs « /tmp/tmpu83gnv5r/secring.gpg » a été créé
gpg: le porte-clefs « /tmp/tmpu83gnv5r/pubring.gpg » a été créé
gpg: demande de la clef C14D7E80 sur le serveur hkp keyserver.ubuntu.com
gpg: /tmp/tmpu83gnv5r/trustdb.gpg : base de confiance créée
gpg: clef C14D7E80 : clef publique « Launchpad PPA for Opensource bq » importée
gpg: Quantité totale traitée : 1
gpg:               importées : 1  (RSA: 1)
OK
usharn@usharn-Toshiba:~$ sudo add-apt-repository ppa:bqopensource/horus
 
 Plus d’info : https://launchpad.net/~bqopensource/+archive/ubuntu/horus
Appuyez sur [ENTRÉE] pour continuer ou Ctrl-C pour annuler l’ajout

gpg: le porte-clefs « /tmp/tmp7fi7vjne/secring.gpg » a été créé
gpg: le porte-clefs « /tmp/tmp7fi7vjne/pubring.gpg » a été créé
gpg: demande de la clef C14D7E80 sur le serveur hkp keyserver.ubuntu.com
gpg: /tmp/tmp7fi7vjne/trustdb.gpg : base de confiance créée
gpg: clef C14D7E80 : clef publique « Launchpad PPA for Opensource bq » importée
gpg: Quantité totale traitée : 1
gpg:               importées : 1  (RSA: 1)
OK
usharn@usharn-Toshiba:~$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Ign:2 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial InRelease      
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Ign:4 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial InRelease
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-security InRelease
Atteint:6 http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial InRelease  
Atteint:7 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:8 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial InRelease
Ign:9 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial Release
Ign:10 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial Release
Ign:11 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 Packages
Ign:12 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main i386 Packages
Ign:13 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr_FR
Ign:15 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr
Ign:16 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-en
Ign:17 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:18 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main DEP-11 64x64 Icons
Ign:19 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 Packages
Ign:20 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main i386 Packages
Ign:21 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main all Packages
Ign:22 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr_FR
Ign:23 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr
Ign:24 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-en
Ign:25 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:26 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 Packages
Ign:12 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main i386 Packages
Ign:13 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr_FR
Ign:15 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr
Ign:16 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-en
Ign:17 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:18 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main DEP-11 64x64 Icons
Ign:19 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 Packages
Ign:20 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main i386 Packages
Ign:21 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main all Packages
Ign:22 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr_FR
Ign:23 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr
Ign:24 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-en
Ign:25 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:26 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 Packages
Ign:12 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main i386 Packages
Ign:13 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr_FR
Ign:15 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr
Ign:16 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-en
Ign:17 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:18 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main DEP-11 64x64 Icons
Ign:19 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 Packages
Ign:20 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main i386 Packages
Ign:21 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main all Packages
Ign:22 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr_FR
Ign:23 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr
Ign:24 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-en
Ign:25 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:26 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 Packages
Ign:12 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main i386 Packages
Ign:13 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr_FR
Ign:15 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr
Ign:16 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-en
Ign:17 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:18 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main DEP-11 64x64 Icons
Ign:19 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 Packages
Ign:20 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main i386 Packages
Ign:21 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main all Packages
Ign:22 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr_FR
Ign:23 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr
Ign:24 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-en
Ign:25 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:26 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main DEP-11 64x64 Icons
Ign:11 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 Packages
Ign:12 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main i386 Packages
Ign:13 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr_FR
Ign:15 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr
Ign:16 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-en
Ign:17 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:18 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main DEP-11 64x64 Icons
Ign:19 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 Packages
Ign:20 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main i386 Packages
Ign:21 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main all Packages
Ign:22 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr_FR
Ign:23 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr
Ign:24 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-en
Ign:25 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:26 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main DEP-11 64x64 Icons
Err:11 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 Packages
  404  Not Found
Ign:12 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main i386 Packages
Ign:13 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr_FR
Ign:15 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-fr
Ign:16 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main Translation-en
Ign:17 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:18 http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial/main DEP-11 64x64 Icons
Err:19 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 Packages
  404  Not Found
Ign:20 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main i386 Packages
Ign:21 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main all Packages
Ign:22 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr_FR
Ign:23 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-fr
Ign:24 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main Translation-en
Ign:25 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:26 http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial/main DEP-11 64x64 Icons
Lecture des listes de paquets... Fait
W: The repository 'http://ppa.launchpad.net/bqopensource/horus/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ppa.launchpad.net/bqopensource/opencv/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Impossible de récupérer http://ppa.launchpad.net/bqopensource/horus/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Impossible de récupérer http://ppa.launchpad.net/bqopensource/opencv/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
usharn@usharn-Toshiba:~$ 

Qu'est ce que cela signifie  et que dois-je faire pour y remédier ?

Merci pour votre aide

Hors ligne

#2 Le 04/01/2017, à 13:02

inbox

Re : pb installation HORUS 3d

Salut,

Les erreurs que tu rencontres, sont dues au fait qu'il n'y a pas de version de paquets disponibles pour Xenial, dans les dépôts que tu as ajoutés.

Dans un 1er temps, il te faut les supprimer proprement.

Ensuite, en te référant à cette page ajouter le PPA horus/dev qui contient une version de paquet pour Xenial.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#3 Le 04/01/2017, à 20:42

Usharn

Re : pb installation HORUS 3d

salut,

et une fois que j'ai fait cette manip :

sudo add-apt-repository ppa:bqlabs/horus-dev
sudo apt-get update

je dois bien faire cette manip pour installer le fichier Horus :

sudo apt-get install horus

?

Hors ligne

#4 Le 05/01/2017, à 11:17

inbox

Re : pb installation HORUS 3d

Oui, c'est bien ce qu'il faut faire.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#5 Le 05/01/2017, à 21:41

Usharn

Re : pb installation HORUS 3d

pourtant quand je tape cette ligne de commande voici ce que j'obtiens comme info :

usharn@usharn-Toshiba:~$ sudo apt-get install horus
[sudo] Mot de passe de usharn : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 horus : Dépend: python-opencv mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
usharn@usharn-Toshiba:~$ 

que dois-je faire ?
Merci

Hors ligne

#6 Le 06/01/2017, à 11:31

inbox

Re : pb installation HORUS 3d

Que donne cette commande ?

apt-cache show python-opencv

Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#7 Le 06/01/2017, à 23:02

Usharn

Re : pb installation HORUS 3d

Voila

usharn@usharn-Toshiba:~$ apt-cache show python-opencv
Package: python-opencv
Source: opencv
Priority: optional
Section: python
Installed-Size: 1358
Maintainer: Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Architecture: amd64
Version: 2.4.9.1.3-xenial3
Replaces: python2.3-opencv (<= 0.9.7-3)
Provides: python2.7-opencv
Depends: python (<< 2.8), python (>= 2.7~), python:any (>= 2.7.5-5~), libc6 (>= 2.14), libgcc1 (>= 1:3.0), libopencv-calib3d2.4, libopencv-contrib2.4, libopencv-core2.4, libopencv-features2d2.4, libopencv-flann2.4, libopencv-highgui2.4, libopencv-imgproc2.4, libopencv-legacy2.4, libopencv-ml2.4, libopencv-objdetect2.4, libopencv-photo2.4, libopencv-stitching2.4, libopencv-video2.4, libpython2.7 (>= 2.7), libstdc++6 (>= 5.2), python-numpy-abi9, python-numpy (>= 1:1.6.1)
Conflicts: python2.3-opencv (<= 0.9.7-3)
Filename: pool/main/o/opencv/python-opencv_2.4.9.1.3-xenial3_amd64.deb
Size: 321194
MD5sum: 5e741a1754c285f932b04940b777029d
SHA1: c236b41d489ca189c8d1294877379d0bc818202b
SHA256: bc1565a0088de28c5159afffdada3b6bcb3947ef06441ccc4b000b882a791d80
Description-en: Python bindings for the computer vision library
 This package contains Python bindings for the OpenCV (Open Computer Vision)
 library.
 .
 The Open Computer Vision Library is a collection of algorithms and sample
 code for various computer vision problems. The library is compatible with
 IPL (Intel's Image Processing Library) and, if available, can use IPP
 (Intel's Integrated Performance Primitives) for better performance.
 .
 OpenCV provides low level portable data types and operators, and a set
 of high level functionalities for video acquisition, image processing and
 analysis, structural analysis, motion analysis and object tracking, object
 recognition, camera calibration and 3D reconstruction.
Description-md5: 882b87b0cdc3c3b619bfd32c682a4b0e

Package: python-opencv
Priority: optional
Section: universe/python
Installed-Size: 1350
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Original-Maintainer: Debian Science Team <debian-science-maintainers@lists.alioth.debian.org>
Architecture: amd64
Source: opencv
Version: 2.4.9.1+dfsg-1.5ubuntu1
Replaces: python2.3-opencv (<= 0.9.7-3)
Provides: python2.7-opencv
Depends: python (<< 2.8), python (>= 2.7~), python:any (>= 2.7.5-5~), libc6 (>= 2.14), libgcc1 (>= 1:3.0), libopencv-calib3d2.4v5, libopencv-contrib2.4v5, libopencv-core2.4v5, libopencv-features2d2.4v5, libopencv-flann2.4v5, libopencv-highgui2.4v5, libopencv-imgproc2.4v5, libopencv-legacy2.4v5, libopencv-ml2.4v5, libopencv-objdetect2.4v5, libopencv-photo2.4v5, libopencv-video2.4v5, libpython2.7 (>= 2.7), libstdc++6 (>= 5.2), python-numpy-abi9, python-numpy (>= 1:1.6.1)
Conflicts: python2.3-opencv (<= 0.9.7-3)
Filename: pool/universe/o/opencv/python-opencv_2.4.9.1+dfsg-1.5ubuntu1_amd64.deb
Size: 310416
MD5sum: b799c5a13be2258c4f18c2ebf9cb40fa
SHA1: edb29080fd154d9120cb6d7753503a6d403219bc
SHA256: 765e50f3d45e4e1546bcad8e8b5e92de9d8021a9beca8b8ee2fd89ef60693bcb
Description-en: Python bindings for the computer vision library
 This package contains Python bindings for the OpenCV (Open Computer Vision)
 library.
 .
 The Open Computer Vision Library is a collection of algorithms and sample
 code for various computer vision problems. The library is compatible with
 IPL (Intel's Image Processing Library) and, if available, can use IPP
 (Intel's Integrated Performance Primitives) for better performance.
 .
 OpenCV provides low level portable data types and operators, and a set
 of high level functionalities for video acquisition, image processing and
 analysis, structural analysis, motion analysis and object tracking, object
 recognition, camera calibration and 3D reconstruction.
Description-md5: 882b87b0cdc3c3b619bfd32c682a4b0e
Homepage: http://opencv.org/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

usharn@usharn-Toshiba:~$ 

Hors ligne

#8 Le 07/01/2017, à 16:14

inbox

Re : pb installation HORUS 3d

Il me faudrait aussi :

apt-cache show horus

Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#9 Le 08/01/2017, à 20:21

Usharn

Re : pb installation HORUS 3d

Voici la reponse obtenue

usharn@usharn-Toshiba:~$ apt-cache show horus
Package: horus
Priority: optional
Section: misc
Installed-Size: 3063
Maintainer: Jesús Arroyo Torrens <jesus.arroyo@bq.com>
Architecture: amd64
Version: 0.2rc1.2-xenial1
Depends: python (>= 2.7), python (<< 2.8), python-serial, python-wxgtk2.8 | python-wxgtk3.0, python-opengl, python-pyglet, python-numpy, python-scipy, python-matplotlib, python-opencv, avrdude, libftdi1, v4l-utils
Filename: pool/main/h/horus/horus_0.2rc1.2-xenial1_amd64.deb
Size: 773742
MD5sum: 8d6232db889881fdce350ced5fd45810
SHA1: 18bc1fcf3ce2b81a3d02b43a47362fa933d1e89e
SHA256: 861e682e3a77bf95e4c85fbf7ecd7ac4864fcd381ff7019c85e03b24e1d788d5
Description-en: Horus is a full software solution for 3D scanning
Description-md5: a2f000accd4ad78873d56344023dd200

usharn@usharn-Toshiba:~$ 

Merci

Dernière modification par Usharn (Le 08/01/2017, à 20:22)

Hors ligne

#10 Le 09/01/2017, à 11:28

inbox

Re : pb installation HORUS 3d

Je voudrais voir à quo ressemble ton fichier sources.list. Donne le résultat de ces commandes.

cat /etc/apt/sources.list
find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#11 Le 10/01/2017, à 04:51

Usharn

Re : pb installation HORUS 3d

Pour cat /etc/apt/sources.list :

usharn@usharn-Toshiba:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse restricted main universe
usharn@usharn-Toshiba:~$ 

Et pour find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \; 

usharn@usharn-Toshiba:~$ find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list.d/bqopensource-ubuntu-opencv-xenial.list.save


/etc/apt/sources.list.d/bqlabs-ubuntu-horus-dev-xenial.list

     1	deb http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial main
     2	deb-src http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial main

/etc/apt/sources.list.d/phablet-team-ubuntu-tools-xenial.list

     1	deb http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial main
     2	deb-src http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial main

/etc/apt/sources.list.d/phablet-team-ubuntu-tools-xenial.list.save

     1	deb http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial main
     2	deb-src http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial main

/etc/apt/sources.list.d/bqopensource-ubuntu-opencv-xenial.list


/etc/apt/sources.list.d/bqlabs-ubuntu-horus-dev-xenial.list.save

     1	deb http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial main
     2	# deb-src http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial main

/etc/apt/sources.list.d/ubuntu-sdk-team-ubuntu-ppa-xenial.list

     1	deb http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial main
     2	deb-src http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial main

/etc/apt/sources.list.d/ubuntu-sdk-team-ubuntu-ppa-xenial.list.save

     1	deb http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial main
     2	deb-src http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial main

/etc/apt/sources.list.d/bqopensource-ubuntu-horus-xenial.list.save


/etc/apt/sources.list.d/bqopensource-ubuntu-horus-xenial.list


/etc/apt/sources.list.save

     1	# deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1)]/ xenial main restricted
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
     6	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    11	
    12	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    13	## team, and may not be under a free licence. Please satisfy yourself as to
    14	## your rights to use the software. Also, please note that software in
    15	## universe WILL NOT receive any review or updates from the Ubuntu security
    16	## team.
    17	deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    18	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    19	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    27	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    28	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    29	
    30	## N.B. software from this repository may not have been tested as
    31	## extensively as that contained in the main release, although it includes
    32	## newer versions of some applications which may provide useful features.
    33	## Also, please note that software in backports WILL NOT receive any review
    34	## or updates from the Ubuntu security team.
    35	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    36	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    37	
    38	## Uncomment the following two lines to add software from Canonical's
    39	## 'partner' repository.
    40	## This software is not part of Ubuntu, but is offered by Canonical and the
    41	## respective vendors as a service to Ubuntu users.
    42	deb http://archive.canonical.com/ubuntu xenial partner
    43	deb-src http://archive.canonical.com/ubuntu xenial partner
    44	
    45	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security main restricted
    46	# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
    47	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security universe
    48	# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
    49	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security multiverse
    50	# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
    51	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse restricted main universe

/etc/apt/sources.list

     1	# deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1)]/ xenial main restricted
     2	
     3	# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     4	# newer versions of the distribution.
     5	deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
     6	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
     7	
     8	## Major bug fix updates produced after the final release of the
     9	## distribution.
    10	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
    11	
    12	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    13	## team, and may not be under a free licence. Please satisfy yourself as to
    14	## your rights to use the software. Also, please note that software in
    15	## universe WILL NOT receive any review or updates from the Ubuntu security
    16	## team.
    17	deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    18	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
    19	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
    20	
    21	## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    22	## team, and may not be under a free licence. Please satisfy yourself as to 
    23	## your rights to use the software. Also, please note that software in 
    24	## multiverse WILL NOT receive any review or updates from the Ubuntu
    25	## security team.
    26	deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    27	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
    28	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
    29	
    30	## N.B. software from this repository may not have been tested as
    31	## extensively as that contained in the main release, although it includes
    32	## newer versions of some applications which may provide useful features.
    33	## Also, please note that software in backports WILL NOT receive any review
    34	## or updates from the Ubuntu security team.
    35	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    36	# deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
    37	
    38	## Uncomment the following two lines to add software from Canonical's
    39	## 'partner' repository.
    40	## This software is not part of Ubuntu, but is offered by Canonical and the
    41	## respective vendors as a service to Ubuntu users.
    42	deb http://archive.canonical.com/ubuntu xenial partner
    43	deb-src http://archive.canonical.com/ubuntu xenial partner
    44	
    45	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security main restricted
    46	# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
    47	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security universe
    48	# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
    49	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security multiverse
    50	# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
    51	deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse restricted main universe
usharn@usharn-Toshiba:~$ 

Hors ligne

#12 Le 10/01/2017, à 11:00

inbox

Re : pb installation HORUS 3d

Essaye ce qui suit :

sudo apt-get clean
sudo apt-get update
sudo apt-get install python-opencv
sudo apt-get install horus

et donne les retours.

[Edit] J'ai testé l'installation de horus et le système m'a proposé d'installer ce qui suit :

Les NOUVEAUX paquets suivants vont être installés :     
  avrdude{a} blt{a} fonts-lyx{a} freeglut3{a} horus i965-va-driver{a} javascript-common{a} libaacs0{a} libavcodec-ffmpeg56{a} libavformat-ffmpeg56{a} libavutil-ffmpeg54{a} libbdplus0{a} libblas-common{a} 
  libblas3{a} libbluray1{a} libcrystalhd3{a} libdc1394-22{a} libexpat1-dev{a} libftdi1{a} libgfortran3{a} libglade2-0{a} libgme0{a} libgsm1{a} libgtkglext1{a} libjs-jquery{a} libjs-jquery-ui{a} liblapack3{a} 
  libmodplug1{a} libmp3lame0{a} libopencv-calib3d2.4{a} libopencv-contrib2.4{a} libopencv-core2.4{a} libopencv-features2d2.4{a} libopencv-flann2.4{a} libopencv-gpu2.4{a} libopencv-highgui2.4{a} 
  libopencv-imgproc2.4{a} libopencv-legacy2.4{a} libopencv-ml2.4{a} libopencv-objdetect2.4{a} libopencv-ocl2.4{a} libopencv-photo2.4{a} libopencv-stitching2.4{a} libopencv-video2.4{a} libopenjpeg5{a} 
  libpangox-1.0-0{a} libpython-dev{a} libpython2.7-dev{a} libschroedinger-1.0-0{a} libshine3{a} libsnappy1v5{a} libsoxr0{a} libssh-gcrypt-4{a} libswresample-ffmpeg1{a} libswscale-ffmpeg3{a} libtbb2{a} 
  libtwolame0{a} libv4l2rds0{a} libva1{a} libvdpau1{a} libwxbase3.0-0v5{a} libwxgtk3.0-0v5{a} libx264-148{a} libx265-79{a} libxvidcore4{a} libzvbi-common{a} libzvbi0{a} mesa-vdpau-drivers{a} python-cycler{a} 
  python-dateutil{a} python-decorator{a} python-dev{a} python-glade2{a} python-imaging{a} python-matplotlib{a} python-matplotlib-data{a} python-numpy{a} python-opencv{a} python-opengl{a} python-pil{a} 
  python-pyglet{a} python-pyparsing{a} python-scipy{a} python-serial{a} python-six{a} python-tk{a} python-tz{a} python-wxgtk3.0{a} python-wxversion{a} python2.7-dev{a} tk8.6-blt2.5{a} ttf-bitstream-vera{a} 
  v4l-utils{a} va-driver-all{a} vdpau-driver-all{a} vdpau-va-driver{a} 
0 paquets mis à jour, 96 nouvellement installés, 0 à enlever et 0 non mis à jour.

Dernière modification par inbox (Le 10/01/2017, à 11:17)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#13 Le 10/01/2017, à 15:51

Usharn

Re : pb installation HORUS 3d

voici ce que j'ai comme reponse :

usharn@usharn-Toshiba:~$ sudo apt-get clean
[sudo] Mot de passe de usharn : 
usharn@usharn-Toshiba:~$ sudo apt-get clean
usharn@usharn-Toshiba:~$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://archive.canonical.com/ubuntu xenial InRelease                 
Atteint:3 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial InRelease    
Réception de:4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Atteint:5 http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial InRelease  
Atteint:6 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial InRelease 
Réception de:7 http://fr.archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Réception de:9 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [208 B]
Réception de:10 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [212 B]
Réception de:11 http://fr.archive.ubuntu.com/ubuntu xenial-backports/multiverse amd64 DEP-11 Metadata [212 B]
Réception de:12 http://fr.archive.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [68,1 kB]
Réception de:13 http://fr.archive.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [43,1 kB]
Réception de:14 http://fr.archive.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [19,4 kB]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [25,6 kB]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [212 B]
Réception de:17 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [2 516 B]
Réception de:18 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [445 kB]
Réception de:19 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [438 kB]
Réception de:20 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [302 kB]
Réception de:21 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [169 kB]
Réception de:22 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [121 kB]
Réception de:23 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [145 kB]
2 086 ko réceptionnés en 2s (936 ko/s)                              
AppStream cache update completed, but some metadata was ignored due to errors.
Lecture des listes de paquets... Fait
usharn@usharn-Toshiba:~$ sudo apt-get install python-opencv
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 python-opencv : Dépend: libopencv-calib3d2.4 mais ne sera pas installé
                 Dépend: libopencv-contrib2.4 mais ne sera pas installé
                 Dépend: libopencv-core2.4 mais ne sera pas installé
                 Dépend: libopencv-features2d2.4 mais ne sera pas installé
                 Dépend: libopencv-flann2.4 mais ne sera pas installé
                 Dépend: libopencv-highgui2.4 mais ne sera pas installé
                 Dépend: libopencv-imgproc2.4 mais ne sera pas installé
                 Dépend: libopencv-legacy2.4 mais ne sera pas installé
                 Dépend: libopencv-ml2.4 mais ne sera pas installé
                 Dépend: libopencv-objdetect2.4 mais ne sera pas installé
                 Dépend: libopencv-photo2.4 mais ne sera pas installé
                 Dépend: libopencv-stitching2.4 mais ne sera pas installé
                 Dépend: libopencv-video2.4 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
usharn@usharn-Toshiba:~$ sudo apt-get install horus
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 horus : Dépend: python-opencv mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
usharn@usharn-Toshiba:~$ 

je n'ai pas les memes reponses que toi , que dois je faire ?

Hors ligne

#14 Le 10/01/2017, à 16:02

inbox

Re : pb installation HORUS 3d

Tu vas remplacer le contenu de ton sources.list par celui que j'indique avec :

gksudo gedit /etc/apt/sources.list

Si gksudo n'est installé, faire ce qui suit :

sudo apt-get install gksu

Nouveau sources.list :

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

Ceci fait, réessaye les commandes précédentes, soit :

sudo apt-get clean

sudo apt-get update

sudo apt-get install python-opencv

et donne les retours.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#15 Le 10/01/2017, à 19:53

Usharn

Re : pb installation HORUS 3d

les retours sont les suivants

usharn@usharn-Toshiba:~$ gksudo gedit /etc/apt/sources.list
Le programme « gksudo » n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt install gksu
usharn@usharn-Toshiba:~$ sudo apt-get install gksu
[sudo] Mot de passe de usharn : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
The following additional packages will be installed:
  libgksu2-0
Les NOUVEAUX paquets suivants seront installés :
  gksu libgksu2-0
0 mis à jour, 2 nouvellement installés, 0 à enlever et 2 non mis à jour.
Il est nécessaire de prendre 123 ko dans les archives.
Après cette opération, 877 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 libgksu2-0 amd64 2.0.13~pre1-6ubuntu8 [71,8 kB]
Réception de:2 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 gksu amd64 2.0.2-9ubuntu1 [51,5 kB]
123 ko réceptionnés en 0s (379 ko/s)
Sélection du paquet libgksu2-0 précédemment désélectionné.
(Lecture de la base de données... 267653 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libgksu2-0_2.0.13~pre1-6ubuntu8_amd64.deb ...
Dépaquetage de libgksu2-0 (2.0.13~pre1-6ubuntu8) ...
Sélection du paquet gksu précédemment désélectionné.
Préparation du dépaquetage de .../gksu_2.0.2-9ubuntu1_amd64.deb ...
Dépaquetage de gksu (2.0.2-9ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
Traitement des actions différées (« triggers ») pour gconf2 (3.2.6-3ubuntu6) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-6ubuntu3.1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.22-1ubuntu5) ...
Traitement des actions différées (« triggers ») pour mime-support (3.59ubuntu1) ...
Paramétrage de libgksu2-0 (2.0.13~pre1-6ubuntu8) ...
update-alternatives: utilisation de « /usr/share/libgksu/debian/gconf-defaults.libgksu-sudo » pour fournir « /usr/share/gconf/defaults/10_libgksu » (libgksu-gconf-defaults) en mode automatique
Traitement des actions différées (« triggers ») pour gconf2 (3.2.6-3ubuntu6) ...
Paramétrage de gksu (2.0.2-9ubuntu1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
usharn@usharn-Toshiba:~$ gksudo gedit /etc/apt/sources.list

(gksudo:3541): GConf-CRITICAL **: gconf_value_free: assertion 'value != NULL' failed

** (gedit:3562): WARNING **: Set document metadata failed: La définition de l'attribut metadata::gedit-spell-enabled n'est pas prise en charge

** (gedit:3562): WARNING **: Set document metadata failed: La définition de l'attribut metadata::gedit-encoding n'est pas prise en charge

** (gedit:3562): WARNING **: Set document metadata failed: La définition de l'attribut metadata::gedit-position n'est pas prise en charge
usharn@usharn-Toshiba:~$ sudo apt-get clean
usharn@usharn-Toshiba:~$ 
usharn@usharn-Toshiba:~$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial InRelease    
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:4 http://ppa.launchpad.net/phablet-team/tools/ubuntu xenial InRelease  
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Atteint:6 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu xenial InRelease 
Réception de:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Réception de:8 http://fr.archive.ubuntu.com/ubuntu xenial/main Sources [868 kB]
Réception de:9 http://security.ubuntu.com/ubuntu xenial-security/main Sources [54,1 kB]
Réception de:10 http://security.ubuntu.com/ubuntu xenial-security/restricted Sources [1 804 B]
Réception de:11 http://security.ubuntu.com/ubuntu xenial-security/universe Sources [15,7 kB]
Réception de:12 http://security.ubuntu.com/ubuntu xenial-security/multiverse Sources [724 B]
Réception de:13 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [200 kB]
Réception de:14 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [194 kB]
Réception de:15 http://fr.archive.ubuntu.com/ubuntu xenial/restricted Sources [4 808 B]
Réception de:16 http://fr.archive.ubuntu.com/ubuntu xenial/universe Sources [7 728 kB]
Réception de:17 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [83,9 kB]
Réception de:18 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [68,1 kB]
Réception de:19 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [47,6 kB]
Réception de:20 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [6 576 B]
Réception de:21 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [6 528 B]
Réception de:22 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en [2 016 B]
Réception de:23 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 DEP-11 Metadata [200 B]
Réception de:24 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [66,6 kB]
Réception de:25 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [64,3 kB]
Réception de:26 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [36,8 kB]
Réception de:27 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [19,4 kB]
Réception de:28 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [25,6 kB]
Réception de:29 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [2 760 B]
Réception de:30 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [2 928 B]
Réception de:31 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [1 124 B]
Réception de:32 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [212 B]
Réception de:33 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons [29 B]
Réception de:34 http://archive.canonical.com/ubuntu xenial InRelease [11,5 kB] 
Réception de:35 http://archive.canonical.com/ubuntu xenial/partner amd64 Packages [2 628 B]
Réception de:36 http://archive.canonical.com/ubuntu xenial/partner i386 Packages [2 924 B]
Réception de:37 http://fr.archive.ubuntu.com/ubuntu xenial/multiverse Sources [179 kB]
Réception de:38 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main Sources [213 kB]
Réception de:39 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted Sources [1 804 B]
Réception de:40 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe Sources [116 kB]
Réception de:41 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse Sources [4 016 B]
Réception de:42 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main Sources [3 244 B]
Réception de:43 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe Sources [1 868 B]
10,1 Mo réceptionnés en 8s (1 207 ko/s)                                        
AppStream cache update completed, but some metadata was ignored due to errors.
Lecture des listes de paquets... Fait
usharn@usharn-Toshiba:~$ 
usharn@usharn-Toshiba:~$ sudo apt-get install python-opencv
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 python-opencv : Dépend: libopencv-calib3d2.4 mais ne sera pas installé
                 Dépend: libopencv-contrib2.4 mais ne sera pas installé
                 Dépend: libopencv-core2.4 mais ne sera pas installé
                 Dépend: libopencv-features2d2.4 mais ne sera pas installé
                 Dépend: libopencv-flann2.4 mais ne sera pas installé
                 Dépend: libopencv-highgui2.4 mais ne sera pas installé
                 Dépend: libopencv-imgproc2.4 mais ne sera pas installé
                 Dépend: libopencv-legacy2.4 mais ne sera pas installé
                 Dépend: libopencv-ml2.4 mais ne sera pas installé
                 Dépend: libopencv-objdetect2.4 mais ne sera pas installé
                 Dépend: libopencv-photo2.4 mais ne sera pas installé
                 Dépend: libopencv-stitching2.4 mais ne sera pas installé
                 Dépend: libopencv-video2.4 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
usharn@usharn-Toshiba:~$ 

Hors ligne

#16 Le 10/01/2017, à 20:02

Usharn

Re : pb installation HORUS 3d

pour le Nouveau sources.list , il fallait bien remplacé l'ancienne list par la nouvelle et l'enregistrer ?

Merci

Hors ligne

#17 Le 11/01/2017, à 10:21

inbox

Re : pb installation HORUS 3d

Oui c'est bien ce qu'il fallait faire.

Je pense que ton problème vient des différents PPA ajoutés qui provoquent un conflit dans la gestion des paquets.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#18 Le 11/01/2017, à 19:30

Usharn

Re : pb installation HORUS 3d

et selon toi quels sont les PPA a retirer ?

Hors ligne

#19 Le 11/01/2017, à 19:39

inbox

Re : pb installation HORUS 3d

C'est bien la le problème, je n'en sais rien.

Si tu veux chercher, il faut te rendre sur les sites des PPA ajoutés pour rechercher si l'un d'eux contient l'un des paquets problématiques. La liste est celle-ci :

Dépend: libopencv-calib3d2.4 mais ne sera pas installé
                 Dépend: libopencv-contrib2.4 mais ne sera pas installé
                 Dépend: libopencv-core2.4 mais ne sera pas installé
                 Dépend: libopencv-features2d2.4 mais ne sera pas installé
                 Dépend: libopencv-flann2.4 mais ne sera pas installé
                 Dépend: libopencv-highgui2.4 mais ne sera pas installé
                 Dépend: libopencv-imgproc2.4 mais ne sera pas installé
                 Dépend: libopencv-legacy2.4 mais ne sera pas installé
                 Dépend: libopencv-ml2.4 mais ne sera pas installé
                 Dépend: libopencv-objdetect2.4 mais ne sera pas installé
                 Dépend: libopencv-photo2.4 mais ne sera pas installé
                 Dépend: libopencv-stitching2.4 mais ne sera pas installé
                 Dépend: libopencv-video2.4 mais ne sera pas installé

En gros un site qui contient des librairies libopencv est à supprimer.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#20 Le 11/01/2017, à 21:11

Usharn

Re : pb installation HORUS 3d

Cela me derange pas dans la mesure ou si tu me me dire

comment aller dans la liste des ppa ajoutées,
et comment rechercher si l'un d'eux contient l'un des paquets problématiques et les supprimer .

Peux tu me guider et m'aider dans cette démarche ?

Merci

Hors ligne

#21 Le 12/01/2017, à 11:46

inbox

Re : pb installation HORUS 3d

Pour être certain de ce que je dis, j'ai ajouté le dépôt horus-dev sur une Xenial. J'ai lancé l'installation de Horus qui s'est terminée sans problème. De même l'application démarre normalement.

Donc ce que j'avançais à propos des PPA n'est pas confirmé, ni infirmé.

Il faut donc que tu supprimes l'ensemble des PPA que tu as ajouté. Ensuite tu pourras rajouter le PPA de horus-dev avant de tenter d'installer horus. Pour supprimer rapidement tout tes PPA lance cette commande :

sudo rm -R /etc/apt/sources.list.d/*

Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#22 Le 12/01/2017, à 20:01

Usharn

Re : pb installation HORUS 3d

et ensuite je dois installer

Essaye ce qui suit :

sudo apt-get clean

sudo apt-get update

sudo apt-get install python-opencv

sudo apt-get install horus

  ?

Hors ligne

#23 Le 12/01/2017, à 20:02

Usharn

Re : pb installation HORUS 3d

Ou dois je faire qqc d'autre ?

Hors ligne

#24 Le 12/01/2017, à 20:12

inbox

Re : pb installation HORUS 3d

Avant de passer ces commandes, tu as bien ajouté le PPA horus-dev ? Si oui, tu peux y aller.


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#25 Le 12/01/2017, à 20:56

Usharn

Re : pb installation HORUS 3d

c'est toujours la meme chose :  Voici toutes les lignes de commandes que j'ai fait :

usharn@usharn-Toshiba:~$ sudo rm -R /etc/apt/sources.list.d/*
[sudo] Mot de passe de usharn : 
usharn@usharn-Toshiba:~$ sudo rm -R /etc/apt/sources.list.d/*
rm: impossible de supprimer '/etc/apt/sources.list.d/*': Aucun fichier ou dossier de ce type
usharn@usharn-Toshiba:~$ sudo add-apt-repository ppa:bqlabs/horus-dev
[sudo] Mot de passe de usharn : 
 
 Plus d’info : https://launchpad.net/~bqlabs/+archive/ubuntu/horus-dev
Appuyez sur [ENTRÉE] pour continuer ou Ctrl-C pour annuler l’ajout

gpg: le porte-clefs « /tmp/tmpeoe3yu6d/secring.gpg » a été créé
gpg: le porte-clefs « /tmp/tmpeoe3yu6d/pubring.gpg » a été créé
gpg: demande de la clef 545A3FCF sur le serveur hkp keyserver.ubuntu.com
gpg: /tmp/tmpeoe3yu6d/trustdb.gpg : base de confiance créée
gpg: clef 545A3FCF : clef publique « Launchpad PPA for Jesus » importée
gpg: Quantité totale traitée : 1
gpg:               importées : 1  (RSA: 1)
OK
usharn@usharn-Toshiba:~$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://security.ubuntu.com/ubuntu xenial-security InRelease          
Réception de:3 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial InRelease [18,1 kB]
Atteint:4 http://archive.canonical.com/ubuntu xenial InRelease                 
Atteint:5 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:6 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Réception de:7 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial/main amd64 Packages [7 864 B]
Réception de:8 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial/main i386 Packages [7 880 B]
Réception de:9 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial/main Translation-en [2 732 B]
36,5 ko réceptionnés en 1s (35,5 ko/s)    
Lecture des listes de paquets... Fait
usharn@usharn-Toshiba:~$ sudo apt-get clean
usharn@usharn-Toshiba:~$ sudo apt-get update
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://archive.canonical.com/ubuntu xenial InRelease                 
Atteint:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease         
Atteint:4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease       
Atteint:5 http://ppa.launchpad.net/bqlabs/horus-dev/ubuntu xenial InRelease    
Atteint:6 http://security.ubuntu.com/ubuntu xenial-security InRelease 
Lecture des listes de paquets... Fait                          
usharn@usharn-Toshiba:~$ sudo apt-get install python-opencv
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 python-opencv : Dépend: libopencv-calib3d2.4 mais ne sera pas installé
                 Dépend: libopencv-contrib2.4 mais ne sera pas installé
                 Dépend: libopencv-core2.4 mais ne sera pas installé
                 Dépend: libopencv-features2d2.4 mais ne sera pas installé
                 Dépend: libopencv-flann2.4 mais ne sera pas installé
                 Dépend: libopencv-highgui2.4 mais ne sera pas installé
                 Dépend: libopencv-imgproc2.4 mais ne sera pas installé
                 Dépend: libopencv-legacy2.4 mais ne sera pas installé
                 Dépend: libopencv-ml2.4 mais ne sera pas installé
                 Dépend: libopencv-objdetect2.4 mais ne sera pas installé
                 Dépend: libopencv-photo2.4 mais ne sera pas installé
                 Dépend: libopencv-stitching2.4 mais ne sera pas installé
                 Dépend: libopencv-video2.4 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
usharn@usharn-Toshiba:~$ sudo apt-get install horus
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 horus : Dépend: python-opencv mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
usharn@usharn-Toshiba:~$ 

Où est mon erreur ?

Hors ligne