Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 12/01/2017, à 09:26

Dylsous

Debian (8) - Connexion à un server Goanywhere avec openssh-client

Bonjour,

Voici mon problème, je souhaite me connecté à mon server GoAhnywhere avec openssh_client.
Après avoir fait la génération de la paire de clé plus la passphrase et la configuration du fichier "ssh_config", je souhaite donc me connecter à mon server avec cette commande "ssh a**@10.XX.XX.XX" mais voici le résultat:

Shell requeslt failed on channel 0

Voici les logs en entier pour y voir plus clair:

OpenSSH_6.7p1 Debian-5+deb8u3, OpenSSL 1.0.1t  3 May 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 10.XX.XX.XX [10.XX.XX.XX] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/identity type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/identity-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /root/.ssh/id_rsa-cert type -1
debug1: Remote protocol version 2.0, remote software version GoAnywhere5.3.6
debug1: no match: GoAnywhere5.3.6
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3
debug2: fd 3 setting O_NONBLOCK
debug3: load_hostkeys: loading entries for host "10.XX.XX.XX" from file "/root/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /root/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1,diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
debug2: kex_parse_kexinit: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1,hmac-md5-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1,hmac-md5-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group1-sha1,diffie-hellman-group14-sha1,diffie-hellman-group-exchange-sha1,diffie-hellman-group-exchange-sha256
debug2: kex_parse_kexinit: ssh-dss,ssh-rsa
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,aes192-cbc,aes256-cbc
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,aes192-cbc,aes256-cbc
debug2: kex_parse_kexinit: hmac-sha2-256,hmac-sha1,hmac-md5
debug2: kex_parse_kexinit: hmac-sha2-256,hmac-sha1,hmac-md5
debug2: kex_parse_kexinit: none,zlib
debug2: kex_parse_kexinit: none,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_setup: setup hmac-sha2-256
debug1: kex: server->client aes128-cbc hmac-sha2-256 none
debug2: mac_setup: setup hmac-sha2-256
debug1: kex: client->server aes128-cbc hmac-sha2-256 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<8192<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: bits set: 4016/8192
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA 20:dd:23:50:8d:69:23:9c:bd:2a:c3:18:91:fb:42:80
debug3: load_hostkeys: loading entries for host "10.53.8.80" from file "/root/.ssh/known_hosts"
debug3: load_hostkeys: found key type RSA in file /root/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys
debug1: Host '10.XX.XX.XX' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:1
debug2: bits set: 4138/8192
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: administrateur@Akoa (0x7f5e85584710),
debug2: key: /root/.ssh/identity ((nil)),
debug2: key: /root/.ssh/id_rsa ((nil)),
debug3: input_userauth_banner
Welcome! Please login.
debug1: Authentications that can continue: password,publickey,keyboard-interactive
debug3: start over, passed a different list password,publickey,keyboard-interactive
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: administrateur@Akoa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug2: input_userauth_pk_ok: fp e8:0f:21:e2:7c:43:36:f5:98:99:0e:7d:4e:44:38:78
debug3: sign_and_send_pubkey: RSA e8:0f:21:e2:7c:43:36:f5:98:99:0e:7d:4e:44:38:78
Authenticated with partial success.
debug2: key: administrateur@Akoa (0x7f5e85584e30),
debug2: key: /root/.ssh/identity ((nil)),
debug2: key: /root/.ssh/id_rsa ((nil)),
debug1: Authentications that can continue: password,keyboard-interactive
debug3: start over, passed a different list password,keyboard-interactive
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug2: input_userauth_info_req
password
Enter password for ako
debug2: input_userauth_info_req: num_prompts 1
Password:
debug3: Received SSH2_MSG_IGNORE
debug1: Authentication succeeded (keyboard-interactive).
Authenticated to 10.XX.XX.XX([10.53.8.80]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: fd 3 setting TCP_NODELAY
debug3: packet_set_tos: set IP_TOS 0x10
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug2: channel 0: request shell confirm 1
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug2: channel_input_status_confirm: type 99 id 0
debug2: PTY allocation request accepted on channel 0
debug2: channel_input_status_confirm: type 100 id 0
shell request failed on channel 0

Merci d'avance à vous

Dernière modification par Dylsous (Le 12/01/2017, à 09:28)

Hors ligne

#2 Le 12/01/2017, à 09:47

Killian.Fr

Re : Debian (8) - Connexion à un server Goanywhere avec openssh-client

Bonjour,

Tu peux te connecter comme ça ?

ssh user@host "/bin/bash -i"

Amateur Linux
Etudiant en administration système et réseau

Hors ligne

#3 Le 12/01/2017, à 10:38

bruno

Re : Debian (8) - Connexion à un server Goanywhere avec openssh-client

Bonjour,

Apparemment il y a plusieurs problèmes…
Est-ce que la connexion sans clé (par saisie du mot de passe) fonctionnait avant que tu n'essaies avec les clés ?
Donne-nous ton sshd_config sur le serveur et garde le ssh_config par défaut du client pour l'instant.

Hors ligne

#4 Le 12/01/2017, à 10:51

Killian.Fr

Re : Debian (8) - Connexion à un server Goanywhere avec openssh-client

Je ne pense pas que ça soit un soucis de clé, vu qu'il n'a pas l'air de raler à ce niveau là ( Je me trompe peut-être hein wink )


Amateur Linux
Etudiant en administration système et réseau

Hors ligne

#5 Le 12/01/2017, à 11:25

Dylsous

Re : Debian (8) - Connexion à un server Goanywhere avec openssh-client

Merci déjà de vos réponses,

Il y a du nouveau dans mon histoire.

Du coup j'ai essayé moi de même générer les clés et de les fournir à mon serveur Goahnywhere avec clé public, privée et passphrase et avec la commande "sftp" cela fonctionnait à merveille  (mais pas en ssh" why ?)

Sauf que notre but et qu'on souhaite nous même de fournir la clé privé aux clients pour être "maitre" donc je génère la clé privé (ppk) et public (.pub) généré même pas Goahnywhere sur mon client debian, je convertis ma clé privée au bon format openssh , je les mets dans mon dossier .ssh et je ne touche même pas au fichier "ssh_config"

Lors de mon essai de nouveau un problème avec :

Permission denied (publickey).
Couldn't read packet: Connection reset by peer
administrateur@Akoa:/$ sftp -v aXX@10.XX.XX.XX
OpenSSH_6.7p1 Debian-5+deb8u3, OpenSSL 1.0.1t  3 May 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 10.XX.XX.XX [10.XX.XX.XX] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/administrateur/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u3
debug1: Remote protocol version 2.0, remote software version GoAnywhere5.3.6
debug1: no match: GoAnywhere5.3.6
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-sha2-256 none
debug1: kex: client->server aes128-cbc hmac-sha2-256 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<8192<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA 20:dd:23:50:8d:69:23:9c:bd:2a:c3:18:91:fb:42:80
debug1: Host '@10.XX.XX.XX' is known and matches the RSA host key.
debug1: Found key in /home/administrateur/.ssh/known_hosts:1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
Welcome! Please login.
debug1: Authentications that can continue: password,publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/administrateur/.ssh/id_rsa
debug1: Trying private key: /home/administrateur/.ssh/id_dsa
debug1: Trying private key: /home/administrateur/.ssh/id_ecdsa
debug1: Trying private key: /home/administrateur/.ssh/id_ed25519
debug1: Next authentication method: keyboard-interactive
password
Enter password for aXX
Password:
Authenticated with partial success.
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
Permission denied (publickey).
Couldn't read packet: Connection reset by peer

Je n'ai pas de serveur ssh donc la config "sshd" n'ai pas modifié smile

Merci d'avance

Hors ligne

#6 Le 12/01/2017, à 11:25

bruno

Re : Debian (8) - Connexion à un server Goanywhere avec openssh-client

Si il y a un bien un souci au niveau des clés puisque l’authentification par clés ne se fait pas complètement et que c'est l'authentification par mot de passe qui est proposée en dernier recours :

debug1: Offering RSA public key: administrateur@Akoa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug2: input_userauth_pk_ok: fp e8:0f:21:e2:7c:43:36:f5:98:99:0e:7d:4e:44:38:78
debug3: sign_and_send_pubkey: RSA e8:0f:21:e2:7c:43:36:f5:98:99:0e:7d:4e:44:38:78
Authenticated with partial success.
debug2: key: administrateur@Akoa (0x7f5e85584e30),
debug2: key: /root/.ssh/identity ((nil)),
debug2: key: /root/.ssh/id_rsa ((nil)),
debug1: Authentications that can continue: password,keyboard-interactive
debug3: start over, passed a different list password,keyboard-interactive
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug2: input_userauth_info_req
password
Enter password for ako

Ensuite la session interactive échoue avec l'erreur :

shell request failed on channel 0

ce qui signifie qu'il est impossible d'ouvrir un pseudo-terminal sur le serveur. Là les causes peuvent être multiples et cela va être difficile de savoir pourquoi si Dylsous n'a pas la main sur le serveur…

Maintenant au vu de ceci :

debug1: Remote protocol version 2.0, remote software version GoAnywhere5.3.6
debug1: no match: GoAnywhere5.3.6

On peut légitimement penser que le serveur n'accepte que du SFTP/SCP et n'autorise les connexions shell. (http://www.goanywhere.fr/)

EDIT : Dylsous à réponsu entre temps et cela confirme ma supposition ci-dessus : le serveur permet de faire du sftp mais ne donne pas accès à un shell SSH.

Dernière modification par bruno (Le 12/01/2017, à 11:27)

Hors ligne

#7 Le 12/01/2017, à 11:32

Dylsous

Re : Debian (8) - Connexion à un server Goanywhere avec openssh-client

Merci Bruno de ta réponse,

Oui en effet après des recherche sur GoAnywhere, en effet il accepte pas le protocole SSH mais bien du SFTP/SCP,
Je peux avoir accès aux serveurs GoAnywhere si vous avez des suppositions à faire dessus.

Sinon pour la seconde erreur je sèche royalement.

Merci d'avance

Hors ligne